Oracle 7.3, PB6.5 can't connect, PB5.003 No Problem

We had a strange problem.

I have an Oracle7.3 DB.

1.  No PB version had connected to it before.
2.  I logged into it using SYSTEM in PB6.5.  The PBCatalog tables were
created.  I logged out and restarted PB6.5.
3.  Then I attempted to log in using another user_id in PB6.5.  I got
the following error message, "Please connect as the PowerBuilder Catalog
Owner.  This is necessary for the initial connection to Oracle to GRANT
priveleges on the repository."
4.  I went to another machine that has PB5.0.03 and attempted to login
using the same user_id.  It went in fine.
5.  Ran This query:
    select * from dba_users
    where username = 'SYSTEM'  --> Default tablespace was 'TOOLS'
6.  Ran this query:
    select * from all_tables
    where table_name like 'PB%'  --> TableSpace was 'TOOLS'

Solution:
1.  Dropped all the PBCat tables.
2.  Logged in using SYSTEM in PB5.0.03. Logged out.
3.  Logged in using user_id in PB6.5.  No Problems.
4.  Ran This query:
    select * from dba_users
    where username = 'SYSTEM'  --> Default tablespace was still 'TOOLS'
5.  Ran this query:
    select * from all_tables
    where table_name like 'PB%'  --> TableSpace was 'SYSTEM'

Analysis:
1.  PB6.5 is clearly writing to the Default Tablespace.
2.  PB5.0.03 is clearly writing to 'SYSTEM' (Disregarding the Default)
3.  I suspect that SYSTEM may be constrained by quotas on the TOOLS
tablespace.  The DBA was not able to confirm this, but also thinks it is
somewhat curious.




0
James
12/9/1998 4:44:46 PM
sybase.powerbuilder.connection 3893 articles. 0 followers. Follow

1 Replies
450 Views

Similar Articles

[PageSpeed] 54

PB5 is hardcoded to put the pbcat tables in the system tablespace.  In PB6.5
you can specify who the table owner is of the pbcat tables.  It defaults to
the system userid.
The problem is that PB5 hardcodes to the system tableowner in its select,
but PB6.5 uses just the table_name.  So you must create public synonyms for
the pbcat tables:

spool x.sql
select 'create public synonym ' || table_name || ' for SYSTEM.' ||
table_name || ';'
from dba_tables
where table_name like 'PBCAT%'
and owner = 'SYSTEM';
spool off
@x.sql


Just to clarify: the default tablespace that is specified for each user (as
seen in dba_users), just determines where Oracle will create segments
(tables, indexes, etc) when you don't specify the tablespace option in your
create table, index etc statements.
--
Terry Dykstra (TeamPS)
Canadian Forest Oil Ltd.
James Money wrote in message <366EA8FD.6BF07E27@aimfunds.com>...
>We had a strange problem.
>
>I have an Oracle7.3 DB.
>
>1.  No PB version had connected to it before.
>2.  I logged into it using SYSTEM in PB6.5.  The PBCatalog tables were
>created.  I logged out and restarted PB6.5.
>3.  Then I attempted to log in using another user_id in PB6.5.  I got
>the following error message, "Please connect as the PowerBuilder Catalog
>Owner.  This is necessary for the initial connection to Oracle to GRANT
>priveleges on the repository."
>4.  I went to another machine that has PB5.0.03 and attempted to login
>using the same user_id.  It went in fine.
>5.  Ran This query:
>    select * from dba_users
>    where username = 'SYSTEM'  --> Default tablespace was 'TOOLS'
>6.  Ran this query:
>    select * from all_tables
>    where table_name like 'PB%'  --> TableSpace was 'TOOLS'
>
>Solution:
>1.  Dropped all the PBCat tables.
>2.  Logged in using SYSTEM in PB5.0.03. Logged out.
>3.  Logged in using user_id in PB6.5.  No Problems.
>4.  Ran This query:
>    select * from dba_users
>    where username = 'SYSTEM'  --> Default tablespace was still 'TOOLS'
>5.  Ran this query:
>    select * from all_tables
>    where table_name like 'PB%'  --> TableSpace was 'SYSTEM'
>
>Analysis:
>1.  PB6.5 is clearly writing to the Default Tablespace.
>2.  PB5.0.03 is clearly writing to 'SYSTEM' (Disregarding the Default)
>3.  I suspect that SYSTEM may be constrained by quotas on the TOOLS
>tablespace.  The DBA was not able to confirm this, but also thinks it is
>somewhat curious.
>
>
>
>


0
Terry
12/10/1998 4:05:39 PM
Reply:

Similar Artilces:

PB6.5 and Oracle 7.3
I'm not able to connect a PB6.5 client application to an Oracle 7.3 database. The error is "no interface driver connected", regardless of which driver I use (pbor7160.dll, pbor7260.dll, or pbor7360.dll). I did not have this problem on PB6.0. Also on a client running an Oracle 8 SQLNet (e.g. version 8.05) I can connect successfully with either the Oracle 8 drivers (pbor8460.dll) or any of the version 7.x drivers. My customer is having the same problem since I sent him an updated deployment version for his Oracle 7.2 installation. Is there a fix on PB6.5? Thanks ...

Can't connect to Oracle 7.3 Server with PB6.5
This is a multi-part message in MIME format. ------=_NextPart_000_00A8_01BE8D87.25046920 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi,=20 WIN95 Oracle 7.3 Installed PB 6.5 DESKTOP I can't seem to set up a connection to an Oracle 7.3 database. I CAN = see the database when using Oracle SQL*Plus 3.3.4. Do I need a different version of Powerbuilder? I see = that there is a PB07360.DLL in the=20 DDDK6\DB Interfaces subdirectory. The path contains C:\ORAWIN95\BIN. = I've changed the PB.ini to try and e...

ERROR [HY000] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'IP Address of the server'(10048) ERROR [HY000] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'IP of the server' (10
Hi, I am randomly getting the following error message in my application. ERROR [HY000] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'IP Address of the server'(10048) ERROR [HY000] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'IP of the server' (10048) I am using .Net 2.0 with VS2005 having ODBC 3.51.14 Driver.  Can any body point out the core reasons of the above error message? Thanks. Nouman Khawaja. I do have the same problem, help me out. Thanks  If the going seems easy, You are going DownHill... When I was writing ...

Can't connect PB 5.0 to Oracle 7.3 since Ip's adresses changed
Hi, I'm Running PB 5.0 on Oracle 7.3, but I can't get connected to the database from the designer since I Change the ip's adresses, I don't understand because I do the tnsping succesfully.. Somebody has an idea about it? Thanks JEsus Gutierrez ...

PB6 and Oracle 7.3.4.0 on NT4
Greetings.. I have PB6 and Oracle 7.3.4.0 both running on NT4 on the same box. I can connect to Oracle through SQL*Plus, but in PB, as soon as I select 'O73 Oracle 7.3' and then hit 'New...' in the Database Profiles window, I get an error: pb60 - Ordinal Not Found The ordinal 41 could not be located in the dynamic link library OCIW32.dll Sounds like it can't get the entry point into the dll for some reason. I have orant/bin in my path, the dll is there, and PB07360.dll is also in the path. What gives? Thanks in advance.. Mike Christensen CPD6 mchrist...

Can't Connect to an Oracle Server Release 7.3.3.00
Hi, I am using PB 651 on Win95, trying to setup the native driver to interface an Oracle server release 7.3.3.0.0. But when I click on the New... button on Data Profile for "O73 Oracle 7.3"k, I got this error message. "Unable to load the requested Powersoft database interface, please make sure both interface and client software are properly installed." I know the SQL PLUS is installed properly and I can connect to the server via the SQL Plus without error. I can even connect to the server thru an Intersolv Oracle ODBC driver, but just can't use the PB nativ...

PB6.5->7.0
I have an app that works fine under PB6.5 which I migrated to 7.0. It used to run fine under 6.5 connecting to SQL Server 6.5. I've made no code changes at all but when I try to connect to the server under PB 7, it just stops and the hard disk goes like crazy. If I connect through PB to the database and then bring up a DW, I can see data. It just appears like my app can't connect. Any ideas? TIA. - Jeffrey There is a huge memory leak with the native driver. The workaround: Put a Space in dbparm. In development, set staticbind or something. -- Terry Dykstra (Team...

PB6.5 & Oracle 7.3 connection problem
Hi, I am trying to install PB6.5 application on win95. Even though I have included all the dlls required while connecting to database it says 'Oracle 7.3 DBMS is not supported in your current installation'. SqlNet is also installed on this machine. Do you think it could be because of 16-bit sqlNet & 32-bit PB application ? Thanks Check to ensure that you have the pbo7360.dll file somewhere accessable by the installation, or that it is not corrupt. This is often a cause of this error. HTH, John Townes College of Law Sydney, Australia >Hi, >I a...

PB6.5.1, MSSNEW, still can't connect to SQLServer 7
We finally upgraded to SQLServer 7 and couldn't connect with the native driver. Tried ODBC and got the "TYPE OUT OF RANGE" error. So, a quick scan through the newsgoup showed that not only is this a known situation, it has already been fixed. So I grab the 6.5.1 maintenance release and install it, then grab the EBF for SQLServer 7 and overlay that. Try to connect again using MS SQL Server 6.x database API... same results. Tried ODBC. That worked. So, is there any way to use the native drivers? Can someone walk me through what I need to do to get them working? Thank...

PB6.5 to Oracle 7.3.3 Connection Failure
I am getting the following error when trying to connect to oracle ORA-3121; No interface driver connected. Function not perfomed I've seen references to this error in other threads, but still cannot figure out the resolution to the problem. Here are the details. Any help would be appreciated. I am running PB6.5 under windows 95. My NT server is running oracle 7.3.3 Server. I am running sql*net client client version 2.3.3.0 My sqlnet easyconfig looks like the following for the connection I am trying to establish: VJD.world = (DESCRIPTION = (ADDRESS_LIST = (A...

Can't get through init 3 from init 5 and can't get through init 5 from init 3.
I tried opensuse 12.1 Gm today. Installation was perfect with xfce 4.8 until I tried installing the nvidia driver. In runlevel 5 as superuser I tried to shift to runlevel 3 and was welcome with a black screen, I have to use ctrl-alt-delete to reboot. During the reboot I used runlevel 3 and I was able to install the nvidia driver. After the nvidia driver installation I tried to shift to runlevel 5 and there, I was welcome with a black screen with a stationary blinking x cursor. I rebooted once again wiith runlevel 5 to get the gui. Any one had seen this happened? This installation is...

PB 5.0.04 (NT) connection to Oracle 7.3.3 problem.
We are having problem connect to Oracle 7.3.3 with PB 5.0.04 in NT. When we try to connect to DB (after create the DB profile) in PB we got a Dr. Watson error and PB closed. We are using the pbo73050.dll and wondering if we need a different Oracle driver in NT (SQLPlus works fine). Thanks in advance. -- Gary Lau CCAC Hi, Have you tried setting StaticBind=0 in your dbparm? HTH -- - Met vriendelijke groet, Eric Aling [TeamPS], Cypres Informatisering bv, The Netherlands http://ourworld.compuserve.com/homepages/alingejj Gary Lau wrote in message <01bd737d$96...

Can't connect to Oracle 9i when connected to DB2
Hi all, We're having a strange problem with a number of perl scripts we use to verify the synchronization of an Oracle database with a DB2 database. We're running perl 5.8.5 on HP-UX 11 (had to do our own compile; used gcc). DBI version is 1.45, DBD::Oracle is 1.16 (client version 9.2.0.5), DBD::DB2 is 0.78 (client version 7.2 (version 7 fixpack 12)). If I first do DBI->connect() to the Oracle 9i database, and then to DB2 (without retrieving data from either, but having prepared some statements), it works fine. However, if I set up the DB2 $dbh and statements first, I g...

PB 7.0.3
I'm trying to connect to a SQL Server 7 database in another location (i.e, over a WAN). I can connect to it just fine from SQL Server client, but I get an error "SQL Server unavailable or does not exist" error message when trying to connect to it from PB 7.0.3. Any suggestions? Connection over a wan (Internet) does work for us. If you can give us some more information maybe we can help you find a solution. <DFortner> wrote in message news:96CDFBF773F137B90065FB2E85256C5B.0065FB3C85256C5B@webforums... > I'm trying to connect to a SQL Server 7 databa...

Web resources about - Oracle 7.3, PB6.5 can't connect, PB5.003 No Problem - sybase.powerbuilder.connection

Resources last updated: 12/6/2015 7:26:45 PM