Upgrade to ASE 15..0.3 from ASE 12.5.4

I'm currently planning to do an upgrade in place from ASE
12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.

Does it just run the installmaster and instmsgs.ebf scripts
?
Will I have to manually run the rest of the scripts i.e.
installsecurity, installdbccdb etc.?
Also in ran the preupgrade program against my old server -
the main errors it came up with were:

Stored Procedure '' uses deprecated builtin functions as:
'rowcnt', which should be changed to 'row_count'.

It doesn't show the stored procedures name - has anyone had
this problem ?

Regards
Kully Sandher
0
ksandher
6/10/2010 1:23:53 PM
sybase.ase.upgrades+migration 687 articles. 0 followers. Follow

7 Replies
954 Views

Similar Articles

[PageSpeed] 19

On 6/10/2010 7:23 AM, ksandher wrote:
> I'm currently planning to do an upgrade in place from ASE
> 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
>
> Does it just run the installmaster and instmsgs.ebf scripts
> ?
> Will I have to manually run the rest of the scripts i.e.
> installsecurity, installdbccdb etc.?


After the upgrade, run "sp_versions" and see if anything
appears out of date.



> Also in ran the preupgrade program against my old server -
> the main errors it came up with were:
>
> Stored Procedure '' uses deprecated builtin functions as:
> 'rowcnt', which should be changed to 'row_count'.
>
> It doesn't show the stored procedures name - has anyone had
> this problem ?


Yes, CR 631130 is open on it.

Assuming stored procedure text hasn't been hidden, you should
be able to find them by searching syscomments for the
depreciated function names:

select object_name(id) from syscomments where text like "%rowcnt%"

0
Bret
6/10/2010 3:15:32 PM
Kully,

It may also be worth while considering going to ASE 15.5.  ASE 15.5 ESD#1
was just posted yesterday on the ESD download site.  ASE 15.5 is the
continuation of the 15.x release.

All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5 ESD#1

NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are concurrent (same
     codeline), so just make sure that you pick up the right version.

- Paul.



ksandher wrote:
> I'm currently planning to do an upgrade in place from ASE
> 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
> 
> Does it just run the installmaster and instmsgs.ebf scripts
> ?
> Will I have to manually run the rest of the scripts i.e.
> installsecurity, installdbccdb etc.?
> Also in ran the preupgrade program against my old server -
> the main errors it came up with were:
> 
> Stored Procedure '' uses deprecated builtin functions as:
> 'rowcnt', which should be changed to 'row_count'.
> 
> It doesn't show the stored procedures name - has anyone had
> this problem ?
> 
> Regards
> Kully Sandher
0
Paul
6/10/2010 9:40:58 PM
Kully,

It may also be worth while considering going to ASE 15.5.  ASE 15.5 ESD#1
was just posted yesterday on the ESD download site.  ASE 15.5 is the
continuation of the 15.x release.

All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5 ESD#1

NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are concurrent (same
     codeline), so just make sure that you pick up the right version.

- Paul.



ksandher wrote:
> I'm currently planning to do an upgrade in place from ASE
> 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
> 
> Does it just run the installmaster and instmsgs.ebf scripts
> ?
> Will I have to manually run the rest of the scripts i.e.
> installsecurity, installdbccdb etc.?
> Also in ran the preupgrade program against my old server -
> the main errors it came up with were:
> 
> Stored Procedure '' uses deprecated builtin functions as:
> 'rowcnt', which should be changed to 'row_count'.
> 
> It doesn't show the stored procedures name - has anyone had
> this problem ?
> 
> Regards
> Kully Sandher
0
Paul
6/10/2010 9:41:42 PM
Thanks for all the responses.
Will most likely stick with ASE 15.0.3ESD#3 - we have
already done a lot of testing with this version.

Regards
Kully

> Kully,
>
> It may also be worth while considering going to ASE 15.5.
> ASE 15.5 ESD#1 was just posted yesterday on the ESD
> download site.  ASE 15.5 is the continuation of the 15.x
> release.
>
> All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5 ESD#1
>
> NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are
> concurrent (same
>      codeline), so just make sure that you pick up the
> right version.
>
> - Paul.
>
>
>
> ksandher wrote:
> > I'm currently planning to do an upgrade in place from
> > ASE 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
> >
> > Does it just run the installmaster and instmsgs.ebf
> > scripts ?
> > Will I have to manually run the rest of the scripts i.e.
> > installsecurity, installdbccdb etc.?
> > Also in ran the preupgrade program against my old server
> > - the main errors it came up with were:
> >
> > Stored Procedure '' uses deprecated builtin functions
> > as: 'rowcnt', which should be changed to 'row_count'.
> >
> > It doesn't show the stored procedures name - has anyone
> > had this problem ?
> >
> > Regards
> > Kully Sandher
0
K
6/11/2010 8:54:23 AM
Also do i just disable replication before upgrade and then
re-enable it after upgrade ?
Is it as simple as that ?

Regards
Kully

> Kully,
>
> It may also be worth while considering going to ASE 15.5.
> ASE 15.5 ESD#1 was just posted yesterday on the ESD
> download site.  ASE 15.5 is the continuation of the 15.x
> release.
>
> All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5 ESD#1
>
> NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are
> concurrent (same
>      codeline), so just make sure that you pick up the
> right version.
>
> - Paul.
>
>
>
> ksandher wrote:
> > I'm currently planning to do an upgrade in place from
> > ASE 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
> >
> > Does it just run the installmaster and instmsgs.ebf
> > scripts ?
> > Will I have to manually run the rest of the scripts i.e.
> > installsecurity, installdbccdb etc.?
> > Also in ran the preupgrade program against my old server
> > - the main errors it came up with were:
> >
> > Stored Procedure '' uses deprecated builtin functions
> > as: 'rowcnt', which should be changed to 'row_count'.
> >
> > It doesn't show the stored procedures name - has anyone
> > had this problem ?
> >
> > Regards
> > Kully Sandher
0
K
6/11/2010 9:34:17 AM
If you're talking about a RDB ... suspending the DSI should be sufficient.

If you're talking about a PDB ... see the ASE 15.0.3 Installation Guide for your OS, in particular you'll want to look 
at Appendix B: Upgrading Servers with Replicated Databases.


K Sandher wrote:
> Also do i just disable replication before upgrade and then
> re-enable it after upgrade ?
> Is it as simple as that ?
> 
> Regards
> Kully
> 
>> Kully,
>>
>> It may also be worth while considering going to ASE 15.5.
>> ASE 15.5 ESD#1 was just posted yesterday on the ESD
>> download site.  ASE 15.5 is the continuation of the 15.x
>> release.
>>
>> All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5 ESD#1
>>
>> NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are
>> concurrent (same
>>      codeline), so just make sure that you pick up the
>> right version.
>>
>> - Paul.
>>
>>
>>
>> ksandher wrote:
>>> I'm currently planning to do an upgrade in place from
>>> ASE 12.5.4 to ASE 15.0.3 using sqlupgrade(res) utility.
>>>
>>> Does it just run the installmaster and instmsgs.ebf
>>> scripts ?
>>> Will I have to manually run the rest of the scripts i.e.
>>> installsecurity, installdbccdb etc.?
>>> Also in ran the preupgrade program against my old server
>>> - the main errors it came up with were:
>>>
>>> Stored Procedure '' uses deprecated builtin functions
>>> as: 'rowcnt', which should be changed to 'row_count'.
>>>
>>> It doesn't show the stored procedures name - has anyone
>>> had this problem ?
>>>
>>> Regards
>>> Kully Sandher
0
Mark
6/11/2010 7:52:15 PM
You should follow the following procedure if you are
upgrading servers with replicated databases...

http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc35889.1502/html/installsun/CHDEJAJG.htm

Cheers,

Susan L.


> Also do i just disable replication before upgrade and then
> re-enable it after upgrade ?
> Is it as simple as that ?
>
> Regards
> Kully
>
> > Kully,
> >
> > It may also be worth while considering going to ASE
> > 15.5. ASE 15.5 ESD#1 was just posted yesterday on the
> > ESD download site.  ASE 15.5 is the continuation of the
> > 15.x release.
> >
> > All fixes in ASE 15.0.3 ESD#3 should be in ASE 15.5
> ESD#1 >
> > NB, with ASE 15.5 ESD#1, ASE CE and ASE SMP releases are
> > concurrent (same
> >      codeline), so just make sure that you pick up the
> > right version.
> >
> > - Paul.
> >
> >
> >
> > ksandher wrote:
> > > I'm currently planning to do an upgrade in place from
> > > ASE 12.5.4 to ASE 15.0.3 using sqlupgrade(res)
> > utility. >
> > > Does it just run the installmaster and instmsgs.ebf
> > > scripts ?
> > > Will I have to manually run the rest of the scripts
> > > i.e. installsecurity, installdbccdb etc.?
> > > Also in ran the preupgrade program against my old
> > > server - the main errors it came up with were:
> > >
> > > Stored Procedure '' uses deprecated builtin functions
> > > as: 'rowcnt', which should be changed to 'row_count'.
> > >
> > > It doesn't show the stored procedures name - has
> > > anyone had this problem ?
> > >
> > > Regards
> > > Kully Sandher
0
Susan
6/14/2010 7:00:18 AM
Reply:

Similar Artilces:

Dump/Load (from ASE 12.5.4 to ASE 15.x) - VS.
Hi All, We are in the process of planning the upgrade of our ASE 12.5.4 dataservers to ASE 15.x. What is the most recommended way to upgrade ASE dataservers from ASE 12.5.4 to ASE 15.x? Potential options: 1) Install new instances of ASE 15.x and load database dumps from our ASE 12.5.4 dataservers to the newly installed ASE 15.x dataservers. - OR - 2) Use the ASE upgrade utility (sqlupgrade) to upgrade our existing ASE 12.5.4 dataservers to ASE 15.x. What are the Pros vs. Cons for loading a 12.5.4 database into a 15.x ASE dataserver versus performing an ASE dataserv...

ASE 12.5.0.3 to ASE 12.5.4 upgrade path
I would like to know if the migration from ASE 12.5.0.3 to 12.5.4 a direct migration or is there an intermediate upgrade to be performed in between? Take a look at the release bulletins and installation guides for your platform. These are the first steps to any upgrade. http://sybooks.sybase.com/nav/detail.do?docset=1287 <passerby> wrote in message news:484e9ca8.3f0d.1681692777@sybase.com... >I would like to know if the migration from ASE 12.5.0.3 to > 12.5.4 a direct migration or is there an intermediate > upgrade to be performed in between? ...

Upgrade ASE 12.0/64 bit on AIX 4.3.3 to ASE 12.5.x/64 bit on AIX 5.2
Trying to find what is the supported upgrade path for the above. Going from 12.0/64bit on AIX 4.3.3 to 12.5 (or 12.5.x) 64bit on AIX 5.2. If I put AIX 5.2 , the dataserver binary of 12.0 will not work which is used during the upgrade. If I put 12.5.x on 4.3.3, the dataserver binary will not work beacuse it is new binary for 5.2. Other than backup the databases and load them to the new server, is there a supported how to upgrade? Thanks! ...

upgrade from ASE 12.5.3 to ASE 15.0.2 ESD#4
What are the correct steps to upgrade from ASE 12.5.3 to 15.0.2#4? 1. Upgrade ASE 12.5.3 to ASE 15.0, then from ASE 15.0 to ASE 15.0.2#4 or 2. Upgrade ASE 12.5.3 to ASE 15.0.2 ESD#4 Thanks, liyp liy wrote: > What are the correct steps to upgrade from ASE 12.5.3 to 15.0.2#4? > > 1. Upgrade ASE 12.5.3 to ASE 15.0, then from ASE 15.0 to ASE 15.0.2#4 > > or > > 2. Upgrade ASE 12.5.3 to ASE 15.0.2 ESD#4 > I did #2. At one point I considered upgrading to 15.0.2 GA and then to ESD#4, but the $SYBASE/ASE/upgrade/upgrade program looks to b...

Upgrade ASE 12.5.3 to ASE 15.0
Can I upgrade my ASE Server 12.5.3 ESD #3 to ASE15.0 without any problems? According to a ESD #2 notice, if I do this it may regress the bug compatibility?. What exactly does that mean? What should I do instead? Deborah, Brown wrote: > Can I upgrade my ASE Server 12.5.3 ESD #3 to ASE15.0 > without any problems? > > According to a ESD #2 notice, if I do this it may regress > the bug compatibility?. What exactly does that mean? What > should I do instead? It means that most of the bugs fixed in 12.5.3 ESDs haven't yet been forward-ported to 15.0....

Upgrade from ASE 12.5.0.3 to ASE 12.5.1
This is a multi-part message in MIME format. ---=_forums-2-dub3ff97039 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: 7bit Hi, I've just upgraded from ASE 12.5.0.3 to ASE 12.5.1. I tried to start the server, but it won't startup. Here is the message: sybase(ASE1250)328 /app/sybase/ASE-12_5/install --> startserver -f RUN_AMXDB sybase(ASE1250)329 /app/sybase/ASE-12_5/install --> 00:00000:00000:2004/01/05 21:37:44.10 kernel Use license file /app/sybase/SYSAM-1_0/licenses/license.dat. 00:00000:00000:2004/01/05 21:37:44.10 ker...

ASE 12.5.0.3 to ASE 15.02 EBF2 upgrade
Hello All, I'm testing my upgrade from Adaptive Server Enterprise/12.5.3/EBF 12600 ESD#3/P/Linux Intel/Enterprise Linux/ase1253/1911/32-bit/ to Adaptive Server Enterprise/15.0.2/EBF 15101 ESD#2/P/x86_64/Enterprise Linux/ase1502/2516/64-bit/FBO/Thu Dec 20 01:26:11 2007 OS: RHEL 5 so far some db are been upgraded nice some I have issues , here is one of my error: ( mentioned this db has replicated tables from other site) Any tips ? 1>online database hstspss 2> go Started estimating recovery log boundaries for database 'hstspss'. Database 'hst...

Migration from ASE-64 bits 12.5.0.2 to ASE 64 bits 12.5.3 for AIX 5.3
Here there someone to indicate me the road tasks in order to migrate an ASE 12.5.0.2 to ASE 12.5.3 on unix 5.3 ? (64 bits) Thank you kamel wrote: > Here there someone to indicate me the road tasks in order to > migrate an ASE 12.5.0.2 to ASE 12.5.3 on unix 5.3 ? (64 > bits) > > Thank you Apply 12.5.2 IR then 12.5.3 esd 5. -- Jason L. Froebe http://jfroebe.livejournal.com http://www.propsmart.com Team Sybase On Tue, 31 Jan 2006 07:18:22 -0800, kamel wrote: > Here there someone to indicate me the road tasks in order to migrate an > ASE 12.5.0.2 ...

Logins + passwords when migrating from ASE 12.5.4/Linux x86 32bit to ASE 15.0.3/Solaris SPARC 64bit
Hi, I'd like to migrate one of our databases from ASE 12.5.4 to ASE 15. Source server is running on Linux x86 32bit, target server is Solaris SPARC 64bit. Cross-plattform dump and load works fine. The problem arises with logins/passwords. I've copied the contents of syslogins from the old server to the new one, but I can't log in using one of the manually migrated logins. Checking syslogins, I noticed that the password hashes on ASE 15 look different. Old hashes are just 60 characters long, the new ones 84 characters. According to Michael Peppler's ASE on Linux FAQ...

Upgrading ASE 11.9.2 to ASE 12.5 on Aix 4.3.3
After migration from ASE 11.9.2 to ASE 12.5, the following error appears when I try to execute a strore procedure : Size of row in the worktable for grouped aggregate, 16542 bytes, exceeds the maximum row size (1962 bytes). Cannot run this query (return status = -6). Is it a bug on ASE 12.5? Why could I run correctly this procedure on the old version? Fabien DUBOIS Fabien DUBOIS wrote: > > After migration from ASE 11.9.2 to ASE 12.5, the following error appears > when I try to execute a strore procedure : > > Size of row in the worktable for grouped aggr...

Exception: SQLException Error After Upgrade from ASE 12.5.0.3 to 12.5.4
After we upgraded ASE on SUN Solaris from 12.5.0.3 to 12.5.4, our web application gives us the following error... Exception: SQLException: Fail on select Invalid column name 'JGUTCHER'. It appears to me that the sql is being interpreted wrong. We have a database table that all the users are stored in for the app. As you can see by the error message, it seems to be treating the user as a column name??? The only thing in our environment that changed is the ASE version. DId sql syntax change between these versions? Thanks for the help, Jeff. Hello, SQL syntax do...

ASE 12.5 32bit to ASE 15.0 64bit upgrade
What are the steps to upgrade from 12.5 32bit to 15.0 64bit on AIX 5.3? The 15.0.1 Installation Guide describes the normal 15.0 upgrade process but then has a terse section towards the end, "Migrating from 32-bit to 64-bit version", that describes other steps. Are these steps in addition to the normal upgrade process (sqlupgrade) or are they in place of sqlupgrade? Do I really have to drop and re-create all compiled objects (step 12 under Method #3: Replacing the binary)? Keith Wonderly wrote: > > What are the steps to upgrade from 12.5 32bit to 15.0 64bit >...

When upgrading from ASE 12.5.x to ASE 15.x, what is the best version to upgrade too?
When upgrading from ASE 12.5.x to ASE 15.x, what is the best version to upgrade too? Dear All, I'm currently working on a ASE 15 upgrade project (upgrading from ASE 12.5.x). I'm trying to decide what version of ASE 15 we should upgrade to. What are your thoughts? Which version is the safest bet (ASE 15.0, ASE 15.0.1, ASE 15.0.2, ASE 15.0.3 or ASE 15.5)? Which ASE version is considered, at this time, the most mature and reliable version (i.e. with the least amount of known bugs, least amount of upgrade issues, etc.)? If applicable, please also give the most recomm...

Upgrading from ASE 12.0 to ASE 12.5.2
Hi everyone, I am basically thinking of upgrading ASE 12.0.x to ASE 12.5.2. How would the migration process be. Is it straight dump and load or otherwise ?? regards Paresh. Paresh wrote: > Hi everyone, > > I am basically thinking of upgrading ASE 12.0.x to ASE 12.5.2. > > How would the migration process be. Is it straight dump and load or > otherwise ?? > > regards > > Paresh. > > see the upgrade/installation guide joop -- Senior Consultant Sybase Professional Services New address per 21 November 2005: Zo...

Web resources about - Upgrade to ASE 15..0.3 from ASE 12.5.4 - sybase.ase.upgrades+migration

H-1 upgrade program - Wikipedia, the free encyclopedia
The H-1 upgrade program refers to the United States Marine Corps 's program to develop the AH-1Z Viper and UH-1Y Venom to replace its aging fleets ...


Tumblr Referrals From Facebook Up 2.5X Following Upgrade For Timeline
Since upgrading for timeline and launching with open graph in April, Tumblr has seen its referral traffic from Facebook rise by more than 2.5 ...

Update on Android Ice Cream Sandwich upgrades
HTC has been working hard to get its Ice Cream Sandwich upgrades ready, and we’re excited to announce that our first round of ICS upgrades will ...

Facebook Platform Upgrade Guide
Upgrade instructions for Facebook's platform across versions.

Facebook Allows Users to Upgrade to the New Messages Product, Why You Should
Some users are seeing a prompt when they visit their Facebook Messages inbox allowing them to upgrade to the New Messages product launched in ...

Search Twitter - upgrade
... here Search Refresh julia @ d0gbones 3m I laughed at the call handler when he told me it'd be £400 to stay on my current price plan and upgrade ...

Todo 6 (for devices that cannot upgrade to version 7) on the App Store on iTunes
Get Todo 6 (for devices that cannot upgrade to version 7) on the App Store. See screenshots and ratings, and read customer reviews.

Desktop Audio Upgrade - Flickr - Photo Sharing!
I needed some new speakers for my desktop computer system at home. I've been tolerating JBL creature 2.1 system for a couple of years now and ...

EU Project INDECT, Orwell gets an upgrade - YouTube
EU Project INDECT, Orwell gets an upgrade - YouTube

Resources last updated: 11/27/2015 2:47:25 AM