ASE 15.0.2 Developer's Edition - srvbuild keyboard issue

I ran into an issue with srvbuild which I haven't seen on the forum.  
Here's a description of the issue and the solution in case anyone else 
runs into it.  My setup is Gentoo, kernel 2.6.22-gentoo-r8, with xorg 
7.2, but I suspect this may apply to anyone using more recent versions of 
xorg.

Issue:

The ASE software installed without a hitch.  Upon launching srvbuild to 
create a server, I received the following errors:

Warning: translation table syntax error: Unknown keysym name:  osfActivate
Warning: ... found while parsing ':<Key>osfActivate:      
ManagerParentActivate()' 

Lots of these, and similar.  After this, the srvbuild window appeared, 
but it was not possible to enter anything using the keyboard.

Solution:

I found this on a completely unrelated website (VA Smalltalk) - http://
www.instantiations.com/forum/viewtopic.php?t=1174

In case this link disappears, here are the details:

cd to /usr/X11R6/lib/X11

create a symbolic link -- ln -s /usr/share/X11/XKeysymDB XKeysymDB

cd to /usr/X11R6/lib/X11/locale

make symbolic links to

/usr/share/X11/locale/en_US.UTF-8
/usr/share/X11/locale/locale.alias
/usr/share/X11/locale/locale.dir 

In my case, I had to create the directory /usr/X11R6/lib/X11/locale; YMMV.

After this, everything was sweet, and I now have a nice little server 
running.

- Guy

-- 
´╗┐This message is brought to you by your Department of Redundancy 
Department.
0
Guy
10/12/2007 1:19:10 PM
sybase.ase.linux 1395 articles. 0 followers. Follow

3 Replies
670 Views

Similar Articles

[PageSpeed] 11

WOW this works great on Ubuntu Feisty (which I'm running) as well.  First
time I've been able to run asecfg in years it seems.

Michael, can you add this to the Sybase FAQ?  This has been a LONG
standing problem on Linux, nice to know that there is finally a solution.

-Chris
0
Chris
10/12/2007 9:25:04 PM
> WOW this works great on Ubuntu Feisty (which I'm running)
> as well.  First time I've been able to run asecfg in years
> it seems.
>
> Michael, can you add this to the Sybase FAQ?  This has
> been a LONG standing problem on Linux, nice to know that
> there is finally a solution.

I'll do that ASAP...

Michael
0
mpeppler
10/17/2007 2:25:11 PM
On Fri, 12 Oct 2007 15:25:04 -0700, Chris N. Brown wrote:

> WOW this works great on Ubuntu Feisty (which I'm running) as well.  First
> time I've been able to run asecfg in years it seems.
> 
> Michael, can you add this to the Sybase FAQ?  This has been a LONG
> standing problem on Linux, nice to know that there is finally a solution.
> 

It's in the FAQ now.

Michael
-- 
Michael Peppler           -                 Peppler Consulting SaRL
mpeppler@peppler.org      -                  http://www.peppler.org
Sybase DBA/Developer      -   TeamSybase: http://www.teamsybase.com
Sybase on Linux FAQ       -   http://www.peppler.org/FAQ/linux.html

0
Michael
10/17/2007 6:23:38 PM
Reply:

Similar Artilces:

Difference between ASE 12.5.1 Developer's Edition and non-Developer's Edition
I am looking for differences between the free developers edition of ASE12.5.1 and the regular ASE 12.5.1. I noticed the OCS-12_5 in the Developer's Edition does not have the include directory and the lib directory only has the .so files and not the .a files. Any help? On Thu, 20 May 2004 21:02:05 -0700, wrote: > I am looking for differences between the free developers edition of > ASE12.5.1 and the regular ASE 12.5.1. I noticed the OCS-12_5 in the > Developer's Edition does not have the include directory and the lib > directory only has the .so files and not...

SQLRemote Problem with 7.0.2-1 and 6.0.2-1 on Linux [ASE 11.9.2-3 and ASE 12.5 eval]
Hi all I got the following problems using sql-remote. on ASE 12.5 eval: I got the following RPMs installed on RedHat Linux 7.2 - Kernel 2.4.17 - glibc-2.2.4 sybase-ase-12.5-3.i386.rpm sybase-common-12.5-3.i386.rpm sybase-openclient-12.5-3.i386.rpm sybase-sqlremote-7.0.2-1.i386.rpm After the execution of ssxtract or ssremote I got an error like: ../ssxtract: /opt/sybase-12.5/SQLRemote/lib/libsstasks7_r.so: version `libdbtasks7_r.so' not found (required by ./ssxtract) The file libsstasks7_r.so exists and the path is correctly specified in /etc/ld.so.conf. There'...

ASE 15.0.2
Is it supported? Anyone tries this, if so, could you post the steps and comments. I don't want to use ECDA (gateway) here, unixODBC driver is preferred. Thanks You can't setup a "remote server" to anything other than another ASE, ECDA, or any other open server product. In order to connect to an ODBC target, your only option is ECDA. "dbMethods" <dbmethods@nospam.com> wrote in message news:47e19f5a@forums-1-dub... > Is it supported? Anyone tries this, if so, could you post the steps and > comments. I don't want to use ECDA (gateway)...

Installing ASE 15.0.2 Developer Edition on Fedora 9
Formerly, it is impossible to install latest Sybase Database (ASE 15.0.2) on Latest Linux system because of glibc issues. With ESD#5, it become possible and easy now. I have installed ASE 15.0.2 Developer Edition on Fedora 9 without any errors, Just write down my steps as following, hope it can help others 1. Install Fedora 9 with typical selections. 2. Apply the latest patches (automatically update features, just like windows system) 3.install libaio-0.3.106-4.2.i386.rpm from Fedora 9 DVD (without libaio, I can not create Master Database) 4.install libXp-1.0.0-11.fc9.i38...

Support for ESQL/C in ASE 15.0 Developers Edition for Linux
I've recently installed the developers edition and was surprised to see that there was no support for ESQL/C. Rather odd definition of "developers". Can this really be true? If not, where are the libraries, headers, and utilities such as cpre available? On 26 abr, 21:57, jplejacq wrote: > I've recently installed the developers edition and was > surprised to see that there was no support for ESQL/C. > Rather odd definition of "developers". > > Can this really be true? If not, where are the libraries, > headers, and utilities such as cp...

ASE 12.5.2 Developer's Edition: Available?
Folks, Is ASE 12.5.2 Developer's Edition still available? I have followed several links to http://www.sybase.com/ase_1252devel but I get We're sorry, this page is no longer available. I am specifically interested in 12.5.2 for Solaris/SPARC, as that is our main platform at work. Thanks! Eric Try the 15.0 Developer's Edition: http://www.sybase.com/ase_1500devel HTH, Rob ------------------------------------------------------------- Rob Verschoor Certified Sybase Professional DBA for ASE 12.5/12.0/11.5/11.0 and Replication Server 12.5 ...

Loading 12.5.1 database to Ase 15.0.2 Developer Edition
I am getting an error while loading database from a backup. Is this a known error What error? <Shamim Aziz> wrote in message news:46f7bca7.12fc.1681692777@sybase.com... >I am getting an error while loading database from a backup. > Is this a known error Can you please post the full error text you're getting? HTH, Rob V. ------------------------------------------------------------- Rob Verschoor Certified Sybase Professional DBA for ASE 12.5/12.0/11.5/11.0 and Replication Server 12.5 / TeamSybase Author of Sybase books (order online at www.sypron.nl...

Segmentation fault when trying to install ASE 15.0 developer edition on Linux SLES 10
I recieve the following segmentation fault when trying to install the developer edition of ASE 15.0. See below... Can anyone make a suggestion I might try to resolve it. I read some of the other issues others were having and I tried the LD_POINTER_GUARD setting change, unsuccesfully. The version of linux I have installed is Linux linux-sybase-trainer 2.6.16.27-0.9-smp #1 SMP Tue Feb 13 09:35:18 UTC 2007 i686 i686 i386 GNU/Linux Thanks, David Building Adaptive Server 'LINUXSYBASETRAINER': Writing entry into directory services... Directory services entry complete. Bui...

Loading a DB Dump from an ASE 12.5.3 load into ASE 15 remaps TABLE ID's but causes issues for Procedures
Hello, When we load a dump of our database, from our ASE 12.5.3 server into our ASE 15 (same sizes, options etc), we find that the table_ID's are different(newly created), but no mapping exist to the old table id's used. So the newly migrated procedures that depend on these tables and still seem to reference the old table ID's somewhere, fail unless entirely dropped and recreated. SP_RECOMPILE does NOT help! They problem persists. It fails when executed and we can't necessarily recompile all.. Any ideas, please let me know Liz > Hello, > > When...

Upgrading ASE 15.0.2 -> 15.0.2 ESD #1
Hi, we have a warm-standby replication (Rep Server 15.0.1) and ASE 15.0.2. We want to upgrade our ASE with the latest ESD #1. I it correct if i say that i only need to Stop my replication, follow the upgrade proces for my ASE (active and standby ASE), and then just start my replication again? (so no steps are required for my replication) greetz Pieter FYI, the latest ASE 15.0.2 upgrade is ESD #2 (released about a week ago). If your RSSD is in one of the ASE's that you're preparing to upgrade then yes, you'll want to shutdown repserver before doing the upgrade. (...

ASE 15.0.2 ebf15354 vs SDK 15.0.2 ebf14847
I am confused. Are SDK's and ASE's ebfs follow same path or different? I had client part from 15.0.2 DE, with applied SDK's EBF14847. Everything was fine. But last week I decide to have my own server for testing purposes and reinstall server in full (15.0.2 DE) and apply EBF 15354 to it, but now isql does not know --retservererror key anymore... So I'm guessing ASE's EBFs do not include updates to client side? And now, I should install SDK's EBF 14847? Will it ruin fixes to server? While you could be running into a bug with the Sybase software we (the n...

Smoke [5.15.0] v5.15.0-108-gd9742aa FAIL(F) linux 2.6.39-2-amd64 [debian] (x86_64/2 cpu)
Automated smoke report for 5.15.0 patch d9742aa386b81e67ce2ecd1229bb8f04bf2899ec v5.15.0-108-gd9742aa bandsman.dyndns-ip.com: AMD Athlon(tm) Dual Core Processor 4450e (AuthenticAMD 2300MHz) (x86_64/2 cpu) on linux - 2.6.39-2-amd64 [debian] using cc version 4.6.1 20110616 (prerelease) smoketime 49 minutes 46 seconds (average 49 minutes 46 seconds) Summary: FAIL(F) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown o...

ASE Developer's Edition
Hi Interested to know if there are any plans of releasing ASE 12.5.3a (column encryption) as a developer's edition or will there be an ASE 15.1 developer's edition (which will also have this option, right?) instead? Regards, /Mattias Mattias Hultman wrote: > Hi > > Interested to know if there are any plans of releasing ASE 12.5.3a (column > encryption) as a developer's edition or will there be an ASE 15.1 > developer's edition (which will also have this option, right?) instead? > > > Regards, > /Mattias > > Hi...

ASE 12.5 developer's edition
I've installed ASE 12.5 developer's edition, which I can connect to with Sybase Central as long as I use localhost as the host name. If I try to connect remotely, or use the machine name or IP address locally, it won't let me connect. Is this a feature of the developer's edition? J. Cavanaugh I guess your running wintendo, check the $SYBASE/ini/sql.ni file which hostname/ip is entered -- Joop "The trouble with the concept of time is, there is no such thing as time, there is only an unlimited permutation of now" http://thedominion.cc "J...

Downgrading from ASE 15.0.2 to ASE 12.5.x...
Downgrading from ASE 15.0.2 to ASE 12.5.x... Dear All, I'm in the process of creating a roll-back / contingency / downgrade plan for an ASE 15 upgrade project (upgrading from ASE 12.5.x to ASE 15.0.2). Just a quick note to confirm my understanding of the below statement I found in Sybase ASE 15.0.2 installation / upgrade documentation. Statement 01: ----------------------------------------------------------------------------------- Downgrading from ASE 15.0.2 release: This section describes how to downgrade from Adaptive Server 15.0.2 to an earlier Adaptive Server ...

Web resources about - ASE 15.0.2 Developer's Edition - srvbuild keyboard issue - sybase.ase.linux

Resources last updated: 1/22/2016 10:35:11 PM