Re: [wxperl-users] Problem for installing last wxPerl on Windows #2

Is there anyone that can give me a windows binary of wxPerl-0.67 ?

It =
should have been located at http://wxperl.sourceforge.net/download.html
=
but the last version updated is only 0.26, a one year old version !

It=
's been 3 days I try to compile it and don't find out how to do it.

My=
 configuration is :
System : Windows XP
Perl   : Active Perl 5.8.8 Buil=
d 819 (last existing version)
wxWidgets version 2.8.0 compiled in all mo=
des

The error I get is described at the end of the message.

Thinkin=
g that I should install Alien::wxWidgets, I tried to do it with version 0=
..27.
It seems that I don't have Module::Build. I tried to install the ve=
rsion 0.2806.
It seems that I don't have :
Module::Signature (optional)=

ExtUtils::ParseXS (optional)
Pod::Readme (optional)
ExtUtils::Cbuilde=
r (optional)
Archive::Tar I have is version 0.072 instead of required ve=
rsion 1.08

Ok. I tried to install Archive::Tar version 1.30.
The perl=
 command line interpreter crashes.

I get more an more unbuildable pack=
ages to build and I'm going to be crazy !
I don't know what to do to get=
 out of this trap...

I continue my investigation by copying the Archiv=
e::Tar files into d:\perl\site\lib.
Alien::wxWidgets seems to install af=
ter adding a new package Module-Pluggable-3.4.

I'm now trying to make =
Wx-0.67 and I get after some lib in VC98 not found...
Attempt to free un=
referenced scalar: SV 0x20eaa10, Perl interpreter: 0x224554 at
 D:/Perl/=
lib/ExtUtils/MakeMaker.pm line 190.
ERROR from evaluation of D:\Wx-0.67\=
ext/Makefile.PL: ERROR from evaluation of D:
\Wx-0.67\ext\stc/Makefile.P=
L: No such 'link' library: 'stc' at D:/Wx-0.67/build/
Wx/build/MakeMaker=
..pm line 206
# Looks like your test died before it could output anything=
..

If I comment the buggy line, the script goes to his end. But in the =
compilation
process, I get more errors...

I'll never reach my goal...=


-----Message d'origine-----
De : Beule, Franck 
Envoy=E9 : mercredi=
 27 d=E9cembre 2006 11:02
=C0 : 'wxperl-users@lists.sourceforge.net'
Ob=
jet : RE: Problem for installing last wxPerl on Windows

Hi,

The las=
t version of what ?
All the versions I use are the last ones :

wxWidg=
ets 2.8.0
wxPerl 0.67

What can be newer ? 

-----Message d'origine-=
----
De : wxperl-users-bounces@lists.sourceforge.net [mailto:wxperl-user=
s-bounces@lists.sourceforge.net] De la part de Mattia Barbon
Envoy=E9 : =
dimanche 24 d=E9cembre 2006 13:07
=C0 : wxperl-users@lists.sourceforge.n=
et
Objet : Re: [wxperl-users] Problem for installing last wxPerl on Wind=
ows

On Fri, 22 Dec 2006 17:15:36 +0100
"Beule, Franck" <FBeule@nds.co=
m> wrote:

  Hi,

> D:\Wx-0.67>perl Makefile.PL
> Warning: prerequis=
ite Alien::wxWidgets 0.25 not found.

<snip>

> Writing Makefile for =
Wx
> Can't locate object method "wx_base_directory" via package
> "Alie=
n::wxWidgets" at
>  D:/Wx-0.67/build/Wx/build/MakeMaker/Win32.pm line 56=
..
> # Looks like your test died before it could output anything.
> 
> =
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> For insta=
llation instructions and further help please see
> docs/INSTALL.pod
> 
=
> For command line switches help use:
> perl Makefile.PL --help
> =3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  It appears Wx=
 does not correctly handle the case of an old
Alien::wxWidgets. For the =
moment, please install a new version before
trying to build Wx.

Regar=
ds
Mattia

------

My first message :

Hi,

for the moment, I've=
 used the Windows compiled version of wxPerl available at
http://wxperl.=
sourceforge.net/download.html

But the version available is only 0.26.
=

I need to install the last 0.67 version. Unfortunately, this version is=
 only available with sources. I need to compil them by myself.

I've do=
wnloaded and installed on d:\perl ActivePerl-5.8.8.819-MSWin32-x86-267479=
..msi
I've downloaded and compiled at every possible modes wxWidget 2.8.0=
 on d:\wxWidgets-2.8.0 with Microsoft Visual C++ 6.0
I've downloaded and=
 unziped Wx-0.67 on d:\Wx-0.67

I've set WXDIR=3Dd:\wxWidgets-2.8.0 and=
 WXWIN=3Dd:\wxWidgets-2.8.0
I've set in PATH the path for perl and the o=
ne for nmake take in Visual C++ subdirs.

And now, when I start to comp=
ile, I get an error (see below)
Someone can help me ?

I don't know wh=
at is this Alien::wxWidgets !

Thanks

D:\Wx-0.67>perl Makefile.PL
W=
arning: prerequisite Alien::wxWidgets 0.25 not found.
Writing Makefile f=
or Wx::Socket
Writing Makefile for Wx::DND
Writing Makefile for Wx::FS
=
Writing Makefile for Wx::Grid
Writing Makefile for Wx::Help
Writing Mak=
efile for Wx::Html
Writing Makefile for Wx::MDI
Writing Makefile for Wx=
::Print
Writing Makefile for Wx::XRC
Writing Makefile for Wx::STC
Writ=
ing Makefile for Wx::DocView
Writing Makefile for Wx::Calendar
Writing =
Makefile for Wx::DateTime
Writing Makefile for Wx::Media
Writing Makefi=
le for Wx::RichText
Writing Makefile for Wx::AUI
Writing Makefile for W=
x::Perl::SplashFast
Writing Makefile for Wx::Perl::Carp
Writing Makefil=
e for Wx::Perl::TextValidator
Writing Makefile for Wx::Perl
Writing Mak=
efile for Wx
Can't locate object method "wx_base_directory" via package =
"Alien::wxWidgets" at
 D:/Wx-0.67/build/Wx/build/MakeMaker/Win32.pm line=
 56.
# Looks like your test died before it could output anything.

=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
For installati=
on instructions and further help please see
docs/INSTALL.pod

For comm=
and line switches help use:
perl Makefile.PL --help
=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D


D:\Wx-0.67>
***************=
********************************************************************
Inf=
ormation contained in this email message is confidential and may be privi=
leged, and is intended only for use of the individual or entity named abo=
ve. If the reader of this message is not the intended recipient, or the e=
mployee or agent responsible to deliver it to the intended recipient, you=
 are hereby notified that any dissemination, distribution or copying of t=
his communication is strictly prohibited. If you have received this commu=
nication in error, please immediately notify the postmaster@nds.com and d=
estroy the original message.
*******************************************=
**************************************** 


0
FBeule
12/27/2006 4:21:40 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
435 Views

Similar Articles

[PageSpeed] 18

Reply: