RE: Re[2]: [wxperl-users] Wx::PreviewFrame issues #2

  Hello,

> Something that I have found ... I can do the following:
> =

> <snip>
> 	package PrintingDemoControlBar;
> 	use base 'Wx::PlPrevie=
wControlBar';
> 	sub CreateButtons {
> 	    Wx::LogMessage( 'PrintingDe=
moControlBar::CreateButtons' );
> 	    shift->SUPER::CreateButtons;
> 	=
}
> </snip>
> 
> But the following:
> 
> <snip>
> 	package Printing=
DemoPreviewFrame;
> 	use base 'Wx::PlPreviewFrame';
> 	sub Initialize {=

> 	    shift->SUPER::Initialize( @_ );
> 	}
> 	sub CreateControlBar {=

> 	    shift->SUPER::CreateControlBar( @_ );
> 	}
> </snip>
> 
> fa=
ils with errors :
> Can't locate object method "CreateControlBar" via pa=
ckage
> PrintingDemoPreviewFrame ...
> or
> Can't locate object method=
 "Initialize" via package PrintingDemoPreviewFrame
> ...
> 
> Is this =
my mistake, by design or can this be fixed/changed?

  It can be change=
d, I will do it this evening.
 
> Just when I started getting to unders=
tand the XS interface to wxWidgets you
> seemed to change the interface.=
 It looks like you are making more use
> typemaps and now I am totally l=
ost .. again.

  I think that now it is much simpler, and anyway
you c=
an run the perl ... xsubppp.pl ... command you find
in (for example) Pri=
nt.xs and look at the plain XS output.

Regards
Mattia
=0A=0A=0A=0A__=
__________________________________________________________=0A6X velocizza=
re la tua navigazione a 56k? 6X Web Accelerator di Libero!=0AScaricalo su=
 INTERNET GRATIS 6X http://www.libero.it=0A


0
mattia
3/15/2005 2:01:31 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
564 Views

Similar Articles

[PageSpeed] 48

Reply:

Similar Artilces:

RE: Re[2]: [wxperl-users] Wx::PreviewFrame issues
Hello, > The Makefile.PL would not run as it reported an error. > T= here was a problem with the ext/print/Makefile.PL which was missing the=0D = > trailing comma on line 19. > But after I added that the make process s= tarted but then I got an error: So much for last-minute changes (I f= orgot to test, $%!^)... > cp lib/Wx/Print.pm ..\..\blib\lib\Wx\Print.= pm > C:\Perl\bin\perl.exe C:\Perl\lib\ExtUtils/xsubpp -noprotot= ypes > -nolinenumbers -typemap C:\Perl\lib\ExtUtils\typemap -typemap ..= \..\typemap > -typemap typemap Print.xs...

RE: [wxperl-users] Re: wxValidator available via wxPerl #2
Dear Mattia, Thanks - this works a treat! I was so close... Anyway, now I'm up and running. I had noticed the 'Attempt to free unreferenced...' error - will await a fix. Now that I've got things working, what do you suggest/would you like? I feel that validators are the way to go when it comes to transferring data to/from controls (rather than explicit GetValue/SetValue calls all over the place) - I have had to implement a similar concept (though not as elegant) in a very large Perl/Tk application which we have developed. I see that you think we should create...

RE: Re[2]: [wxperl-users] Simple Messagebox . . . Take 2
-----Original Message----- From: Mattia Barbon [mailto:mbarbon@dsi.unive.it] Sent: Saturday, December 07, 2002 4:07 AM To: 'DH'; 'wxperl-users@lists.sourceforge.net'; Everett, Toby Subject: Re[2]: [wxperl-users] Simple Messagebox . . . Take 2 > No, it is designed to be used as a modal dialog. Given that, is there a way to ask for a feature to be added that would let the programmer request that the dialog be brought to the foreground when "ShowModal" is called? I realize that this is probably more of a Wx feature request than a wxPerl feature . . . In m...

RE: Re[2]: [wxperl-users] Installation on FreeBSD 5.3 #2
Hello, > > > > Can anyone point me in the right direction? > > =0D = > > > Not without some more information... > > > what ExtUtils::MakeMa= ker version do you have? > > > > $VERSION =3D '6.17'; > > > > > Wh= at is the output of > > > make > > > > ./cpp/helpers.h:27: error: `wx= OutputStream' does not name a type > > ./cpp/helpers.h:37: error: expect= ed `,' or `...' before '*' token > > ./cpp/helpers.h:37: error: ISO C++ = forbids declarati...

RE: Re[4]: [wxperl-users] [OT, or maybe not?] wxPerl T-Shirt? #2
Extending this idea, we could have the ASCII art camel on a "green = screen". Then the graphical camel would be shown in three separate = windows below, one in each of the OS flavors (GTK, Win32, Mac OS X). --Toby Ovod-Everett -----Original Message----- From: Ovod-Everett, Toby=20 Sent: Monday, July 28, 2003 10:45 AM To: wxperl-users@lists.sourceforge.net Subject: RE: Re[4]: [wxperl-users] [OT, or maybe not?] wxPerl T-Shirt? What about an ASCII art camel on top (assuming O'Reilly gives a thumbs = up). Then a "use Wx;" Then a very n...

Re:Re[2]: [wxperl-users] Wx::Mozilla -- testers needed!
> Thursday, March 9, 2006, 1:59:44 AM, you wrote: > Dan> I don't -- I built this on Linux. > > Okay, I'll try on Linux, I was just using Windows at the moment (for so= me reason). If it works on Linux then maybe it will build with cygwin. > > Mattia, do you use mingw or MSVC to make the Windows binaries for wxPer= l? MinGW with GCC 3.4. Mattia >>Mattia, do you use mingw or MSVC to make the Windows binaries for wxPerl? >> >> > > MinGW with GCC 3.4. > > You can get a "free" version of MS...

RE: [wxperl-users] Plans for wxPerl 0.23, wxWidgets 2.6.0 #2
Hello, > I tried to compile wxPerl CVS against 2.6.0 and I got the = errors as below. > > I am compiling on WinXP using MSVC6. Should this = work? Have others > successfully compiled? Yes, but with MSVC 5 and= GCC (various versions), not MSVC 6. Are you up to date with MSVC servic= e packs? > C:\Perl\bin\perl.exe C:\Perl\lib\ExtUtils/xsubpp = -noprototypes > -nolinen <snip> > Grid.c(390) : warning C4189: 'CLAS= S' : local variable is initialized but not > referenced > Grid.c(464) := fatal error C1001: INTERNA...

RE: [wxperl-users] Building wxPerl with wxWindows 2.3.1, and usingXML resources #2
Dear Mattia, Thanks for the info - I'm getting further! I've built xrc using: nmake -f makefile.vx FINAL=3D1 to create wxxrc.lib (rather than wxxrcd.lib), and this worked fine. However, when I try building wxPerl, using: nmake=20 perl Makefile.PL nmake=20 I get the following errors (I've snipped sections out to give the gist, as it goes on quite a bit): link -out:..\..\blib\arch\auto\Wx\XRC\XRC.dll -dll -nologo -nodefaultlib -release -libpath:"c:\perl\5.6.1\lib\MSWin32-x86-multi-thread\CORE" -machine:x86 XRC.obj ..\..\blib\arch\auto\Wx\Wx.lib C:\p...

RE: Re[2]: [wxperl-users] Building Wx::ActiveX 0.03 on XP
Dear Mattia, Got the solution - it was the lack of nmake all This made and installed the build directory in the correct location. (It was absent before). Could I suggest the readme for wxPerl is updated to tell us to do [dn]make all rather than just=20 [dn]make=20 please? That apart - thanks for your, as usual, great support and help. James -----Original Message----- From: Mattia Barbon [mailto:mbarbon@dsi.unive.it]=20 Sent: 14 April 2003 22:16 To: wxPerl users ML; James Lavery; James Lavery Subject: Re[2]: [wxperl-users] Building Wx::ActiveX 0.03 on XP On Mo...

Forwarded message: Re[2]: [wxperl-users] Trying to wrap Wx::Metafile #2
Oops... sending to list, too ------ Forwarded message ------ From: Mattia Barbon <mattia.barbon@libero.it> Date: Wed, 8 Oct 2003 20:25:22 +0200 (ora legale Europa occidentale) Subject: Re[2]: [wxperl-users] Trying to wrap Wx::Metafile To: Jouke Visser <jouke@pvoice.org> Il Sat, 04 Oct 2003 11:03:20 +0200 Jouke Visser <jouke@pvoice.org> ha scritto: > <this is a resend, with a smaller wmf> > Damnit, that's when you get when you've been puzzling all day and > try to > post something and prepare that in 3 minutes... > > Here...

Re: [wxperl-users] wxPerl on wxX11 ? #2
> --- John Ralls <jralls@ceridwen.fremont.ca.us> wrote: > > > > > On Jul 11, 2006, at 5:31 PM, Sergei Steshenko wrote: > > > > > Hello All, > > > > > > is it possible to compile wxPerl on wxX11 rather than on wxGTK ? > > > > > > If yes, will it be functional ? > > > > > > Thanks, > > > Sergei. > > > > If wxX11 works (which is to say, if you can build it and run some of = > > the samples), then wxPerl will work fine with it. wxPerl doesn't care= ...

Re:[wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> I've just built wxPerl 0.20 as indicated in the subject, and I had a =0D = > few issues: > > First, the syntax for wx-config used in > Any_wx_c= onfig.pm::get_core_libs_25 seems to have changed: Instead of > "--libs=3D= list" it's now "--libs list". yes, it was changes in wxWidgets CVS l= ast week. > Next, Makemaker is building the root Makefile with both b= libdirs: and Which MakeMaker version? If 6.22, downgrade to 6.17 or= use the snapshot at makemaker.org. > blibdirs::. That produces an = error. Cha...

Re: [wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> MakeMaker 6.21. Sorry. Below I meant to write: "If 6.21, downgrad= e to 6.17 or use the snapshot at makemaker.org." ^^^^ Regards=0D = Mattia > On Aug 18, 2004, at 11:56 PM, mattia.barbon@libero.it wrote:=0D = > ''' > >> Next, Makemaker is building the root Makefile with both blibd= irs: and > > > > Which MakeMaker version? If 6.22, downgrade to 6.17 = or > > use the snapshot at makemaker.org. > > > ... > > Thanks! > > = Mattia > > > > > > > > > &g...

RE: Re[2]: [wxperl-users] ToggleButton
Thank you. -----Original Message----- From: Mattia Barbon [mailto:mbarbon@dsi.unive.it] Sent: Tuesday, February 04, 2003 1:47 PM To: wxPerl users ML; Ismail Mutlu Subject: Re[2]: [wxperl-users] ToggleButton [ please keep replies on-list, thanks! ] On Tue, 4 Feb 2003 13:36:53 -0800 Ismail Mutlu <imutlu@pechanga.com> = wrote: > Hi Mattia, >=20 > Please bear with me as I am new to both wxPErl and OO, but here is = what > I am doing. Well, after looking at the code, you are right, and I am wrong: = GetValue isn't (and can't be inherited). I w...

Web resources about - RE: Re[2]: [wxperl-users] Wx::PreviewFrame issues #2 - perl.wxperl.users

Resources last updated: 11/28/2015 6:31:38 PM