[wxperl-users] [ wxperl-Patches-1015129 ] wxFIXED_MINSIZE added in 2.5.2

Patches item #1015129, was opened at 2004-08-24 10:07
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=315655&aid=1015129&group_id=15655

Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: D.H. (crazyinsomniac)
Assigned to: Nobody/Anonymous (nobody)
Summary: wxFIXED_MINSIZE added in 2.5.2

Initial Comment:
--- Constant.xs 2004-08-24 03:00:13.093750000 -
0700
+++ Constant.xs.new     2004-08-24 
03:04:18.781250000 -0700
@@ -836,6 +836,11 @@
     r( wxFDIAGONAL_HATCH );             // brush pen

     r( wxFILE_MUST_EXIST );
+
+#if WXPERL_W_VERSION_GE( 2, 5, 1 )
+    r( wxFIXED_MINSIZE );
+#endif
+
     r( wxFLOOD_SURFACE );               // dc
     r( wxFLOOD_BORDER );                // dc



----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=315655&aid=1015129&group_id=15655

0
noreply
8/24/2004 10:08:07 AM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
482 Views

Similar Articles

[PageSpeed] 0

Reply:

Similar Artilces:

[wxperl-users] [ wxperl-Patches-1161088 ] Listbook GetListView not in 2.5.2
Patches item #1161088, was opened at 2005-03-10 19:17 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=315655&aid=1161088&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: Listbook GetListView not in 2.5.2 Initial Comment: Not sure if it was added in 2.5.3 or 2.5.4, but something like this is needed in XS/Listbook.xsp #if WXPERL_W...

[wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
I've just built wxPerl 0.20 as indicated in the subject, and I had a few issues: First, the syntax for wx-config used in Any_wx_config.pm::get_core_libs_25 seems to have changed: Instead of "--libs=list" it's now "--libs list". Next, Makemaker is building the root Makefile with both blibdirs: and blibdirs::. That produces an error. Changing the single colon to a double colon fixes the problem, but it has to be done every time one runs Makefile.PL. I couldn't figure out where to fix it in the MakeMaker files. Last, could you take out the...

Re:[wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> I've just built wxPerl 0.20 as indicated in the subject, and I had a =0D = > few issues: > > First, the syntax for wx-config used in > Any_wx_c= onfig.pm::get_core_libs_25 seems to have changed: Instead of > "--libs=3D= list" it's now "--libs list". yes, it was changes in wxWidgets CVS l= ast week. > Next, Makemaker is building the root Makefile with both b= libdirs: and Which MakeMaker version? If 6.22, downgrade to 6.17 or= use the snapshot at makemaker.org. > blibdirs::. That produces an = error. Cha...

Re: [wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> MakeMaker 6.21. Sorry. Below I meant to write: "If 6.21, downgrad= e to 6.17 or use the snapshot at makemaker.org." ^^^^ Regards=0D = Mattia > On Aug 18, 2004, at 11:56 PM, mattia.barbon@libero.it wrote:=0D = > ''' > >> Next, Makemaker is building the root Makefile with both blibd= irs: and > > > > Which MakeMaker version? If 6.22, downgrade to 6.17 = or > > use the snapshot at makemaker.org. > > > ... > > Thanks! > > = Mattia > > > > > > > > > &g...

[wxperl-users] [ wxperl-Bugs-935780 ] WxPerl 0.18 fails to compile with wxGTK 2.5.1
Bugs item #935780, was opened at 2004-04-15 19:21 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=935780&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Philipp Thomas (psmt) Assigned to: Nobody/Anonymous (nobody) Summary: WxPerl 0.18 fails to compile with wxGTK 2.5.1 Initial Comment: When trying to compile WxPerl against wxGTK 2.5.1, g++ stops with an error because in 2.5.1 void wxLogTrace...

[wxperl-users] wxPerl Documentation #2
Regarding wxPerl documentation, please look at the wxGlade/wxPerl demonstration at http://wxglade.sourceforge.net/demo/ It demonstrates the basics of wxGlade with wxPerl and it gives some examples of how to "translate" the wxWidgets documentation for use with wxPerl. I had problems understanding the documentation at first also; however, I now like the fact that I am always going to the core wxWidgets documentation instead of a Perl specific version. For all the controls I have used, the wxPerl exceptions are noted properly in the wxWidgets documentation. The followin...

[wxperl-users] wxPerl Wiki #2
Some <ahem> charming person has attacked the wxPerl Wiki and replaced some of the pages (including the home page, unfortunately) with a bunch of annoying links. Could whoever has control of the server restore it? My project homepage was similarly hacked last week. They get in through the "search" binary, apparently. I simply removed that binary and hopefully that has solved the problem. There's a warning being sent around from the TWiki developers about how the exploit works, and they apparently have a patch available. I just decided that the search...

[wxperl-users] wxPerl 0.22 with wxWidgets 2.5.4
Hi, I just compiled wxWidgets 2.5.4 with mingw (dev cpp) and wxPerl 0.22 on =20 WinXP ActivePerl 5.8.4. The demo workes and some other scripts I tested. But I get some errors while testing and cause it's my first time compilin= g =20 on WinXP (BTW: feels good ;-) ) I don't really know what they mean. Here is the test report. greetz & blessings Manuel ########################### C:\Perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" =20 "test_harness(0, 'bl ib\lib', 'blib\arch')" t\01_load.t t\02_inheritance.t ...

RE: [wxperl-users] Building wxPerl with wxWindows 2.3.1, and usingXML resources #2
Dear Mattia, Thanks for the info - I'm getting further! I've built xrc using: nmake -f makefile.vx FINAL=3D1 to create wxxrc.lib (rather than wxxrcd.lib), and this worked fine. However, when I try building wxPerl, using: nmake=20 perl Makefile.PL nmake=20 I get the following errors (I've snipped sections out to give the gist, as it goes on quite a bit): link -out:..\..\blib\arch\auto\Wx\XRC\XRC.dll -dll -nologo -nodefaultlib -release -libpath:"c:\perl\5.6.1\lib\MSWin32-x86-multi-thread\CORE" -machine:x86 XRC.obj ..\..\blib\arch\auto\Wx\Wx.lib C:\p...

RE: [wxperl-users] Plans for wxPerl 0.23, wxWidgets 2.6.0 #2
Hello, > I tried to compile wxPerl CVS against 2.6.0 and I got the = errors as below. > > I am compiling on WinXP using MSVC6. Should this = work? Have others > successfully compiled? Yes, but with MSVC 5 and= GCC (various versions), not MSVC 6. Are you up to date with MSVC servic= e packs? > C:\Perl\bin\perl.exe C:\Perl\lib\ExtUtils/xsubpp = -noprototypes > -nolinen <snip> > Grid.c(390) : warning C4189: 'CLAS= S' : local variable is initialized but not > referenced > Grid.c(464) := fatal error C1001: INTERNA...

Re:[wxperl-users] wxPerl 0.22 with wxWidgets 2.5.4
Hello, > I just compiled wxWidgets 2.5.4 with mingw (dev cpp) and wx= Perl 0.22 on > WinXP ActivePerl 5.8.4. > The demo workes and some oth= er scripts I tested. > But I get some errors while testing and cause it'= s my first time compiling > on WinXP (BTW: feels good ;-) ) I don't re= ally know what they mean. In this case the error is more of a warnin= g, but I will correct it ASAP. There will be no problems in running any = wxPerl application. Thanks! Mattia =0A=0A=0A=0A____________________= ________________________________________=0A6X...

[wxperl-users] [ wxperl-Feature Requests-1433740 ] New System Setting Constants in 2.6.2
Feature Requests item #1433740, was opened at 2006-02-17 19:06 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=365655&aid=1433740&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Priority: 5 Submitted By: Outaspace (outaspace) Assigned to: Nobody/Anonymous (nobody) Summary: New System Setting ...

Re: [wxperl-users] wxPerl on wxX11 ? #2
> --- John Ralls <jralls@ceridwen.fremont.ca.us> wrote: > > > > > On Jul 11, 2006, at 5:31 PM, Sergei Steshenko wrote: > > > > > Hello All, > > > > > > is it possible to compile wxPerl on wxX11 rather than on wxGTK ? > > > > > > If yes, will it be functional ? > > > > > > Thanks, > > > Sergei. > > > > If wxX11 works (which is to say, if you can build it and run some of = > > the samples), then wxPerl will work fine with it. wxPerl doesn't care= ...

[wxperl-users] Make Test failures on wxPerl 0.21 & wxPython 2.5.3.1 GTK
I've installed 0.21 on my laptop (Mandrake 10.0) and built it against a custom build of wxWidgets 2.5.3 from the wxPython 2.5.3.1 distro. Seems to work OK, except that tests 1 and 2 hang after completing the last test and test 8 segfaults at test 121. Oh, and the NotebookSizer thing kills the demo program... Regards, John Ralls ...

Web resources about - [wxperl-users] [ wxperl-Patches-1015129 ] wxFIXED_MINSIZE added in 2.5.2 - perl.wxperl.users

Resources last updated: 1/6/2016 9:55:11 PM