[wxperl-users] [ wxperl-Bugs-1407418 ] wxPerl crashes in Debug Mode

Bugs item #1407418, was opened at 2006-01-16 16:25
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1407418&group_id=15655

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Outaspace (outaspace)
Assigned to: Nobody/Anonymous (nobody)
Summary: wxPerl crashes in Debug Mode

Initial Comment:
Hi,

I have found a little problem when I try to debug a
wxPerl Script, with my own Debug Script.

I want to print out a Call Stack, so I can see what
functions are called. When I try to print the parameter
of the functions, Perl crashes on some wxWidgets Classes.
Namly they are so far: wxTreeItemId, wxFont,
wxNotebookpage. I dont know if there are more classes
that cause this kind of crash, thats the only I
encountered so far. I had made a workaround for the
first two classes, but then I had a wxPanel, that I
want to add via AddPage() in a Notebook and that I cant
fix without missing lots of info.

It seems that Perl are entering an infinite loop,
trying to get the Info and then crashes. I think that
this has something to do with XS or overloading, but
these are only guesses.

I included my "Debug" Script so you can test this.
To test it just replace the original Perl Debugger with
this script and call: "perl -d scriptname". Just make
shure that the classes mentioned above are used in the
script.


Using : wxPerl 0.25, wxWindows 2.4.2 on Win2000, Perl
5.6.1 (Active State)

I hope this isnt a mayor problem, would be nice if its
going to work.

Thanks for the work so far,

Andre

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1407418&group_id=15655

0
noreply
1/16/2006 3:26:04 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
546 Views

Similar Articles

[PageSpeed] 12

Reply:

Similar Artilces:

[wxperl-users] [ wxperl-Bugs-588884 ] wxperl will not compile
Bugs item #588884, was opened at 2002-07-30 17:13 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=588884&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Dan Stahlke (danstahlke) Assigned to: Nobody/Anonymous (nobody) Summary: wxperl will not compile Initial Comment: I cannot get the wxPerl module to compile. It breaks with this message: c++ -c -I/usr/local/lib/wx/include/gtk-2.3 -I/usr/local/include -I. -fno-rtti -fno-exceptions -O2 -DVERSION=\0.10\ -DXS_VERSION=\...

[wxperl-users] [ wxperl-Bugs-1237847 ] wxPerl does not build with wxUniversal
Bugs item #1237847, was opened at 2005-07-13 23:24 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1237847&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Mattia Barbon (mbarbon) Assigned to: Nobody/Anonymous (nobody) Summary: wxPerl does...

[wxperl-users] [ wxperl-Bugs-1163248 ] wxperl webpage is appalling broken
Bugs item #1163248, was opened at 2005-03-14 12:24 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1163248&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Karl Palsson (kpalsson) Assigned to: Nobody/Anonymous (nobody) Summary: wxperl webpage is appalling broken Initial Comment: Despite loudly proclaiming to be XHTML 1.0 and having the link to invite users to prove it http://validator.w3.org/che...

[wxperl-users] [ wxperl-Bugs-1544543 ] http://www.wxperl.de/
Bugs item #1544543, was opened at 2006-08-22 14:49 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1544543&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Stephan Springer (tengai) Assigned to: Nobody/Anonymous (nobody) Summary: http://ww...

[wxperl-users] wxPerl Wiki => wxPerl Kwiki
Hello all, Once upon a time I installed a Wiki, called it the wxPerl Wiki and didn't look at it anymore. I noticed that only a few people use it, it's been hacked a few times, and to make it work, at least yours truly should put more time and effort in it. This morning I started installing Kwiki, which is a far better Wiki platform than the Wiki that was installed. Apart from the UserPreferences page (working on it), everything works as it should. However, the data people entered in the old Wiki can't be converted to Kwiki automatically. Therefore I need your ...

[wxperl-users] [ wxperl-Bugs-1237845 ] Crash with PerlApp
Bugs item #1237845, was opened at 2005-07-13 23:23 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1237845&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: Build Group: None Status: Open Resolution: None Priority: 5 Submitted By: Mattia Barbon (mbarbon) Assigned to: Mattia Barbon (mbarbon) Summary: Crash with P...

[wxperl-users] [ wxperl-Bugs-1014484 ] wxGrid crashes
Bugs item #1014484, was opened at 2004-08-23 10:01 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1014484&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: wxGrid crashes Initial Comment: when trying to call SetCellValue() on a Grid object with an empty string, i receive a crash error. this is on wxPerl 0.19 with wxWidgets...

[wxperl-users] [ wxperl-Bugs-1508063 ] WxPerl on DMG causes grief on Intel Mac
Bugs item #1508063, was opened at 2006-06-18 02:56 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1508063&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: WxPerl on...

[wxperl-users] [ wxperl-Bugs-1460615 ] EVT_GRID_CMD_CELL_CHANGE possible typo in wxPerl 0.26
Bugs item #1460615, was opened at 2006-03-29 13:56 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1460615&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Manuel Renz (pfuschi) Assigned to: Nobody/Anonymous (nobody) Summary: EVT_GRID_CMD_...

[wxperl-users] [ wxperl-Bugs-449415 ] wxPerl 0.04 warnings in toolbar.pl sampl
Bugs item #449415, was opened at 2001-08-09 01:07 You can respond by visiting: http://sourceforge.net/tracker/?func=detail&atid=115655&aid=449415&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: wxPerl 0.04 warnings in toolbar.pl sampl Initial Comment: For all bitmaps in the sample Perl prints these warnings: Argument "bitmaps/print.bmp" isn't numeric in addition (+) at D:/Perl/site/lib/Wx.pm line 147. Use of uninitializ...

[wxperl-users] wxPerl CLI crash
Hi All, I've just noticed this and wondered if anybody else had experienced anything similar or had some advice (my searches through the list archives didn't turn up anything, but it's possible I missed it). System Configuration: Win2k SP3 ActivePerl/Win32 build 635 and build 806 wxPerl PPM 0.15, w/ Unicode support, for both perl 5.6 and 5.8 And when I execute this simple script from the command line: use Wx; use strict; my $dlg = Wx::FileDialog->new(undef); $dlg->ShowModal(); Perl crashes. The information I get from windows isn't terribl...

[wxperl-users] Patch for debugging wxPerl
I have found that when I use the perl debugger to debug wxPerl programs, the program hangs when I quit using 'q'. What I now do is to set up the environment variable PERL_QUIT_KILL. I patched perl5db.pl for the 'q' command, so that it kills itself rather than exit. It seems to work on Linux and Windows. Comments? $cmd =~ /^q$/ && do { if ($ENV{PERL_QUIT_KILL}) { kill 9, $$ ; } $fall_off_end = 1; clean_ENV(); exit $?; }; Peter ...

Fwd: wxPerl on the Mac; was: [wxperl-users] Re: problems with wxPerl
>To: Jouke Visser <jouke@pvoice.org>, wxperl-users@lists.sourceforge.net >From: Christian Jaeger <christian.jaeger@sl.ethz.ch> >Subject: wxPerl on the Mac; was: [wxperl-users] Re: problems with wxPerl >Date: Sun, 30 Sep 2001 23:08:19 +0100 > >Hello, > >I'm crossposting this reply to the macosx-perl mailing list because >there is some interest, too. Actually I forgot to put the macosx-perl adress on it. >At 14:02 Uhr +0200 24.9.2001, Jouke Visser wrote: >>I wondered if anyone yet tried to compile wxPerl on a Mac. If not, I'...

[wxperl-users] [ wxperl-Bugs-667032 ] ListCtrl drag item crashes
Bugs item #667032, was opened at 2003-01-12 23:51 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=667032&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: ListCtrl drag item crashes Initial Comment: Hi. This problem was observed to occur on Windows 98 SE, running wxPerl 0.12 under ActivePerl 5.6.1. If you make a non-empty listctrl, select one or more items in the list and then try to drag them ...

Web resources about - [wxperl-users] [ wxperl-Bugs-1407418 ] wxPerl crashes in Debug Mode - perl.wxperl.users

Resources last updated: 1/4/2016 9:51:02 PM