[wxperl-users] wxperl-0.15 does not compile on mandrake 9.1

Hello,

on mandrake 9.1 i tried to use the build rpm with "--nodeps" option howeve=
r due to diffrent file locations
between redhat and mandrake it seems not to work even with some work aroun=
d.=20

I tried to build wxperl0-15  from source . The "make"  stops  at the dnd.c=
 file with the error  message:

c++ -c  -I. -I/usr/lib/wx/include/gtk2-2.4 -I../.. -I/home/dakna/rpm/BUILD=
/Wx-0.
15/..//contrib/include -O2 -fomit-frame-pointer -pipe -march=3Di586 -mcpu=3Dpe=
ntiump
ro   -DVERSION=3D\"0.01\" -DXS=5FVERSION=3D\"0.01\" -fpic "-I/usr/lib/perl5/5.8.=
0/i386
-linux-thread-multi/CORE"  -DWXPL=5FEXT -DGTK=5FNO=5FCHECK=5FCASTS -D=5F=5FWXGTK=5F=5F -D=5F=
FILE=5FO
FFSET=5FBITS=3D64 -D=5FLARGE=5FFILES  DND.c
DND.c: In function `void XS=5FWx=5F=5FDataFormat=5FnewNative(PerlInterpreter*, CV*=
)':
DND.c:231: cannot convert `wxDataFormatId' to `=5FGdkAtom*' in assignment
make[2]: *** [DND.o] Error 1

does any one knows how to fix it.=20
Thanks
MD

=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F=5F
Mit der Grupppen-SMS von WEB.DE FreeMail k=F6nnen Sie eine SMS an alle=20
Freunde gleichzeitig schicken: http://freemail.web.de/features/=3Fmc=3D021179



0
mdakna
6/19/2003 4:03:08 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

1 Replies
466 Views

Similar Articles

[PageSpeed] 26

On Thu, 19 Jun 2003 18:02:06 +0200 Mohammed Dakna <mdakna@web.de> wrote:

> Hello,
  Hello,

> on mandrake 9.1 i tried to use the build rpm with "--nodeps" option
> however due to diffrent file locations
> between redhat and mandrake it seems not to work even with some work
> around. 
> 
> I tried to build wxperl0-15  from source . The "make"  stops  at the
> dnd.c file with the error  message:
> 
> c++ -c  -I. -I/usr/lib/wx/include/gtk2-2.4 -I../..
> -I/home/dakna/rpm/BUILD/Wx-0.
> 15/..//contrib/include -O2 -fomit-frame-pointer -pipe -march=i586
> -mcpu=pentiump
> ro   -DVERSION=\"0.01\" -DXS_VERSION=\"0.01\" -fpic
> "-I/usr/lib/perl5/5.8.0/i386
> -linux-thread-multi/CORE"  -DWXPL_EXT -DGTK_NO_CHECK_CASTS -D__WXGTK__
> -D_FILE_O
> FFSET_BITS=64 -D_LARGE_FILES  DND.c
> DND.c: In function `void XS_Wx__DataFormat_newNative(PerlInterpreter*,
> CV*)':
> DND.c:231: cannot convert `wxDataFormatId' to `_GdkAtom*' in assignment
> make[2]: *** [DND.o] Error 1
> 
> does any one knows how to fix it. 
  Your wxWIndows was compiled against GTK 2, and I can't test it (I only
have GTK 1.2). As a workaround, if you don't need Clipboard/Drag'n'Drop
support, you can just do "perl Makefile.PL --disable-dnd" to skip it.

HTH
Mattia



0
mbarbon
6/20/2003 9:50:04 PM
Reply:

Similar Artilces:

[wxperl-users] [ wxperl-Bugs-935780 ] WxPerl 0.18 fails to compile with wxGTK 2.5.1
Bugs item #935780, was opened at 2004-04-15 19:21 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=935780&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Philipp Thomas (psmt) Assigned to: Nobody/Anonymous (nobody) Summary: WxPerl 0.18 fails to compile with wxGTK 2.5.1 Initial Comment: When trying to compile WxPerl against wxGTK 2.5.1, g++ stops with an error because in 2.5.1 void wxLogTrace...

[wxperl-users] [ wxperl-Bugs-794428 ] could not compile 0.15 on RH9
Bugs item #794428, was opened at 2003-08-24 20:38 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=794428&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Jim Liedeka (jliedeka) Assigned to: Nobody/Anonymous (nobody) Summary: could not compile 0.15 on RH9 Initial Comment: has a lot of lines like this: invalid use of undefined type `struct wxStyledTextCtrl' cpp/st_typedef.h:20: forward declara...

[wxperl-users] Compile problems for wxPerl 0.10 on OS X 10.1.3
Hello all. As I said before, I compiled and installed wxMac 2.3.2 without problems. The samples look nice :). However, I had problems compiling wxPerl 0.08. Mattia sent me a workout, and that didn't work. 0.10 came around, and I tried that. Still doesn't work, but the wxTimer error from before doesn't occur. Please tell me what i can do (maybe send compile logs?) to help. Matt _____________________________________________________________ Run a small business? Then you need professional email like you@yourbiz.com from Everyone.net http://www.everyone.net?tag Is it possi...

[wxperl-users] [ANNOUNCE] wxPerl 0.15
A new version of wxPerl, the Perl bindings to wxWindows, is out! You can download the source from CPAN. Screenshots: http://wxperl.sourceforge.net/sshot01.html Binary packages for ActivePerl/Win32 6xx and 8xx builds, and Red Hat Linux are available along with documentation in HTML and MS HTML Help format from http://wxperl.sourceforge.net/download.html Changes since the last version: - Removed support for wxWindows 2.2.x and 2.3.x. - Removed support for Perl 5.004. - Started documentation for the extension api (see Wx/Api.pod). - Added...

[wxperl-users] [ wxperl-Bugs-588884 ] wxperl will not compile
Bugs item #588884, was opened at 2002-07-30 17:13 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=588884&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Dan Stahlke (danstahlke) Assigned to: Nobody/Anonymous (nobody) Summary: wxperl will not compile Initial Comment: I cannot get the wxPerl module to compile. It breaks with this message: c++ -c -I/usr/local/lib/wx/include/gtk-2.3 -I/usr/local/include -I. -fno-rtti -fno-exceptions -O2 -DVERSION=\0.10\ -DXS_VERSION=\...

Re: [wxperl-users] Compile problems for wxPerl 0.10 on OS X 10.1.3
I just downloaded the latest CVS snapshot, and it compiles. However, it doesn't work. I sent Mattia a log of output from `make test`, so maybe some workaround can be done... Matt --- Jouke Visser <jouke@pvoice.org> wrote: >On Tue, Mar 12, 2002 at 08:56:18PM +0100, Mattia Barbon wrote: >> > Hello all. As I said before, I compiled and installed wxMac 2.3.2 without problems. The samples look nice :). However, I had problems compiling wxPerl 0.08. Mattia sent me a workout, and that didn't work. 0.10 came around, and I tried that. Still doesn't work, but the wx...

[wxperl-users] wxPerl on SuSE Linux 9.0
--0OAP2g/MAC+5xKAE Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Hello list! I just compiled wxPerl (current CVS) on SuSE Linux 9.0 (comes with wxGTK-2.4.1.2 and Perl-5.8.1). The compiler is GCC 3.3.1 and I had to apply the attached patch file to wxPerl. Without the #undef in wxapi.h, I got a lot of errors about macros with to few arguments. I'm not really sure, if this is a problem of the standard C++ library, so a better #ifdef should probably go around the #undef before checking the patch in. The other change in ext/docview/cpp/docview.h is a ...

[wxperl-users] compile wxperl on SLES 8.0
Hello! I try to compile wxPerl (Wx-0.13) on SUSE LINUX Enterprise Server.=20 Perl version: 5.8.0 wxgtk-2.4-config --version says: 2.4.0 After a while the build stops with the following error message: make[3]: Entering directory `/home/admin/wxperl/Wx-0.13/ext/pperl/carp' Array found where operator expected at /usr/lib/perl5/5.8.0/warnings.pm l= ine=20 294, at end of line (Missing operator before ?) syntax error at /usr/lib/perl5/5.8.0/warnings.pm line 294, near "croak @_= " Compilation failed in require at /usr/lib/perl5/5.8.0/warnings/register.p= m=...

[wxperl-users] Re:Some difficulty compiling wxPerl 0.26
Hello, in general, it is a good idea to send questions to wxperl-users@lists.sorceforge.net (CCd); I have limited connectivity these days. > I've tried to build and install wxPerl 0.26, but have come across a > compilation error. My system is Mandriva Linux 10.2. I have wxGTK 2.5.3= > installed. 'make' ran very cleanly until it got to compiling Constant.c= .. > The output is shown below: > > Constant.c: In function `double constant(const char*, int)': > Constant.c:640: error: `wxBUFFER_VIRTUAL_AREA' undeclared (first use th= is >...

[wxperl-users] failed dependencies installing wxPerl 0.15
when trying to install wxPerl 0.15 from RPM , I get this error: error: Failed dependencies: perl(Wx::Wx_Exp) is needed by perl-Wx-0.15-1 perl(Wx::_Constants) is needed by perl-Wx-0.15-1 perl(Wx::_Functions) is needed by perl-Wx-0.15-1 and when tring via CPAN or by manually doing a perl Makefile.PL i am getting this error: cpp/st_constants.cpp:637: `wxSTC_VISIBLE_SLOP' undeclared (first use this function) cpp/st_constants.cpp:638: `wxSTC_VISIBLE_STRICT' undeclared (first use this function) cpp/st_constants.cpp:641: `wxSTC_WRAP_NONE' un...

[wxperl-users] [ wxperl-Bugs-1460615 ] EVT_GRID_CMD_CELL_CHANGE possible typo in wxPerl 0.26
Bugs item #1460615, was opened at 2006-03-29 13:56 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=1460615&group_id=15655 Please note that this message will contain a full copy of the comment thread, including the initial issue submission, for this request, not just the latest update. Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Manuel Renz (pfuschi) Assigned to: Nobody/Anonymous (nobody) Summary: EVT_GRID_CMD_...

[wxperl-users] wxPerl 0.49_01
Hello, this is te first beta release depending on Alien::wxWidgets. You should be able to install wxPerl from CPAN even if wxWidgets is not installed yet (provided you have a compiler, of course): Alien::wxWidgets will ask if you want to build wxWidgets from sources. Regards Mattia Mattia, There are a few files missing from Wx-0.49_01.tar.gz. (I grabbed it off pause) 1. the whole of directory \ext\media 2. \ext\datetime\XS\DateSpan.xsp 3. \ext\datetime\XS\TimeSpan.xsp Once these are added from CVS, the build works fine for me (VC6 , wxWidgets 2.6.3) with &#...

[wxperl-users] wxPerl 0.20
Hello, this is a source-only release that should solve all wxWidgets 2.5.2-related problems reported until now. Regards Mattia C:\Perl\.cpanplus\5.8.3\build\Wx-0.20>perl Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for Wx::Grid Writing Makefile for Wx::STC Writing Makefile for Wx::Print Writing Makefile for Wx::DateTime Writing Makefile for Wx::Calendar Writing Makefile for Wx::DND Writing Makefile for Wx::Socket Writing Makefile for Wx::Html Writing Makefile for Wx::Help Writing Makefile for Wx::DocView Writing Makefile for Wx::XRC ...

[wxperl-users] wxPerl 0.24
Hello, I hope to have it uploaded by tomorrow. It fixes: - A problem when running with PAR on Linux - The crash on bitmap load on Win95 reported by Nick Johnston and a similar (possibly the same) crash when loading a bitmap on WinXP - The problem with Wx::Log::SetTimestamp reported by Johan Vromans - The fact that Wx::Menu::Append should return a Wx::MenuItem with wxWidgets 2.6.x. Just a bugfix release (it will not be available for Mac unless somebody asks for it). Regards Mattia ...

Web resources about - [wxperl-users] wxperl-0.15 does not compile on mandrake 9.1 - perl.wxperl.users

O'Reilly Open Source Convention 2007 • July 23-27, 2007 • Portland, Oregon
O'Reilly Open Source Convention 2007 - July 23-27, 2007 - Portland, Oregon

Resources last updated: 12/1/2015 8:48:52 AM