[wxperl-users] Ubuntu wxPerl 0.65 with wxWidgets 2.8.0

I managed to get wxPerl 0.65 to build against the new wxWidgets 2.8.0.

I used the Ubuntu wxWidgets binaries for 2.8.0 
(http://www.wxwidgets.org/downloads/), but had a few problems with 
Alien::WxWidgets:

mike@mbs:~/downloads/Alien-wxWidgets-0.25$ perl Build
'animate' library not found at inc/My/Build/Any_wx_config.pm line 141.
'deprecated' library not found at inc/My/Build/Any_wx_config.pm line 141.

So I added this line to inc/My/Build/Any_wx_config.pm:

    next if $k =~ m/^animate|deprecated$/;

just to see if things would build, etc.  After that everything worked 
fine.  Not the most elegant fix :-/   but hopefully gives a clue to 
those who are in the know...

BTW, I now have an Ubuntu binary Wx-0.65 against wxWidgets 2.8.0 
(wxperl_0.65-1_i386.deb) if anyone wants it, just let me know...


Mike.




0
MikeSchroeder
12/14/2006 5:11:29 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
436 Views

Similar Articles

[PageSpeed] 15

Reply: