[wxperl-users] From whence "Wx::App Error" "Fatal error: exiting"?

This is a multi-part message in MIME format.

------_=_NextPart_001_01C48798.98A9B782
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

I tried to send this message some months ago (early May), but for some
reason at that time I was unable to send to the wxPerl mailing list.  It
seems to be working now, so . . .

I'm stumbling around trying to find a single, fail-free method for
exiting a running wxPerl app that may or may not have open frames.  The
Perl functions "exit" and "die" seem vulnerable to problems with Perl
exiting (I keep getting the obnoxious Microsoft "Can I send in an error
report" dialog box).  Wx::Exit functions, except that it pops up a
dialog box captioned "Wx::App Error" with the body "Fatal error:
exiting".  Is there any way to suppress that dialog box?  I'm in a
situation where there may or may not be other Wx::Frame or Wx::Dialog
objects, and I'd like the code to be independent of any specific
knowledge about the status of the application.  I've been testing using
wxPerl-0.19-wx-2.4.2-win32-u-5.8.3 in conjunction with both 5.8.3.809
and 5.8.4.810.  Any hints?

--Toby Ovod-Everett

------_=_NextPart_001_01C48798.98A9B782
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Dus-ascii">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
6.0.6487.1">
<TITLE>From whence &quot;Wx::App Error&quot; &quot;Fatal error: =
exiting&quot;?</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/rtf format -->

<P ALIGN=3DLEFT><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">I</FONT></SPAN><SPAN LANG=3D"en-us"> <FONT SIZE=3D2 =
FACE=3D"Arial">tried to send this message some months ago (early May), =
but for some reason at that time I was unable to send to the wxPerl =
mailing list.&nbsp; It seems to be working now, so . . =
..</FONT></SPAN></P>

<P ALIGN=3DLEFT><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">I&#8217;m stumbling around trying to find a single, =
fail-free method for exiting a running wxPerl app that may or may not =
have open frames.&nbsp; The Perl functions &#8220;exit&#8221; and =
&#8220;die&#8221; seem vulnerable to problems with Perl exiting (I keep =
getting the obnoxious Microsoft &#8220;Can I send in an error =
report&#8221; dialog box).&nbsp; Wx::Exit functions, except that it pops =
up a dialog box captioned &#8220;Wx::App Error&#8221; with the body =
&#8220;Fatal error: exiting&#8221;.&nbsp; Is there any way to suppress =
that dialog box?&nbsp; I&#8217;m in a situation where there may or may =
not be other Wx::Frame or Wx::Dialog objects, and I&#8217;d like the =
code to be independent of any specific knowledge about the status of the =
application.</FONT></SPAN><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">&nbsp; I</FONT></SPAN><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">&#8217;</FONT></SPAN><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">ve been testing using</FONT></SPAN><SPAN LANG=3D"en-us"> =
<FONT SIZE=3D2 =
FACE=3D"Arial">wxPerl-0.19-wx-2.4.2-win32-u-5.8.3</FONT></SPAN><SPAN =
LANG=3D"en-us"><FONT SIZE=3D2 FACE=3D"Arial"> in conjunction with both =
5.8.3.809 and 5.8.4.810.&nbsp; Any hints?</FONT></SPAN><SPAN =
LANG=3D"en-us"></SPAN></P>

<P ALIGN=3DLEFT><SPAN LANG=3D"en-us"><FONT SIZE=3D2 =
FACE=3D"Arial">--Toby Ovod-Everett</FONT></SPAN></P>

</BODY>
</HTML>
------_=_NextPart_001_01C48798.98A9B782--

0
tovod
8/21/2004 4:06:02 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

0 Replies
883 Views

Similar Articles

[PageSpeed] 16

Reply:

Similar Artilces:

myDiv.style["display"]="none"; gives me an error while using a div in a User Control: Syntax error
Hi I have this part of my ascx user control that gives me a client side error : Syntax error <DIV id="dvRecurant"><asp:textbox id="txtFoisRecurant" tabIndex="7" runat="server" Height="20px"> </DIV> <script language="javascript">dvRecurant.style["display"]="none"</script>Thanks a lot, I appreciate your taking the time to help me. The the following client-side code: dvRecurant.style.display="none";/Fredrik Normén - fredrikn @ twitterMicrosoft MVP, MCSD, MCAD, MCTASPInsidersMy Blog Try:dvRecurant.style.display="none";Hope this helps. Home Is Where the...

Precedence of "where" ("of", "is", "will")?
Nobody on #perl6 today could answer this one. Is: Str | Int where { $_ } the same as: (Str | Int) where { $_ } or: Str | (Int where { $_ }) ? Followup questions, Mr. President: What kind of operators are "where", "of", "is", and "will"? Is there a reason that S03 doesn't list them? What are their precedence(s)? -- Chip Salzenberg - a.k.a. - <chip@pobox.com> Open Source is not an excuse to write fun code then leave the actual work to others. Chip Salzenberg writes: &...

.ALLCOL("%COLUMN%", " ", ", ", ", ")
Do you know anyway for me to exclude a subset of columns returned by this function. We have two columns (rec_user and rec_datetime) which are in all of our tables, but when generating triggers I want automatically generate a script which does not include those two columns but does include all other columns in that table. Bruce I should add that I am using PD 9.0.0.580. Bruce "Bruce Lamb" <lamb.bruce@mayo.edu> wrote in message news:6HgI315nCHA.155@forums.sybase.com... > Do you know anyway for me to exclude a subset of columns returned by this > function. ...

[wxperl-users] wxPerl "weirdness"
Hey Guys, I'm wondering if anyone has gotten results anything like I'm getting. I can change very little things in a program, and it will cause wxPerl to crash. Also, I added an event and now default text shows up as *'s. I know I'm being very non-specific, I'm just wondering if anyone else has had weird things happen like this. I'd be happy to send off my code for perusal. I *am* running on XP Pro, would that be a problem? TIA -Casey Williams Ok, I'll work on putting something together. This is a straight script without Perlapp. I fixed...

[wxperl-users] [ wxperl-Bugs-851065 ] Wx::CalendarCtrl not included in "use Wx qw(:everything)"
Bugs item #851065, was opened at 2003-11-29 00:03 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=851065&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Nobody/Anonymous (nobody) Assigned to: Nobody/Anonymous (nobody) Summary: Wx::CalendarCtrl not included in "use Wx qw(:everything)" Initial Comment: I'm on Windows 2000, using ActiveState ActivePerl 5.8.0.806 and wxPerl 0.18 with wxWi...

Unauthorized users getting "Index of /xxxx" directory instead of "Unauthorized" error.
--____LPHMXLZMXOMRLFKSEJCW____ Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: quoted-printable Hi,=20 A user has to authenticate to get to a directory. If they have rights, = they get in. If they *don't* have rights, they are presented with the = Index of /xxxx directory. (Which they can't do anything anyway...) Any = clues as to what I need to do to the httpd.config file, etc to make them = get the "Unauthorized" error message instead of the directory index?=20 Thanks in advanced.=20 Tommie Sue --____LPHMXLZMXOMRLFKSEJCW____ Content...

"Error Group: WINSOCK" "Error Code:11004"
Hi Just setup iPrint on the server and tried to install the printer to the laptop and got the following message: Error code:11004 Error message: Winsock 11004 - The DNS name has been found in the database, but its associated data is not correct. Error group: WINSOCK Error code:11004 Anyone know what associated data it is referring to? Thanks in advance -- iangh2 A quick Google found this on http://www.sockets.com/err_lst1.htm WSANO_DATA (11004) Valid name, no data record of requested type Berkeley description: The requested name is valid, but does not hav...

quotes, quotes, quotes...
I am getting this error and I know what is causing it, but I have no idea how to fix it, any help would be great. The script steps through the /var/log/messages file on a linux server and puts The entries into a mysql database. However when it gets to the 'hlt' line in the messages file it just barfs. The single quotes are freaking it out. I know about quotes but not how to use in this situation. Thanks, Paul Error: May 27 17:53:00 localhost kernel: Checking 'hlt' instruction... OK. <----- doesn't like this in the messages file DBD::mysql::st exec...

"Assign To", "QA Contact", "CC" how manage users ?
Hi My bugzilla have many projects, when user is adding bug, he got weird-long list "Assign To", "QA Contact", "CC". Only when user is not in any group, he is not in lists. How can i limit that ? projects 1 2 users q w e r t y When user q is adding bug in project 1, he got list ("Assign To", "QA Contact", "CC") like that: q, w, ...

unbalanced "/" before "switch" statement cause fatal error
Hi, I was going to report this as a bug in Switch, after spending over an hour debugging why a script was failing compilation. Then I saw it was already reported... over a year ago :( http://rt.cpan.org/NoAuth/Bug.html?id=3D5607 Any chance of this being fixed? Thanks, -- Offer Kaye On 11/23/05, Offer Kaye wrote: > I was going to report this as a bug in Switch, after spending over an > hour debugging why a script was failing compilation. Then I saw it was > already reported... over a year ago :( > > http://rt.cpan.org/NoAuth/Bug.html?id=3D5607 > > Any...

"Locked By Unknown User" and "Can not get user info" ...
Similar problem to one posted earlier. I have an HTML file as part of a PowerSite project with a status of "Locked by unknown user". The file size is 2K. When I try and delete the file from the project, I get the second message of "Can not get user info". I have deleted this file from the <orphaned items> project hoping this may help, but I am unable to get past the "Can not get user info" message. I have tried recycling the component manager and restarting my NT 4.0 machine. Any ideas ? Mike PowerSite 1.0 NT 4.0 SP3 Hi ! Try following u...

"Error on page" when clciking "Jobs" in "Printer Control" with iManager
Hello all, I have the following issue in iManager : when I click on "Jobs" in "Printer Control" tab for a printer object, I have the following error message : "Error on page"/"Done with Error" in the left down corner of my Internet Explorer (v6.0) If I double click on the error message, I have either "Expected ')'" or "Object Expected" in the error description window. What surprise me is the fact that it occurs only on printers from one of our four NDPSM. (This is why I didn't post on the imanager forum) Tho...

Error when using Masterpage "asp:content" with a user web control page containing "ajaxToolkit:AccordionPane"
I got this error "Sys.WebForms.PageRequestManagerServerErrorException: An unknown error occurred while processing the request on the server. The status code returned from the server was: 400" when i tried to use my control web page (witch contain an ajaxToolkit) in a Masterpage with "ContentPlaceHolder" the problem is that when i use this control witout in masterpage it work good. Here is my ascx page(control page);<%@ Control Language="C#" AutoEventWireup="true" CodeFile="indexation.ascx.cs" Inherits="inde...

"ApplicationException("Error: ......");
hi,I was wondering if somebody could tell me what happens when I write "throw new ApplicationException("Error: .......");"I don't know where is this exception written too. Could somebody explain me this please. Thank you...Sanch Try it and you will quickly find you what happens....

Web resources about - [wxperl-users] From whence "Wx::App Error" "Fatal error: exiting"? - perl.wxperl.users

O'Reilly Open Source Convention 2007 • July 23-27, 2007 • Portland, Oregon
O'Reilly Open Source Convention 2007 - July 23-27, 2007 - Portland, Oregon

Resources last updated: 1/4/2016 2:00:19 PM