[wxperl-users] Compiling on Win32 with MingW wx2.3.2 and snapshot wxperl 0.11

This is a multi-part message in MIME format.

------=_NextPart_000_0023_01C1EA25.F49F3A90
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

I'm trying to compile wxperl 0.11 with MingW and wxWindows 2.3.2

All the compilation of objects are fine, but when the link are made A =
lot of functions doesn't have references!!!

- wx2.3.3 are needed?!
- the library libwxmsw232.a are libwx.a?
- why make looks for libwxmsw232.a using the base dir -> =
/lib/libwxmsw232.a ?



------=_NextPart_000_0023_01C1EA25.F49F3A90
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 5.50.4207.2601" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>I'm trying to compile wxperl 0.11 with =
MingW and=20
wxWindows 2.3.2</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>All the compilation of objects are =
fine, but when=20
the link are made A lot of functions doesn't have =
references!!!</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>- wx2.3.3 are needed?!</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>- the library libwxmsw232.a are=20
libwx.a?</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>- why make looks for libwxmsw232.a =
using the base=20
dir -&gt; /lib/libwxmsw232.a ?</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV></BODY></HTML>

------=_NextPart_000_0023_01C1EA25.F49F3A90--


0
gm
4/22/2002 8:36:27 PM
perl.wxperl.users 3070 articles. 0 followers. Follow

1 Replies
323 Views

Similar Articles

[PageSpeed] 44

[ please set word wrap so ~75 columns, also don't send HTML, just plain text
  thanks! ]

> I'm trying to compile wxperl 0.11 with MingW and wxWindows 2.3.2
> 
> All the compilation of objects are fine, but when the link are made
> A lot of functions doesn't have references!!!

> - wx2.3.3 are needed?!
> - the library libwxmsw232.a are libwx.a?
> - why make looks for libwxmsw232.a using the base dir -> /lib/libwxmsw232.a ?
I didn't notice the build instructions were incomplete, sorry

build wxWindow as a dll:
cd z:\path\to\wxdir\src\msw
make -f makefile.g95 clean 
make -f makefile.g95 WXMAKINGDLL=1

cd w:\path\to\wxPerl
set WXDIR=z:/path/to/wxdir
set WXWIN=z:/path/to/wxdir
perl Makefile.PL 
make

should work; if not feel free to contact me off list

Regards
Mattia


0
mbarbon
4/22/2002 9:02:08 PM
Reply:

Similar Artilces:

[wxperl-users] wxPerl 0.11 *beta* + wxWindows 2.3.3 *snapshot* available
This is a Win32-only binary snapshot. Use only if you know you need it. http://wwwstud.dsi.unive.it/~mbarbon/wx/ Regards mattia ...

[wxperl-users] [ wxperl-Bugs-935780 ] WxPerl 0.18 fails to compile with wxGTK 2.5.1
Bugs item #935780, was opened at 2004-04-15 19:21 Message generated for change (Tracker Item Submitted) made by Item Submitter You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=935780&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Philipp Thomas (psmt) Assigned to: Nobody/Anonymous (nobody) Summary: WxPerl 0.18 fails to compile with wxGTK 2.5.1 Initial Comment: When trying to compile WxPerl against wxGTK 2.5.1, g++ stops with an error because in 2.5.1 void wxLogTrace...

[wxperl-users] Compiling wxPerl with MinGW
Hello, there seems to be quite a lot of interest on this topic :-) here are the instructions. Download and install MinGW; I suggest using the all-in-one package [1]. Note: I do not use it myself, but it should work w/o problems. Otherwise just take the single packages for gcc-core, gcc-g++, MinGW runtime, Windows API, binutils, make from [2] and unpack them all in a single directory. Put the directory $MINGW\bin in the path. Do *NOT* download MSYS. Download and install dmake [3] (you can also use the freely downloadable nmake version from Microsoft). Download ExtUtils...

[wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
I've just built wxPerl 0.20 as indicated in the subject, and I had a few issues: First, the syntax for wx-config used in Any_wx_config.pm::get_core_libs_25 seems to have changed: Instead of "--libs=list" it's now "--libs list". Next, Makemaker is building the root Makefile with both blibdirs: and blibdirs::. That produces an error. Changing the single colon to a double colon fixes the problem, but it has to be done every time one runs Makefile.PL. I couldn't figure out where to fix it in the MakeMaker files. Last, could you take out the...

[wxperl-users] wxPerl 0.11 "soon" #2
Mattia wrote: >Of course if someone (hi, Marcus), has some work he can't finish >before the weekend, I can delay the release (it may be delayed anyway, >since I have a lot of platforms/perl versions to test). Thanks for letting me know. I don't have anything new since what I sent you, so you can go ahead and incorpate those additions. I first need to switch the regular TextCtrl in my app with STC before I can continue. We should benefit from a real life app and the user feedback it will hopefully generate. Marcus ...

Re:[wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> I've just built wxPerl 0.20 as indicated in the subject, and I had a =0D = > few issues: > > First, the syntax for wx-config used in > Any_wx_c= onfig.pm::get_core_libs_25 seems to have changed: Instead of > "--libs=3D= list" it's now "--libs list". yes, it was changes in wxWidgets CVS l= ast week. > Next, Makemaker is building the root Makefile with both b= libdirs: and Which MakeMaker version? If 6.22, downgrade to 6.17 or= use the snapshot at makemaker.org. > blibdirs::. That produces an = error. Cha...

Re: [wxperl-users] wxPerl-0.20 Source Build on OSX.3.5/wxPython 2.5.2.7
> MakeMaker 6.21. Sorry. Below I meant to write: "If 6.21, downgrad= e to 6.17 or use the snapshot at makemaker.org." ^^^^ Regards=0D = Mattia > On Aug 18, 2004, at 11:56 PM, mattia.barbon@libero.it wrote:=0D = > ''' > >> Next, Makemaker is building the root Makefile with both blibd= irs: and > > > > Which MakeMaker version? If 6.22, downgrade to 6.17 = or > > use the snapshot at makemaker.org. > > > ... > > Thanks! > > = Mattia > > > > > > > > > &g...

RE: [wxperl-users] Plans for wxPerl 0.23, wxWidgets 2.6.0 #2
Hello, > I tried to compile wxPerl CVS against 2.6.0 and I got the = errors as below. > > I am compiling on WinXP using MSVC6. Should this = work? Have others > successfully compiled? Yes, but with MSVC 5 and= GCC (various versions), not MSVC 6. Are you up to date with MSVC servic= e packs? > C:\Perl\bin\perl.exe C:\Perl\lib\ExtUtils/xsubpp = -noprototypes > -nolinen <snip> > Grid.c(390) : warning C4189: 'CLAS= S' : local variable is initialized but not > referenced > Grid.c(464) := fatal error C1001: INTERNA...

[wxperl-users] Compile problems for wxPerl 0.10 on OS X 10.1.3
Hello all. As I said before, I compiled and installed wxMac 2.3.2 without problems. The samples look nice :). However, I had problems compiling wxPerl 0.08. Mattia sent me a workout, and that didn't work. 0.10 came around, and I tried that. Still doesn't work, but the wxTimer error from before doesn't occur. Please tell me what i can do (maybe send compile logs?) to help. Matt _____________________________________________________________ Run a small business? Then you need professional email like you@yourbiz.com from Everyone.net http://www.everyone.net?tag Is it possi...

[wxperl-users] [ANNOUNCE] wxPerl 0.11
A new version of wxPerl, the Perl bindings to wxWindows is out! You can download the source from http://prdownload.sourceforge.net/wxperl/Wx-0.11.tar.gz Binary packages for ActivePerl/Win32 6xx builds, Redhat Linux 7.1 and Debian GNU/Linux 3.0 are available along with documentation in HTML and MS HTML Help format from http://sourceforge.net/project/showfiles.php?group_id=15655 and http://wxperl.sourceforge.net/ Changes since the last version: - wxStyledTextControl, based on Scintilla (thanks to Marcus Friedlaender) - Wx::Perl::SplashFast, for faster splash screens (...

[wxperl-users] [ wxperl-Bugs-588884 ] wxperl will not compile
Bugs item #588884, was opened at 2002-07-30 17:13 You can respond by visiting: https://sourceforge.net/tracker/?func=detail&atid=115655&aid=588884&group_id=15655 Category: None Group: None Status: Open Resolution: None Priority: 5 Submitted By: Dan Stahlke (danstahlke) Assigned to: Nobody/Anonymous (nobody) Summary: wxperl will not compile Initial Comment: I cannot get the wxPerl module to compile. It breaks with this message: c++ -c -I/usr/local/lib/wx/include/gtk-2.3 -I/usr/local/include -I. -fno-rtti -fno-exceptions -O2 -DVERSION=\0.10\ -DXS_VERSION=\...

Re: [wxperl-users] Compile problems for wxPerl 0.10 on OS X 10.1.3
I just downloaded the latest CVS snapshot, and it compiles. However, it doesn't work. I sent Mattia a log of output from `make test`, so maybe some workaround can be done... Matt --- Jouke Visser <jouke@pvoice.org> wrote: >On Tue, Mar 12, 2002 at 08:56:18PM +0100, Mattia Barbon wrote: >> > Hello all. As I said before, I compiled and installed wxMac 2.3.2 without problems. The samples look nice :). However, I had problems compiling wxPerl 0.08. Mattia sent me a workout, and that didn't work. 0.10 came around, and I tried that. Still doesn't work, but the wx...

[wxperl-users] Plans for wxPerl 0.23, wxWidgets 2.6.0
Hello, as some of you might already know, wxWidgets 2.6.0, the next stable wxWidgets release, has just been ...err... released. I would like to release wxPerl 0.23 as soon as RPMs become available, but I am definitely not going to provide binaries for all combinations of Perl 5.6.x/5.8.x, wxWidgets 2.4.2/2.6.0, Unicode/non Unicode, for Windows, GTK2, Mac OS X. I am going to provide only wxWidgets 2.6.x releases from now on, and I will consider if I will keep distributing Perl 5.6.x-enabled binaries. If anybody is willing to take the time to compile and relase wxWidgets 2.4....

[wxperl-users] Ubuntu wxPerl 0.65 with wxWidgets 2.8.0
I managed to get wxPerl 0.65 to build against the new wxWidgets 2.8.0. I used the Ubuntu wxWidgets binaries for 2.8.0 (http://www.wxwidgets.org/downloads/), but had a few problems with Alien::WxWidgets: mike@mbs:~/downloads/Alien-wxWidgets-0.25$ perl Build 'animate' library not found at inc/My/Build/Any_wx_config.pm line 141. 'deprecated' library not found at inc/My/Build/Any_wx_config.pm line 141. So I added this line to inc/My/Build/Any_wx_config.pm: next if $k =~ m/^animate|deprecated$/; just to see if things would build, etc. After that everything ...

Web resources about - [wxperl-users] Compiling on Win32 with MingW wx2.3.2 and snapshot wxperl 0.11 - perl.wxperl.users

O'Reilly Open Source Convention 2007 • July 23-27, 2007 • Portland, Oregon
O'Reilly Open Source Convention 2007 - July 23-27, 2007 - Portland, Oregon

Resources last updated: 1/6/2016 6:23:52 PM