Should the docs are about 5.5 source compatibility, how about 5.6?

If you read:

    perldoc -f use

We're still warning that people shouldn't do e.g. "use v5.24.0",
instead they should do "use 5.0240" because the latter will break
*before* 5.6 (i.e. 5.5 and earlier).

I subsequently started grepping the docs for mentions of 5.6.0, we
have some like this in perlop: "If the final match did indeed match p,
it's a good bet that you're running an older (pre-5.6.0) Perl".

I propose that these docs be amended so we stop prominently describing
the nowadays historical trivia of what did and didn't work on 5.6 and
before.

I'm mainly interested in getting rid of the prominent warning in
"perldoc -f use" of "...should generally be avoided...". But I wanted
to bring up the more general subject.

I'm happy to patch this, just wanted to see if anyone disagreed.
0
avarab
8/10/2017 10:23:09 PM
perl.perl5.porters 46514 articles. 0 followers. Follow

0 Replies
0 Views

Similar Articles

[PageSpeed] 38

Reply: