Problems with threaded build of DBI under HPUX 11.X

I am trying to build DBI (and then DBD::Oracle) under HPUX 11.00. It has to
be threaded because the Oracle OCI libraries for 11.X (Oracle 8.0.5) are
threaded, and there are no non-thread versions available. I am building under
Perl 5.005_61 (in hopes of better thread code), which built and passed all
tests under this machine (for the sake of the p5p folks keeping track :-).

When compiling the DBI.c file generated from DBI.xs, I get:

cc -c  -D_POSIX_C_SOURCE=199506L -D_HPUX_SOURCE -Aa -I/opt/ims/include \
  -I/usr/local/include -O     -DVERSION=\"1.13\" -DXS_VERSION=\"1.13\" \
  +z -I/opt/ims/perl5.005/lib/5.00561/PA-RISC2.0-thread/CORE  DBI.c
cc: "DBI.xs", line 1754: error 1621: Too few arguments for indirect function \
  call.
cc: "DBI.xs", line 1754: warning 604: Pointers are not assignment-compatible.
cc: "DBI.xs", line 1754: warning 563: Argument #1 is not the correct type.
make: *** [DBI.o] Error 1

(the first and second lines were broken at <80 cols for readability)

Unfortunately, I don't have enough familiarity with either the internals of
DBI or with the HPUX compilers to determine the cause of this. It is within
a conditional-compilation block that only gets used under threads.

This is for a fairly critical application, so any help greatly appreciated.

Randy
--
"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
Randy J. Ray            | In this life there are only two tragedies. One is not
rjray@redhat.com        | getting what one wants. The other is getting it.
415-777-9810 x246       |                                          -Oscar Wilde
0
rjray
8/30/1999 2:56:06 AM
perl.perl5.porters 47809 articles. 1 followers. Follow

0 Replies
424 Views

Similar Articles

[PageSpeed] 4

Reply:

Similar Artilces:

RE: DBD-Sybase 1.07, FreeTDS 0.63, HPUX 11.11: Build problem (maketest)
--0__=4EBBFA76DFAA3D9C8f9e8a93df938690918c4EBBFA76DFAA3D9C Content-Transfer-Encoding: 7bit Content-Type: text/plain; charset="us-ascii" These errors are to be expected. Your binaries should be fine. Michael Extranet rfrink@theoccamgroup.com - 27/12/2005 21:36 Please respond to rfrink@theoccamgroup.com To: mpeppler cc: dbi-users Subject: RE: DBD-Sybase 1.07, FreeTDS 0.63, HPUX 11.11: Build problem (maketest) Michael, Thanks for the reply. I guess I assumed that since TDS supports the host+port that the Sybase DBD would a...

DBD-Sybase 1.07, FreeTDS 0.63, HPUX 11.11: Build problem (make test)
Hello, I am trying to use freetds (0.63) as the library for DBD::Sybase (1.07) to communicate with MS SQL 2000 servers. After the build, it does not appear that DBD::Sybase reconizes the freetds config file (/usr/local/freetds/freetds.conf), in particular for defining which host+port make up the Server. I even tried it in the local `pwd`. Most importantly, 'make test' fails and will not complete the install. Also, the "connect" method complains about accepting host+port arguments, and seems to want a "Server", only. The manpage says it accepts host...

Problem installing DBI on HPux 11.00
------_=_NextPart_000_01C29A15.C404D73C Content-Type: multipart/alternative; boundary="----_=_NextPart_001_01C29A15.C404D73C" ------_=_NextPart_001_01C29A15.C404D73C Content-Type: text/plain; charset="iso-8859-1" I am having trouble installing DBI-1.30 on my HPUX Unix system. I attach a file with the details of the 'make' failure. I did manage to install it on my test machine (which should be identical, but obviously isn't quite !!) I would appreciate any help you have <<DBI3.doc>> Malcolm Taylor ------_=_NextPart_001...

install problems on HPUX 11.11
------_=_NextPart_001_01C68E5F.5FBE0F04 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable I know I will probably need another compiler but wanted to make sure. I changed the make file to point to gcc, g++, cpp and c++ and I am still getting errors. Here are my errors using /usr/bin/cc =20 root@DUBHADM1# make cp Size.pm blib/lib/Term/Size.pm AutoSplitting blib/lib/Term/Size.pm (blib/lib/auto/Term/Size) /usr/bin/perl /opt/perl/lib/5.8.2/ExtUtils/xsubpp -typemap /opt/perl/li b/5.8.2/ExtUtils/typemap Size.xs > ...

OT : HPUX 11 + Perl5.6 + DBI + DBD:Oracle + MQSeries
My sincere apologies for posting here, but I've tried the Perl news groups without success, and am desperate to get this working. I have (after experiencing the usual pain), got DBI-1.14 and DBD-Oracle-1.06 working quite OK. I now want to install the MQSeries module. I've done it on a sun machine we have, and everything worked fine. That is, Perl 5.6, DBI-1.14, DBD-Oracle-1.06 (Oracle 8.1.7), and MQSeries-1.13. The exact same versions on HPUX-11 builds OK, but on the 'make test' fails to connect to the queue manager. I suspect it has something to do with needing t...

Unable to build DBD on HPUX 11.11
------=_NextPart_000_04C9_01C33F36.79FA8170 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi All, I am trying to build DBD-mysql-2.1012 perl and mysql database driver on = HPUX 11.11 operating system. I am getting this error, if I say 'make'. = Can someone help me to resolve this. Mysql 3.23.42 and DBI 1.37 are = installed on the machine. ipvbs:/tmp/DBD-mysql-2.1012>make /bin/sh -c true /bin/sh -c true rm -f blib/arch/auto/DBD/mysql/mysql.sl LD_RUN_PATH=3D"/opt/mysql/lib...

Problem Setting up Par on HPUX 11.11
--0-1585754156-1123863587=:6955 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit Hello Everyone I am having problems setting up PAR on HPUX 11. Below is how I have set things up and the errors I am getting. Thank You. INFO on problem follows: cpan> get PAR Running get for module PAR CPAN: Digest::MD5 loaded ok LWP not available CPAN: Net::FTP loaded ok Fetching with Net::FTP: ftp://cpan.org/pub/CPAN/authors/id/A/AU/AUTRIJUS/CHECKSUMS Fetching with Net::FTP ftp://cpan.org/pub/CPAN/authors/id/A/AU/AUTRIJUS/CHECKSUMS.gz Tr...

Matlab doubleclick problem in openSuSE 11.x (with VNC/X)
I have a small, but painful problem with Matlab in openSuSE 11.x, when working over VNC. My setup: openSuSE 11.1 (recent upgrade from 10.2) Matlab (R2007a, 32bit) VNC KDE 3.5.x (from openSuSE 11.1). Problem: When I open Matlab main window and try to work in File Open / File Save dialog, I can't double click on files and folders. Single-click (=selection) works, and if I press Enter the default action works. However, pressing Enter leads to wrong action in Set Path dialog (it should go into the directory, but selects the directory as a path). Diagnostics: 1) It works c...

[Fwd: Re: Problem Setting up Par on HPUX 11.11]
I am going to rely on a poor memory here, but I think I had to to to the directory I extracted par to, then cd myldr perl Makefile.PL nmake and then cd .. and then perl Makefile.PL etcetera -------- Original Message -------- Subject: Re: Problem Setting up Par on HPUX 11.11 Date: Mon, 15 Aug 2005 14:40:47 +1000 From: sisyphus1@optusnet.com.au (Sisyphus) To: na na <hpunixguy@yahoo.com>, <par@perl.org> Newsgroups: perl.par References: <20050812161947.11376.qmail@web35305.mail.mud.yahoo.com> ----- Original Message ---...

Ultralite 11 - Deployment problem
This is my first go with UL, I have several production ASA apps, but UL is a little different. I am rewriting an app in UL due to its better memory footprint and common codebase with UltraliteJ. With ASA, to deploy on our remote devices, we included the "template database" with the installer. Before building the installer, we clear the ml_remote_id of the ASA database, and drop the test subscription, plus clean out test data. During install, the subscription gets recreated with a new username, and upon first sync, a new ml_remote_id is set. NOW, with UltraLite, it a...

Open Client 11.x and 10.x: index visibility problems
I've just installed ASE 11.5 NT, and as part of that I installed the Open Client and ODBC that came with that; I've also applied the EBF that brings the Client to 11.1.1. The problem is that Borland database engine applications now cannot see indexes on a table I use on an System 11 server on an HPUX box across campus. I can see *some* indexes on other tables, but no indexes on this particular one. I can see the indexes in Sybase Central. I can also see them from my Borland tools on a win95 box that has ODBC 10.0.3 and the older Client 10.x. It's also interesting th...

[perl5-dbi/DBI-Test] aaad8f: Update README section about threads, subtests and ...
----==_mimepart_5301bf0737482_665382dd40477bb Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Branch: refs/heads/master Home: https://github.com/perl5-dbi/DBI-Test Commit: aaad8f083421518c9a002c9aaa41642a6f6ad87d https://github.com/perl5-dbi/DBI-Test/commit/aaad8f083421518c9a002c9aaa41642a6f6ad87d Author: Tim Bunce <Tim.Bunce@pobox.com> Date: 2014-02-12 (Wed, 12 Feb 2014) Changed paths: M sandbox/tim/README.pod Log Message: ----------- Update README section about threads, subtests and skip_all Commit: 17d...

DBI Build Problems
------_=_NextPart_000_01C1364D.34D6D240 Content-Type: text/plain; charset="iso-8859-1" Can you please tell me what am I doing wrong in building DBI 1.20 ? make test is failing. Here are the logs for perl Makefile.PL, make, make test, make test TEST_VERBOSE=1 as well as Perl version info. Any help is greatly appreciated. Thanks. <<make.log>> <<perl.version>> ------_=_NextPart_000_01C1364D.34D6D240 Content-Type: application/octet-stream; name="make.log" Content-Transfer-Encoding: quoted-printable Content-Disposition: attach...

DBI Build problem
Hi, Iam new to the list but have been using perl on VMS for several years. I recently needed to upgrade some modules and that setoff a=20 complete perl re-build. I have built perl 5.8.0 with some help from the list archive but the DBI 1.30 module is proving difficult. I get the well known message but none of the previously suggested cures seemed to work=20 %MMK-F-CANTUPD, cannot update target [.BLIB.ARCH.AUTO.DBI]DRIVER.XST - sour= ces unknown =20 Also if I do 'MMK CLEAN' I get this warning on the next build attempt. Warning: the following files are missing in y...

Web resources about - Problems with threaded build of DBI under HPUX 11.X - perl.perl5.porters

Is–ought problem - Wikipedia, the free encyclopedia
The is–ought problem in meta-ethics as articulated by Scottish philosopher and historian David Hume (1711–76) is that many writers make claims ...

The fate of one small mouse hints at a huge problem for Australia
On Saturday morning I cupped a grey mouse in my hands. He was still warm and breathing. It was just a mouse, but I felt a profound sadness.

Is there a problem with Apple Music?
... page on my iOS device, the song or playlist began playback. In my case, the signup page didnt return until I force quit the app. The problem ...

Astronomy’s sexual harassment problem gets Congressional attention
Last year, a confidential report was leaked that revealed that University of California, Berkeley had conducted an investigation into one of ...

BMW recalls i8 for stability control problem
Filed under: Green , Recalls , BMW , Safety , Coupe , Hybrid , Performance BMW will recall a small number of 2015 i8s because of a problem with ...

Breakthrough research could solve a major problem with lithium-ion batteries
... they're also unstable and can be explosive when they overheat . Researchers at Stanford University have been working on how to fix this problem ...

Tom Stoppard's "The Hard Problem"
by Doctor Science The American premiere of Tom Stoppard's latest play, "The Hard Problem", is at the Wilma Theater in Philadelphia. We went last ...

42% OF AMERICANS NOW REJECT 2-PARTY SYSTEM: Confirm That Government is the Problem
... the government topped the U.S. populace’s list of pressing grievances in a separate Gallup poll . They named it the nation’s number one problem ...

Marc Andreessen predicted GoPro's current problems back when it filed to go public
... 2014 . But even back when GoPro was basking in glowing investor sentiment, there were already warning signs that the company could face problems ...

IDG Contributor Network: No more heroes: View problems as solvable together
You must have felt it, if you have worked in IT for even a few years that creeping sense that more of the time you once spent installing, configuring, ...

Resources last updated: 1/15/2016 10:01:47 AM