perl-5.10.0-4 -> perl-5.10.0-5 site_perl update needed

2008/7/9 Reini Urban:
> 2008/7/9 Reini Urban:
>> 2008/7/8 Reini Urban:
>>> 2008/7/8 Gary R. Van Sickle:
>>>> Hi Reini,
>>>>
>>>> It looks like something changed between perl 5.10.0-4 and -5 which breaks
>>>> the DateTime module from CPAN (version 0.4302, latest).  The attached Simple
>>>> Test Case(tm) results in only the following errors:
>>>>
>>>> Use of uninitialized value $id in pattern match (m//) at
>>>> /usr/lib/perl5/site_perl/5.10/DateTime/Locale.pm line 65.
>>>
>>> Bad side-effect with a third party module in site_perl.
>>> Strange that I didn't see this in my tests, because I tested over
>>> thousand CPAN modules with this release.
>>> Oh, I see, I reported that it failed on June 5.
>>>
>>> $ cpan DateTime
>>> requires DateTime::Locale
>>>
>>> DateTime::Locale cannot be installed because of this error,
>>> but since you upgraded perl we have to fix DateTime::Locale now.
>>>
>>> Oops. This seems to affect more modules.
>>> Params::Validate with type => SCALAR seems to be broken.
>>>  http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Params%3A%3AValidate
>>>
>>> I have to go now, but will provide a patch soon.
>>> As workaround I would disable the validation in DateTime::Locale::_register
>>> but this also doesn't work as expected.
>>>
>>>    if (! defined $p{id} or !$id) {
>>>        # cygperl5 error in Params::Validate?
>>>        #warn "Broken Params::Validate. Given ".join(",",@_);
>>>        $p{id} = $_[0];
>>>        $p{en_language} = $_[1];
>>>        my @keys = qw(en_script en_territory en_variant native_language
>>> native_script native_territory native_variant class replace);
>>>        for my $i (2 .. @_) {
>>>            $p{$keys[$i]} = $_[$i];
>>>        }
>>>    }
>>
>> Update on this issue:
>> As you can see, there's only one machine with this error, which is my laptop.
>> http://cpantesters.perl.org/show/DateTime-Locale.html#DateTime-Locale-0.4001
>> My normal devel machine passed the DateTime::Locale test, which is weird.
>> I also pass the Params::Validate test on my laptop, which is weirder,
>> because this fails for DateTime::Locale on my laptop.
>>
>> Anyway, until I find out the differences between my laptop and my
>> devel machine,
>> the short summary:
>>
>> Params::Validate fails in an BEGIN block, in a type => SCALAR check only on
>> certain machines with 5.10.0 patch 34065 on Cygwin. (Tested only
>> release and patch 34065).
>> Reproducible with DateTime::Locale.
>> Within the debugger everything works ok. (Probably because of the BEGIN block)
>> The other DateTime::Locale reports show no clue.
>> There's a Darwin report on the same patchlevel which passed.
>>
>> Within DateTime-Locale-0.4001 after make
>> even perl -Mblib -cw t/01basic.t fails with the same errors.
>>
>> Moving the register call from BEGIN to INIT also does not help.
>
> The adhoc workaround for perl-5.10.0-5 is to move away the Validate XS module:
>
> mv /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/Params/Validate/Validate.dll \
>  /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/Params/Validate/_Validate.dll
>
> Now it works, because Params::Validate has a slower pure-perl fallback.

I've analyzed the symbols in the dll's and found the explanation and
solution for this update problems. p5p and module authors need not to
be concerned. It's a simple cygwin perl update problem.

In short:
All old perl-5.10.0-4 generated binary site_perl modules need to be
recompiled with perl-5.10.0-5.
They are not ABI cross-compatible with the new vendor and archlib modules.

Explanation:
perl-5.10.0-5 is based on patchlevel 34065, perl-5.10.0-4 was based on
plain 5.10.0 with a lot of patches.

perl-5.10.0-5 adds a new utf8 handling of strings via a new
newSVpvn_flags function
sv.h: #define newSVpvn_utf8(s, len, u) newSVpvn_flags((s), (len), (u)
? SVf_UTF8 : 0)
perl-5.10.0-4 does not contain newSVpvn_utf8 nor newSVpvn_flags.

So any new XS module using strings may not call an old perl-5.10.0-4 dll, which
does not contain the _utf8  and _flags functions.

Solution:
# delete all old site packages with dll's and reinstall them
for pack in $(find /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto \
  -name .packlist \! -newer /bin/perl.exe);
do
  grep .dll $pack && rm -f $(cat $pack)
done | \
perl -MCPAN -ne'
s|/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/(.+?)/\w+\.dll$|$1|;
s|/|::|g; push @p, $_; END {install(@p) }'

should recompile them all.

-- 
Reini Urban
http://phpwiki.org/ http://murbreak.at/
0
rurban
7/10/2008 8:16:18 AM
perl.perl5.porters 47653 articles. 1 followers. Follow

3 Replies
598 Views

Similar Articles

[PageSpeed] 48

2008/7/10 Reini Urban <rurban@x-ray.at>:
> 2008/7/9 Reini Urban:
>> 2008/7/9 Reini Urban:
>>> 2008/7/8 Reini Urban:
>>>> 2008/7/8 Gary R. Van Sickle:
>>>>> Hi Reini,
>>>>>
>>>>> It looks like something changed between perl 5.10.0-4 and -5 which breaks
>>>>> the DateTime module from CPAN (version 0.4302, latest).  The attached Simple
>>>>> Test Case(tm) results in only the following errors:
>>>>>
>>>>> Use of uninitialized value $id in pattern match (m//) at
>>>>> /usr/lib/perl5/site_perl/5.10/DateTime/Locale.pm line 65.
>>>>
>>>> Bad side-effect with a third party module in site_perl.
>>>> Strange that I didn't see this in my tests, because I tested over
>>>> thousand CPAN modules with this release.
>>>> Oh, I see, I reported that it failed on June 5.
>>>>
>>>> $ cpan DateTime
>>>> requires DateTime::Locale
>>>>
>>>> DateTime::Locale cannot be installed because of this error,
>>>> but since you upgraded perl we have to fix DateTime::Locale now.
>>>>
>>>> Oops. This seems to affect more modules.
>>>> Params::Validate with type => SCALAR seems to be broken.
>>>>  http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Params%3A%3AValidate
>>>>
>>>> I have to go now, but will provide a patch soon.
>>>> As workaround I would disable the validation in DateTime::Locale::_register
>>>> but this also doesn't work as expected.
>>>>
>>>>    if (! defined $p{id} or !$id) {
>>>>        # cygperl5 error in Params::Validate?
>>>>        #warn "Broken Params::Validate. Given ".join(",",@_);
>>>>        $p{id} = $_[0];
>>>>        $p{en_language} = $_[1];
>>>>        my @keys = qw(en_script en_territory en_variant native_language
>>>> native_script native_territory native_variant class replace);
>>>>        for my $i (2 .. @_) {
>>>>            $p{$keys[$i]} = $_[$i];
>>>>        }
>>>>    }
>>>
>>> Update on this issue:
>>> As you can see, there's only one machine with this error, which is my laptop.
>>> http://cpantesters.perl.org/show/DateTime-Locale.html#DateTime-Locale-0.4001
>>> My normal devel machine passed the DateTime::Locale test, which is weird.
>>> I also pass the Params::Validate test on my laptop, which is weirder,
>>> because this fails for DateTime::Locale on my laptop.
>>>
>>> Anyway, until I find out the differences between my laptop and my
>>> devel machine,
>>> the short summary:
>>>
>>> Params::Validate fails in an BEGIN block, in a type => SCALAR check only on
>>> certain machines with 5.10.0 patch 34065 on Cygwin. (Tested only
>>> release and patch 34065).
>>> Reproducible with DateTime::Locale.
>>> Within the debugger everything works ok. (Probably because of the BEGIN block)
>>> The other DateTime::Locale reports show no clue.
>>> There's a Darwin report on the same patchlevel which passed.
>>>
>>> Within DateTime-Locale-0.4001 after make
>>> even perl -Mblib -cw t/01basic.t fails with the same errors.
>>>
>>> Moving the register call from BEGIN to INIT also does not help.
>>
>> The adhoc workaround for perl-5.10.0-5 is to move away the Validate XS module:
>>
>> mv /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/Params/Validate/Validate.dll \
>>  /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/Params/Validate/_Validate.dll
>>
>> Now it works, because Params::Validate has a slower pure-perl fallback.
>
> I've analyzed the symbols in the dll's and found the explanation and
> solution for this update problems. p5p and module authors need not to
> be concerned. It's a simple cygwin perl update problem.
>
> In short:
> All old perl-5.10.0-4 generated binary site_perl modules need to be
> recompiled with perl-5.10.0-5.
> They are not ABI cross-compatible with the new vendor and archlib modules.
>
> Explanation:
> perl-5.10.0-5 is based on patchlevel 34065, perl-5.10.0-4 was based on
> plain 5.10.0 with a lot of patches.
>
> perl-5.10.0-5 adds a new utf8 handling of strings via a new
> newSVpvn_flags function
> sv.h: #define newSVpvn_utf8(s, len, u) newSVpvn_flags((s), (len), (u)
> ? SVf_UTF8 : 0)
> perl-5.10.0-4 does not contain newSVpvn_utf8 nor newSVpvn_flags.
>
> So any new XS module using strings may not call an old perl-5.10.0-4 dll, which
> does not contain the _utf8  and _flags functions.

Is not perl-5.10.1 disallowed to add newSVpvn_utf8() and newSVpvn_flags()?
Another ABI disaster as with the beginning of 5.8.1 ... updates.

> Solution:
> # delete all old site packages with dll's and reinstall them
> for pack in $(find /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto \
>  -name .packlist \! -newer /bin/perl.exe);
> do
>  grep .dll $pack && rm -f $(cat $pack)
> done | \
> perl -MCPAN -ne'
> s|/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/(.+?)/\w+\.dll$|$1|;
> s|/|::|g; chomp; push @p, $_; END {install(@p) }'
>
> should recompile them all.
-- 
Reini Urban
http://phpwiki.org/ http://murbreak.at/
0
rurban
7/10/2008 8:51:12 AM
On Thu, 10 Jul 2008, Reini Urban wrote:
> 2008/7/10 Reini Urban <rurban@x-ray.at>:
>> 2008/7/9 Reini Urban:
>>> 2008/7/9 Reini Urban:
>>>> 2008/7/8 Reini Urban:

Talk to yourself a lot? :)

>> So any new XS module using strings may not call an old perl-5.10.0-4
>> dll, which does not contain the _utf8 and _flags functions.

Yes, that has never been allowed: modules compiled with a later version
of Perl are not guaranteed to be compatible with earlier versions of libperl,
even from the same maintenance track.  Otherwise you could never add
any new symbols to libperl, or extend internal structures by adding
additional elements at the end.
 
> Is not perl-5.10.1 disallowed to add newSVpvn_utf8() and newSVpvn_flags()?

No, it is allowed to *add* them, it is not allowed to *remove* any exported
symbols.  Even if a function gets turned into a macro, the original function
must still be exported so that moduled compiled with perl-5.10.0 will be able
to find them.

> Another ABI disaster as with the beginning of 5.8.1 ... updates.

Those were changes to internal structure layouts, which broke modules
compiled under 5.8.0 when run under 5.8.1:

http://www.nntp.perl.org/group/perl.perl5.porters/2003/10/msg84439.html

Cheers,
-Jan


0
jand
7/11/2008 1:33:13 AM
On Thu, 10 Jul 2008, Reini Urban wrote:
> I've analyzed the symbols in the dll's and found the explanation and
> solution for this update problems. p5p and module authors need not to
> be concerned. It's a simple cygwin perl update problem.
> 
> In short:
> All old perl-5.10.0-4 generated binary site_perl modules need to be
> recompiled with perl-5.10.0-5.

This should not be true: if the modules were compiled with 5.10.0-4, then
they should work with 5.10.0-5.

> They are not ABI cross-compatible with the new vendor and archlib modules.
> 
> Explanation:
> perl-5.10.0-5 is based on patchlevel 34065, perl-5.10.0-4 was based on
> plain 5.10.0 with a lot of patches.
> 
> perl-5.10.0-5 adds a new utf8 handling of strings via a new
> newSVpvn_flags function
> sv.h: #define newSVpvn_utf8(s, len, u) newSVpvn_flags((s), (len), (u)
> ? SVf_UTF8 : 0)
> perl-5.10.0-4 does not contain newSVpvn_utf8 nor newSVpvn_flags.
> 
> So any new XS module using strings may not call an old perl-5.10.0-4 dll, which
> does not contain the _utf8  and _flags functions.

So how do you end up with a site_perl compiled against 5.10.0-5, but
running with 5.10.0-4? You installed the new site_perl into an older
Perl installation?

> Solution:
> # delete all old site packages with dll's and reinstall them
> for pack in $(find /usr/lib/perl5/site_perl/5.10/i686-cygwin/auto \
>   -name .packlist \! -newer /bin/perl.exe);
> do
>   grep .dll $pack && rm -f $(cat $pack)
> done | \
> perl -MCPAN -ne'
> s|/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/(.+?)/\w+\.dll$|$1|;
> s|/|::|g; push @p, $_; END {install(@p) }'
> 
> should recompile them all.

But that would compile them with 5.10.0-4 again, right. Wouldn't it be
better to replace your 5.10.0-4 dll with the 5.10.0-5 dll?

I guess I'm confused about how you ended up in this situation in the
first place.

Cheers,
-Jan

0
jand
7/11/2008 1:39:59 AM
Reply:

Similar Artilces:

problems with Sybase ASE 12.5.4 on Solaris 5.10 x86-64 architecture and Oracle 10.2.0.3.0 on Solaris 5.10 x86-64 architecture
Hello, My problem is that on the Oracle's side I can't make any connection with my Sybase server. The Sybase, on another side, doesn't have any solution that we can take to solve this problem (except the ECDA that haves a lot o problem) Any idea how can find on link or something to make on connection between these two databases? Thanks, Sergio what is your specific problem with ECDA? <Sergio> wrote in message news:4b683d8d.7586.1681692777@sybase.com... > Hello, > > My problem is that on the Oracle's side I can't make any > conne...

List::MoreUtils-0.25_1 pass on 5.10.1RC0, 5.10.0, 5.8.9, 5.8.8
Following up on my report that List::MoreUtils-0.24 failed its tests on the "maint-5.10 snapshot (aka 'RC0')" that came out on July, and Tassilo later confirming the nature of the problem ... List::MoreUtils-0.25_1 was just released on CPAN, and I have tested it manually from a download of the tarball from search.cpan.org, and the problem appears to be fixed. A clean unpack/Makefile/make/make-test passes all tests on 4 versions of Perl on my same PPCG4/MacOSX10.5.7 machine: - 5.10.1RC0 built by me with defaults, custom install loc - 5.10.0 built by m...

Security advisory for Bugzilla 4.5.5, 4.4.5, 4.2.10, and 4.0.14
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Summary ======= Bugzilla is a Web-based bug-tracking system used by a large number of software projects. The following security issue has been discovered in Bugzilla: * An attacker can get access to some bug information using the victim's credentials using a specially crafted HTML page. All affected installations are encouraged to upgrade as soon as possible. Vulnerability Details ===================== Class: Cross Site Request Forgery Versions: 3.7.1 to 4.0.13, 4.1.1 to 4.2.9, 4.3.1 to 4.4.4, 4.5.1 to 4.5...

[ANN] Release of Bugzilla 4.5.5, 4.4.5, 4.2.10, and 4.0.14
Today we are releasing 4.4.5, 4.2.10, 4.0.14, and the unstable development snapshot 4.5.5. All releases fix a security issue found since the last release. Bugzilla 4.4.5 is our latest stable release. Bugzilla 4.4.5, 4.2.10 and 4.0.14 are security updates for the 4.4, 4.2, and the 4.0 branches, respectively. Note that 4.5.5 is an unstable development release and should not be used in production environments. We are not yet feature-frozen at this time so the features you see in 4.5.5 might not accurately represent the behavior that 5.0 will have. Note that when Bugzilla 5...

Smoke [5.8.4] 22871 FAIL(Fc) cygwin_nt-5.0 1.5.10(0.116/4/2) (x86/1 cpu)
Automated smoke report for 5.8.4 patch 22871 PC09: x86 Family 15 Model 1 Stepping 2, GenuineIntel (x86/1 cpu) on cygwin_nt-5.0 - 1.5.10(0.116/4/2) using gcc version 3.3.1 (cygming special) smoketime 9 hours 8 minutes (average 45 minutes 42 seconds) Summary: FAIL(Fc) O =3D OK F =3D Failure(s), extended report at the bottom X =3D Failure(s) under TEST but not under harness ? =3D still running or test results not (yet) available Build failures during: - =3D unknown or N/A c =3D Configure, m =3D make, M =3D make (after miniperl), t =3D make test-p= rep ...

How to do from ASA5.5.0.4 #1867 To 5.5.0.5?
Hi , I have 1 database on ASA5.5.04 Built #1867, Today I download the package 5.5.0.5 from Sybase web page,after I run the setup.exe. I can not start my database anymore. Can anyone help me. Thanks A Lot! Kadee What error are you getting? /ck "kadee" <kadee@pchome.com.tw> wrote in message news:$O6WtrS6BHA.238@forums.sybase.com... > Hi , > > I have 1 database on ASA5.5.04 Built #1867, > Today I download the package 5.5.0.5 from > Sybase web page,after I run the setup.exe. > I can not start my database anymore. > > Can...

Smoke [5.10.0] maint-5.10-1196-ga8a43ff FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch a8a43ff0f2638c954fe34867dadcb2d38093888d maint-5.10-1196-ga8a43ff p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 5 hours 12 minutes (average 39 minutes 5 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t =...

Smoke [5.10.0] maint-5.10-1171-ga2d4e51 FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch a2d4e51092c9dc1403a07e3cc313045aa0fabe63 maint-5.10-1171-ga2d4e51 p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 5 hours 13 minutes (average 39 minutes 10 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t ...

Smoke [5.10.0] maint-5.10-1156-g45957f2 FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch 45957f2ee9816a6647753f1d918f837b83e9bf04 maint-5.10-1156-g45957f2 p5netbsd.refcnt.homeunix.org: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 5 hours 12 minutes (average 39 minutes 5 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (...

Smoke [5.10.0] maint-5.10-1169-ga0ab88b FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch a0ab88bb2bd59be4e0b0733f8f9f8557e373aed1 maint-5.10-1169-ga0ab88b p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 5 hours 11 minutes (average 38 minutes 58 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t ...

Smoke [5.10.0] maint-5.10-1334-gb78898b FAIL(M) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch b78898b8dbfe9f00fd16a8e70459e0d92ba1b9fd maint-5.10-1334-gb78898b p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 15 minutes 50 seconds (average 1 minute 58.750 seconds) Summary: FAIL(M) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl)...

Smoke [5.10.0] maint-5.10-1338-ga725c5e FAIL(M) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch a725c5ec96926d5d481dff0fa79534be2769e27e maint-5.10-1338-ga725c5e p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 15 minutes 52 seconds (average 1 minute 59 seconds) Summary: FAIL(M) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t ...

Smoke [5.10.0] maint-5.10-1342-gc09d26c FAIL(M) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch c09d26c405f109be79e3487f71a3b134d4f9bc04 maint-5.10-1342-gc09d26c p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 15 minutes 46 seconds (average 1 minute 58.250 seconds) Summary: FAIL(M) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl)...

Smoke [5.10.0] maint-5.10-1141-g2700d9b FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch 2700d9b0bf253b12ed6a4ccf931fa4705edf2315 maint-5.10-1141-g2700d9b p5netbsd: AMD 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 22 hours 1 minute (average 2 hours 45 minutes) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t = make...

Smoke [5.10.0] maint-5.10-1220-gd0f0947 FAIL(XF) netbsd 5.0 (i386/1 cpu)
Automated smoke report for 5.10.0 patch d0f09470a55cd54ec20843bfdb3ba974a83bd6bb maint-5.10-1220-gd0f0947 p5netbsd: Intel 686-class (i386/1 cpu) on netbsd - 5.0 using cc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120) smoketime 5 hours 15 minutes (average 39 minutes 25 seconds) Summary: FAIL(XF) O = OK F = Failure(s), extended report at the bottom X = Failure(s) under TEST but not under harness ? = still running or test results not (yet) available Build failures during: - = unknown or N/A c = Configure, m = make, M = make (after miniperl), t ...

Web resources about - perl-5.10.0-4 -> perl-5.10.0-5 site_perl update needed - perl.perl5.porters

DLPS Error Page
DBI-> connect(dlxs:localhost) failed: Too many connections at /usr/lib/perl5/site_perl/5.6.0/Apache/Session/Store/MySQL.

DLPS Error Page
DBD::mysql::st execute failed: Got error 127 from storage engine at /usr/lib/perl5/site_perl/5.8.5/Apache/Session/Store/DBI.pm line 88.

SFgate terminated Search of 2008 Fall Meeting database
... SFgate terminated SFgate terminated with message Can't locate loadable object for module Wais in @INC (@INC contains: /usr/lib/perl5/site_ ...

pskl.us - Preset Kill Limit
Setup: 1) Install the Palo Alto UserID Agent (download from the Palo Alto support site) on two member servers in your domain. The account you ...

SFgate terminated Search of 2005 Fall Meeting database
... SFgate terminated SFgate terminated with message Can't locate loadable object for module Wais in @INC (@INC contains: /usr/lib/perl5/site_ ...

Resources last updated: 1/15/2016 3:40:01 PM