[ID 19991111.001] Problem while installing perl5 on HPUX 10.2

Hi,
On giving cmd sh Configure, at one point it goes like
this and aborts 


Do you wish to attempt to use the malloc that comes
with perl5? [y] 

Your system wants malloc to return 'void *', it would
seem.
Your system uses void free(), it would seem.

Checking out function prototypes...
Your C compiler doesn't seem to understand function
prototypes.


Configure:  FATAL ERROR:
This version of perl5 can only be compiled by a
compiler that
understands function prototypes.  Unfortunately, your
C compiler
        cc -D_HPUX_SOURCE
doesn't seem to understand them.  Sorry about that.

If GNU cc is available for your system, perhaps you
could try that instead.

Eventually, we hope to support building Perl with
pre-ANSI compilers.
If you would like to help in that effort, please
contact <perlbug@perl.org>.

Aborting Configure now.

i cld not understand the reason of this abort, all
help is appreciated ...
thanks
achal

=====

__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com
0
achalt
11/11/1999 9:17:40 AM
perl.perl5.porters 47902 articles. 1 followers. Follow

1 Replies
432 Views

Similar Articles

[PageSpeed] 49

Not really DBI, but...
It's like it says.  Have you installed GCC?  or have you purchased the
unbundled ANSI C compiler suite from HP?  You need to do either one for
HP/UX, since the toy compiler they give you is non-ANSI C capable and is
really suitable only for building the kernel, not software.

You need to either buy the HP compiler, or install GCC.
-Alan

Achal Tandon wrote:
> On giving cmd sh Configure, at one point it goes like
> this and aborts
> 
> Configure:  FATAL ERROR:
> This version of perl5 can only be compiled by a
> compiler that
> understands function prototypes.  Unfortunately, your
> C compiler
>         cc -D_HPUX_SOURCE
> doesn't seem to understand them.  Sorry about that.
>
0
asparks
11/11/1999 3:40:47 PM
Reply:

Similar Artilces:

[ID 19991113.002] Fwd: Problem while installing perl5 on HPUX 10.2
--0-1804289383-942492322=:4000 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Hi folks, Resending, since there was no response .. i'd really appreciate ur help. thanks achal Note: forwarded message attached. ===== __________________________________________________ Do You Yahoo!? Bid and sell for free at http://auctions.yahoo.com --0-1804289383-942492322=:4000 Content-Type: message/rfc822 X-Apparently-To: achalt@yahoo.com via web1206.mail.yahoo.com Return-Path: <dbi-users-bounce@isc.org> X-Track: 1: 40 Received: from ib.rc.vix.com ...

[ID 20001107.006] Problems installing perl5.6.0, perl5.00405 on AIX
Hiya. I'm attempting to install both Perl 5.6 and/or Perl 5.4.5 on an AIX box running AIX 4.1.2. They both compile with no problems: they fail a few tests, but those still result in 99% functionality. What blows up is the install. Perl 5.4.5 reports an out of memory error upon installation, like so: root@appf ***** /netadmin/temp/perl5.004_05 28 % ./perl installperl -n cp perl /usr/local/bin/perl5.00405 chmod 755 /usr/local/bin/perl5.00405 Out of memory! ('top' shows 1400MB free virtual memory, 124MB free real memory, etc.)...

[ID 19990909.001] Problem with compiling perl5
Hello, This is my configuration root@tws-83:/tmp/perl5.005_03 # ./myconfig Summary of my perl5 (5.0 patchlevel 5 subversion 3) configuration: Platform: osname=hpux, osvers=10.20, archname=PA-RISC1.1 uname='hp-ux tws-83 b.10.20 a 9000715 -1 two-user license ' hint=previous, useposix=true, d_sigaction=define usethreads=undef useperlio=undef d_sfio=undef Compiler: cc='/opt/gcc/bin/gcc', optimize=' ', gccversion=2.8.1 cppflags='-D_HPUX_SOURCE' ccflags ='-D_HPUX_SOURCE' stdchar='unsigned char', d_st...

[ID 20010208.001] Net::POP3 problem with perl5.6.0
This is a bug report for perl from systemgroup@telenet-ops.be, generated with the help of perlbug 1.28 running under perl v5.6.0. ----------------------------------------------------------------- [Please enter your report here] when using perl 5.003 (and higher) the module Net::POP3 can be used as follow: #!/opt/perl/bin/perl use Net::POP3; if ($pop = Net::POP3->new($server) { #connection established } else { print "no connection\n"; } Now in perl 5.6.0, I have to type: if ($pop = Net::POP3->new($server, Port=>110)) { If I don't spe...

[ID 20010122.132] Problem with "make depend" during Perl5.005 installation
--------------996934EA9CA5A9E9332D2764 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit Attached is both an error message, associated with "make depend" during the ./configure process, and the output from the ./myconfig shell script. It appears that "make" can't find the "Compiler" and "Language", however I don't know why, especially since both "cc" and "f90" are located in $PATH. Any ideas? Thanks in advance. Waylon -- ************************************************************...

[ID 19991019.004] problems compiling perl5.005_03 on AIX 4.3.2.0
I am trying to get a working version of perl5.005_03 on a AIX 4.3.2.0. Configuring was not a problem. But when using make, I keep having problems. The first problem occured when using miniperl on pod/pod2text.PL; it resulted in a core dump. Calling it from the prompt solved this problem. The second problem was that ext/Opcode/Makefile.PL would not generate a Makefile. Temporary solved it by using Makefile.old. Here also a core dump. And again problems this time when calling: ../miniperl -Ilib -e 'use AutoSplit; autosplit_lib_modules(@ARGV)' lib/*.pm lib/*/*.pm make: ...

[ID 19991230.001] perl5.05_63 XSLoader failure in File::Glob on OpenBSD 2.6
I've had problems getting 63 installed on OpenBSD 2.6. This seems to be related to the new "File/Glob.pm" module. (Or maybe to "XSLoader.pm", which I hadn't heard about; its docs are sparse at best.) When you try to do a make install, you get this: ./perl installperl Can't load 'lib/auto/File/Glob/Glob.so' for module File::Glob: No such file or directory at lib/XSLoader.pm line 73. at lib/File/Glob.pm line 94 Compilation failed in require at installperl line 65. BEGIN failed--compilation aborted at installper...

problem in compiling perl5.6.2 using gcc compil er on aix 5.2 #2
------_=_NextPart_001_01C43C13.A0B99088 Content-Type: text/plain; charset="iso-8859-1" Hi, I am facing problem in compiling the perl5.6.2 source code using gcc. 1.installed the gcc 3.3.2 and added to the PATH. 2.installed GNU Make downloaded from gnu.org and added to PATH. 3.downloaded the perl 5.6.2 from cpan and executed Failed 96 test scripts out of 282, 65.96% okay. ### Since not all tests were successful, you may want to run some of ### them individually and examine any diagnostic messages they produce. ### See the INSTALL document's section on ...

10.0.2 installed, still asks to install 10.0.2 update
I installed the 10.0.2 update about ten days ago and it is verified on the About page. However, I get numerous daily reminders to install the 10.0.2 update. So I checked "never check for updates" but that apparently isn't working either because I'm getting all of the reminders. So what's my only option: uninstall and then reinstall? I'm a bit leery of doing that: everything else seems to be functioning properly. However, when I previously installed the 10.0.1 update, numerous things were broken on my Win7 system and I had to revert to a restore poi...

[ID 20001226.001] dec_osf.sh mis-parses gcc version 2.95.2 as less than 2.95, causing installation-failure
This is a bug report for perl from jhbrown@newspaper-taxi.ai.mit.edu, generated with the help of perlbug 1.28 running under perl v5.6.0. ----------------------------------------------------------------- [Please enter your report here] The configuration hint file perl-5.6.0/hints/dec_osf.sh mis-parses "gcc version 2.95.2" as being a version less than 2.95, and thus running > sh Configure -Dcc=gcc -de generates a message saying that building perl doesn't work with older gccs on this platform (DEC Alpha); the configuration process exits unsuccessfully as a result....

11.9.2 problem with ebf 8569 on HPUX 10.2
We installed on HPUX 11.9.2 ebf 8569. This started a constant stream of complaints from developer community that started getting this error(See below) from powerbuilder, c and regular isql using parallelism. Msg 9539, Level 17, State 1: Server 'dsy_gmd1', Line 1: Insufficient amount of memory per worker process to execute this parallel query. Increase the value of the configuration parameter 'memory per worker process'. I increased the worker process memory config variable from the default of 1024 to 2048. Did not work. We rolled back to th...

problem in compiling perl5.6.2 using gcc compil er on aix 5.2
------_=_NextPart_001_01C43BFB.439184BC Content-Type: text/plain; charset="iso-8859-1" Hi, I am facing problem in compiling the perl5.6.2 source code using gcc. 1.installed the gcc 3.3.2 and added to the PATH. 2.installed GNU Make downloaded from gnu.org and added to PATH. 3.downloaded the perl 5.6.2 from cpan and executed # sh Configure -Dcc=gcc #make gcc: `-b' must come at the start of the command line make: 1254-004 The error code from the last command is 1. Stop. I am getting the above error while running the make command. Ple...

Problem upgrading from 10.2 to 10.2.1
When I click on the 10.2.1 update and tell it to deploy the update, the page refreshes with the error message at the top basically telling me I need to be on version 10.2 first. But when I click on my ZCM server it tells me I am on version 10.2. Any ideas? I even tried to reapply 10.2 and it went successful. 'Image 1' (http://jdover.com/images/zcm01.jpg) 'Image 2' (http://jdover.com/images/zcm02.jpg) -- Justin Dover ------------------------------------------------------------------------ Is it possible to baseline 900 laptops? I don't think I...

[ID 19991025.007] Build Issues with perl5.005.2 on AIX 4.3.2.0
Hi, I've just completed a good build with AIX 4.3.2.0 using gcc 2.95.1 There were some problems with the hints and I needed to add -lmssa in order to get the math functions to work I've still got the build dir intact so if I can send you anything to help let me know Thanks, Bob French UNIX system manager US Diagnostics Inc bfrench@usdl.com The output from myconfig..... Summary of my perl5 (5.0 patchlevel 5 subversion 2) configuration: Platform: osname=aix, osvers=4.3.2.0, archname=aix uname='aix u-sewpbcbo-vis2 3 4 00059247a100 ' hint=...

Web resources about - [ID 19991111.001] Problem while installing perl5 on HPUX 10.2 - perl.perl5.porters

Help:Installing Japanese character sets - Wikipedia, the free encyclopedia
This help page will help you install Japanese character sets so that your computer will display them properly on the internet in your web browser ...

Earn Free Facebook Credits For Installing Apps — Of Course, There’s A Catch
This looks pretty cool at first: Earn free Facebook Credits for installing applications on your iPhone or Android device. AppDog offers this ...

Installing solar panels - Flickr - Photo Sharing!
Solar panels are lifted into place.

Installing Afterglow AX.1 Wired XBOX 360 Controller on Lion/Mountain Lion 10.7.3+ - YouTube
I finally managed to install an Afterglow AX.1 (Wired XBOX Controller) and make it work on Lion 10.7.3 with TattiBogle 0.08. This tutorial works ...

Fatal unit fire: Builder Ray Finianos reduced height of building to avoid installing fire sprinklers ...
The builder of&nbsp;a south-west Sydney unit block where a young woman plunged to her death during a ferocious fire told a certifier to reduce ...

Ballarat man accused of installing spy cameras in ex-wife's house
A man accused of concealing surveillance cameras in skirting boards at his ex-wife's home also allegedly attached a GPS tracker to her car, a ...

Iran installing new nuclear equipment
Sky News is Australia's leader in 24-hour news. Iran has begun installing next-generation equipment at one of its main nuclear plants, a new ...

Rentasaur Installing 'Spyware' On Rental Laptops
An Australian business that rents out computers is installing software that in the US has been used to spy on users, including taking webcam ...

Gillard defends installing Slipper
BBC News Gillard defends installing Slipper Sydney Morning Herald Prime Minister Julia Gillard has defended her decision to install Peter ...

CSIRO says installing solar panels on roofs of businesses could take pressure off the electricity grid ...
Installing more solar panels on the roofs of businesses would help Australia's energy grid cope with increased demand.

Resources last updated: 12/25/2015 4:48:36 PM