installed version not updated after install

--============_-1187831132==_ma============
Content-Type: text/plain; charset="us-ascii" ; format="flowed"

For a few modules, the CPAN_VERSION and INST_VERSION reported by the 
i CPAN command disagree, even after I apparently successfully 
installed/updated a module.  Can someone explain what's going on 
here?  For instance [Perl 2.6.1, Mac OS 10.1.5], here's the CPAN 
output for Net::Ping.  (The same thing happens with Storable, where 
CPAN_VERSION is 2.04 but INST_VERSION is 1.014 even after apparently 
successfully installing Storable 2.04.)  And what's the best way to 
tell what's really installed?  (What I would get if I did "Use 
Net::Ping", for example.)

cpan> install Net::Ping
CPAN: Storable loaded ok
Going to read /Users/mitchell/.cpan/Metadata
   Database was generated on Sun, 16 Jun 2002 18:40:08 GMT
Running install for module Net::Ping
Running make for B/BB/BBB/Net-Ping-2.19.tar.gz
CPAN: Digest::MD5 loaded ok
Checksum for 
/Users/mitchell/.cpan/sources/authors/id/B/BB/BBB/Net-Ping-2.19.tar.gz 
ok
Scanning cache /Users/mitchell/.cpan/build for sizes
Deleting from cache: /Users/mitchell/.cpan/build/CPAN-1.61 (10.3>10.0 MB)
Net-Ping-2.19/
Net-Ping-2.19/t/
Net-Ping-2.19/t/140_stream_inst.t
Net-Ping-2.19/t/110_icmp_inst.t
Net-Ping-2.19/t/200_ping_tcp.t
Net-Ping-2.19/t/250_ping_hires.t
Net-Ping-2.19/t/130_tcp_inst.t
Net-Ping-2.19/t/100_load.t
Net-Ping-2.19/t/300_ping_stream.t
Net-Ping-2.19/t/120_udp_inst.t
Net-Ping-2.19/README
Net-Ping-2.19/lib/
Net-Ping-2.19/lib/Net/
Net-Ping-2.19/lib/Net/Ping.pm
Net-Ping-2.19/MANIFEST
Net-Ping-2.19/perl-Net-Ping.spec.PL
Net-Ping-2.19/Makefile.PL
Net-Ping-2.19/Changes
Net-Ping-2.19/perl-Net-Ping.spec
Net-Ping-2.19/INSTALL
Removing previously used /Users/mitchell/.cpan/build/Net-Ping-2.19

   CPAN.pm: Going to build B/BB/BBB/Net-Ping-2.19.tar.gz

WARNING: constants takes a string/number not a hash reference.
          Please inform the author.
Checking if your kit is complete...
Looks good
Writing Makefile for Net::Ping
cp lib/Net/Ping.pm blib/lib/Net/Ping.pm
Manifying blib/man3/Net::Ping.3
   /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/100_load...........ok
t/110_icmp_inst......ok
t/120_udp_inst.......ok
t/130_tcp_inst.......ok
t/140_stream_inst....ok
t/200_ping_tcp.......ok
t/250_ping_hires.....skipped
         all skipped: no Time::HiRes
t/300_ping_stream....ok
         11/12 skipped: Local echo port is off
All tests successful, 1 test and 11 subtests skipped.
Files=8, Tests=34, 15 wallclock secs ( 2.13 cusr +  0.48 csys =  2.61 CPU)
   /usr/bin/make test -- OK
Running make install
Writing /Library/Perl/darwin/auto/Net/Ping/.packlist
Appending installation info to /System/Library/Perl/darwin/perllocal.pod
   /usr/bin/make install  -- OK

cpan> m Net::Ping
     DESCRIPTION  TCP, UDP, or ICMP ping
     CPAN_USERID  BBB (Rob Brown <bbb@cpan.org>)
     CPAN_VERSION 2.19
     CPAN_FILE    B/BB/BBB/Net-Ping-2.19.tar.gz
     DSLI_STATUS  SupO (standard,comp.lang.perl.*,perl,object-oriented)
     MANPAGE      Net::Ping - check a remote host for reachability
     INST_FILE    /System/Library/Perl/Net/Ping.pm
     INST_VERSION 2.02



--============_-1187831132==_ma============--
0
mlm (3)
6/17/2002 5:22:40 AM
perl.macosx 2309 articles. 0 followers. Follow

1 Replies
758 Views

Similar Articles

[PageSpeed] 0

On Monday, June 17, 2002, at 03:22  PM, Mitchell L Model wrote:
> For a few modules, the CPAN_VERSION and INST_VERSION reported 
> by the i CPAN command disagree, even after I apparently 
> successfully installed/updated a module.  Can someone explain 
> what's going on here?  For instance [Perl 2.6.1, Mac OS 
> 10.1.5], here's the CPAN output for Net::Ping.  (The same thing 
> happens with Storable, where CPAN_VERSION is 2.04 but 
> INST_VERSION is 1.014 even after apparently successfully 
> installing Storable 2.04.)  And what's the best way to tell 
> what's really installed?  (What I would get if I did "Use 
> Net::Ping", for example.)

They're both installed.

Unfortunately, /System/Library/Perl comes before /Library/Perl 
in @INC.  That means you'll have to remove the old version 
(probably using 'make install UNINSTALL=1') when you install the 
new one.

>
> cpan> m Net::Ping
>     DESCRIPTION  TCP, UDP, or ICMP ping
>     CPAN_USERID  BBB (Rob Brown <bbb@cpan.org>)
>     CPAN_VERSION 2.19
>     CPAN_FILE    B/BB/BBB/Net-Ping-2.19.tar.gz
>     DSLI_STATUS  SupO (standard,comp.lang.perl.*,perl,object-oriented)
>     MANPAGE      Net::Ping - check a remote host for reachability
>     INST_FILE    /System/Library/Perl/Net/Ping.pm
>     INST_VERSION 2.02
>
>
>

  -Ken

0
ken
6/17/2002 5:33:44 AM
Reply:

Similar Artilces:

To install or not to install?
What's the difference between installing qpsmtpd as in...=0A=0Aperl Makefil= e.PL=0Amake=0Amake test=0Amake install=0Amake clean=0A=0A... or running it = directly from /home/smtpd/qpsmtpd?=0A=0APresently I'm running ./qpsmtpd fro= m xinetd, so the installed copy is probably wasted, right?=0A=0AIs there an= y benefit/downside in running an installed copy, and how would I do that?= =0A=0AHans=0A=0A=0A There is no benefit to installing. I've been running under xinetd for a couple of years, directly from an svn checkout in /var/qpsmtpd. In fact, I dont even make changes ...

Install D2010 on side of D2009
I am installing D2010 from the iso image. But the setup complains that I should install Update 3 for D2009 before that. However, D2009 Check for Updates said that no updates were available, so I copied the setup packages from another D2009 installation and installed Update 3, 4, etc. And D2010 installation still fails to start, complaining that I should install Update 3 to D2009. How can I tell the installer that I DO have Update 3 for D2009? Jouni Aro Prosys I have the same problem. BDS 2009 is up to date with Version3, but Delphi 2010 will not install because it claim...

Install PB 10 update without needing to install PB 9 update, then PB 8 update....
We have a bunch of updates to PB. Is there a way we can install PB 10 without needing to install all the previous versions of PB? If all you have is an update version, then you'll need to have some previous version of PB installed. On 4 Mar 2005 05:54:11 -0800, "Daniel Coppersmith" <daniel_N.0.S.P.A.M_at_InFrontSoftware_D0T_C0M> wrote: >We have a bunch of updates to PB. Is there a way we can install PB 10 >without needing to install all the previous versions of PB? > > Bruce Armstrong [TeamSybase] http://www.teamsybase.com Vote for D...

Software update 898461 installs a permanent copy of the Package Installer for Windows version 6.1.22.4
Software update 898461 installs a permanent copy of the Package Installer for Windows version 6.1.22.4 http://support.microsoft.com/kb/KB898461 ----------------------------------------------------------- Quote ----------------------------------------------------------- Article ID : 898461 Last Review : June 28, 2005 Revision : 1.0 APPLIES TO * Microsoft Windows XP Home Edition SP1 * Microsoft Windows XP Home Edition SP2 * Microsoft Windows XP Professional SP1 * Microsoft Windows XP Professional SP2 * Microsoft Wi...

[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing.
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. --JivePart=_4a211.zeB8CwDOH5aMJzMl Content-Type: text/plain; charset="Utf-8" ?I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing. --JivePart=_4a211.zeB8CwDOH5aMJzMl Content-Type: image/png; name="Update 1 Boost Install.PNG" Content-Transfer-Encoding: base64 Content-Disposition: attachment; filename="Update 1 Boost Install.PNG" iVBORw0KGgoAAAANSUhEUgA...

[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing.
?[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing. Should I report this as a problem in QC? ( See public.attachements ) Larry ...

Firefox 2.0.0.4 Automatic Update installation in Limited User account auto up-date installation bug (previously reported in earlier FireFox versions)
Name: Dave, Edmonton, Alberta, Canada Product: Firefox Summary: Firefox 2.0.0.4 Automatic Update installation in Limited User account auto up-date installation bug (previously reported in earlier FireFox versions) Comments: The bug already discussed at length in Bug Reports 374900, 370280, 303595, 340535 and perhaps others, still exists in FireFox version 2.0.0.4. While operating FireFox from a Limited User account in Windows XP, SP2, I received the message from the FireFox up-dater that the 2.0.0.4 up-date had been downloaded and FireFox needed to be restarted. Fool that I am...

Installing updates without babysitting installer?
It would certainly be nice if I could install RAD Studio updates on a new installation without having to babysit the installer. Currently the 3 updates available come as 4 installers, each of which requires the trivial action of pressing the "Next" button to begin installation. Very annoying. Jason ...

Update installation source for autoyast installation
Hi, I'm trying to set up an autoyast installation. How can I add all available updates to the installation source. I tested with create_update_source.sh, but now I have wrong dependencies with older rpms like glibc. I marked "do not install glibc-2.4-31.30", so I get more and more dependency problems. How can I fix this? Thanks! Nicole #### YaST2 conflicts list - generated 2008-04-29 07:37:42 #### Installation von glibc-2.4-31.30.i686[SUSE Linux Enterprise Server 10 SP1] nicht m.glich glibc-2.4-31.30.i686[SUSE Linux Enterprise Server 10 SP1] kann n...

upgrade from 4.0.1 install version to 4.0.2 install version, how?
Hi, I have a workable, clean 4.0.1 installed version of DNN running and am trying to upgrade to 4.0.2. i tried to follow the instruction on the documentation unzip the DNN_402_Install and put in corresponding directory in 4.0.1's website, run up the website and upgrade it. but it keeps hung up on the upgrade screen and going nowhere.  what files exactly should i extract and place in where, any special commands for running this upgrade? thank you very much in advance.  ...

install netware components not installed in the 1st installation
I have a NW5.1 running file services and NW5.0 running GW3.6. Both servers are installed in the same tree. I now wish to install Netware components like Portal, HTTP, NTTP etc one my NW5.1 server. I have SP6 installed on my NW5.1 What is the correct procedure I should adopt to successfully install these components? Thanks, Martin. On Wed, 11 Aug 2004 09:00:46 GMT, martin.scicluna@deltamalta.com wrote: >What is the correct procedure I should adopt to successfully install these >components? Use the console GUI Install, and select the products you want to inst...

Windows Update stops responding if you click Install to download and install updates for Windows XP or Windows 2000
followup to grc.techtalk Windows Update stops responding if you click Install to download and install updates for Windows XP or Windows 2000 http://support.microsoft.com/kb/896227 ----------------------------------------------------------- Quote ----------------------------------------------------------- Article ID : 896227 Last Review : March 29, 2005 Revision : 1.0 SYMPTOMS If you scan for updates for your Microsoft Windows XP-based or Microsoft Windows 2000-based computer at the Microsoft Windows Update Web site, Windows Update may displa...

Occassional appearance of Install/Install.aspx?mode=Install
Since upgrading to 3.1.1 I am getting the occasional redirection to Install/Install.aspx?mode=Install.  Is anyone else recieving this or does this suggest the installation script didn't complete?Jonathan Palmer Check your web.config and see if install=true.... In a previous version this was happening to me until i turned it off. ...

Is there a Gzip installer that I could install ?
Trying to make things easier I have a question about the linux desktop interface .. is direct package installed that I could use opening it on files using the right click method from windows ? "open with" / "chosen freeware" = click ! -- Cypher7 ------------------------------------------------------------------------ Cypher7 wrote: > > Trying to make things easier I have a question about the linux desktop > interface The linux desktop interface can be a lot of things, KDE,GNOME, windowmaker to name but a few. > .. is direct packa...

Web resources about - installed version not updated after install - perl.macosx

States of India by installed power capacity - Wikipedia, the free encyclopedia
^ "ALL INDIA REGIONWISE GENERATING INSTALLED CAPACITY OF POWER" (PDF) . Central Electricity Authority, Ministry of Power, Government of India. ...

Facebook, Messenger Pre-Installed on New Nokia 215, Nokia 215 Dual SIM Low-Cost Handsets
Facebook and Facebook Messenger are among the preinstalled applications on the new Nokia 215 and Nokia 215 Dual SIM entry-level phones from Microsoft ...

HTC reveals HTC First, an Android smartphone pre-installed with Facebook Home
HTC today revealed the HTC First, the first Android smartphone that comes with Facebook Home pre-installed on the device. With Facebook Home ...

Introducing installed app category targeting: a new way to target users and gain insights into mobile ...
We’re excited to introduce installed app category targeting: a new tool that enables app advertisers to reach users based on the categories of ...

Installed a new HDD - Flickr - Photo Sharing!
Seagate 100GB, 7200RPM in the 3 year old PowerBook.

FIRST EVER IPAD MINI INSTALLED INTO DASH OF A CAR - YouTube
Soundwaves of Tampa is the first to install a iPad Mini into a dash of a car. Please check us out and build pics at http://Facebook.com/soundwavesoftampa ...

Queensland's first Bitcoin ATM installed in South Brisbane
What is believed to be Queensland&#8217;s first Bitcoin ATM is up and running at a South Brisbane cafe, allowing customers to withdraw and sell ...

Cameras installed on hull of ISS (00:59)
RAW VIDEO: Russian cosmonauts perform a spacewalk to install photographic and scientific equipment on the hull of the International Space Station. ...

Where in the US is solar installed?
New data shows that Californians' penchant for photovoltaics has them leading in pipeline capacity by a factor of five, while Nevada's love of ...

Giant Gollum installed at airport ahead of Hobbit film
A 12 metre-long sculpture carved using robotics and chainsaws has been installed at Wellington Airport ahead of The Hobbit premiere.

Resources last updated: 12/1/2015 8:41:50 PM