Can't Update CPAN, Can't Install DBD::mysql

I upgraded to Lion.  I have pre-existing Perl modules that I had 
installed, but I hadn't yet installed DBD::mysql.

When I try to install DBD::mysql, I get this:

Checking if your kit is complete...
Looks good
Using DBI 1.615 (for perl 5.012003 on darwin-thread-multi-2level) 
installed in 
/System/Library/Perl/Extras/5.12/darwin-thread-multi-2level/auto/DBI/
Writing Makefile for DBD::mysql
Can't exec "/usr/bin/make": No such file or directory at 
/System/Library/Perl/5.12/CPAN/Distribution.pm line 2026.
   CAPTTOFU/DBD-mysql-4.020.tar.gz
   /usr/bin/make -- NOT OK
Running make test
   Can't test without successful make
Running make install
   Make had returned bad status, install seems impossible
Failed during this command:
  CAPTTOFU/DBD-mysql-4.020.tar.gz              : make NO


When I try to update CPAN, I get this:

Warning: Prerequisite 'File::HomeDir => 0.69' for 
'ANDK/CPAN-1.9800.tar.gz' failed when processing 
'ADAMK/File-HomeDir-0.98.tar.gz' with 'make => NO'. Continuing, but 
chances to succeed are limited.
Can't exec "/usr/bin/make": No such file or directory at 
/System/Library/Perl/5.12/CPAN/Distribution.pm line 2026.
   ANDK/CPAN-1.9800.tar.gz
   /usr/bin/make -- NOT OK
Running make test
   Can't test without successful make
Running make install
   Make had returned bad status, install seems impossible
Failed during this command:
  ADAMK/Test-Script-1.07.tar.gz                : make NO
  CHANSEN/Mac-SystemDirectory-0.06.tar.gz      : writemakefile NO -- No 
'Makefile' created

  ANDK/CPAN-1.9800.tar.gz                      : make NO
  ADAMK/File-HomeDir-0.98.tar.gz               : make NO
  RJBS/IPC-Run3-0.044.tar.gz                   : make NO
  ADAMK/File-Which-1.09.tar.gz                 : make NO

So the common denominator is: Can't exec "/usr/bin/make": No such file 
or directory at /System/Library/Perl/5.12/CPAN/Distribution.pm line 2026.

Looks like I need to install make.  This means, I need to get XCode so I 
can install make, right?

-- 
Lola J. Lee Beno
LinkedIn: http://www.linkedin.com/in/lolajleebeno
Facebook: http://www.facebook.com/profile.php?id=714355583
Blog: http://www.lolajl.net/blog/

0
lola (29)
9/28/2011 5:41:49 PM
perl.macosx 2309 articles. 0 followers. Follow

5 Replies
1205 Views

Similar Articles

[PageSpeed] 7

On Sep 28, 2011, at 1:41 PM, Lola Lee Beno wrote:
>=20
> Looks like I need to install make.  This means, I need to get XCode so =
I can install make, right?

Yes, but - you should also read this =
http://deflatermouse.livejournal.com/149721.html

 - alh

0
alh
9/28/2011 5:45:59 PM
At 13:41 -0400 28/9/11, Lola Lee Beno wrote:

>...Can't exec "/usr/bin/make": No such file or directory at

>Looks like I need to install make.  This means, I need to get XCode 
>so I can install make, right?

Absolutely!  Isn't it on your Mac OS X install disks?

JD
0
JD
9/28/2011 7:30:31 PM
On 2011-09-28, Lola Lee Beno wrote:

>Looks like I need to install make.  This means, I need to get XCode so I c=
an install make, right?

Other than the huge download of a bunch of XCode stuff you might=20
never use, that's probably the best way to install make.



    - Bruce

_bruce__van_allen__santa_cruz_ca_

0
bva
9/28/2011 7:48:23 PM
On Sep 28, 2011, at 7:41 PM, Lola Lee Beno wrote:
> I upgraded to Lion.  I have pre-existing Perl modules that I had =
installed, but I hadn't yet installed DBD::mysql.
>=20
> When I try to install DBD::mysql, I get this:
>=20
> Checking if your kit is complete...
> Looks good
> Using DBI 1.615 (for perl 5.012003 on darwin-thread-multi-2level) =
installed in =
/System/Library/Perl/Extras/5.12/darwin-thread-multi-2level/auto/DBI/
> Writing Makefile for DBD::mysql
> Can't exec "/usr/bin/make": No such file or directory at =
/System/Library/Perl/5.12/CPAN/Distribution.pm line 2026.
>  CAPTTOFU/DBD-mysql-4.020.tar.gz
>  /usr/bin/make -- NOT OK
> Running make test
>  Can't test without successful make
> Running make install
>  Make had returned bad status, install seems impossible
> Failed during this command:
> CAPTTOFU/DBD-mysql-4.020.tar.gz              : make NO
>=20
>=20
> When I try to update CPAN, I get this:
>=20
> Warning: Prerequisite 'File::HomeDir =3D> 0.69' for =
'ANDK/CPAN-1.9800.tar.gz' failed when processing =
'ADAMK/File-HomeDir-0.98.tar.gz' with 'make =3D> NO'. Continuing, but =
chances to succeed are limited.
> Can't exec "/usr/bin/make": No such file or directory at =
/System/Library/Perl/5.12/CPAN/Distribution.pm line 2026.
>  ANDK/CPAN-1.9800.tar.gz
>  /usr/bin/make -- NOT OK
> Running make test
>  Can't test without successful make
> Running make install
>  Make had returned bad status, install seems impossible
> Failed during this command:
> ADAMK/Test-Script-1.07.tar.gz                : make NO
> CHANSEN/Mac-SystemDirectory-0.06.tar.gz      : writemakefile NO -- No =
'Makefile' created
>=20
> ANDK/CPAN-1.9800.tar.gz                      : make NO
> ADAMK/File-HomeDir-0.98.tar.gz               : make NO
> RJBS/IPC-Run3-0.044.tar.gz                   : make NO
> ADAMK/File-Which-1.09.tar.gz                 : make NO
>=20
> So the common denominator is: Can't exec "/usr/bin/make": No such file =
or directory at /System/Library/Perl/5.12/CPAN/Distribution.pm line =
2026.
>=20
> Looks like I need to install make.  This means, I need to get XCode so =
I can install make, right?

Yes, that would be a good start.  :-)   No guarantees after that though, =
but Xcode is essentially a prerequisite on Mac OS X.



Liz=
0
liz
9/28/2011 7:53:37 PM
That's what I was afraid of.  Apparently a previous install of make got 
blown away. In the process of downloading XCode from App Store (uggggh) 
.. . .


On 9/28/11 3:48 PM, Bruce Van Allen wrote:
> On 2011-09-28, Lola Lee Beno wrote:
>
>> Looks like I need to install make.  This means, I need to get XCode 
>> so I can install make, right?
>
> Other than the huge download of a bunch of XCode stuff you might never 
> use, that's probably the best way to install make.
>


-- 
Lola J. Lee Beno
LinkedIn: http://www.linkedin.com/in/lolajleebeno
Facebook: http://www.facebook.com/profile.php?id=714355583
Blog: http://www.lolajl.net/blog/

0
lola
9/28/2011 7:59:25 PM
Reply:

Web resources about - Can't Update CPAN, Can't Install DBD::mysql - perl.macosx

Resources last updated: 12/11/2015 10:08:34 PM