DBI install error under Solaris 10

Hi,

    I need to install the DBD::Pg under Solaris 10 sparc, the DBI::DBD
installed without errors with CPAN, but when trying to install DBI I
get the following error:
"Can't create variants of tests in 't' directory: No such file or
directory at /usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI/DBD.pm
line 3119."

   This is the exact same error with Sun Studio or GCC 3.4.6 - I'm not
sure if this is the correct location to ask for help.

Thank you for any advice.

0
zilonx
11/14/2007 6:11:37 PM
perl.dbi.users 11034 articles. 1 followers. Follow

1 Replies
215 Views

Similar Articles

[PageSpeed] 50

------=_Part_3029_13155400.1195097864244
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

On Nov 14, 2007 10:11 AM, zilonx <zilonx@gmail.com> wrote:

>    I need to install the DBD::Pg under Solaris 10 sparc, the DBI::DBD
> installed without errors with CPAN, but when trying to install DBI I
> get the following error:
> "Can't create variants of tests in 't' directory: No such file or
> directory at /usr/perl5/site_perl/5.8.4/sun4-solaris-64int/DBI/DBD.pm
> line 3119."
>
>   This is the exact same error with Sun Studio or GCC 3.4.6 - I'm not
> sure if this is the correct location to ask for help.
>

Normally, I would have expected DBI::DBD (which is basically a POD for
developers of DBD modules) to come along with DBI.

The "Can't create" message suggests that you are trying to build in a
directory where you don't have a sub-directory called 't', which in turn
suggests that your current directory is not where the DBI source code is.

It is good that you have both Sun Studio and GCC available; the build will
use the same one as was used to build Perl.  That should save you angst
later.


-- 
Jonathan Leffler <jonathan.leffler@gmail.com>  #include <disclaimer.h>
Guardian of DBD::Informix - v2007.0914 - http://dbi.perl.org
"Blessed are we who can laugh at ourselves, for we shall never cease to be
amused."

------=_Part_3029_13155400.1195097864244--
0
jonathan
11/15/2007 3:37:44 AM
Reply:

Similar Artilces:

DBI 1.50 install error in Solaris 10
------_=_NextPart_001_01C7C48F.DFCF4018 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hi, =20 Iam sending the output of Makefile.PL,make and perl -V =20 =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D= =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D= =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D =20 perl Makefile.PL: =20 *** Note: The optional PlRPC-modules (RPC::PlServer etc) are not installed. If you want to use the DBD::Proxy driver and ...

Error Installing DBI on Solaris
------_=_NextPart_001_01C8C241.9AFB03FA Content-Type: multipart/alternative; boundary="----_=_NextPart_002_01C8C241.9AFB03FA" ------_=_NextPart_002_01C8C241.9AFB03FA Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hello, =20 I got a problem when trying to install DBI-1=2E48 module on a solaris 9 box=2E=20 The error is: [EMAIL PROTECTED] # make /bin/sh -c true cc -c -D_REENTRANT -I/usr/local/include -D_LARGEFILE_SOURCE=20 -D_FILE_OFFSET_BITS=3D64 -O -DVERSION=3D\"1=2E48\" -DXS_VERSION=3D\"1...

Attempting to manually install DBI...errors with DBI.DLL
------=_NextPart_000_0003_01C23109.8133FD90 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit This issue just will not die. I have recently moved to a server that is under the same architecture as my intranet server (Intel) and we are both running the same version and builds of ActiveState Perl (5.6.1 Build 629). I do not have any way (telnet, SSH, shell) of *properly* (via automation) installing modules to the host machine and the host provider will not install *additional* modules not included in the standard distribution of Perl. ...

POSSIBLE BUG IN Win32 DBI INSTALL MODULE: DBI "prepare" no work FW: List 'dbi-users' closed to public posts
I have ActiveState Win32perl running. I installed fresh DBI, DBD, etc. from perl ppm.pl> prompt. But prepare( ) doesn't work (see below). perldoc DBI/DBD/DBI-FAQ are not useful since they assume it works. Any hints? Art www.mp3.com/ArthurSulit Classical Artist recently charted above Madonna -----Original Message----- From: Art Sulit [mailto:art@prs.net] Sent: Saturday, January 20, 2001 1:51 PM To: Webmaster@ActiveState.com Subject: POSSIBLE BUG IN YOUR DBI INSTALL MODULE: DBI "prepare" no work Hello, THERE IS A POSSIBLE BUG IN YOUR DBI INSTALL M...

Re: error during DBD::Oracle installation (was: error during DBI installation)
------=_Part_6037_22545193.1207194199772 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline Looks like time to get the development stuff you need installed. The log file says: Reading /export/home/oracle/product/9Iclient/precomp/lib/env_precomp.mk Attempting to discover Oracle OCI build rules gcc -c -I. -I/export/home/oracle/product/9Iclient/precomp/public -I/export/home/oracle/product/9Iclient/rdbms/public -I/export/home/oracle/product/9Iclient/rdbms/demo -I/export/home/oracle/product/9Iclient/plsql/public -I/export/hom...

DBI module installation problem on solaris 10
HI I am trying to install DBI and DBD modules on Solaris 10 and getting following error. Please suggest is there any solution for this problem. Perl.xsc && mv Perl.xsc Perl.c cc -c -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=3D64 -xarch=3Dv8 -D_TS_ERRNO -xO3 -xspace -xildoff -DVERSION=3D\"1.48\" -DXS_VERSION=3D\"1.48\" -KPIC "-I/usr/perl5/5.8.4/lib/sun4-solaris-64int/CORE" -DDBI_NO_THREADS Perl.c sh: cc: not found *** Error code 1 make: Fatal error: Command failed for target `Perl.o' This is perl, v5.8.4 built for sun4-solaris...

problems with make test
--------------enig63544CDCE79D97CB2EE19B0A Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable make test fails with many errors similar to the following: Can't locate object method "no_diag" via package "Test::Builder" Thanks in advance for any help. Full log: + cd DBD-Oracle-1.23 + export ORACLE_HOME=3D/export/home/oracle/product/rel102040 + ORACLE_HOME=3D/export/home/oracle/product/rel102040 + export LD_LIBRARY_PATH=3D/export/home/oracle/product/rel102040/lib32 + LD_LIBRARY_PATH=3D/export/home/oracle/product/re...

Re: DBI-1.50 | make error on Solaris 10
------=_Part_14485_18465677.1184462254937 Content-Type: text/plain; charset=WINDOWS-1252; format=flowed Content-Transfer-Encoding: quoted-printable Content-Disposition: inline I've cc'd dbi-users@perl.org again - I intended to previously... That's a nuisance. It usually means something is confused about which headers are where - it could be GCC or Perl or something else. Have you installed any other C-based modules since you created Perl with gcc? OK - you've got Perl 5.8.2 (5.8.8 has been out several years), and it was built with GCC 2.95 (they've stop...

Need HELP: trying to install DBI-1.613 or even DBI-1.616 same errors ...see message??
HELP: $ uname -a SunOS recondfw 5.10 Generic_139556-08 i86pc i386 i86pc isainfo -v 64-bit amd64 applications ssse3 cx16 mon sse3 sse2 sse fxsr mmx cmov amd_sysc cx8 tsc fpu 32-bit i386 applications ssse3 cx16 mon sse3 sse2 sse fxsr mmx cmov sep cx8 tsc fpu bash-3.00# echo $PATH /usr/sbin:/usr/bin:/usr/sfw/bin bash-3.00# /usr/perl5/bin/perlgcc Makefile.PL Creating test wrappers for DBD::Gofer: t/zvg_01basics.t t/zvg_02dbidrv.t t/zvg_03handle.t t/zvg_04mods.t t/zvg_05concathash.t t/zvg_06attrs.t t/zvg_07kids.t t/zvg_08keeperr.t t/zvg_09trace.t t/zvg_...

Error while DBI installation
------=_NextPart_000_0029_01C1D415.54270690 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hello, I am trying to install DBI Perl module on Linux. First 2 commands ( perl Makefile.PL , make) went successful. But when i give "make test", i get an error in preparse.t. Following is the log attached for the command. Regards, Laxmikant=20 ------=_NextPart_000_0029_01C1D415.54270690-- ...

error while installing DBI
Hi, When I try to install DBI the following error is coming.... Please help.... PPM> install DBI Install package 'DBI?' (y/N): y Installing package 'DBI'... Error installing package 'DBI': Could not locate a PPD file for package DBI PPM> Thanks in advance Murugan. I don't think DBI is available in PPD format. You need to CPAN or do it by hand (download the package and its dependencies, gzip -d, tar, perl Makefile.pl, make, make tests, make install). I've had mixed success with CPAN on Windows. HTH, Dave On Sep 2, MURUGAN V ...

Install DBI on Solaris
Hi all, I'm having an issue installing DBI on Solaris. I've read on many people having this issue and the solutions seem to revolve around installing a new compiler, etc. However, I've already installed other perl modules successfully on this box, so it seems to be related to this module only. Following are the results of the log of my total install and the perl -V. Thanks for any help or clarification that you can provide: install: # perl Makefile.PL Creating test wrappers for DBI::PurePerl: t/zvp_01basics.t t/zvp_02dbidrv.t t/zvp_03handle.t t/zvp_04mods.t t/z...

error in installing DBI
Hai, While installing dbi on Linux/SuSE machine I got an error. I entered as a root on the machine. When I executed the command perl Makefile.PL it gave the following error Unable to open the file MakeMaker.tmp : permission denied at /usr/lib/perl5/5.6.1/ExtUtils/makeMaker.pm at line number 759. My perl version is 5.6.1 Please suggest me how to install it. Advanced thanks. regards, china. ===== cnu. __________________________________ Do you Yahoo!? Yahoo! Calendar - Free online calendar with sync to Outlook(TM). http://calendar.yahoo.com ...

Error installing DBI
Hi All, While I am trying to install DBI 1.15 on Solaris, perl Makefile.PL PREFIX=$HOME INSTALLSITELIB=$HOME INSTALLSITEARCH=$HOME/sun4-solaris I got this error: Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: lib /usr/local/lib/perl5/sun4-solaris/5.00404 /usr/local/lib/perl5 /usr/local/lib/perl5/site_perl/sun4-solaris /usr/local/lib/perl5/site_perl ..) at Makefile.PL line 14. BEGIN failed--compilation aborted at Makefile.PL line 14. Any explanations? Why it is looking in /usr/local.... I have only the Perl interpreter on the machine, is there anythin...

Web resources about - DBI install error under Solaris 10 - perl.dbi.users

Nullsoft Scriptable Install System - Wikipedia, the free encyclopedia
This article has an unclear citation style . The references used may be made clearer with a different or consistent style of citation , footnoting ...

Can Facebook Advertisers Test Mobile App Install Ads On Their Devices?
Some Facebook advertisers are now able to preview their mobile application install ads directly on their mobile devices, complete with active ...

Drive Mobile App Awareness and Installs Over The Holidays
Just in time for the holidays, we're announcing new buying, creative and targeting options for Facebook mobile app ads.

New Features to Mobile App Install Ads
Today we are happy to announce some updates to mobile app install ads to improve the experience people and developers have when viewing and creating ...

Facebook tries new designs for mobile page-Like and app install ads
Facebook began testing new designs for its mobile app install ads and page post ads this weekend. Following an update for Facebook for iOS, ...

WA Premier Colin Barnett urges City of Joondalup to install shark net at Sorrento Beach - PerthNow Search ...
PREMIER Colin Barnett has urged the City of Joondalup to “get on with it” and install a shark net at Sorrento Beach.

Ted Mack working to install an independent in Joe Hockey's old seat
Ted Mack is plotting the defeat of another Liberal Party candidate in North Sydney.

You can now try Firefox OS 2.5 on your Android device with a quick APK install
Bored with your current flavor Android, but don’t want to flash a new ROM? You're in luck. Firefox has today released an interesting "Developer ...

You can now install popular automatic screen brightness app Flux on iPhone and iPad
With iOS 9, it is now possible to install screen brightness app Flux (or f.lux). Flux adjusts screen brightness and color depending on the time ...

Android adware can install itself even when users explicitly reject it
(credit: Lookout) Two weeks ago, Ars reported on newly discovered Android adware that is virtually impossible to uninstall . Now, researchers ...

Resources last updated: 12/1/2015 12:46:17 AM