Can't get around this problem, Can't load

install_driver(Oracle) failed: Can't load 
'/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so' 
for module DBD::Oracle: ld.so.1: 
/usr/dist/share/perl5,v5.6.1/5bin.sun4/perl: fatal: relocation error: 
file 
/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so: 
symbol Perl_no_modify: referenced symbol not found at 
/usr/dist/share/perl5,v5.6.1/lib/sun4-solaris/DynaLoader.pm line 206, 
<BOM> line 5362.
 at (eval 1) line 3
Compilation failed in require at (eval 1) line 3, <BOM> line 5362.

I installed DBI and DBD using a local version of perl. Tested and 
working I then wanted to distribute for other users
to use, our IT group requires us to use their disted version of perl 
which is 5.6.1. I then recompiled both DBI and DBD
after changing my perl path to point to the IT version, so when I do 
perl -V it points to IT 's version. But, now when
 I try to run my program I get the above error. What am I missing?

Any help much appreciated.



0
morry
7/15/2003 9:16:18 PM
perl.dbi.users 11100 articles. 1 followers. Follow

2 Replies
1064 Views

Similar Articles

[PageSpeed] 44

I have solved the problem partially, found some documentation on how to 
run the perl Makefile.PL with
arguments so I don't have to edit the Makefile. I got DBI to compile and 
install in the correect location
correctly. I haven't been able to figure out what argument to add to 
perl Makefile.PL to see the non-standard
location I installed the DBI module in. Here is what I used on the DBI 
module.
perl Makefile.PL CC=/usr/dist/share/forte_dev,v6.2/SUNWspro/bin/cc \
LD=/usr/dist/share/forte_dev,v6.2/SUNWspro/bin/cc \
PREFIX=/home/morry/src/pcdesign,v14.x/lib/site_perl \
LIB=/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005

Any help much appreciated, Thanks Morry

Morrison Davis wrote:

> install_driver(Oracle) failed: Can't load 
> '/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so' 
> for module DBD::Oracle: ld.so.1: 
> /usr/dist/share/perl5,v5.6.1/5bin.sun4/perl: fatal: relocation error: 
> file 
> /home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so: 
> symbol Perl_no_modify: referenced symbol not found at 
> /usr/dist/share/perl5,v5.6.1/lib/sun4-solaris/DynaLoader.pm line 206, 
> <BOM> line 5362.
> at (eval 1) line 3
> Compilation failed in require at (eval 1) line 3, <BOM> line 5362.
>
> I installed DBI and DBD using a local version of perl. Tested and 
> working I then wanted to distribute for other users
> to use, our IT group requires us to use their disted version of perl 
> which is 5.6.1. I then recompiled both DBI and DBD
> after changing my perl path to point to the IT version, so when I do 
> perl -V it points to IT 's version. But, now when
> I try to run my program I get the above error. What am I missing?
>
> Any help much appreciated.
>
>
>


0
morry
7/17/2003 5:59:35 PM
Sorry didn't full state the problem DBI is fine but whe I try DBD I get 
the 'Can't find DBI.pm in @INC'

Morrison Davis wrote:

> I have solved the problem partially, found some documentation on how 
> to run the perl Makefile.PL with
> arguments so I don't have to edit the Makefile. I got DBI to compile 
> and install in the correect location
> correctly. I haven't been able to figure out what argument to add to 
> perl Makefile.PL to see the non-standard
> location I installed the DBI module in. Here is what I used on the DBI 
> module.
> perl Makefile.PL CC=/usr/dist/share/forte_dev,v6.2/SUNWspro/bin/cc \
> LD=/usr/dist/share/forte_dev,v6.2/SUNWspro/bin/cc \
> PREFIX=/home/morry/src/pcdesign,v14.x/lib/site_perl \
> LIB=/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005
>
> Any help much appreciated, Thanks Morry
>
> Morrison Davis wrote:
>
>> install_driver(Oracle) failed: Can't load 
>> '/home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so' 
>> for module DBD::Oracle: ld.so.1: 
>> /usr/dist/share/perl5,v5.6.1/5bin.sun4/perl: fatal: relocation error: 
>> file 
>> /home/morry/src/pcdesign,v14.x/lib/site_perl/5.005/sun4-solaris/auto/DBD/Oracle/Oracle.so: 
>> symbol Perl_no_modify: referenced symbol not found at 
>> /usr/dist/share/perl5,v5.6.1/lib/sun4-solaris/DynaLoader.pm line 206, 
>> <BOM> line 5362.
>> at (eval 1) line 3
>> Compilation failed in require at (eval 1) line 3, <BOM> line 5362.
>>
>> I installed DBI and DBD using a local version of perl. Tested and 
>> working I then wanted to distribute for other users
>> to use, our IT group requires us to use their disted version of perl 
>> which is 5.6.1. I then recompiled both DBI and DBD
>> after changing my perl path to point to the IT version, so when I do 
>> perl -V it points to IT 's version. But, now when
>> I try to run my program I get the above error. What am I missing?
>>
>> Any help much appreciated.
>>
>>
>>
>
>


0
morry
7/17/2003 6:04:42 PM
Reply:

Similar Artilces:

I can't get no cache, I can't get no cache. 'Cause I try and I try and I try and, I can't get no, I can't get no cache.
I have fiddled out for days tinkering with the setting in about:config trying to get FireFox 12 to use the disk cache. I have NOT found the trick. This One Trick Pony ain't doing it like it used to up until recently. Pray tell anyone, What information can I share that will point a knowledgeable person to aid me in getting FF to disk.cache? I have also tried restarting FF with add-ons disabled, (There were NOT too many to do this to, so it was quick and easy) Here is my stab at trying to convey the information that MIGHT govern matters Using about:cache Informatio...

Re: I can't get no cache, I can't get no cache. ' Cause I try and I try and I try and, I can't get no, I can't get no cache.
<div>please com e see me about htis<br /> <br /> ------- Original Message f= rom the Global Relay Archive -------<br /> From: Hp &lt;ferd@farkel.net&gt;= <br /> To: "support-firefox@lists.mozilla.org" &lt;support-firefox@lists.mo= zilla.org&gt;<br /> Sent: Sun, 27 May 2012 18:30:18 -0700<br /> Subject: I = can't get no cache, I can't get no cache. 'Cause I try and I try and I try = and, I can't get no, I can't get no cache.<br /> <br /></div> <pre class=3D"gr-maex-body-pre&qu...

2010: Can't register - can't download the software - can't register until I have the software
I have active maintenance on Rad Studio: From: Vicky Rassmisaengthong [mailto:Vicky.Rassmisaengthong@EMBARCADERO.COM] Sent: Wednesday, February 25, 2009 1:58 PM To: rgrossman Cc: amer.supportadmin@codegear.com; Ashley Cosentino Subject: Software Assurance Support for Tech III Inc PO# Credit Card Dear Embarcadero Technologies Support Customer, Welcome! You have been registered as the primary contact on support account number AM####### Herewith we confirm your Embarcadero Technologies support agreement covering: Qty 1 RAD Studio Enterprise Named User licens...

Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I?
Name: Ed Leech Email: ELCraftatzoominternetdotnet Product: Thunderbird Summary: Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I? Comments: I am getting frusted with all the emails coming in that I do not want, I am using the tools to get thme out but they keep coming. They just use different names or whatever. I have been thinking of just switching to something else but my business intrusts know this email and it is tooo confusing to change. Every time I go out of town on bu...

Can't get it to work. Can't get help.
Name: Tony Clarke Email: minionataondotat Product: Thunderbird Summary: Can't get it to work. Can't get help. Comments: Installed T'bird. Had to change defunct server that T'bird selected by default. Kept asking for passwords associated with previous email (Outlook Express ), when passwords entered then got error messages saying aon responded with 're-authentification failure'. Searched your knowledge base & help forums to no avail. Found them very user-unfriendly & ended up more confused than before. Would like to try T'bird, but I think ...

Debian Woody, two problems: can't get kppp to work and can't su in X
Hello, I have Debian Woody installed on this Dell i8100 laptop via Libranet 2.0. I have two hurdles left that I can't seem to overcome. 1. I can't get kppp to work. I always get the following error message: Apr 27 19:38:48 libranet pppd[622]: The remote system is required to authenticate itself Apr 27 19:38:48 libranet pppd[622]: but I couldn't find any suitable secret (password) for it to use to do so. Apr 27 19:38:48 libranet pppd[622]: (None of the available passwords would let it use an IP address.) Exit Status From 'man pppd': 1 An immediately f...

update fails, can't get out of it and now can't get my email
Name: martha Email: mjhartleyatchampmaildotcom Product: Thunderbird Summary: update fails, can't get out of it and now can't get my email Comments: The directions about bugging aren't helpful to me because I don't know what you're talking about. You offered an update, I tried it, now it is in an endless loop of trying to install, failing, and trying again. It is very frustrating because I can't even get into my old email files to get addresses, photos, etc. I have turned off my firewall and have rebooted the computer, per some of the suggestions in the...

can't get any support and can't open firefox
Name: Jacquelyn Flora Email: jacquelynfloraatmacdotcom Product: Firefox Summary: can't get any support and can't open firefox Comments: I am so completely frustrated since I have been trying to resolve this issue for weeks. I cannot open firefox at all ever since I upgraded (big mistake) to 3.0.5 and then 3.0.6. Your support site isn't worth anything because it doesn't answer any of the questions. I am so frustrated that I am ready to give up. Browser Details: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/525.27.1 (KHTML, like...

Can't get through init 3 from init 5 and can't get through init 5 from init 3.
I tried opensuse 12.1 Gm today. Installation was perfect with xfce 4.8 until I tried installing the nvidia driver. In runlevel 5 as superuser I tried to shift to runlevel 3 and was welcome with a black screen, I have to use ctrl-alt-delete to reboot. During the reboot I used runlevel 3 and I was able to install the nvidia driver. After the nvidia driver installation I tried to shift to runlevel 5 and there, I was welcome with a black screen with a stationary blinking x cursor. I rebooted once again wiith runlevel 5 to get the gui. Any one had seen this happened? This installation is...

Can't base report on stored procedure--'Can't create Datawindow'
I installed IM65 today to give it a try. I made a db config to our local ASE 11.9.2 engine via Sybase' odbc driver that came with 11.9.2. I start a new report, tell it to be tabular and to get data from a SP. It asks which SP and I tell it. The result is an odbc error: Cannot create DataWindow Intersolv SQL ODBC driver: Incorrect syntax near '='. 1 execute dbo.sp_si_addressbest_;0 RETURN_VALUE = :RETURN_VALUE' I can execute the SP fine from SQL Advantage or from Crytal Reports. Thanks. -- Frank Burleigh Indiana University School of Law Bloomi...

Firefox won't load; can't get it to work!
Name: Robbie Email: torocityatgmaildotcom Product: Firefox Summary: Firefox won't load; can't get it to work! Comments: I'm running Windows 7, and I can't get Firefox 3.6 to work. I get the following message when I try to run it: We're sorry. Firefox had a problem and crashed. We'll try to restore your tabs and windows when it restarts. To help us diagnose and fix the problem, you can send us a crash report. I've tried to reinstall, to run in Safe Mode, and to do the dozens of things suggested on the Internet, but I can't run Firefo...

Can't add users to CC list because they can't edit the product
I've just found that I can't add some users as CC on a bug, apparently beca= use they can't edit the Product. I know they can't edit it. That's fine. I just want to add them as CC on the bug. The bug's visibility has been changed so that they can see it (Read-only ac= cess). Can anyone tell me why not being able to edit it is stopping them being add= ed as CCs? Surely that's not relevant ? Uncertainly, Richard. Richard Kerry Colledia Control Engineer Siemens IT Solutions and Services Ltd Room 457 Drama Building, BBC Television Centre, Wo...

Slashdot
A couple of weeks ago, the tags feature on Slashdot stopped working. The arrow that you click on to bring up an edit box to tag stories doesn't click any more. Any ideas why this might be? Also, Slashdot is the only web site that Firefox can't remember the user name and password for, because they use a pop-up log in window. Very annoying. Phil Hibbs. ...

Desperate!!!! -- can't get DNN4 with sqlexpress2005 to work on winxp --- can't connect to DB!!!!!
HELP!!!!! HELP!!!!I followed the install guide for DNN4 (install version)...but it doesn't work with SQL 2005 express on Win XP...i have tried everything!! below is the error message and the connection strings...HELP!!!   Error Installing DotNetNukeCurrent Assembly Version: 04.00.00ERROR: Could not connect to database specified in connectionString for SqlDataProviderSystem.Data.SqlClient.SqlException: Unable to open the physical file "C:\dotnetnuke\App_Data\dotnetnuke.mdf". Operating system error 5: "5(Access is denied.)". An attempt to attach an auto-named database for file C:\dotne...

Web resources about - Can't get around this problem, Can't load - perl.dbi.users

Resources last updated: 12/27/2015 8:56:40 AM