cpan>install NET::SSH ----> Can't install NET::SSH don't know what it is?

Good day!
  This is the first time I'll be using the cpan to
install modules. I run:

perl -MCPAN -e shell

and answer the questions one by one. When its done,
I issued install NET::SSH at the cpan> prompt and I
got the message:

Can't install NET::SSH Don't know what it is.

Question:
How will I make cpan> know what NET::SSH is? Is there
something I have to update first? How can I search for
some useful modules using cpan> rather than using cpan
search in www.cpan.org?

What is auto bundle? And what does 'cpan -a' does?
When I ran it, I can some perl modules, scrolling. Are
they the ones installed in my system?
I've heard somewhere from perlfaq that cpan> supports
proxy connection. Is this true? Because I'm at home
right now and tomorrow I would want to use perl at
work and also the cpan> to install and search for some
useful modules, but my workstation is behind proxy.

Thanks a lot for your help.
Have a nice day!















__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
0
b0ydaem0n
11/7/2004 1:35:28 PM
perl.beginners 29344 articles. 3 followers. Follow

1 Replies
1037 Views

Similar Articles

[PageSpeed] 13

On 11/7/2004 8:35 AM, Harold Castro wrote:
> Good day!
>   This is the first time I'll be using the cpan to
> install modules. I run:
> 
> perl -MCPAN -e shell
> 
> and answer the questions one by one. When its done,
> I issued install NET::SSH at the cpan> prompt and I
> got the message:

cpan> install Net::SSH

case matters

0
ml
11/7/2004 1:40:03 PM
Reply:

Similar Artilces:

Can't Update CPAN, Can't Install DBD::mysql
I upgraded to Lion. I have pre-existing Perl modules that I had installed, but I hadn't yet installed DBD::mysql. When I try to install DBD::mysql, I get this: Checking if your kit is complete... Looks good Using DBI 1.615 (for perl 5.012003 on darwin-thread-multi-2level) installed in /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level/auto/DBI/ Writing Makefile for DBD::mysql Can't exec "/usr/bin/make": No such file or directory at /System/Library/Perl/5.12/CPAN/Distribution.pm line 2026. CAPTTOFU/DBD-mysql-4.020.tar.gz /usr/bin/make -- NOT...

Re: Can't Update CPAN, Can't Install DBD::mysql
Good morning, On 28/09/11 at 3:59 PM -0400, Lola Lee Beno <lola@his.com> wrote: >That's what I was afraid of. Apparently a previous install of=20 >make got blown away. In the process of downloading XCode from=20 >App Store (uggggh) . . . I had to install Xcode twice (not download, just install twice).=20 And I seem to recall some reports from others saying the same=20 thing. Installing twice also fixed borked xcode for a colleague.=20 I never bothered to find out why that fixed things; just=20 proceeded and kept working. Charlie --=20 =E1=8F=8A C...

Can't install opensuse 12.1 from DVD, installer can't find DVD devices?
Hi, I have an HP pavilion dv7 laptop (3 years old) with Windows and Linux mint in a dual boot mode, and I wanted to install opensuse 12.1 from a DVD over my mint partition. When I boot with the 64bit KDE live CD in my DVD I can get to the menu where I can choose to try the live session or install. If I choose either, I see the linux kernel loading successfuly, then a green screen with opensuse logo, and after about 10 seconds the screen becomes a black text screen, and I see an error message saying that my DVD device wasn't found, and that the system is restarting in 120 se...

Can't reach internet directly, can via ssh to another 'puter on my net.
Problem box: Has 2 realtek rtl8168/8111 gigabit nic on mainboard (yes, that troubled one), added an Intel gigabit nic. Connect (cable) only Intel nic. =20 Cannot see outside my net, no ping, nothing. This is a fresh install of OS 11.4 LXDE. Can ping and ssh local machines. I can browse the internet with ssh to firefox on another machine. =20 I have rebooted my router (WRVS4400N) and updated its DHCP assignment tables. No change. Any ideas on what is going on? ?-) Your problem is that you don't have a default route. This will probably work: Yast --> Networ...

Sending email via the port 465 of Gmail don't work! I don't know if there are bugs in .NET.
I use the following code to send  email via  Gmail , it works well when I use client.Port = 587, but it doesn't work if I use client.Port = 465 !  but If I use email client software such as Outlook Express with port 465, it woks well, I don't know if there are bugs in .NET.     protected void btnSend_Click(object sender, EventArgs e)    {        //Add Async="true" to .ASPX page         SmtpClient client=new SmtpClient();     ...

can't install amsn, suse dont't install tcl scripting langua
Hi all i recently installed opensuse 11.1 i586, and i need to install amsn here, but i got a error when installing, it says that needs the TCL Scripting Language, i typed "tcl" on yast and i found the files needed, i check the files on software management, and i click accept, it asks for the opensuse cd, but i only have the dvd install, i put it on the dvd rom, but i get a error message "failed to mount /dev/srO ...." :( i dont understand whats going on. EDIT: I think i posted in the wrong section, sorry i didnt find any other that matchs my problem PS: so...

I can't get no cache, I can't get no cache. 'Cause I try and I try and I try and, I can't get no, I can't get no cache.
I have fiddled out for days tinkering with the setting in about:config trying to get FireFox 12 to use the disk cache. I have NOT found the trick. This One Trick Pony ain't doing it like it used to up until recently. Pray tell anyone, What information can I share that will point a knowledgeable person to aid me in getting FF to disk.cache? I have also tried restarting FF with add-ons disabled, (There were NOT too many to do this to, so it was quick and easy) Here is my stab at trying to convey the information that MIGHT govern matters Using about:cache Informatio...

Re: I can't get no cache, I can't get no cache. ' Cause I try and I try and I try and, I can't get no, I can't get no cache.
<div>please com e see me about htis<br /> <br /> ------- Original Message f= rom the Global Relay Archive -------<br /> From: Hp &lt;ferd@farkel.net&gt;= <br /> To: "support-firefox@lists.mozilla.org" &lt;support-firefox@lists.mo= zilla.org&gt;<br /> Sent: Sun, 27 May 2012 18:30:18 -0700<br /> Subject: I = can't get no cache, I can't get no cache. 'Cause I try and I try and I try = and, I can't get no, I can't get no cache.<br /> <br /></div> <pre class=3D"gr-maex-body-pre&qu...

2010: Can't register - can't download the software - can't register until I have the software
I have active maintenance on Rad Studio: From: Vicky Rassmisaengthong [mailto:Vicky.Rassmisaengthong@EMBARCADERO.COM] Sent: Wednesday, February 25, 2009 1:58 PM To: rgrossman Cc: amer.supportadmin@codegear.com; Ashley Cosentino Subject: Software Assurance Support for Tech III Inc PO# Credit Card Dear Embarcadero Technologies Support Customer, Welcome! You have been registered as the primary contact on support account number AM####### Herewith we confirm your Embarcadero Technologies support agreement covering: Qty 1 RAD Studio Enterprise Named User licens...

Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I?
Name: Ed Leech Email: ELCraftatzoominternetdotnet Product: Thunderbird Summary: Two things,Why do I keep getting emails that I don't want. can't get rid of them? Why can't I get my email when I am out of town? Or can I? Comments: I am getting frusted with all the emails coming in that I do not want, I am using the tools to get thme out but they keep coming. They just use different names or whatever. I have been thinking of just switching to something else but my business intrusts know this email and it is tooo confusing to change. Every time I go out of town on bu...

Installation 'Sybase DataWindow PS' printer on W98 doesn't work (so PDF export can't work either)
I have a problem with export DataWindow content to PDF on W98 systems. (I don't have any problem with PDF export on other systems like as WINNT, W2K, WXP). I found out that the problem is in the Sybase DataWindow PS printer. It looks like installed but it DOESN'T WORK on W98. When I try print something on this printer then no PostScript file is created. So I tried manual installation of it but it occurs an error during manual installation (I used description of instalation from Bruce Armstrong). The error said that printer driver (PSCRIPT.DLL) can't be loaded. I use...

Can't install grub/lilo, can't restor windows boot
Hi I tried to install opensuse 11 yesterday. But it couldn't install GRUB. It says - *disk doesn't exist* I cancelled the installation and now I cannot even access my windows (fixmbr and fixboot don't help) Please help! -- greg606 ------------------------------------------------------------------------ Well, In some cases (especially when using recovery boot) grub reports installation problems. But this is the first time somebody reports fixmbr problems. 1/ I would consider using windows disk to load emergency console to try to access windows disk. If...

Crystal reports don't run well after Windows Update installs .net 2.0 and .net 3.5
 I have a web reporting application build using VS2003 and Crystal ver 9.5.Everything was working fine until the infrastructure team run the windows 2003 server WINDOWS UPDATE where the new .net 2.0 & .net 3.5 got installed.I started to get CrystalDecisions.CrystalReports.Engine.InternalException: Error in File:crreport5.rpt -The request could not be submittted for background processing.After I restart IIS , the reports start working again but they stop after a while and I have to restart again ...Please, advise.    ...

Can't install Email-Send & Can't access Bugzilla in Browser
Hi All I am facing this problem for many days now and actually am stuck at this point can somebody please help me in resolving this (platform is Windows Server 2003, perl 5.8.8, Apache 2.2.4) 1) When I runchecksetup.pl command it give me error that Email Send and Emil MIME Modifier are not installed ..... I followed the instructions and run the commands but am unable to install these two C:\Bugzilla\bugzilla-3.0>ppm install Email-Send Downloading ActiveState Package Repository packlist...not modified Downloading theory58S packlist...redirect Downloading theory58S packlist...

(newbie) Installation completed... but can't login with 'host' or 'admin'
Can't do the first step after completing installation: login with default host or admin accounts. What and where should I modify? I did the installation by the book (by the video tutorial, to be precise ;) and got stuck here, since whatever I try, I cannot access the host or admin account. Thanks in advance. If you can't login with host/host or admin/admin, it appears that your installation failed!I would start the process over by doing the following:1.   Delete the instance of DNN created in SQL server.2.   Delete the existing DNN files in the folder yo...

Web resources about - cpan>install NET::SSH ----> Can't install NET::SSH don't know what it is? - perl.beginners

Resources last updated: 11/30/2015 9:47:13 PM