problem with openldap 2.4.26.2.3... client will not work.

I have 12.1 milepost 5.
set up ldap.
Looks like I have the openldap server running, the ldap browser appears
to recognize it.
Having trouble getting tls - ssl to work for the client software.
The setup is correct from all of the ldap.conf stuff I can see on the
net. I get a handshake failure on starting up the client.
client works on standard ldap, tls/ssl is the problem.

So I looked at some documentation for the openssl software.
I got the idea to update the openssl to 10.0.0e package, but when I:
nightmare:/media/NoName # rpm -U -v openssl-1.0.0e-32-1.i586
error: Failed dependencies:
openssl = 1.0.0d is needed by (installed)
libopenssl-devel-1.0.0d-32.1.i586
nightmare....

I have some other issues with openssl [see second post]

all current updates are on [fixed that today]
Am I really missing libopenssl-devel-1.0.0d-32.1.i586, and if so where
can I get it?
any ideas on how I can get this problem resolved?

I am beginning to believe i am missing some important parts of
openssl.
Unless there are some major differences between distributions [and
there are some I know] specifically in the openssl package
I seem to be missing /usr/lib/openssl..... stuff, one of these is
called /engines, and appears to have some
major influence on security.

I did write to the openldap folks, they weren't all that helpful.
If I get more information, put together a trace / documentation, I will
probably copy you on the doc, and keep you updated on the outcome, it
maybe Suse dependent if this openssl difficulty is the problem.

tob

if at all possible please copy jctobin@po-box.esu.edu, I have too many
mail locations already.


-- 
jctobin
------------------------------------------------------------------------



0
jctobin
10/14/2011 7:36:02 PM
opensuse.org.prerelease-beta 2066 articles. 0 followers. Follow

2 Replies
540 Views

Similar Articles

[PageSpeed] 25

Sorry,

Real question is where is :
Am I really missing openssl = 1.0.0d?
It is listed as on in rpm [YAST2 gui].

if I :
nightmare:/media/noname # rpm -i -v openssl-1.0.0d-32.1.i586.rpm
Preparing packages for installation...
package openssl-1.0.0d-32.1.i586.rpm is already installed

if I:
nightmare:/media/noname # rpm -U -v openssl-1.0.0e-32.1.i586.rpm
error: Failed dependencies:
openssl = 1.0.0d is needed  by (installed)
libopenssl-devel-1.0.0d-32.1.i586

What's wrong?

please copy jtobin@po-box.esu.edu.


-- 
jctobin
------------------------------------------------------------------------
jctobin's Profile: http://forums.opensuse.org/member.php?userid=60084
View this thread: http://forums.opensuse.org/showthread.php?t=466494

0
jctobin
10/17/2011 2:16:03 PM
finger slip.

-- 
DD
openSUSE®, the "German Automobiles" of operating systems
0
DenverD
10/17/2011 3:09:10 PM
Reply:

Similar Artilces:

[ANN] Release of Bugzilla 4.3.2, 4.2.2, 4.0.7, and 3.6.10
Today we are releasing 4.2.2, 4.0.7, 3.6.10, and the unstable development snapshot 4.3.2. All of today's releases contain security fixes. We recommend all Bugzilla administrators to read the Security Advisory linked below. Bugzilla 4.2.2 is our latest stable release. It contains various useful bug fixes and security fixes for the 4.2 branch. Bugzilla 4.0.7 and 3.6.10 are security updates for the 4.0 branch and the 3.6 branch, respectively. 4.0.7 also contains several bug fixes. Note that 4.3.2 is an unstable development release and should not be used in producti...

Security advisory for Bugzilla 4.3.2, 4.2.2, 4.0.7 and 3.6.10
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Summary ======= Bugzilla is a Web-based bug-tracking system used by a large number of software projects. The following security issues have been discovered in Bugzilla: * In HTML bugmails, an improper validation of the permissions of the addressee can lead to confidential information about bugs and attachments to be visible to the addressee. * The description of a private attachment can be visible to a user who hasn't permissions to access this attachment if the attachment ID is mentioned in a comment in a bug. Al...

Upgrading DNN from 3.2.2 to 4.0.2 problem
Hi, i just upgrade my website from 3.2.2 to 4.0.2, the process went fine (the "click here to access your portal" link appeared) however, the app keeps redirecting to the install.aspx file. What's wrong? I had no problem with upgrading before. Here is the link: http://dnnvn.net Any help would be appreciated. Regard, NVThttp://dnnvn.de...

problem with jss sha1withrsa verify raising exceptions (works in jss 3.3, jss 3.4 but not jss 4.2.5)
Hi, can someone please confirm the following bug. It seems to be regression in jss. signatureValue & publicKey & validData1 == valid signature (verify return true in every version of jss) signatureValue & publicKey & validData2 == invalid signature (verify should return false, since signatureValue is still in the same correct format, but validData2 is different). Jss 3.3 and Jss 3.4 return true and false ... Jss 4.2.5 returns true and exception (instead of false) java.security.SignatureException: Failed to complete verification operation ...

I ran CVS update from 3.2.3 to 3.2.4, but still display 3.2.3
Hi, On Windows Server with Bugzilla 3.2.3 I ran: cvs update -R -d -rBugzilla_Stable I thought I was updating to 3.2.4. When I log in, I still see 3.2.3. Did I do something incorrectly? Thanks, Yuri Have you run checksetup.pl since the cvs update command? This is required. - Brian Small -----Original Message----- From: support-bugzilla-bounces+bsmall=3Dnwlogic.com@lists.mozilla.org [mailto:support-bugzilla-bounces+bsmall=3Dnwlogic.com@lists.mozilla.org] On Behalf Of Yuri Ivanov Sent: Friday, July 24, 2009 10:31 AM To: support-bugzilla@lists.mozilla.org Subject: I ran...

Anyone running NetWare 3.12/3.2 in production? Or 4.11/4.2? NT 3.51? OS/2 Warp 3.0?
Just curious to see who's using something that is really old... On 12/1/10 9:16 AM, Mike M wrote: > Just curious to see who's using something that is really old... I remember wanting to buy OS/2 back in the days of Windows 3.1 and even 95, but I just couldn't afford it. :P -- http://www.thecrankyitguy.com http://www.thecrankyitforum.com I still support a couple 4.11 servers, if you can call never having to do anything to them "support". They just keep running and running and running and running. -Bob Carroll "Mike M" <nospam@nosp...

solpartmenu menualignment tag does not work in 3.2.2 and 4.0.2
solpartmenu menualignment tag does not work in 3.2.2 and 4.0.2 All skins which use menualignment tag (center | justify) they all go to left. But the same skins work perfect with 3.1.1 and below. any idea?...

KDE 4.2.2 to KDE 4.2.3
Hi Guys, I know this is kinda stupid:shame:, but how do i upgrade my KDE from 4.2.2 to 4.2.3? I remember just update my KDE from in YAST2 but i can't seem to go past 4.2.2 Any Help is really appreciated:) -- sabbyman ------------------------------------------------------------------------ add the repo for your suse version 'Index of /repositories/KDE:/42' (http://download.opensuse.org/repositories/KDE:/42/) -- My repo: http://download.opensuse.org/repositories/home:/microchip8 -----------------------------------------------------------------...

KDE 4.2.3 but Konqueror only 4.2.2. Why?
In addition to this oddity, the Konqueror plug-ins are 4.2.3. Any ideas as to when Konqueror will be bought into line? -- Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy "I wear the cheese. It does not wear me." Code: -------------------- maelstrom:/home/heidi # zypper info kde4-konqueror Loading repository data... Reading installed packages... Information for package kde4-konqueror: Repository: @System Name: kde4-konqueror Version: 4.2.3-3.1 Arch: i586 Vendor: openSUSE Build Service Installed: Yes Status: ...

Webservice on EAServer 4.2/4.2.3 with AXIS Client
List, I am attempting to use a Java client application to invoke a web service (hosted on EAServer) using Apache Axis 1.1. This fails due to: {http://xml.apache.org/axis/}stackTrace: org.xml.sax.SAXParseException: Document root element is missing. Please see attachment for complete error message and Java client class. I can successfully invoke the same web service using the Sybase ClientProxy method (see attachment for Java client class). Does anyone know what I am doing wrong or whether these versions are incompatible ? Thanks James begin 666 wsnewsgroup_issue.doc MT,\...

JavaBean (de)serialisation problem: NullPointerException with EAS4.2.3 (4.2 OK) #2
Hi Folks, I have set up a very simple webservice on EAServer 4.2, based on a component created from a Java class with the return value encapsulated in a JavaBean. The service is consumed by a simple Java client, which deserializes the result to an instance of the same JavaBean, then prints out the result. After upgrading to EAServer to 4.2.3, the webservice method is invoked as before (prints comments to server log) but fails to return the result to the client. -------------------------------------------------------------- The error message at the client is: java.lang.NullPointe...

Problem updating: libkdepim4-4.2.4-2.3.x86_64.rpm not found
Code: -------------------- Retrieving: libkdepim4-4.2.4-2.3.x86_64.rpm [error] File './x86_64/libkdepim4-4.2.4-2.3.x86_64.rpm' not found on medium 'http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/' -------------------- Hi, this message I get when I run zypper up. Any chance this file comes back within a few hours? Where should I report this issue? Thanks. Remco -- TheUnknownCylon ------------------------------------------------------------------------ Your repositories are "out of date" (Refresh off?) or the mirr...

Firefox 3 Beta 2 problem #2
Name: Heather Email: srngdrgnathotmaildotcom Product: Firefox Summary: Firefox 3 Beta 2 problem Comments: http://www.vbulletin.org/forum/showthread.php?t=134676 The link above is to the skin I'm experiencing problems with while viewing with Firefox 3. In this link there is also a Demo forum which is much like the one I'm using. In Firefox 2 the skin works perfectly and is my favorite one on the site I"m about to show you screenshots of. Firefox 3, however, stretches the skin to at least double it's normal length, making it hard to get to buttons and see th...

Upgrading from 3.2.4 to 4.4.2
Hi folks, sorry to bother you with this (I have just search the 27K messages on the server for "Upgrading from 3.2.4" and there's not a lot there). I have a new customer who wants me to upgrade all of his software and he's on ancient versions of *everything*. In particular he's currently on version 3.2.4 of Bugzilla and he wants to get onto the latest stable release. So my questions are: 1. Is this still possible? 2. If it is, is it going to take a long time as I'm going to have to go from release to release or can I do the upgrade in one gia...

Web resources about - problem with openldap 2.4.26.2.3... client will not work. - opensuse.org.prerelease-beta

OpenLDAP, Main Page
The Open Source for LDAP software and information. Home of OpenLDAP.

johnshew (@johnshew) on Twitter
Sign in Sign up You are on Twitter Mobile because you are using an old version of Internet Explorer. Learn more here johnshew @ johnshew Redmond, ...

Active Directory - Wikipedia, the free encyclopedia
Active Directory (AD) is a directory service created by Microsoft for Windows domain networks. It is included in most Windows Server operating ...

Active Directory comes to Linux with Samba 4
Enterprise networks now have an alternative choice to Microsoft Active Directory (AD) servers, with the open source Samba project aiming for ...

LDAP Proxy Server - Certificate Discovery Service - Carillon Information Security Inc.
Pathfinder enabled Certificate Discovery Service (LDAP Proxy) compatible with TSCP Secure Email and Boeing LDAP Proxy (Pathfinder, OpenLDAP, ...

OpenBSD 4.8版正式发布:改进硬件支持_Unix子站_IT专家网
OpenBSD 是一个从BSD派生出的类Unix操作系统,是在1995年由项目发起人Theo de Raadt从NetBSD分支而出。OpenBSD以对开放源代码的坚持、高品质的文件、坚定的软件受权条款和专注于系统安全及代码品质而闻名。OpenBSD以河豚作为项目吉祥物。 OpenBSD ...

Apple - OS X Lion Server - Technical Specifications
Read all about the technical specifications, system requirements, and ordering information for Mac OS X Server Snow Leopard.

Lion LDAP Authentication Problem: Apple Support Communities
Hi helpers, we are using an OpenLDAP server to authenticate our users to different desktop machines. Using SL everything worked just perfect. ...

Source Browser
Name Size Parent Directory - Apple16X50Serial/ - Apple3Com3C90x/ - AppleAC97Audio/ - AppleADBButtons/ - AppleADBDisplay/ - AppleADBKeyboard/ ...

Mac OS X: Disk Utility's Repair Disk Permissions messages that you can safely ignore
... . The following messages that may appear in Mac OS X Server may also be safely ignored: Permissions differ on "private/var/db/openldap/openldap-data", ...

Resources last updated: 12/13/2015 11:23:53 PM