struggling with NVidia Proprietary driver on 11.4

Hi guys,

I have a Lenovo Thinkpad T610 with NVS-3100M and the embedded intel
graphics. I recently did a clean install of 11.4.   I was using the
default opensource driver that came with 11.4 and everything was working
fine, except for sporadic crashes and hangs.  It happened quite often
that the system would crash straight after restarting.  Usually 1 out of
3 restarts would end up crashing.  Also every now and then when the
computer was going on sleep automatically, on the way out the system
would crash with 'resuming ...' printed a few times on the screen.  
After a bit of googling around for the symptoms I was experiencing found
out this is usually caused by the graphic card + driver, and hence
decided to give the nvidia proprietary driver a go.

I installed the driver both the easy way ( using zypper ) and the hard
way using the nvidia run script and following the instructions, but had
no luck.  At the beginning I was getting a few issues with i915 and drm.
The most important ones were:


Code:
--------------------
    intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled
  [drm:intel_dsm_pci_probe] *ERROR* failed to get supported _DSM functions
  fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
  
--------------------

I could boot the system in failsafe, but the normal boot wouldn't load
any graphics and start the command line interface.

The  i915 issue was then resolved by adding i915 and intel_agp to the
/etc/sysconfig/kernel and doing a mkinitrd, and blacklisting Nouveau.

However the other two are still hassling me.  I looked around different
forums and etc but found no concrete information on how to resolve the
two. So  ended up removing the xorg.conf file, and now the laptop boots
normally but not using the nvidia drivers.  I'm really not sure what's
happening at the moment, as Nouveau is blacklisted and there is no
xorg.conf file.

Currently the boot log only contains two errors/conflicts which are
the


Code:
--------------------
    
  <3>[   10.525497] [drm:intel_dsm_pci_probe] *ERROR* failed to get supported _DSM functions
  <3>[   10.526144] [drm:intel_dsm_pci_probe] *ERROR* failed to get supported _DSM functions
  <3>[   10.736911] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
--------------------


NVidia X Server Settings application warns me that:

Code:
--------------------
    
  You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
  
--------------------


The NVidia module and i915 are not complaining about much:

Code:
--------------------
    
  <4>[    2.853468] nvidia: module license 'NVIDIA' taints kernel.
  <4>[    2.853472] Disabling lock debugging due to kernel taint
  <6>[    2.863479] [drm] Initialized drm 1.1.0 20060810
  <6>[    2.902244] i915 0000:00:02.0: power state changed by ACPI to D0
  <6>[    2.902256] i915 0000:00:02.0: power state changed by ACPI to D0
  <6>[    2.902263] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
  <7>[    2.902267] i915 0000:00:02.0: setting latency timer to 64
  <6>[    2.930103] nvidia 0000:01:00.0: power state changed by ACPI to D0
  <6>[    2.930134] nvidia 0000:01:00.0: power state changed by ACPI to D0
  <6>[    2.930141] nvidia 0000:01:00.0: enabling device (0104 -> 0107)
  <6>[    2.930150] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
  <7>[    2.930158] nvidia 0000:01:00.0: setting latency timer to 64
  <6>[    2.930165] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
  <4>[    2.930343] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  295.33  Sat Mar 17 14:55:45 PDT 2012
  <7>[    2.952958] i915 0000:00:02.0: irq 41 for MSI/MSI-X
  <3>[    2.953476] [DRM:INTEL_DSM_PCI_PROBE] *ERROR* FAILED TO GET SUPPORTED _DSM FUNCTIONS
  <3>[    2.954030] [DRM:INTEL_DSM_PCI_PROBE] *ERROR* FAILED TO GET SUPPORTED _DSM FUNCTIONS
  <7>[    3.147813] checking generic (f0000000 1ff0000) vs hw (f0000000 8000000)
  <3>[    3.147819] FB: CONFLICTING FB HW USAGE INTELDRMFB VS VESA VGA - REMOVING GENERIC DRIVER
  
--------------------


I was wondering if anyone's got any idea what's happening here,
possible ways to fix it, what's worth investigating and etc.   I know
this is not a Suse issue but didn't know what forum would be the best
place to discuss this.

Thanks,
Shuku


-- 
shukuboy
------------------------------------------------------------------------



0
shukuboy
4/9/2012 6:36:02 AM
opensuse.org.help.hardware 8187 articles. 0 followers. Follow

2 Replies
429 Views

Similar Articles

[PageSpeed] 42

shukuboy wrote:

> 
> Hi guys,
> 
> I have a Lenovo Thinkpad T610 with NVS-3100M and the embedded intel
> graphics. I recently did a clean install of 11.4.   I was using the
> default opensource driver that came with 11.4 and everything was 
working
> fine, except for sporadic crashes and hangs.  It happened quite often
> that the system would crash straight after restarting.  Usually 1 out 
of
> 3 restarts would end up crashing.  Also every now and then when the
> computer was going on sleep automatically, on the way out the system
> would crash with 'resuming ...' printed a few times on the screen.
> After a bit of googling around for the symptoms I was experiencing 
found
> out this is usually caused by the graphic card + driver, and hence
> decided to give the nvidia proprietary driver a go.
> 
> I installed the driver both the easy way ( using zypper ) and the 
hard
> way using the nvidia run script and following the instructions, but 
had
> no luck.  At the beginning I was getting a few issues with i915 and 
drm.
> The most important ones were:
> 
> 
> Code:
> --------------------
>     intel ips 0000:00:1f.6: failed to get i915 symbols, graphics 
turbo
>     disabled
>   [drm:intel_dsm_pci_probe] *ERROR* failed to get supported _DSM 
functions
>   fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing 
generic
>   driver
>   
> --------------------
> 
> I could boot the system in failsafe, but the normal boot wouldn't 
load
> any graphics and start the command line interface.
> 
> The  i915 issue was then resolved by adding i915 and intel_agp to the
> /etc/sysconfig/kernel and doing a mkinitrd, and blacklisting Nouveau.
> 
> However the other two are still hassling me.  I looked around 
different
> forums and etc but found no concrete information on how to resolve 
the
> two. So  ended up removing the xorg.conf file, and now the laptop 
boots
> normally but not using the nvidia drivers.  I'm really not sure 
what's
> happening at the moment, as Nouveau is blacklisted and there is no
> xorg.conf file.
> 
> Currently the boot log only contains two errors/conflicts which are
> the
> 
> 
> Code:
> --------------------
>     
>   <3>[   10.525497] [drm:intel_dsm_pci_probe] *ERROR* failed to get
>   supported _DSM functions
>   <3>[   10.526144] [drm:intel_dsm_pci_probe] *ERROR* failed to get
>   supported _DSM functions
>   <3>[   10.736911] fb: conflicting fb hw usage inteldrmfb vs VESA 
VGA -
>   removing generic driver
> --------------------
> 
> 
> NVidia X Server Settings application warns me that:
> 
> Code:
> --------------------
>     
>   You do not appear to be using the NVIDIA X driver.  Please edit 
your X
>   configuration file (just run `nvidia-xconfig` as root), and restart 
the
>   X server.
>   
> --------------------
> 
> 
> The NVidia module and i915 are not complaining about much:
> 
> Code:
> --------------------
>     
>   <4>[    2.853468] nvidia: module license 'NVIDIA' taints kernel.
>   <4>[    2.853472] Disabling lock debugging due to kernel taint
>   <6>[    2.863479] [drm] Initialized drm 1.1.0 20060810
>   <6>[    2.902244] i915 0000:00:02.0: power state changed by ACPI to 
D0
>   <6>[    2.902256] i915 0000:00:02.0: power state changed by ACPI to 
D0
>   <6>[    2.902263] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, 
low) ->
>   IRQ 16
>   <7>[    2.902267] i915 0000:00:02.0: setting latency timer to 64
>   <6>[    2.930103] nvidia 0000:01:00.0: power state changed by ACPI 
to D0
>   <6>[    2.930134] nvidia 0000:01:00.0: power state changed by ACPI 
to D0
>   <6>[    2.930141] nvidia 0000:01:00.0: enabling device (0104 -> 
0107)
>   <6>[    2.930150] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, 
low)
>   -> IRQ 16
>   <7>[    2.930158] nvidia 0000:01:00.0: setting latency timer to 64
>   <6>[    2.930165] vgaarb: device changed decodes:
>   PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
>   <4>[    2.930343] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  
295.33
>    Sat Mar 17 14:55:45 PDT 2012
>   <7>[    2.952958] i915 0000:00:02.0: irq 41 for MSI/MSI-X
>   <3>[    2.953476] [DRM:INTEL_DSM_PCI_PROBE] *ERROR* FAILED TO GET
>   SUPPORTED _DSM FUNCTIONS
>   <3>[    2.954030] [DRM:INTEL_DSM_PCI_PROBE] *ERROR* FAILED TO GET
>   SUPPORTED _DSM FUNCTIONS
>   <7>[    3.147813] checking generic (f0000000 1ff0000) vs hw 
(f0000000
>   8000000)
>   <3>[    3.147819] FB: CONFLICTING FB HW USAGE INTELDRMFB VS VESA 
VGA -
>   REMOVING GENERIC DRIVER
>   
> --------------------
> 
> 
> I was wondering if anyone's got any idea what's happening here,
> possible ways to fix it, what's worth investigating and etc.   I know
> this is not a Suse issue but didn't know what forum would be the best
> place to discuss this.
> 
> Thanks,
> Shuku
> 
> 
Just to be clear
This is switchable graphics is it?

I do know there are issues generally, but I have no experience here.
And I have seen similar threads reporting problems when trying to use 
the nvidia driver
0
caf4926
4/9/2012 6:43:33 AM
Seems to be an Optimus system. First you have to realize that it's not
possible to run xorg on the Nvidia harware, it's only possible on Intel.
Nvidia can only be used under bumblebee, here's the best HOWTO so far:
http://tinyurl.com/c97lozl
Good luck!


-- 
hank_se
------------------------------------------------------------------------
hank_se's Profile: http://forums.opensuse.org/member.php?userid=202
View this thread: http://forums.opensuse.org/showthread.php?t=474233

0
hank
4/9/2012 9:46:03 AM
Reply:

Similar Artilces:

Help
hello, im having an ASUS K501N series laptop that has a G102M GeForce NVIDIA graphic card.Im having a dual boot with windows XP and OpenSUSE 11.1.i have already installed the graphic driver to windows but dont really Know how to installed it in SUSE 11.1..so i came up to this forum topic and did as what was told: > Start the Software installer and make sure you have the pattern 'Linux > Kernel Development' installed. > > Open a terminal window and issue following commands: > > mkdir NVIDIA-driver > cd NVIDIA-driver > wget ftp://download.nvidia...

need help to install nvidia driver on GEFORCE 6150se hardware in opensuse11.4
hi all i need help with installing nvidia driver . i'm useing gnome desk top.thank's -- aburroughs92 ------------------------------------------------------------------------ 'nVidia Driver via Repo in 11.3 & 11.4 - Guide' (http://tinyurl.com/29vv32s) -- Box: openSUSE 11.4 | Gnome 2.3 | AMD 64 X2 5200+ | nVidia 8500GT | 4GB RAM Lap #1: openSUSE 11.4 | Duo T4300 | KDE 4.6 | Gnome 2.3 | Intel M4 Graphics | Lenovo G550 | 3GB RAM Lap#2: 11.4 | Gnome | Celeron 550 | Intel 965GM | Lenovo R61 | Tumbleweed 'My Guides' (http://tinyurl.com/...

Intsalling xen with nvidia drivers, what drivers xen capable on open suse 11.4 ?
Hi, I am just wondering, what the steps should I take to install opensuse with xen, and a xen capable nvidia driver.. what versions are okay to use with xen? I just did a clean install becuase my old opensuse just used the current version, and it wouldn't boot into xen.. this install, I car more about having xen working then having nvidia installed but would still like to have a current display driver. os : 11.4 clean, xeon 5650 12gigs ram -- ghostcyber ------------------------------------------------------------------------ ...

11.4
Nvidia h/w: Quadro FX 570 Installed 11.4 yesterday. No problems. Installed Gnome 3 today and it goes into fallback mode. Assuming that the graphics driver might be the culprit, I attempted to install the latest nvidia driver. Added repo ftp://download.nvidia.com/opensuse/11.4/ in Yast2. Did a refresh and it complains that it cannot access installation media at the above. Paste the above in Firefox and it gets there OK. One-click method also fails. Never had a problem with updating nvidia driver before. Not sure what to check. I did delete and add with no succe...

KDE 4 slow with proprietary NVIDIA driver
Hi all, Installed openSUSE 11.1 over the weekend with KDE 4. Unfortunately, as soon as I installed the latest NVIDIA proprietary drivers from the NVIDIA repository, responsiveness in KDE 4 dropped horribly, although compositing works. I've got a Quadro FX 1600M. I remember reading about poor NVIDIA performance with early releases of KDE 4 but I thought those problems had been solved with the most recent drivers. Can anyone shed light? -- rhasselbaum ------------------------------------------------------------------------ ...

Install problem for laptop nvidia drivers with 11.4
In a fresh install from DVD I do a new boot and root partition and try to direct Yast to the repo for the Nvidia drivers. Yast does not want to connect to any repos in the installation system. I let it do the Network setup and use DHCP then the list of community repos comes up blank. I also tried to enter a URL for Nvidia and it just won't connect. This wouldn't be a problem but the generic driver does NOT work on this laptop and did NOT work in 11.3 either. The vid card is NVIDIA GeForce 7150M in the 'HP Pavilion dv2715nr' (http://tinyurl.com/3uzdlch). Whe...

xinerama with nvidia proprietary drivers : 3 or 4 screens
Have some of you managed to use xinerama (no twinview) with nvidia proprietary drivers on Opensuse 11.2 or 11.3 , using 3 or 4 screens ? -- dsant_fr ------------------------------------------------------------------------ ...

[11.4 RC2 64bit]
[11.4 RC2 64BIT] - HOW TO INSTALL NVIDIA DRIVER ? Hi, How do I install nVidia's proprietary display driver in openSUSE 11.4 RC2 64bit ? Thanks! Jesse -- JeZ-l-Lee ------------------------------------------------------------------------ There is guidance here (the hard way (which is not hard)): 'SDB:NVIDIA the hard way - openSUSE' (http://en.opensuse.org/SDB:NVIDIA_the_hard_way) Note you may need to disable KMS for this to succeed (hardware dependent) which can be done by running "yast" (you can run yast in text mode with root permissi...

Bad performance with 11.1 and proprietary nvidia drivers
I've just installed openSUSE 11.1 (64bits) with KDE4.1. I also installed the nvidia proprietary drivers by using this link: http://opensuse-community.org/nvidia.ymp Now kwin effects work but the overall performance is terrible. I can't even move a window without seeing glitches. I've got a Core2Duo T8100 at 2.10GHz, 4GB of memory and a GeForce8400M so i would expect a much better performance. Any tips on how to improve performance ? Thanks. -- hpalma ------------------------------------------------------------------------ hpalma;1915463 Wrote: >...

11.4 new nvidia driver install problems
11.4 with Gnome 3. Saw a new nvidia driver -- let's get it. 290.10 Tried to install with both one-click and zypper with no luck. Log file entry: missing or misconfigured D-bus session bus daemon ------- I've been able to install nvidia in the past using either method in the past with no problems but I'm pretty sure this is the first time I've tried since installing 11.4 and Gnome 3. Searched for similar problems but all I came up with was the D-bus message for other issues, not installing nvidia. Maybe 12.1 has similar problems? Dunno. -- gudewdl ...

No windows after 11.4 update - nvidia - old hardware
Hello all, Thought I would share this. I recently installed 11.4 on an older cpu (6 - 7years old). Initial install ran fine, box up and running fine. However, after an update (first after initial install), I could not get any graphic to work. Looking through the logs etc, I found a msg from the kernel complaining "reserve_memtype failed...". Recent kernels use x86 PAT (Page Attribute Table) support enabled by default. When I disabled this with the option "nopat" on the boot command options, all was well again. Why the initial kernel was ok with my old ...

how to have two desktop kernels and nvidia drivers in suse 11.4
I would like to have 2 desktop kernels in my suse 11.4, I also would like to have nvidia drivers working on both, how can I get this? situation: dell latitude e6510 /windows partition /data partition /home and / separated partition with 11.3 (I dont want to touch this becouse it works:-)) /home and / separated partition with 11.4 and kde 4.6.2 and kernel 2.6.37.1-1.2-desktop and nvidia drivers 270.41.06 (installed in the hard way that is not hard) as I'm interested to test new kernel becouse my touchpad scroll doesn't works, but I don't want to bork my 11.4, is it pos...

Re: Nvidia drivers - suse 11.4
Gentleman, I do not know why lord_valerian started his thread here, nor why stakanov answered here, both in English, in the Dutch part of the forums. It escapes me completely how you venture here either by: . not knowing Dutch, but nevertheless fopllowing the Forums - subforums tree down to here without ever asking yourself "why can't I understand the subjects here?"; . or knowing Dutch and thus understanding where you went, but then posting in English (in the hope nobody understands you?). Please understand that the languae parts of the forums are made to serve peop...

11.4 NVIDIA drivers and X compositing (or XComposite and XDamage)
Greetings, I've set up a basic 11.4 server/workstation at my home and am having trouble post-nvidia install when it comes to dual-monitors and compositing. Now, I've looked at many posts here and have not found an answer, since most of the answers are obviously for single-monitor setups. The reason I think this is that all the solutions render my second monitor useless (ie, blackscreen/does not function). Background: I've set up the nvidia 275 drivers via blacklisting neauveau(sorry if I have misspelled) and installing the package [nvidia drivers] from the nvidia...

Web resources about - struggling with NVidia Proprietary driver on 11.4 - opensuse.org.help.hardware

Proprietary - Wikipedia, the free encyclopedia
Text is available under the Creative Commons Attribution-ShareAlike License ;additional terms may apply. By using this site, you agree to the ...

All sizes - LG Smart TV Proprietary Apps - Flickr - Photo Sharing!
Flickr is almost certainly the best online photo management and sharing application in the world. Show off your favorite photos and videos to ...

LG debuts Urbane LTE, the world’s first 4G-capable smartwatch, with proprietary WebOS-based software
LG today unveiled the world's first LTE-equipped smartwatch, dubbed the LG Watch Urbane LTE. Unlike other recent smartwatches, the Urbane LTE ...

The Inside Story Behind Intel's Proprietary Font Design
... Which is why the company, along with design agency Red Peak and U.K.-based font foundry Dalton Maag, worked more than a year to create a proprietary ...

Every Time You Call a Proprietary Feature “CSS3,” a Kitten Dies
Any -webkit- feature that doesn’t exist in a specification (not even an Editor’s draft) is not CSS3. Yes, they are commonly evangelized as such, ...

New York Mag: Dodd-Frank has changed Wall Street, reduced bonus pools, ended proprietary trading at many ...
... 25 percent, Goldman fell 21 percent, and Citigroup fell 16—in a period when the Dow rose 25 percent. ■ The Volker Rule, which forbids proprietary ...


Fllu offers cash to "organically" promote Samsung's push for proprietary Android apps
Users contributing Android bug reports to the StackOverflow developer community were offered cash in exchange for "organically" directing interest ...

Sony saddles Vita with expensive, proprietary memory and short battery life
Sony is sticking with proprietary memory for the PlayStation Vita, and it's …

The Tell Of The Proprietary First Movers
... and that Bitcoin is likely to the be the first killer app for the Blockchain. He talks about how we were able to send email on the proprietary ...

Resources last updated: 12/10/2015 8:57:57 PM