NVIDIA: "You do not appear to be using the NVIDIA X driver"

Dear all,

I am using openSUSE 11.4 on a Lenovo Y570 laptop, which has switchable
graphics (NVIDIA GeForce 555M 1GB graphics, Intel HD Graphics 3000).
uname -a gives " #1 SMP PREEMPT 2011-07-21 02:17:24
+0200 x86_64 x86_64 x86_64 GNU/Linux".

I've installed the latest NVIDIA drivers (version 285.05.09) using the
guide on the OpenSUSE wiki ('SDB:NVIDIA drivers - openSUSE'
(http://en.opensuse.org/SDB:NVIDIA_drivers)) and the lnvhw script by
jdmcdaniel3 ('LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3
- Version 1.10 - Blogs - openSUSE Forums'

Even after all this, when I run NVIDIA X Server Settings, I'm met with
the error "You do not appear to be using the NVIDIA X driver. Please
edit your X configuration file ...". I don't attempt any such thing,
since having an xorg.conf file prevents openSUSE from booting into
graphics mode after the NVIDIA installation.

"modprobe -l | grep -i nvidia" gives several .ko files:


and "lsmod | grep -i nvidia" yields

nvidia              11709941  0 

Can someone kindly suggest what I may try next, please?

There is no option in my BIOS to disable the integrated graphics, only
a switch on the outside of the laptop (which seems to do something in
Windows, but I'm not sure about openSUSE). I wonder if I shouldn't
expect the NVIDIA driver to work with my system just yet, and stick with
the nouveau driver.

Thank you very much in advance for any advice you have!



10/12/2011 6:56:03 PM
opensuse.org.help.hardware 8187 articles. 0 followers. Follow

2 Replies

Similar Articles

[PageSpeed] 47

There are a number of threads, such as
'Switchable graphics - how do I disable one of the video drivers? -
Page 3' (http://tinyurl.com/3at3ckq)

search via
'Search - openSUSE.org' (http://search.opensuse.org/)

Box: 11.4 | KDE 4.7.2 | AMD 64 X2 5200+ | nVidia 8500GT | 4GB RAM 
Lap #1: 12.1 | Duo T4300 | KDE 4.7.1 | Intel M4 Graphics | Lenovo G550
Lap#2: 11.4  | KDE 4.7.2 | Celeron 550 | Intel 965GM | Lenovo R61 |
'My_Guides' (http://tinyurl.com/6cabu2j)
caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=466428

10/12/2011 8:06:03 PM
A thread concerning Optimus hybrid graphics

'No vga_switcheroo' (http://tinyurl.com/6du5d5v)

deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=466428

10/12/2011 9:16:02 PM