DVD drive won't work after install of 11.3.. No.. I did not spill beer in it..

I think I broke something. I have been playing with SUSE 11.3 for 2 days
now getting it ready for me to work on. Now that I want to put some
pictures on, I notice my DVD/CD is not working at all. I can seethe icon
in Nautilus but when I click on it nothing happens. I ran the hardware
info from Yast and this is what came up.

55: SCSI 100.0: 10602 CD-ROM (DVD)

[Created at block.249]

Unique ID: KD9E.dkrhozW_Ty1

Parent ID: vuMS.iyIwgooRAo4

SysFS ID: /class/block/sr0

SysFS BusID: 1:0:0:0

SysFS Device Link:
/devices/pci0000:00/0000:00:0e.0/host1/target1:0:0/1:0:0:0

Hardware Class: cdrom

Model: "ATAPI DVD A  DH16A3L"

Vendor: "ATAPI"

Device: "DVD A  DH16A3L"

Revision: "8H1B"

Driver: "sata_nv", "sr"

Driver Modules: "sata_nv"

Device File: /dev/sr0 (/dev/sg1)

Device Files: /dev/sr0, /dev/block/11:0, /dev/scd0,
/dev/disk/by-path/pci-0000:00:0e.0-scsi-1:0:0:0, /dev/cdrom, /dev/cdrw,
/dev/dvd, /dev/dvdrw

Device Number: block 11:0 (char 21:1)

Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW,
DVD+R DL, DVD-RAM, MRW, MRW-W

Drive status: no medium

Config Status: cfg=no, avail=yes, need=no, active=unknown

Attached to: #28 (IDE interface)

Drive Speed: 12

I cant seem or know how to mount it if need be. I opened the System
Services and saw this..

Start the autofs daemon for automatic mounting of filesystems.

This is set to off. should it be on? I'm thinking it is just for HDs
though.

I have no clue. I was doing the live cd thing for a while and it worked
great. Then I thought.. hey do a full install with dual boot and learn
this linux stuff. So here I am asking for some tips again. 

Thanks


-- 
Nakedmason
------------------------------------------------------------------------



0
Nakedmason
2/12/2011 6:36:01 AM
opensuse.org.help.hardware 8187 articles. 0 followers. Follow

5 Replies
344 Views

Similar Articles

[PageSpeed] 35

> Now that I want to put some pictures on, I notice my DVD/CD is not
> working at all.
From the other hardware info you've supplied I doubt you have a
hardware problem as such, just some learning required perhaps. Not all
DVD's and CD's are mountable (so Nautilus is not always the relevant
tool to be using). Not all have mountable file systems - Audio CD's for
example. Are you trying to play a DVD movie? Maybe this is a media
player issue.... A little specific info on what you're trying to
accomplish may help us point you in the right direction...


-- 
deano_ferrari
------------------------------------------------------------------------
deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=454031

0
deano
2/12/2011 9:06:01 AM
deano_ferrari;2289164 Wrote: 
> Are you trying to play a DVD movie? Maybe this is a media player
> issue.... A little specific info on what you're trying to accomplish may
> help us point you in the right direction...

Well I was going to copy a DVD with JPEG pictures on it to my HD so I
could do a little more exploring with Gimp and a few other programs I
read about. The drive opened when I hit the eject button, I put in my
DVD and closed it. Then nothing.  I cannot access it at all through
Nautilus. JUst the pretty Icon of a dvd/cd. I'd just like to get to
files on my disks for the moment. DVD movie playback is not important
nor is music cd's. Come to think of it I have not even tried a movie to
see if it will play. Duh.. I let you know what happens. I'm still
searching the fourms and google for answers to many of my questions.
Hopefully you can push me in the right direction.
Thank you for your time..


-- 
Nakedmason
------------------------------------------------------------------------
Nakedmason's Profile: http://forums.opensuse.org/member.php?userid=55131
View this thread: http://forums.opensuse.org/showthread.php?t=454031

0
Nakedmason
2/12/2011 10:06:03 AM
I'm not a Gnome user, but two things that are worth checking:

1) Maybe this is a gconf configuration issue. Run 'gconf-editor' to
make sure that

apps > nautilus > preferences > media_automount is enabled

2) Check if nautilus with root privileges gives you cd/dvd browsing


Code:
--------------------
    gnomesu nautilus
--------------------


If that works, it may be a permissions issue that needs addressing.

Can a Gnome user assist here?


-- 
deano_ferrari
------------------------------------------------------------------------
deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=454031

0
deano
2/12/2011 9:06:01 PM
FWIW, a similar thread 'here.' (http://tinyurl.com/4q9crhp) It was about
usb device mounting, but cd/dvd devices are mentioned too. Towards the
end of the thread it was speculated that this may be due to a security
(policykit) setting.


-- 
deano_ferrari
------------------------------------------------------------------------
deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=454031

0
deano
2/12/2011 9:06:01 PM
You could try executing the following command (as user) from a console


Code:
--------------------
    udisks --mount /dev/sr0
--------------------


Does nautilus then show the cd/dvd file system in /media?

Another useful diagnostic here is to monitor the device with


Code:
--------------------
    udisks --monitor-detail /dev/sr0
--------------------


Now insert the dvd, then maybe try clicking on the nautilus icon... it
should tell you what kind of media has been detected, file system,
mounted by uuid etc


-- 
deano_ferrari
------------------------------------------------------------------------
deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
View this thread: http://forums.opensuse.org/showthread.php?t=454031

0
deano
2/13/2011 5:06:02 AM
Reply: