Bluetooth does not work correctly with Smeegol

I'm resuming here (after suggestion of malcolmlewis) my problems with
Bluetooth and Smeegol. May be there is out there someone able to give
some advice. TIA.

My setup: Samsung N150 (Atom 450), 2Gig ram, Suse 11.3 - Smeegol 1

The problem is:

From the netbook (Samsung) i see the available bluetooth advices and
can even configure them but doing file research *ON* that devices is not
possible. I can only send files to, but not get files from there (e.g.
Nokia cellphone or PB G4 running Debian). Now, i think (but not sure on
this) in Smeegol the administration of bluetooth is done by the connman
(as i understand a connection manager developped by the Intel Open
Source Group which was responsable for Moblin as well (?) ) and so, it
might be a defect. of that connection utility.

So, i installed blueman (i know from other devices i use, runs very
fine and stable in Debian) but with blueman i got this error, when i
tried to access the other devices by bluetooth:

> Could not display "obex://[00:25:48:3A:A9:58]/".
> Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not
> receive a reply (timeout by message bus)
> Please select another viewer and try again. 

Then, after suggestion of malcolmlewis, i installed bluez-hcidump and
tried as root in a terminal: hcidump. The "result" was:

> HCI sniffer - Bluetooth packet analyzer ver 1.42
> device: hci0 snap_len: 1028 filter: 0xffffffff 

and then the process froze without any additional info (even after an
hour i didn't get back to the terminal prompt!).

And here, i'm out of any further idea. Might be a bug in Smeegol, as
someone suggested. Would be sad (since that feature of bluetooth is
pretty much essential for me, since i often use the phone to take
occasional photoshots i need for my work) but good to know as well.
Would be even better if there would be a workaround . . . :D

TIA for any help or suggestion.


-- 
Farinet
------------------------------------------------------------------------



0
Farinet
12/21/2010 8:36:02 AM
opensuse.org.help.hardware 8187 articles. 0 followers. Follow

8 Replies
2257 Views

Similar Articles

[PageSpeed] 5

[QUOTE=3DFarinet]
I'm resuming here (after suggestion of malcolmlewis) my problems with
Bluetooth and Smeegol. May be there is out there someone able to give
some advice. TIA.

My setup: Samsung N150 (Atom 450), 2Gig ram, Suse 11.3 - Smeegol 1

The problem is:

=46rom the netbook (Samsung) i see the available bluetooth advices and
can even configure them but doing file research *ON* that devices is not
possible. I can only send files to, but not get files from there (e.g.
Nokia cellphone or PB G4 running Debian). Now, i think (but not sure on
this) in Smeegol the administration of bluetooth is done by the connman
(as i understand a connection manager developped by the Intel Open
Source Group which was responsable for Moblin as well (?) ) and so, it
might be a defect. of that connection utility.

So, i installed blueman (i know from other devices i use, runs very
fine and stable in Debian) but with blueman i got this error, when i
tried to access the other devices by bluetooth:

> Could not display "obex://[00:25:48:3A:A9:58]/".
> Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not
> receive a reply (timeout by message bus)
> Please select another viewer and try again.=20

Then, after suggestion of malcolmlewis, i installed bluez-hcidump and
tried as root in a terminal: hcidump. The "result" was:

> HCI sniffer - Bluetooth packet analyzer ver 1.42
> device: hci0 snap_len: 1028 filter: 0xffffffff=20

and then the process froze without any additional info (even after an
hour i didn't get back to the terminal prompt!).

And here, i'm out of any further idea. Might be a bug in Smeegol, as
someone suggested. Would be sad (since that feature of bluetooth is
pretty much essential for me, since i often use the phone to take
occasional photoshots i need for my work) but good to know as well.
Would be even better if there would be a workaround . . . :D

TIA for any help or suggestion.


[/QUOTE]
Hi
You should get output from the hcidump for any bluetooth
communications..

As root user (sudo -i will get you there) can you open a terminal and
run hcidump. Then open another terminal (ensuring the phone bluetooth is
active) and run;
[CODE]
hcitool scan
[/CODE]
=46rom the above you will get the MAC address <MAC_ADDRESS> of the phone,
now;
[CODE]
hcitool inq <MAC_ADDRESS>
hcitool info <MAC_ADDRESS>
[/CODE]
Do you get information back and see activity in the hcidump window? If
not then try;
[CODE]
hcitool con <MAC_ADDRESS>
[/CODE]
Then re run the inq and info commands.

--=20
Cheers Malcolm =B0=BF=B0 (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.24-0.2-default
up 8 days 18:29, 2 users, load average: 0.05, 0.03, 0.00
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.29

0
malcolmlewis
12/21/2010 5:21:04 PM
Ok, followed your instructions and that's the result:

hcitool scan
> Scanning ...
> 	00:0A:95:34:B1:FD	G4-Ubuntu
> 	00:25:48:3A:A9:58	Nokia 3120 classic
hcitool inq 00:25:48:3A:A9:58
> Inquiring ...
> 	00:0A:95:34:B1:FD	clock offset: 0x5099	class: 0x015a00
> 	00:25:48:3A:A9:58	clock offset: 0x0691	class: 0x5a0204
hcitool info 00:25:48:3A:A9:58
> Requesting information ...
> 	BD Address:  00:25:48:3A:A9:58
> 	Device Name: Nokia 3120 classic
> 	LMP Version: 2.0 (0x3) LMP Subversion: 0x6cc
> 	Manufacturer: Cambridge Silicon Radio (10)
> 	Features: 0xbf 0xee 0x0f 0xc6 0x98 0x39 0x00 0x00
> 		<3-slot packets> <5-slot packets> <encryption> <slot offset> 
> 		<timing accuracy> <role switch> <sniff mode> <RSSI> 
> 		<channel quality> <SCO link> <HV3 packets> <u-law log> 
> 		<A-law log> <CVSD> <paging scheme> <power control> 
> 		<transparent SCO> <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> 
> 		<inquiry with RSSI> <extended SCO> <AFH cap. slave> 
> 		<AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL> 
> 		<AFH cap. master> <AFH class. master> <EDR eSCO 2 Mbps> 
> 

And now? ;-)


-- 
Farinet
------------------------------------------------------------------------
Farinet's Profile: http://forums.opensuse.org/member.php?userid=53005
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
Farinet
12/21/2010 9:36:01 PM
[QUOTE=Farinet]
Ok, followed your instructions and that's the result:

hcitool info 00:25:48:3A:A9:58
> Requesting information ...
> 	BD Address:  00:25:48:3A:A9:58
> 	Device Name: Nokia 3120 classic
> 	LMP Version: 2.0 (0x3) LMP Subversion: 0x6cc
> 	Manufacturer: Cambridge Silicon Radio (10)
> 	Features: 0xbf 0xee 0x0f 0xc6 0x98 0x39 0x00 0x00
> 		<3-slot packets> <5-slot packets> <encryption> <slot
> offset> <timing accuracy> <role switch> <sniff mode> <RSSI> 
> 		<channel quality> <SCO link> <HV3 packets> <u-law
> log> <A-law log> <CVSD> <paging scheme> <power control> 
> 		<transparent SCO> <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> 
> 		<inquiry with RSSI> <extended SCO> <AFH cap. slave> 
> 		<AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL> 
> 		<AFH cap. master> <AFH class. master> <EDR eSCO 2
> Mbps> 
> 

And now? ;-)
[/QUOTE]
Hi
So what happens if you try;
[CODE]
hcitool cc 00:25:48:3A:A9:58
[/CODE]
Then browse the device?

-- 
Cheers Malcolm ��� (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.24-0.2-default
up 8 days 23:21, 4 users, load average: 0.13, 0.15, 0.18
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.29

0
malcolmlewis
12/21/2010 10:09:22 PM
Hi
What I suggest is let sleeping dogs lie over the holiday period, then
look towards Smeegol 1.1 and then raise a bug report on that release.
I'm not sure, but have you tried the latest meego to see how it
compares?


-- 
Cheers Malcolm ��� (Linux Counter #276890)
openSUSE Global Moderator, openSUSE Member and Novell Knowledge
Partner
ASUS eeePC 1000HE GPU Mobile 945 - Gnome openSUSE 11.3 (i586)
Desktop AMD X2 4400+ GPU NVidia GTS8600 - Gnome SLED 11 SP1 (x86_64)
------------------------------------------------------------------------
malcolmlewis's Profile: http://forums.opensuse.org/member.php?userid=740
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
malcolmlewis
12/21/2010 11:06:01 PM
Hey, now, blueman works! That's at least some kind of a workaround . . .
(not really comfortable, but . . .) . . . ;)

But the default bluetooth utility of Smeegol rests dead like before
(search is impossibile, send file can be done) :-(


-- 
Farinet
------------------------------------------------------------------------
Farinet's Profile: http://forums.opensuse.org/member.php?userid=53005
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
Farinet
12/21/2010 11:06:01 PM
Ok. 

As for MeeGo, i gave up with it - save big news. I never got the
broadcom wireless working with the original one, so, that's a no go (and
i'd several other problems, installing programs for example). I still
have an installation on an external hd, but didn' touch since a while.

Among some suisse friends (much more experienced than me) i also heard
they consider Smeegol the only viable solution at this moment.

So, ok, i'll wait for aSmeegol 1.1 - in this very moment it's not
really a problem since i'm at home and i've always the trusted G4 as a
workhorse. Will be a problem when i'm away and in need of a reliable
solution. 

Thanks for your help. Btw, is there a way to automatize the hcitool cc
<Macaddress> thing?


-- 
Farinet
------------------------------------------------------------------------
Farinet's Profile: http://forums.opensuse.org/member.php?userid=53005
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
Farinet
12/21/2010 11:36:02 PM
Ok, i waited for the holidays. And now, lookin for Smeegol 1.1 i found
'this file' (http://tinyurl.com/29tmopg), installed it using Yast and .
. .  dang: nearly all crashed. Now, i'm booting only in Gnome, non
chance to get back to Smeegol and even Gnome seems pretty much strange:
there isn't a ControlCenter, no Appearance ecc. respectively, they are
there but do not open (very strange compared to what i use - Debian
Squeeze/MintPPC on the PB G4 i'm writing on this msg). Anyway even a
complete re-install wouldn't be that tragic since i've a complete double
data set (only i pity for the work i spent on tuning & tweaking firefox,
evolution and some other program). But, the downloaded version of
'Smeegol from the Meego Repository '
(http://download.opensuse.org/repositories/Meego:/Netbook/images/iso/)
(8 jan 2011 1.0.5. build 1.11) seems to be defective: Starting the live
disk works but when i try to access applications i get the msg: Sorry
applications is broken. So, i don't know how i could access the live
installer. Anyone has an idea here?

TIA

PS: Happy New Year to all! :)


-- 
Farinet
------------------------------------------------------------------------
Farinet's Profile: http://forums.opensuse.org/member.php?userid=53005
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
Farinet
1/9/2011 11:36:03 PM
Small addendum: 

Meanwhile i managed to get working MeeGo 1.1 including the wireless
support (Broadcom drivers!): There, curiously, by bluetooth i can access
flawlessly the phone, search for files ecc. Now, not being a programmer,
i think, in Smeegol there might be a problem with cooperation of
bluetooth and the obex related extensions for the filesystem :sgrat:
:sgrat: . . .


-- 
Farinet
------------------------------------------------------------------------
Farinet's Profile: http://forums.opensuse.org/member.php?userid=53005
View this thread: http://forums.opensuse.org/showthread.php?t=451650

0
Farinet
1/11/2011 8:36:03 AM
Reply: