Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

I have a fresh OpenSuSE 11.3 install on an Acer Aspire 5740-6491.  I
installed the latest qt-sdk package, and qtcreator and qmake seem to
work fine.  Designer does not work when I run the "designer" command.  I
get an error saying: 

kniles@ClownCar:~> designer 
designer: symbol lookup error:
/usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so: undefined symbol:
_ZN6Phonon12PulseSupport11getInstanceEv
kniles@ClownCar:~> 

When I run this command and get this error nothing happens.  The
program does not open or hang.  It simply exits.  Does anyone else have
this problem or know how I might be able to work around it.  We have
Qt-4.6.3 installed on OpenSuSE 11.2 and designer works fine.  Any advice
is welcome.  I am considering reporting this as a kde bug.  Thank you in
advance for any help.

-Kisron


-- 
kizbot777
------------------------------------------------------------------------



0
kizbot777
9/1/2010 2:06:02 AM
opensuse.org.help.applications 21533 articles. 1 followers. Follow

9 Replies
499 Views

Similar Articles

[PageSpeed] 56

starts OK here : libqt4-devel-4.6.3-1.5.x86_64 / openSUSE 11.3


-- 
please_try_again
------------------------------------------------------------------------
please_try_again's Profile: http://forums.opensuse.org/member.php?userid=10877
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
please
9/1/2010 2:06:02 AM
Do you have phonon-backend-xine-4.4.2-1.6.x86_64 installed ? (as I do
and designer doesn't complain)


-- 
please_try_again
------------------------------------------------------------------------
please_try_again's Profile: http://forums.opensuse.org/member.php?userid=10877
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
please
9/1/2010 2:06:02 AM
In Yast it shows that I have all phonon packages installed including
phonon-backend-xine-4.4.2-1.6.x86+64.  So I don't know what to try.


-- 
kizbot777
------------------------------------------------------------------------
kizbot777's Profile: http://forums.opensuse.org/member.php?userid=35429
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
kizbot777
9/1/2010 2:36:02 AM
There has been report of this same issue on the Qt bug page at

'[#QTBUG-7207] qmediaplayer demo fails to launch - Qt Bug Tracker'
(http://tinyurl.com/3x6tvkt)

In reading the other day, Qt discarded this bug as a kde issue since it
is a kde4 lib issue.  This seems strange to me and I don't understand
why this could be happening.  Thanks again.


-- 
kizbot777
------------------------------------------------------------------------
kizbot777's Profile: http://forums.opensuse.org/member.php?userid=35429
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
kizbot777
9/1/2010 2:36:03 AM
I'm afraid I  cannot help further. 
All I can tell is that I can start QT4 designer (/usr/bin/designer)
either in KDE or Gnome. I don't know what I have installed that you
dont' have.
I don't know what is qmediaplayer demo.  I can start qtdemo and launch
some demos. Some others are apparently not built in.
If it helps : 

rpm -qa | grep qt | sort 

google-gadgets-qt-0.11.2-3.1.x86_64
libavahi-qt4-1-0.6.25-14.1.x86_64
libavahi-qt4-devel-0.6.25-14.1.x86_64
libpackagekit-qt14-0.6.3-5.4.x86_64
libpolkit-qt-1-0-0.95.1-5.2.x86_64
libpolkit-qt-1-devel-0.95.1-5.2.x86_64
libpoppler-qt4-3-0.12.3-4.1.x86_64
libpoppler-qt4-devel-0.12.3-4.1.x86_64
libqt4-32bit-4.6.3-1.5.x86_64
libqt4-4.6.3-1.5.x86_64
libqt4-devel-4.6.3-1.5.x86_64
libqt4-devel-doc-4.6.3-1.4.x86_64
libqt4-devel-doc-data-4.6.3-1.3.noarch
libqt4-qt3support-32bit-4.6.3-1.5.x86_64
libqt4-qt3support-4.6.3-1.5.x86_64
libqt4-sql-32bit-4.6.3-1.5.x86_64
libqt4-sql-4.6.3-1.5.x86_64
libqt4-sql-mysql-32bit-4.6.3-1.3.x86_64
libqt4-sql-mysql-4.6.3-1.3.x86_64
libqt4-sql-sqlite-32bit-4.6.3-1.5.x86_64
libqt4-sql-sqlite-4.6.3-1.5.x86_64
libqt4-x11-32bit-4.6.3-1.5.x86_64
libqt4-x11-4.6.3-1.5.x86_64
libsvnqt6-1.5.3-1.20.x86_64
patterns-openSUSE-devel_qt4-11.3-22.1.x86_64
pinentry-qt4-0.8.0-3.2.x86_64
python-qt4-4.7.3-1.9.x86_64
qt3-3.3.8b-103.1.x86_64
qt4-qtscript-0.1.0-7.1.x86_64
vlc-qt-1.1.4-1.pm.1.1.x86_64
yast2-control-center-qt-2.19.1-3.2.x86_64
yast2-qt-2.19.1-1.9.x86_64
yast2-qt-graph-2.19.0-1.12.x86_64
yast2-qt-pkg-2.19.2-1.10.x86_64


-- 
please_try_again
------------------------------------------------------------------------
please_try_again's Profile: http://forums.opensuse.org/member.php?userid=10877
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
please
9/1/2010 3:36:04 AM
Thank you for the package information.  I am still troubleshooting the
problem.  I believe there could be a mismatch of repositories even
though I couldn't tell you why.  The package repositories initialized
themselves when I ran yast for the first time and they look like the
same repositories that OpenSuSE always uses.  The same person who posted
the qmediaplayer issue also reported the same error when running
designer.  It is a second post on that same bug page.  I will post my
findings when I figure it out.  Thanks again for the help.


-- 
kizbot777
------------------------------------------------------------------------
kizbot777's Profile: http://forums.opensuse.org/member.php?userid=35429
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
kizbot777
9/1/2010 5:06:02 PM
I checked my installation media and the checksum is fine.  i reinstalled
OpenSuSE 11.3 and included all development packages upon install.  I
then installed qt-4.6.3 for x86_64 Linux that was downloaded directly
from the Qt Nokia website.  There is no possible way that I mismatched
repositories when I installed all of the kde, phonon, and qt libraries
from the OpenSuSE 11.3 DVD.  The only outside program I ran was the
Qt-4.6.3 binary which is provided by Qt.  There is a problem somewhere
here and nobody seems to think it exists when it clearly does.  I copied
over /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so from an
OpenSuSE 11.2 install to my 11.3 install and I no longer receive this
error.  Somehow the phonon_xine.so that is being installed by default by
the package manager or whoever installs that library is wrong.  This was
the default phonon_xine.so that was installed by OpenSuSE 11.3

Who can help me locate a permanent fix for this?  I have already
reported it to the kde bug site.

Thanks for your time.


-- 
kizbot777
------------------------------------------------------------------------
kizbot777's Profile: http://forums.opensuse.org/member.php?userid=35429
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
kizbot777
9/1/2010 6:06:02 PM
KDE developers are telling me this is a Qt issue and Qt is claiming it
is a kde issue.  Does anyone know what OpenSuSE repository has a Qt
installer?  I have been getting it directly from Qt and KDE folks say I
should be pulling it from a repository.  What repository might that be? 
Thanks.


-- 
kizbot777
------------------------------------------------------------------------
kizbot777's Profile: http://forums.opensuse.org/member.php?userid=35429
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
kizbot777
9/1/2010 8:36:02 PM
hmm ... I don't know. I had OpenSUSE:KDE:Community enabled for a while
(but I don't remember for what). I disabled it yesterday because it
seemed to be done as I got packagekit errors. That would be the only
repo I can think of.
Here's the md5 checksum of my phonon_xine.so :
2d6d934551c6815337607193d32b5362
I didn't borrow that one from 11.2


-- 
please_try_again
------------------------------------------------------------------------
please_try_again's Profile: http://forums.opensuse.org/member.php?userid=10877
View this thread: http://forums.opensuse.org/showthread.php?t=445387

0
please
9/1/2010 9:06:02 PM
Reply:

Similar Artilces:

after 3.6.3 upgrade, Firefox won't open at all on Mac OS 10.4.11
Name: Product: Firefox Summary: after 3.6.3 upgrade, Firefox won't open at all on Mac OS 10.4.11 Comments: After download, I tried to restart Firefox, but it won't open. The icon just bounces twice and nothing happens. Please fix this! Browser Details: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to ...

Firefox 3.6.4 and 3.6.6 won't work on my Vista HP Desktop
Name: Dick McCoy Email: d_mccoy03atinsightbbdotcom Product: Firefox Summary: Firefox 3.6.4 and 3.6.6 won't work on my Vista HP Desktop Comments: Every time I update Firefox with either 3.6.4 or 3.6.6 is sets proxy setting that won't work, per the screen messages ,and the web sites I try to load error out. I end up having to restore my system settings to 6/23/10. After the restore I can use Firefox again, BUT NOT IF I RUN THE 3.6.4 OR 3.6.6 UPDATES. I WILL NOT update Firefox using 3.6.4 or 3.6.6. unless I receive an update that I know will work. Browser Detai...

[ANN] Release of Bugzilla 4.3.3, 4.2.3, 4.0.8, and 3.6.11
Today we are releasing 4.2.3, 4.0.8, 3.6.11, and the unstable development snapshot 4.3.3. All of today's releases contain security fixes. We recommend all Bugzilla administrators to read the Security Advisory linked below. Bugzilla 4.2.3 is our latest stable release. It contains various useful bug fixes and security fixes for the 4.2 branch. Bugzilla 4.0.8 and 3.6.11 are security updates for the 4.0 branch and the 3.6 branch, respectively. Both also contain one bug fix. Note that 4.3.3 is an unstable development release and should not be used in production envir...

Security advisory for Bugzilla 4.3.3, 4.2.3, 4.0.8 and 3.6.11
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Summary ======= Bugzilla is a Web-based bug-tracking system used by a large number of software projects. The following security issues have been discovered in Bugzilla: * When the user logs in using LDAP, the username is not escaped before being passed to LDAP which could potentially lead to LDAP injection. * Extensions are not protected against directory browsing by default and users can view the source code of templates used by the extensions. These templates may contain sensitive data. All affected installations ar...

After Patch for IDM 3.6/3.51 GW Driver won't start
In the trace my error is below. Any ideas? This is on NW6.5sp5 14:25:22 91FA10A0 Drvrs: GroupWise ST: DirXML Log Event ------------------- Driver: \LABGRPTREE\GRP\GrandRapids\SERVICES\eDirDriverSet\GroupWise Status: Error Message: Code(-9010) An exception occurred: java.lang.NoClassDefFoundError at com.novell.gw.directory.GwInitialContextFactory.getInitialContext(Unknown Source) at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:662) at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:243) at javax.naming.InitialContext.init(InitialConte...

HELP! ASE11.0.3 won't run on AIX 4.3.1 -Library Incompatabilities
Hello, I'm trying to run ASE 11.0.3 ebf 7631 on AIX 4.3.1 (I bleieve all filesets are at the liatest level). I did not install ASE but copied the binaries from a 4.2.1 machine. When I try an execute dataserver I get: 0509-023 Symbol kaio_rwr in /usr/lib/libc.a is not defined .. (insert other symbols) .. .. 0509-026 can't run a file that does have a valid format Can anyone help me please! I can't put the server back on the old machine it has to run on the 4.3.1 machine. Thanks Miles Miles.Purdy@pangea.ca Miles Purdy wrote: > > Hello, > I'm tr...

Disaster of Firefox 3.6.8, 3.6.10, 3.6.11 and 4.06beta.
Name: Lindsay Stubbin Email: stubbo44attpgdotcomdotau Product: Firefox Summary: Disaster of Firefox 3.6.8, 3.6.10, 3.6.11 and 4.06beta. Comments: I have been using Firefox for about 3 or 4 years, and have always been very quick to praise it and recommend it to anyone who would listen, but no more. For me, all versions after 3.6 have been an unmitigated disaster. I am totally unable to access many websites, including my own ISP, and many pages that I am able to access can take literally several minutes to load. Many times, before a page even loads, I am redirected to google a...

Upgrade to 3.6.3 (from 3.0.?) and google calendar now won't load
Name: Product: Firefox Summary: Upgrade to 3.6.3 (from 3.0.?) and google calendar now won't load Comments: This happened right after downloading new firefox. I now see it in lots of places on the web as a problem. You should list it as a known issue on the main page for 3.6.3 so we can see it is a problem before downloading! Please list it until you fix it. thanks Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response ...

3.6.7 and 3.6.8 have missing license file, won't update
Name: Anna Lockwood Email: a_lockwooathotmaildotcom Product: Firefox Summary: 3.6.7 and 3.6.8 have missing license file, won't update Comments: This is beyond absurd. I’ve been struggling to persuade Firefox to update itself all weekend, first with 3.6.7 and now 3.6.8. Neither will actually update, as there is a missing ‘license file.’ Firefox 3.6.6 crashes pretty much every time I try to use it, though it will load the homepage I have set (i.e., iGoogle). If you need to know how irked I am, I’ve actually been using Google Chrome. I dislike it and would much pr...

(OOPS MEANT 3.6.4 not 3.6.3) No google.com pages will load in firefox 3.6.4
Name: Product: Firefox Summary: (OOPS MEANT 3.6.4 not 3.6.3) No google.com pages will load in firefox 3.6.4 Comments: I have been trying since I dl'ed 3.6.4 to get to my home page ( http://www.google.com/ig?hl=en). I can not get it or any other google.com site to load. I have tested it on all my other browswers & google loads fine. I can't even fill out the broken website form from the browwser menu because it never loads. PLEASE FIX THIS ASAP!!!!!!!!!! Browser Details: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4...

Some kde apps won't work after downgrading 11.4->11.3
Hi, after being not so satisfied with opensuse 11.4 (worked really slow at times), i decided to downgrade to 11.3. But now, some applications won't start. When starting personal kontact, i only got a notification that akonadi server is starting but it doesn't progress. Only thing I can do is to kill the app.Same for Clementine (amarok-like player), but here it doesn't even try to start. So, I was thinking to delete all the settings folders concerning these apps in my home folder, but it doesn't change anything. I did so by searching for *kmail* *kontact* and ...

Suse 11.1, XFCE 4.4.3 won't shutdown or restart.
Pressing the shutdown or restart buttons in XFCE simply logs me out and leaves the system running. I did some Googling and it was suggested that by default users don't have permission to shutdown. (not sure how this is a XFCE specific problem in that case but moving on...) I've taken the following advice found on this forum: kingf451;1984813 Wrote: > For a "desktop" system that wants to protect itself from casual attacks > (and "puzzled penguins"), but still grant the user control of their > system, run the following as "root": ...

[11.4 kde Version 4.6.00 (4.6.0) "release 6"] kaddressbook won't launch anymore
Greetings !! I launched *KAddressBook* to try import some contacts but now it won't launch anymore. Is there a way to set it up as it was the first time ? Now with *akonadi* I'm sure of nothing, I really don't know if there is a file like in Mac OS X to delete to restore the default application "workable"... Thank you... -- soundlord ------------------------------------------------------------------------ I just log off/on and now it worked better but there is error messages telling "no writable/editable resources found, re-configure Kma...

Can't start X server and can't install NVIDIA display driver when upgrade to 11.3 from 11.2
Hi, all, I upgrade to 11.3 from 11.2 according to official portal "system upgrade". Code: -------------------- #zypper ref -------------------- Code: -------------------- #zypper dup -------------------- After complete, I restart the system, it just can login in by terminate. When I run Code: -------------------- #startx -------------------- Got below message: > > ... > Current version of pixman: 0.18.0 > Before reportign problems, check help http://wiki.x.og > to make sure that you have the latest version. > Ma...

Browser won't start after 3.5.3 update
Name: Product: Firefox Summary: Browser won't start after 3.5.3 update Comments: Firefox auto-updated normally but, would not start after version 3.5.3 was installed on Windows XP. Browser Details: Opera/9.80 (Windows NT 5.1; U; en) Presto/2.2.15 Version/10.00 From URL: Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see it. ...

Web resources about - Designer in Qt 4.6.3 won't start in OpenSuSE 11.3 - opensuse.org.help.applications

Resources last updated: 1/9/2016 10:38:24 PM