Workstation Association: Failed to cache application .... Error Code was 2 #2

Hi I've seen this here before but not an answer.  I have an all MS
Windows
env (so yes the source files are on an MS server).  We have an app
that is
just for laptops so it needs to be associated to the workstation and
not the
user.  It is set for download and install but all I get is Failed to
cache
application... Error code was 2.  A user was logged in at the time.
Is this another feature of Zen that doesn't work in an all Windows env
or am
I missing something here?


Thanks

-mark





0
MarkB432
12/19/2003 4:45:08 PM
novell.zenworks.4x.app-launch 2789 articles. 0 followers. Follow

5 Replies
435 Views

Similar Articles

[PageSpeed] 41

MarkB432

Ok, but does the workstation have rights to were the application is
being stored on the server?
Are you using UNC paths?

-- 
Jared L Jennings, CNE
Novell Support Forums SysOp.
http://support.novell.com/forums/faq_nntp.html

Posting with XanaNews Reader 1.15.8.4
Geek by Nature, NetWare by Choice.



0
Jared
12/19/2003 11:26:51 PM
Jared,

NDS objects can't be assigned rights to MS Networking resources.
I suspect this is the issue.
You may need to script the RUNAS command to accomplish some of these
tasks.




Jared L Jennings wrote:

> MarkB432
>
> Ok, but does the workstation have rights to were the application is
> being stored on the server?
> Are you using UNC paths?
>
> --
> Jared L Jennings, CNE
> Novell Support Forums SysOp.
> http://support.novell.com/forums/faq_nntp.html
>
> Posting with XanaNews Reader 1.15.8.4
> Geek by Nature, NetWare by Choice.

--
Craig Wilson
CNE3, 4, 5 - MCSE - CCNA
NSC Sysop (http://support.novell.com/forums/)

Tech Writer - http://www.ithowto.com
(I Peter 4:10)





0
Craig
12/20/2003 12:30:06 AM
Craig Wilson

> Jared,
> 
> NDS objects can't be assigned rights to MS Networking resources.
> I suspect this is the issue.
> You may need to script the RUNAS command to accomplish some of these

> tasks.
> 
Hum, going to have to think about that a little more.


-- 
Jared L Jennings, CNE
Novell Support Forums SysOp.
http://support.novell.com/forums/faq_nntp.html

Posting with XanaNews Reader 1.15.8.4
Geek by Nature, NetWare by Choice.



0
Jared
12/20/2003 3:05:58 AM
Me too.  And play with a few things.

Jared L Jennings wrote:

> Craig Wilson
>
> > Jared,
> >
> > NDS objects can't be assigned rights to MS Networking resources.
> > I suspect this is the issue.
> > You may need to script the RUNAS command to accomplish some of
these
> > tasks.
> >
> Hum, going to have to think about that a little more.
>
> --
> Jared L Jennings, CNE
> Novell Support Forums SysOp.
> http://support.novell.com/forums/faq_nntp.html
>
> Posting with XanaNews Reader 1.15.8.4
> Geek by Nature, NetWare by Choice.

--
Craig Wilson
CNE3, 4, 5 - MCSE - CCNA
NSC Sysop (http://support.novell.com/forums/)

Tech Writer - http://www.ithowto.com
(I Peter 4:10)





0
Craig
12/20/2003 4:31:46 PM
In  novell.support.management.zenworks.desktops.4x.app-launcher,
MarkB432 says...

> Hi I've seen this here before but not an answer.  I have an all MS
Windows
> env (so yes the source files are on an MS server).  We have an app
that is
> just for laptops so it needs to be associated to the workstation and
not the
> user.  It is set for download and install but all I get is Failed to
cache
> application... Error code was 2.  A user was logged in at the time.
> Is this another feature of Zen that doesn't work in an all Windows
env or am
> I missing something here?
>
>
if you are using a pure ms environment you will either grant rights to

the wks object from AD, enable the guest account or configure the wm
to
log on as a domain account...

you cannot grant the nds wks object any rights as Craig already
noted...
but normaly in your case you stumble upon that the wm will try to
access
sources on the server as system account...
-- 

Marcus Breiden

Please change -- to - to mail me.
The content of this mail is my private and personal opinion.
http://www.edu-magic.net



0
Marcus
12/21/2003 8:40:23 PM
Reply:

Similar Artilces:

Workstation Association: Failed to cache application .... Error Code was 2
I'm using ZfD4 in an all Windows environment with XP Pro workstations. No Novell client installed; just the ZEN Agent. When an application is set to Force Cache and associated to a Zen workstation object it fails with "Failed to cache application.... Error Code was 2". When it is associated to a user it caches just fine. Seems to be a rights issue or system context issue. With full reporting on I see Cache Failure, 61 but that is all. Any ideas on how I can get around this? Thanks -mark Try changing the macro %SOURCE_PATH% to a UNC-Path. The...

failed to cache application error code 2
i'm randomly getting this error on workstations when the nal is started "failed to cache application error code 2" sometimes a reboot of the workstation will do the job in some cases reinstalling de zdfagent will help. can anybody give me advise regards Erik van Leeuwen On Sun, 18 Jul 2004 18:35:03 GMT, erik_leeuwen@hotmail.com wrote: > i'm randomly getting this error on workstations when the nal is > started "failed to cache application error code 2" you can enable logging NAL / HELP / F2+More -- Marcus Breiden Please change -- t...

Failed to cache application, error code 2
I am receiving the above error with a specific application object on a few of our computers. It deploys fine on most of our desktops but does not deploy on others and returns that error code. The app is configured as workstation associated, force run, run once, run as user if workstation associated. ZFD version is 4.0.1 ir5 on winxp pro sp2 on all desktops. Any help would be appreciated. Thanks! I enabled ZFD agent logging on an affected computer with More+F2 and here is the section of the ZAPPLIB.LOG logfile concerning the application where the problem occurs (it appears the -603 ...

Failed to cache application error code was 2
Well its been a while ago i posted this error, but now after upgrading zen 4 to sp1 + postfiles servp2 the error is still there. When i create a new object, give the object a name and associate it to 1 user, force run, after login in the error occurs. The object is empty, no app files ed. The user has all rights, other app objects create a folder in nal cache Tried this with several objects any ideas, Jan, do you have the client installed or is this through mid tier? What's different about the apps that don't work, compared to those that do? -- ...

Failed to cache application .... Error Code was 2
This is the error code i receive on a applications i distribute, this object can't write to the nal cache folder, while the others can. any id of the error code ? ( zen 4.0 ) Jan > ( zen 4.0 ) I am pretty sure that is a bug in 4.0. If you apply sp1b it will be fixed. -- Jared L Jennings, CNE Novell Support Forums SysOp. http://support.novell.com/forums/faq_nntp.html Posting with XanaNews Reader 1.15.8.2 Geek by Nature, NetWare by Choice. well i hope so, the update is planned for dec ,13 "Jared L Jennings" <jaredljenningsNO@SP...

Get error 2 failed to cache with second error Unable to get attributes [application] id=-603 in application chain
Application (chain) working find, but i got these error a the end. Error "Failed to cache application <dn of app>. Error code was 2" AND Unable to get attributes for application object [/<file name>] (ID=-603) begin 666 spacer.gif M1TE&.#EA`0`!`)'_`/___P```/___P```"'_"T%$3T)%.DE2,2XP`M[M`"'Y 6! $```(`+ `````!``$```("5 $`.P`` ` end JFK, It appears that in the past few days you have not received a response to your posting. That concerns us, and has triggered this automated reply. Has your pr...

[LDAP: error code 49
I'm trying to get iManager 2.0.2 running on Netware 6 SP5 with eDirectory 8.7.3.6 and iManager.html is returning the following: The portal is unable to login: authenticate: [cn=pco,ou=Extend,ou=BVU_SL,o=Bvu] :: javax.naming.AuthenticationException::[LDAP: error code 49 - NDS error: failed authentication (-669)] PKIDIAG reports no problems, and I can make SSL and non-SSL LDAP bindings using the pco account with LDAP Browser. DSTRACE reports the following for the LDAP connection that iManager is trying to use: New TLS connection 0x264df2e0 from 147.92.2.14:20952, moni...

regiis failing after 2.0 installation; errors in App Log looking for FW 1.2?!
All, Seeing very strange behavior on a Win2003 server onto which I'm trying to install just MDAC9b1 and the 2.0 Framework (from dotnetfx.exe which ships with VS2005 March 2004 Preview). The Dot Net installer takes forever, seeming to hang on the aspnet_regiis.exe -i step, and when I check the Application Log, I get a few errors which read: The ASP.NET DLL (Path: C:\WINDOWS\Microsoft.NET\Framework\v1.2.30703\aspnet_isapi.dll) (Version:1.2.30703.0) is missing That looks like the old Whidbey path (Oct 2003 codebase), so I'm wondering if something is corrupted in this server's registry...

Workstation/Workstation group associated apps #2
What I have is a container called "Workstations" that all the PC's are imported into. In that container are the workstation groups based on Room number. I tested just a workstation association (not group) with an app and no go. I have enabled the setting in the Launcher config that eanbles association via workstation group. The only way I've been successful at distribution is by user association. HELP! On Tue, 19 Apr 2005 16:09:53 GMT, sean.mccoy@obps.org wrote: > The only way I've been successful at > distribution is by user association. HELP! i...

IManager fails after upgrade from 2.5.2 to 2.7.2
Attempted to upgrade IManager per readme from 2.5.2 to 2.7.2. Done for windows 7 iprint support. After upgrade when IManager launches, login screen is fine, but on initial screen all roles are listed down the left side but no icons across top (Home, configure, etc). Instead this appears com.novell.emframe.dev.eMFrameFactory.getMContext(Ljavax/servlet/http/HttpServletRequest;)Lcom/novell/emframe/dev/MContext; aA similar message appears when you attempt to manage a printer or anything else. ersion still says 2.5.2. Help please, how to uninstall, reinstall, whatever it take...

Error when upgrading Bugzilla and Testopia to 3.2 and 2.2 respectively #2
Hello, I upgraded testopia and Bugzilla to 2.2 and 3.2 respectively. Previous versions are Bugzilla 3.0.2 and Testopia 2.2. It seems that when I am clicking the "Do some testing" link, error shown below is occuring. Also after I restored the database, test runs doesn't appear anymore. Software error: DBD::mysql::db selectrow_hashref failed: Unknown column 'target_pass' in 'field list' [for Statement " SELECT run_id,plan_id,environment_id,product_version,build_id,plan_text_version,manager_id,start_date,stop_date,summary,notes,target_...

Workstation associated apps #2
I distribute my MS security patches as force run, run once, workstation associated packages. All good except for the fact that it requires the user to reboot the workstation for the app to distribute. After reading TID 10065051 I checked the "force run as user if application is workstation associated" box in the run options tab. I thought great now I get all those users who just loggoff their PC at night rather than fully rebooting. The down-side of this is that the application fully redistributes for every user that logs onto that PC (that behaviour doesn't occur i...

Workstation associated apps #2
Running ZENWorks 4.01 on a NW6SP5 server. I have not been able to ditribute or run apps via workstation or workstation group association. I have checked trustee rights to workstation container, object, etc. but no success. Any thoughts? Thanks Sean 1) Workstation Group association is disabled by default, so let's start with direct workstation assocition while troubleshooting. 2) There are a number of issues with Force-Run WS associated apps - Fixable - But while getting things straight, lets focus on manually launched objects. 3) Do the apps fail to appear or fail to functio...

Error: Upgrading from From 2.1.2 to 3.2
Aynyone seen this message? Error Installing DotNetNuke Current Assembly Version: 03.02.00 Invalid object name 'Version'. Invalid object name 'Version'....

Web resources about - Workstation Association: Failed to cache application .... Error Code was 2 #2 - novell.zenworks.4x.app-launch

Resources last updated: 12/23/2015 6:01:00 PM