Forced run application always runs?

Okay, I've got an app setup to force run.  I have not checked the "run 
always" box, nor is the "run once" box checked.

It runs a simple application (the nipp-s.exe file for iPrint 4.05)

But it runs every time you login?  I thought that the force run looked 
at the GUID in the registry and if it was there, it wouldn't run again?  

If it's supposed to run always, then what's the purpose of the run 
always box (seems redundant)

Further, I put a registry key requirement that IF it sees the 
DisplayName key and it does NOT equal:  "Novell iPrint Client 
v04.50.00" as a condition.

The key is most definitely there, but the NAl deploys the application 
anyway (it basically is ignoring the system requirements).

the only fix at this point is to check the "run once" box.

BTW, the back-end and schema are ZEN 6.5 SP1b and the application was 
created with the ZEN 4.01 IR4 snapins and the pc's are still running the 
ZFD IR4 agent.

--Kevin
0
Kevin
5/20/2005 2:25:03 PM
novell.zenworks.4x.app-launch 2789 articles. 0 followers. Follow

4 Replies
587 Views

Similar Articles

[PageSpeed] 34

Kevin,

> BTW, the back-end and schema are ZEN 6.5 SP1b and the application was
> created with the ZEN 4.01 IR4 snapins and the pc's are still running the
> ZFD IR4 agent.

Here is your problem,(at least I bet)
ZEN 6.5 made a change to the distribution rules(availability requirements)

For the ZEN 4x agent to see the availability requirements you must put 
these rules in the legacy rules, not the distribution rules.
http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/br47lpl.html

-- 
Jared
Novell Support Forums SysOp
Systems Analyst with Data Technique, INC.

Using XanaNews 1.16.5.2 as a News Reader

Novell eDirectory Services 1.6 Billion users worldwide
81% 0f Fortune 500 use Novell's eDirectory
Novell Desktop Management 40 Million users worldwide
0
Jared
5/23/2005 8:28:37 PM
Good to know, but I interpreted that to mean that if you created a ZEN 
6.5 app and it was "read" with a ZEN 4 NAL that you'd need to make 
changes?

In my case, the app objects are still 4.x (never touched with a 6.5 
snapin) and the workstations are still ZEN 4 agents.

although it may explain my 6.5 agent not seeing my 4.x app object issue.

--kevin


In article <V1rke.191$_w.15@prv-forum2.provo.novell.com>, 
jaredljenningsNO@SPAMmyrealbox.co says...
> Kevin,
> 
> > BTW, the back-end and schema are ZEN 6.5 SP1b and the application was
> > created with the ZEN 4.01 IR4 snapins and the pc's are still running the
> > ZFD IR4 agent.
> 
> Here is your problem,(at least I bet)
> ZEN 6.5 made a change to the distribution rules(availability requirements)
> 
> For the ZEN 4x agent to see the availability requirements you must put 
> these rules in the legacy rules, not the distribution rules.
> http://www.novell.com/documentation/zenworks65/index.html?page=/documentation/zenworks65/dmadmin/data/br47lpl.html
> 
> 

0
Kevin
5/26/2005 2:18:31 AM
Kevin,

> although it may explain my 6.5 agent not seeing my 4.x app object issue.

Well, the only thing that really matters about this is the Availability 
requirements.

-- 
Jared
Novell Support Forums SysOp
Systems Analyst with Data Technique, INC.

Using XanaNews 1.16.5.2 as a News Reader

Novell eDirectory Services 1.6 Billion users worldwide
81% 0f Fortune 500 use Novell's eDirectory
Novell Desktop Management 40 Million users worldwide
0
Jared
5/27/2005 7:49:20 PM
Hmmm.

Anyway, I've now got just about every application object doing this.

Any app object that's set for force run (even if I put "other" things in 
the system requirements, like "only run if this registry key is there") 
is now functioning as a "runs always".

These are ZEN 4 apps (haven't been touched with ZEN 6.5 snapins) with 
ZEN 4.01 agents.

I have no idea why a schema upgrade to 6.5 would all of a sudden make 
the 4.x app objects run always or totally ignore stuff, but apparently 
that's what's happening.

I'll see what happens when I "touch" it with ZEN 6.5 snapins.

--Kevin


In article <4RKle.4115$_w.13@prv-forum2.provo.novell.com>, 
jaredljenningsNO@SPAMmyrealbox.co says...
> Kevin,
> 
> > although it may explain my 6.5 agent not seeing my 4.x app object issue.
> 
> Well, the only thing that really matters about this is the Availability 
> requirements.
> 
> 
0
Kevin
6/3/2005 8:03:53 PM
Reply:

Similar Artilces:

Running Running Running
Name: John Harris Email: jkharrisatmindspringdotcom Product: Firefox Summary: Running Running Running Comments: Why, does Firefox, even when mimimized, still takes up to 20, 30, 40% (or more) of my CPU on my Windows XP Pro computer. It seems to just happily chew up cycles. How do I get it to do nothing while minimized. Especially a problem with virtual machines. Thanks, John Harris Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers...

We recently migrated a PB6.5 application to PB 9 (Ver 9.0.1 Build 6533) and when we run the app in interactive mode, it runs fine but upon exiting the app
We recently migrated a PB6.5 application to PB 9 (Ver 9.0.1 Build 6533) and when we run the app in interactive mode, it runs fine but upon exiting the app - it always generates the following message: PB90.exe has generated errors and will be closed by Windows. You will need to restart the program. An error log is being created. If we run the app through the debugger, there is never any such error upon closing out of the application. I can never find any error log file that gets created. We are running the PB code on a Novell network against an Oracle 8 database. Any s...

Run apps without zenworks running?
This may be a really dumb-headed and probably useless question, but I'm curious (but not enough to try it during prod hours). If I have a NW server that has zenworks installed on it, but the services not running (zfdstop), can users still click on apps to distribute them? I only ask because zfdstart only starts WOL, Imaging, WS Imp/Rem and PXE. My gut and head says no it cant, but I only wonder. Thanks for answering my useless questions, Frank. Sorry, wrong area. I reposted in novell.support.zenworks.desktop-management.6x.install-setup -Frank On 11/9/2005 frank@email.e...

NAL force run workstation app not running
Hi: I am trying to install the latest zen ws agent (MSI) using my newly imported workstation objects. I have ze ver 4.0.1 and ws agents 4.0.1.4. I have set that application to force run on workstations. It is set to run as an unsecure system user, and force run as user if workstation enabled. For some reason it will not force run. I can start nal and manually launch it and it runs fine. I created a simple app that auto launches notepad, assiciated it to the same workstations, and set it to force run as user if workstation enabled. This one works. Does anyone hav...

SR6 is running, and running, and running...
I started it last night at about 1130pm, now its 905 am. It seems to be stuck at 95% on the first partition, with 12 minutes left, and 4 hours 21 minutes elapsed, which I know is bologna. The SMART information has all dissapeared, except for the EEC stuff. Dynastat is not running, but it shows data moving across at a normal speed. I'm not totally sure it's hung up, but it may be taking it's time because it won't move the files in the current area, due to them all being marked as system/hidden. I hope it moves on. Torrance "Torrance Bell" <st...

How to Run my .exe file or Application in the Background using .NET Application like explorer.exe file is Running always in the Background...(you can see in task Manager..)
Hi , This is Sundar , i want to develope one small Application in windows or web ,that should send the mail continiously according to at what time scheduled in the application and that should Running in the Background always like windows service,SQL server ........ so , please help me ......................  what;s the problem if you develop an windows service and install it in your system.  http://www.15seconds.com/issue/021007.htmGive a man a fish and you feed him for a day. Teach a man to fish and you feed him forever.  see, i have created the Windows services and wh...

Run once and Force run as user if application is W/S assoc.
I have a NAL that is Workstation associated, set to Force Run, Run Once Only and Force run as user if application is workstation associated. With these settings, is it normal operation that the NAL runs each time a different user logs in? Also, I have tried putting a Availability dependency that itself must not be installed in order to run. But is all this ignored if a different user logs in? Please tell me. . . my sanity and the fate of the known universe depends on it. . . . . :o) On Fri, 19 Mar 2004 13:29:31 GMT, cupps@trinity-health.org wrote: > is it normal operati...

Force Run happening when not set to Force Run
We have recently turned off the Force Run association for two application objects for our staff users and just have the applications appearing in the NAL. However we have found that despite this the application still pushes out when a user logs in. If you uninstall the program and refresh the NAL it reinstalls the application. The only way we have found of having it not push out is to unassociate our STAFF container with the applications. This not ideal, as we do want the applications to be available to the staff, just not automatically installing them. We have also tried de...

object force runs without being checked force run
Hi everyone, I am packaging Oracle 10g J2EE Suite. I took a snapshot of the installation, then clean out all the junk out of it. I have a freshly rebuilt pc (windows xp clean install) and as soon as I logon the app pushes down. At first I thought that I had checked it to a Force Run by mistake but no. I then deleted the object and recreated it again. Same thing. Anybody have a clue? The app is behaving like it was Force Run but it isnt. Has any other object ever shared the same name? By the sounds of it you are not trying to assign any specific GUID? The only time I ev...

Refresh not running Force Run
Hi there, maybe I'm missing something but shouldn't a NAL refresh excecute any Force Run objects? Isn't that one of the major functions of that feature? I'm running Mgt Agent 4.00.1029 and I have created an app object that runs notepad.exe. This is associated to a user and set to force run. Notepad runs everytime the user logs in but not on an manual or timed refresh. I don't need to reboot; just log out/in. So this shows that "Run Once" isn't set. If I go in and change the version of the object then a refresh will run notepad. I need it run on ...

run as a service, not run as an application
How to make a program (PowerPro) to run as a service than run as an application. Your kindest most honest response will be appreciated. ------ PIII / 1Ghz / 384mb ram / WinXP Pro Sp2 / AntiVir / Kerio 4.2.1 / Ad-aware / Spybot / a-squared / Spyware Doctor / Proxomitron / A4Proxy "John Abraham" <Nobodyknowsabcdef@unknown.com> wrote: > How to make a program (PowerPro) to run as a service than run as an > application. Use the MS utility srvany.exe, MS info here: How To Create a User-Defined Service http://support.microsoft.com/kb/q137890/ G...

No verify available for force run apps unless user "runs" them from NAL.
I have a certain MSI based AO that is associated with a workstation group (Force Run AND Launcher). Environment is WXP SP1, NetWare 6.5, ZEN 4.0.1 ir4. AO settings are as follows: Disconectable - NO Wait On Force Run - YES Determine Force Run Order - YES Show Progress - YES User Interface Level - Progress Distribute Always - NO Install Only - YES Run Once - NO Force run as user if application is workstation associated - YES Symptom Aplication installs just fine after user login (as it is "force run" app). All is fine. But when the user opens NAL or App Explore...

force run not consistentally forcing app
I am using zenworks 4.0.1.60 to push out Office updates. I created the zen apps for each of my 7 patches and used the /q:u switch on the exe to install the file in user quiet-mode. I also set it to Run as Secure System User. I made all 7 the same and it seems that some push out and others do not. Is their any way to have it create a log file that details what was force installed at login and what was not etc? Thanks On Wed, 06 Jul 2005 19:32:13 GMT, bill@nospam.com wrote: > I also set it to Run as Secure System User. run as secure system user doesn't have a user ...

SQLCA works when application runs in PB not when application is run with Powerbuilder WDK.
Hi, My applications with out SQLCA run great through Powerbuilder WDK, my applications that contain SQLCA information doesn't. When I run the application in PB I get a splash screen and then the application starts. When I run it through PB WDK the splash screen starts and the I get a login box. No matter what I do it always show's up and when I hit OK I get the following SQLSTATE = 08001 error. How can I stop this from occurring? The SQLCA code and ini file are below. code: startupfile = "pds.ini" /* Populate sqlca from current PB.INI settings */ sqlca.DBMS...

Web resources about - Forced run application always runs? - novell.zenworks.4x.app-launch

Application - Wikipedia, the free encyclopedia
Text is available under the Creative Commons Attribution-ShareAlike License ;additional terms may apply. By using this site, you agree to the ...

Would you give up chocolate for better application performance?
Application performance is critical to business performance according to 98 percent of businesses, yet 89 percent of executives say the poor ...

NASA is accepting astronaut applications, and this quiz will tell you if you qualify
... gone before, then you might want to sign up to be a NASA astronaut. On Dec. 14, for the first time in four years, NASA began accepting applications. ...

MBA: Mortgage Applications Increase in Latest MBA Weekly Survey, Purchase Applications up 29% YoY
From the MBA: Mortgage Applications Increase in Latest MBA Weekly Survey Mortgage applications increased 1.2 percent from one week earlier, ...

Falling Costs, Rising Applications Will Boost US Energy Storage Market
... in 2013 to 3,659MWh by 2020 on improving economics and policy developments, predicted GTM Research's Shayle Kann Falling Costs, Rising Applications ...

California Film & TV Tax Credits Applications Dip In New Small Screen Round
With production on the uptick in the home of Hollywood , the second round of those seeking small screen Golden State tax credits saw 32 applications ...

SMIC and M31 introduce differentiated IP solutions for storage controller applications
China-based IC foundry Semiconductor Manufacturing International (SMIC) has announced the company will expand its IP portfolio with M31 Technology's ...

NASA accepting applications for the position of 'astronaut'
Wanted ads aren't usually newsworthy, unless the company is NASA and the job is "going to space." The US space agency has started recruiting ...

10 Killer Media Applications Enabled by 'Virtual Reality' Headsets
... can do much more than 'virtual reality,' a technical term that is badly defined in most news reports. Here are 10 rapidly developing applications. ...

New patent application suggests Nintendo’s NX console is like nothing we’ve seen before
Nintendo has been close-mouthed about its plans for the Nintendo NX, but a recent patent filing may have tipped the company's hand. If so, then ...

Resources last updated: 12/16/2015 10:31:36 AM