10.2.2 update not installed correctly

I have a problem with upgrading zcm from 10.2.0 to 10.2.2

The 10.2.2 update downloaded normally, but when I tried to install the
update on our *1 Windows 2003 primary server* it kept saying (I'm
paraphrasing from memory) "An unknown error has occurred, check the
update log for more details."

Well the update log was not being created.  All of the other updates
had multiple log files in their respective log directories.  So I tried
multiple things to get it to install, including: deleting and
re-downloading it, downloading it manually importing it, setting the log
level to debug for more information, removing some of the .rpm files
that it was complaining about in the loader-messages log, rebooting
after each try, etc.

Then I found 'this post'
(http://forums.novell.com/novell-product-support-forums/zenworks/configuration-management/zcm-server-install/386466-zcm-10-2-10-2-1-system-upgrade-failing.html)
and 'this post'
(http://forums.novell.com/novell-product-support-forums/zenworks/configuration-management/zcm-server-install/341489-force-10-0-3-agent-update-10-0-3-2-a.html)
with useful information about running the update manually using the
command

Code:
--------------------
    zenupdater -v -c /opt/novell/log/zenworks/system-update/guid/update_commands.xml 
--------------------

(Where "guid" is the 510...... corresponding to the 10.2.2 update)

*Well that worked great, it installed the update*, and after rebooting
the server things looked promising, the agent on the server showed
10.2.2.#### for things as it should.  I checked the deployment in the
System Update page of the Control Center and it showed competed as well.
Then I noticed that we could not register Windows 7 machines like
10.2.2 should be able to. * Checking the server version on the server's
page in the Control Center shows the _Agent_ as 10.2.2, but the _server_
still on 10.2.0.*  Sigh.

Can someone post the update_commands.xml from 10.2.2 from your Windows
Server 2003 I can compare mine to it? Looking at mine it appears to have
only installed the client MSI files, the server ones are absent.

Also, can someone post what file versions show when you click on the
ZCM version on the server's information in the Control Center?  Perhaps
I can just apply the needed updates.


-- 
thomas-j
------------------------------------------------------------------------



0
thomas
1/6/2010 3:26:06 PM
novell.zenworks.10.install 2954 articles. 0 followers. Follow

2 Replies
516 Views

Similar Articles

[PageSpeed] 37

By what file versions show in the Control Center, I mean the text you
get when clicking on the link highlighted in 'this'
(http://i782.photobucket.com/albums/yy106/thomas-j_bucket/serverVersion.png)
screenshot.


-- 
thomas-j
------------------------------------------------------------------------
thomas-j's Profile: http://forums.novell.com/member.php?userid=22786
View this thread: http://forums.novell.com/showthread.php?t=397419

0
thomas
1/6/2010 4:56:03 PM
Anyone have an update_commands.xml file I could look at from a Windows
Server 2003 box that successfully completed the 10.2.2 update?

The location is the logs\system-update folder in the Zen home
directory. In my case it is D:\Program
Files\Novell\ZENworks\logs\system-update\50100202008b93e7d3949f03b6fb5eb5\update_commands.xml


-- 
thomas-j
------------------------------------------------------------------------
thomas-j's Profile: http://forums.novell.com/member.php?userid=22786
View this thread: http://forums.novell.com/showthread.php?t=397419

0
thomas
1/6/2010 10:56:02 PM
Reply:

Similar Artilces:

10.0.2 installed, still asks to install 10.0.2 update
I installed the 10.0.2 update about ten days ago and it is verified on the About page. However, I get numerous daily reminders to install the 10.0.2 update. So I checked "never check for updates" but that apparently isn't working either because I'm getting all of the reminders. So what's my only option: uninstall and then reinstall? I'm a bit leery of doing that: everything else seems to be functioning properly. However, when I previously installed the 10.0.1 update, numerous things were broken on my Win7 system and I had to revert to a restore poi...

Unable in apply 10.2.1 Update to a clean install of 10.2
I ahve a test ZCM 10.2 Server running on SLES10.1. It was installed fresh from the 10.2 iso. I have the 10.2.1 update downloaded but When I attempt to Apply The Blue Message Text appears saying that I must have Service Pack 2 for ZCM ( ZCM 10.2 ). There is only 1 primary server in the test ZONE and techinically it hasn't had the service pack 2 update applied as it was clean install of SP2 but you would expect the update not to worry about that :) Andrew Mallett, >There is only 1 primary server in the test ZONE and techinically it hasn't >had the service pack 2...

10.2.2->10.3 Works, just 10.3 install doesn't
I have a very odd issue. If i install 10.2.2 and then upgrade it to 10.3 through the system update deployment, everything works fine. If i try to install 10.3 on a fresh machine without installing 10.2.2 first it starts failing on things like downloading DAU, downloading group policy files, etc. Any ideas? I have run the post-10.3 patch after installing it the day it came out. I have rebuilt my preagent packages.....still not working... Primary Server 1 10.3 Win2k8 Primary Server 2 10.3 Linux VMware appliance clients are all windows xp sp3 -- adisarro ---------...

ZCM 10.2
We are running ZCM 10.2 on a SUSE Linux server. It has been running good, until recently. We attempted to do some imaging with a new machine and it required the latest March PRU. I looked at our ZCM and it reported we had 10.2.0. I went to configuration and searched for latest updates. It came back with Support Pack 2 for ZCM (10.2). I downloaded it. I also downloaded Update for ZCM 10.2.2, and the March PRU. I then had it deploy the support pack, in the deploying service pack it now says STATIS PENDING = 0 Successful =1. I then rebooted the ZCM server. When I go to che...

updating agent from 10.2.0 to 10.2.2
We updated our server from 10.2.0 to 10.2.2 however there is nothing on the sytem update page for an agent update.. i realize i could do a 10.3 server/agent update..but i really can't update the server at this time so in an effort to get the agent on the same page as the server can anyone help.. there must be an update i can download.. i don't want to have to uninstall and reinstall the agent from the tools page (massive task) -- smartz136 ------------------------------------------------------------------------ smartz136;1973355 Wrote: > We updated our serv...

Agent updated from 10.2.1 to 10.2.2
We have a few thousand machines in our company and recently deployed an agent update from 10.2.1 to 10.2.2. Out of these machines we have 400 that give errors. We have 40 machines that say "Installing" We have about 20 machines that say "awaiting reboot" And the rest say "Update Assigned" I don't see any Zenworks errors in the event logs of the individual PCs so not sure what is causing the agent to not install. For the machines that say "awaiting reboot" we already rebooted them using another software package. For the ones that ...

Bundles from 10.0.3 install after a new 10.1.2 install
I have installed 10.1.2 on some new client machines and after the install I am noticing bundles from 10.0.3 are installing from somewhere. I don't make any 10.0.3 bundles so I am guessing it is some type of auto update that did not get shut off. Anyone have a idea where I can kill this off? Windows 2003SP2 server w/ ZCM 10.1.2 Thanks, Jim Koerner Jim, It appears that in the past few days you have not received a response to your posting. That concerns us, and has triggered this automated reply. Has your problem been resolved? If not, you might tr...

10.3.0a installed but ZCM Version 10.2.2 displayed on device
Hello all, I upgraded our Suse 11 ZCM server from 10.2.2 to 10.3.0a and according to ZCC installation was successful. The version.txt also confirms this, yet the server device still displays 10.2.2. This is still the case after a reboot. Is there a fix or should I not be concerned? Thanks, Matt -- mrivenbark ------------------------------------------------------------------------ mrivenbark, >Hello all, I upgraded our Suse 11 ZCM server from 10.2.2 to 10.3.0a and >according to ZCC installation was successful. The version.txt also >confirms this, yet the ...

Stuck 10.2.2 (from 10.2.0) update stuck
I have a system stuck with the "in process" status. Nothing seems to help, and no System-Update.log is generated. I have rebooted countless times, redeployed, and refreshed even more... So, before I sacrifice the left femur of an 18 year old virgin, and springle some tea leaves, I just wanted to ask the forum if anyone have any thoughts? Usually I just end up with the Agent missing the runlevel's on SLES, but this is on Windows 2003, and the Agent is still 10.2.0. Anyone? Regards Allan Brehm Clausen > So, before I sacrifice the left femur of an 18 year...

Update 10.2.1
Upgraded from 10.2.0 to 10.2.1 with no error. BUT The RPM and MSI folder under Zenworks\Install\Downloads still contains files for 10.2.0. Under System-Updates all new files have version 10.2.1 The folder tools contains files with version 10.2.1 What is wrong? Can I move the files manually? /Niklas -- hellblad ------------------------------------------------------------------------ hellblad, It appears that in the past few days you have not received a response to your posting. That concerns us, and has triggered this automated reply. Has your problem be...

ZCM 10.2 Blank version numbers
Hi all, i've problem with ZCM 10. I've installed ZCM 10.2 on SLES 11 64bit. Then i've manually imported 10.2.2 update and status of the update in ZCC is "Downloaded". But i was unable to deploy this update to the server with error message: "The Update for ZCM (10.2.2) update requires the following update(s) to be applied before it can be deployed: Support Pack 2 for ZCM (10.2) ". I was really shocked as i installed ZCM from 10.2 iso file. Then I checked the version number of ZCM components through ZCC and in the Server Hierarchy field of my prima...

Upgrade from 10.2.0 to 10.2.2
Is there a direct migration path from 10.2.0 to 10.2.2? In my ZCC, the following updates are 'Baselined': 10.1.1, 10.1.2a and 10.1.3. Not everyone is running Support Pack 2 for 10.2 so it isn't 'Baselined'. I have an option for 10.3, but it doesn't show 10.2.1 or 10.2.2. Thanks in advance, Eric -- tidewins ------------------------------------------------------------------------ tidewins;1958672 Wrote: > Is there a direct migration path from 10.2.0 to 10.2.2? > > In my ZCC, the following updates are 'Baselined': ...

Updating from 10.2.2 to 10.3.0a
Is there any sybase updates that need to be installed before the 10.3.0a update? Thanks -- hwilliam ------------------------------------------------------------------------ hwilliam;2035888 Wrote: > Is there any sybase updates that need to be installed before the 10.3.0a > update? > > Thanks When you update to 10.3 Sybase should be automatically updated to the latest version. Thomas -- http://thsundel.blogspot.com/ ------------------------------------------------------------------------ thsundel's Profile: http://forums.novell.com/mem...

ZCM update from 10.2.2 to 10.3
Hello I am sorry if this is in the wrong section but I am in a jam. I am running ZCM 10.2.2 on a SLES box. I noticed there was a 10.3a update so I downloaded it and deployed. I now have a different agent on the workstations than on the server so they won't talk. I assumed that the update would update the server as well. I was wrong. I have 2 questions. What did I do wrong and how do I fix it. I am not good with linux at all. I would think I have to update the server? -- whitee27 ------------------------------------------------------------------------ I moved this po...

Web resources about - 10.2.2 update not installed correctly - novell.zenworks.10.install

Pre-installed software - Wikipedia, the free encyclopedia
Bundled software is another name for pre-installed software, as pre-installed are all bundled with a hardware device of some kind. However, bundled ...

REPORT: Facebook Home Can Be Installed On All Android Devices Running 4.0 And Up
The good news: Facebook Home can now be run on all Android devices running version 4.0 of the mobile operating system or higher, even if they ...

HTC reveals HTC First, an Android smartphone pre-installed with Facebook Home
HTC today revealed the HTC First, the first Android smartphone that comes with Facebook Home pre-installed on the device. With Facebook Home ...

Introducing installed app category targeting: a new way to target users and gain insights into mobile ...
We’re excited to introduce installed app category targeting: a new tool that enables app advertisers to reach users based on the categories of ...

CPU fan installed - Flickr - Photo Sharing!
Explore Garrette's photos on Flickr. Garrette has uploaded 3652 photos to Flickr.

Gay-friendly traffic lights installed in Vienna - YouTube
Keep up-to-date with the latest news, subscribe here: http://bit.ly/AFP-subscribe Several pedestrian crossings in Vienna are showing symbols ...

Chris Gayle posts photos of strip club installed in his own house
... his party lifestyle off the cricket field, but the West Indian has gone to a whole new level by showing off the new "strip club" he has installed ...

Cameras installed on hull of ISS (00:59)
RAW VIDEO: Russian cosmonauts perform a spacewalk to install photographic and scientific equipment on the hull of the International Space Station. ...

Where in the US is solar installed?
New data shows that Californians' penchant for photovoltaics has them leading in pipeline capacity by a factor of five, while Nevada's love of ...

Giant Gollum installed at airport ahead of Hobbit film
A 12 metre-long sculpture carved using robotics and chainsaws has been installed at Wellington Airport ahead of The Hobbit premiere.

Resources last updated: 1/22/2016 10:56:39 PM