Novell Client 2 upgrade fails to install NICI (error 1603)

I have configured the automatic update agent to specifically use
Administrator Privileges according to the documentation:
http://www.novell.com/documentation/windows_client/pdfdoc/windows_client_admin/windows_client_admin.pdf
When I run the update from "Novell Services" in system tray as a normal
user the update completes with errors: fails to install NICI (error
1603).
When I do the exact same thing as an admin, everything works fine.
I'm am trying to update Novell Client 2 SP 1 (IR7) to Novell Client 2
SP 2 (IR2) on all of our workstations.
And I am seeing the exact same error when trying to upgrade:
Novell Client 2 SP 1 (IR7) to Novell Client 2 SP 2
Novell Client 2 SP 1 (IR7) to Novell Client 2 SP 2 (IR1)

What is going on here, is the update agent broken or am I doing
something wrong?
I don't want all of my users getting errors when their Novell Client
gets updated.


-- 
jimbjorklund
------------------------------------------------------------------------



0
jimbjorklund
3/28/2012 12:46:02 PM
novell.netware.winnt-2x-xp 10573 articles. 1 followers. Follow

11 Replies
1828 Views

Similar Articles

[PageSpeed] 22

On 28/03/12 14:46, jimbjorklund wrote:
>
> I have configured the automatic update agent to specifically use
> Administrator Privileges according to the documentation:
> http://www.novell.com/documentation/windows_client/pdfdoc/windows_client_admin/windows_client_admin.pdf
> When I run the update from "Novell Services" in system tray as a normal
> user the update completes with errors: fails to install NICI (error
> 1603).
> When I do the exact same thing as an admin, everything works fine.
> I'm am trying to update Novell Client 2 SP 1 (IR7) to Novell Client 2
> SP 2 (IR2) on all of our workstations.
> And I am seeing the exact same error when trying to upgrade:
> Novell Client 2 SP 1 (IR7) to Novell Client 2 SP 2
> Novell Client 2 SP 1 (IR7) to Novell Client 2 SP 2 (IR1)
>
> What is going on here, is the update agent broken or am I doing
> something wrong?
> I don't want all of my users getting errors when their Novell Client
> gets updated.
>
>

there is a defect regarding this issue.
In the meantime, can you see if setting the UAC to currently disabled or 
set it to Never notify bypass the issue?

Thanks
0
Mysterious
3/28/2012 1:34:31 PM
Or give the Novell Client update Process 'Administrative rights" so that
it can perform the updates without question.


Leroy Joseph
Visual Click Software
(eDirectory Management and Reporting)
'eDirectory Management and Reporting | DSRAZOR for eDirectory'
(http://www.visualclick.com/content/dsrazor-for-edirectory.htm)


-- 
leroyjjr
------------------------------------------------------------------------
leroyjjr's Profile: http://forums.novell.com/member.php?userid=75462
View this thread: http://forums.novell.com/showthread.php?t=454011

0
leroyjjr
3/28/2012 5:36:03 PM
UAC is already disabled. The user is not shown any other
messages/dialogs except for the NICI failed to install (1603) error.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
3/29/2012 6:56:02 AM
Like it says on the first line of my post "Administrator Rights" are
enabled. I have a settings file containing these lines:
!Client_Update_Agent_Administrator=YES
!Client_Update_Agent_Administrator_Distribute=Always
The settings file is included in the install.ini-file using this line:
NovellClientPropertiesFile="my settings file". I also tried to disable
the installation of NMAS and NICI in install.ini with these lines:
InstallNMAS=No
InstallNICI=No
But all of these settings are just ignored for some reason.
After the installation fails when i look at the Novell Client
Properties the Use Administrator Privileges checkbox is unchecked,
however aftar a reboot it is checked again.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
3/29/2012 11:36:02 AM
Like it says on the first line of my post "Administrator Rights" are
enabled. I have a settings file containing these lines:
!Client_Update_Agent_Administrator=YES
!Client_Update_Agent_Administrator_Distribute=Always
The settings file is included in the install.ini-file using this line:
NovellClientPropertiesFile="my settings file". I also tried to disable
the installation of NMAS and NICI in install.ini with these lines:
InstallNMAS=No
InstallNICI=No
But all of these settings are just ignored for some reason.
After the installation fails when i look at the Novell Client
Properties the Use Administrator Privileges checkbox is unchecked,
however aftar a reboot it is checked again.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
3/29/2012 11:36:02 AM
OK - let's try removing the old Novell Client, NICI and NMAS and
reinstalling a fresh copy of the Novell Client (IR2).

Leroy Joseph
Visual Click Software
'eDirectory Management and Reporting | DSRAZOR for eDirectory'
(http://www.visualclick.com/content/dsrazor-for-edirectory.htm)


-- 
leroyjjr
------------------------------------------------------------------------
leroyjjr's Profile: http://forums.novell.com/member.php?userid=75462
View this thread: http://forums.novell.com/showthread.php?t=454011

0
leroyjjr
3/29/2012 5:46:02 PM
Well that would defeat the whole purpose of an "Update Agent" wouldn't
it?
That would mean manually uninstalling and reinstalling the Novell
Client on over a hundred workstations which I have no intention of
doing. In case I was unclear the same error has occurred on every single
workstation where I have tried upgrading.

The computers are running:
Windows 7 Enterprise 64-bit
ZENworks 11 SP1
Novell Client 2 SP1 (IR7)

If I'm not able to find a solution to this problem my next option is
probably a ZENworks Bundle that handles the upgrade of the Novell
Client, because I know the ZENworks "Run as secure system user"-option
works.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
3/30/2012 7:26:01 AM
I think I'm getting closer to the actual issue, after enabling Novell
Client Debugging by setting this registry value:
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Authentication\NCCredProvider]
"Debug"=dword:00000003

This error is found in
"C:\ProgramData\Novell\Client\Log\NICIInst64.log": Error 2103.Could not
resolve path for shell folder 26

I think this has something to do with the MSI-setup (NICI_wx64.msi) not
being able to find certain keys in the registry for some reason

Recently we had problem with an MSI-based Java-installation running
with admin-privileges where it would fail if "Folder Redirection" was
enabled. We had set My Documents to point to H:\ which was mapped via
Novell as the home folder.
the registry settings for that are found under:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User
Shell Folders]. This however is NOT the problem here so the root cause
for the error is still unclear to me.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
3/30/2012 10:16:02 AM
jimbjorklund;2186387 Wrote: 
> I think I'm getting closer to the actual issue, after enabling Novell
> Client Debugging by setting this registry value:
> [HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Authentication\NCCredProvider]
> "Debug"=dword:00000003
> 
> This error is found in
> "C:\ProgramData\Novell\Client\Log\NICIInst64.log": Error 2103.Could not
> resolve path for shell folder 26
> 
> I think this has something to do with the MSI-setup (NICI_wx64.msi) not
> being able to find certain keys in the registry for some reason
> 
> Recently we had problem with an MSI-based Java-installation running
> with admin-privileges where it would fail if "Folder Redirection" was
> enabled. We had set My Documents to point to H:\ which was mapped via
> Novell as the home folder.
> the registry settings for that are found under:
> [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User
> Shell Folders]. This however is NOT the problem here so the root cause
> for the error is still unclear to me.

Indeed, but remember we are troubleshooting the client here- it may
be possible that there was some corruption in the first failed update. �
So thus removing any components and with a clean install of the Novell
client, to try the update process again to ascertain were exactly the
process may have failed by examining any logs and/or dumps. 

Leroy Joseph
Visual Click Software
'eDirectory Management and Reporting | DSRAZOR for eDirectory'
(http://www.visualclick.com/content/dsrazor-for-edirectory.htm)


-- 
leroyjjr
------------------------------------------------------------------------
leroyjjr's Profile: http://forums.novell.com/member.php?userid=75462
View this thread: http://forums.novell.com/showthread.php?t=454011

0
leroyjjr
3/31/2012 11:26:02 PM
I have run into the same issue with SP2 upgrades from SP1 irXX - royal
pain in the arse to fix

What i've ended up doing is finding the msi for it in the
windows\sys32\install directory and uninstalling using that, but I think
it will still want the 'old' original MSI for it to uninstall, I was
fortunate to have kept the old extracted IR7 / IR8 releases

all the problem machines for me are win7 pro 64 bit

UAC is off on these machines and in most cases i'm logged in with the
administrator account, even tried 'run as administrator' just to be
sure

surely this shouldn't have made it through QA in such a problematic
state??


-- 
gleach1
------------------------------------------------------------------------
gleach1's Profile: http://forums.novell.com/member.php?userid=934
View this thread: http://forums.novell.com/showthread.php?t=454011

0
gleach1
4/1/2012 10:56:02 PM
I have now tried the following upgrade paths:
1. Upgrade from SP1 (IR7) to SP2, as admin which completed without
errors and then upgrade from SP2 to SP2 (IR1) as normal user, which
failed.
2. Complete removal of SP1 (IR7) as admin and installation of SP2 as
admin, then upgrade from SP2 to SP2 (IR1) as a normal user, which also
failed.
From the Log file: C:\ProgramData\Novell\Client\Log\NICIInst64.log I
can still find the exact same error.


-- 
jimbjorklund
------------------------------------------------------------------------
jimbjorklund's Profile: http://forums.novell.com/member.php?userid=67487
View this thread: http://forums.novell.com/showthread.php?t=454011

0
jimbjorklund
4/2/2012 1:16:01 PM
Reply:

Similar Artilces:

2.3.2 update failed on XP limited user, upgraded from Admin, but limited user still sees "upgrade failed"
On a Windows XP system my daughter uses, she runs SeaMonkey from a regular/limited user account. The 2.3.2 upgrade was attempted, but failed. I then performed the upgrade from an administrator account, successfully. However, when using the limited user account, SeaMonkey reports "upgrade failed" whenever it starts. Bob Tue, 06 Sep 2011 10:48:37 -0400, /Bob Fleischer/: > On a Windows XP system my daughter uses, she runs SeaMonkey from a > regular/limited user account. The 2.3.2 upgrade was attempted, but > failed. I then performed the upgrade from an admi...

Windows Client Install, Error installing NICI. Error Code: -3
This is a Windows 2003 server. I was just trying to re-install the Novell Client and can't seem to get past this NICI issue. I tried Client 4.91 SP5 and Client 4.91 SP5 IR1. No success searching TIDs, any ideas? Thanks, Marc Resolved by un-installing Client, then deleting files in: C:\WINDOWS\system32\novell\nici Solved error by deleting folders: "C:\WINDOWS\system32\novell\nici\" To do so: 0- Login as domain user "Administrator" with no Novell login. 1- Right-click "nici\SUBFOLDER1" folder and select Properties 2- Choose "Sec...

Solution to imanger 2.02 install failing during upgrade to NetWare 6.5 sp3
Hi all, I have found that in doing an upgrade to NetWare 6.5 sp3(overlay) my install would fail every time with 1 error something about null and you must install imanager manually. I followed numerous tids to no avail (recreated new ssl ldap certificate, ran tcedirInt.ncf and tckeygen.ncf) . I noticed on two of my servers it installed with no errors and on all others the install of imanger 2.02 would fail. The problem is you need to have an ldap proxy username configured on the LDAP server group object for the server you are installing imanager. If you do not have this configured...

3.2.2 upgrade/ install errors
I am trying to move a site from one hosting company to another, bu am having problems.  I have tried a few different things which have not worked,  The original site was ver 3.0.1 which was successfully upgraded to 3.2.2.  There are some differences between in the table names as the new site needs to have the ObjectQualifier and databaseowner are different. I got errors trying to copy the stored procedures. So:This is my current plan.1. clean install on the new site (ver 3.2.2)2. modify web.config  (that works on the old site) to reflect the database changes.(thus retaini...

Upgrade failed from 9.0.2 to 10 failed with error "not enough memory"
Hi all Upgrade from ASA 9.0.2 to ASA 10.0.0.2465 failed 'dbunload -c "dbf=sucursal.db,uid=DBA,pwd=xxxx" -an sucursal10.db' SQL Anywhere Unload Utility Version 10.0.0.2465 Connecting and initializing ***** SQL error: Not enough memory to start Operating System: Redhat 4 - 2.6.18.6 (kernel version) Gblic: 2.3.4 RAM= 8Gb Any help or idea will be welcome ? Thanks in advance Pablo Benavidez My first step is always to check whether the error was accurate. You stated that the machine has 8GB of RAM, but I don't see h...

client install error #2
When I install GW7SP2 client on an XP SP2 machine, I am getting error "gxmim1.dll failed to register". Do I have to be concern with the error message or I should reinstall? Thanks Gina I get this all the time. Wreaks havouc on the scripted install.... Actually there are a few .DLL's that don't register. Gina, try registering it manually with regsvr32. Uwe -- Novell Support Connection Volunteer SysOp Please don't send me support related e-mail unless I ask you to do so. Well yes, you can register it manually. The problem for me is in ...

Upgrading failing from DNN 2.1.2 > 3.1.0 without an any errors
All, I've finally managed to test and test and test some more to what I thought get to a place where I can finally upgrade our production system to DNN 3.  Problem is, I came across an issue that I never saw on other servers and I can't figure out why it did what it did.  The biggest difference that I can tell is the SQL box is Win2k3 on a clustered environment. Anyway the issue is this: once the user transfers are done, it goes into the spot to run the general upgrades as labeled in upgrade.vb.  The method UpgradeApplication() never runs (about line 1363). ...

regiis failing after 2.0 installation; errors in App Log looking for FW 1.2?!
All, Seeing very strange behavior on a Win2003 server onto which I'm trying to install just MDAC9b1 and the 2.0 Framework (from dotnetfx.exe which ships with VS2005 March 2004 Preview). The Dot Net installer takes forever, seeming to hang on the aspnet_regiis.exe -i step, and when I check the Application Log, I get a few errors which read: The ASP.NET DLL (Path: C:\WINDOWS\Microsoft.NET\Framework\v1.2.30703\aspnet_isapi.dll) (Version:1.2.30703.0) is missing That looks like the old Whidbey path (Oct 2003 codebase), so I'm wondering if something is corrupted in this server's registry...

IManager fails after upgrade from 2.5.2 to 2.7.2
Attempted to upgrade IManager per readme from 2.5.2 to 2.7.2. Done for windows 7 iprint support. After upgrade when IManager launches, login screen is fine, but on initial screen all roles are listed down the left side but no icons across top (Home, configure, etc). Instead this appears com.novell.emframe.dev.eMFrameFactory.getMContext(Ljavax/servlet/http/HttpServletRequest;)Lcom/novell/emframe/dev/MContext; aA similar message appears when you attempt to manage a printer or anything else. ersion still says 2.5.2. Help please, how to uninstall, reinstall, whatever it take...

Windows XP stops responding and you receive a stop error message after you install Windows XP Service Pack 2
Windows XP stops responding and you receive a stop error message after you install Windows XP Service Pack 2 http://support.microsoft.com/kb/888413 ----------------------------------------------------------- Quote ----------------------------------------------------------- Article ID : 888413 Last Review : March 7, 2005 Revision : 1.0 SYMPTOMS After you install Microsoft Windows XP Service Pack 2 (SP2) on a Windows XP-based computer, Windows XP stops responding and you receive a stop error message. CAUSE This problem may occur after you ins...

Netware 6.5 SP4 install fails with "Failed to mount the CD-ROM volume NW65OS" error !
I am doing a fresh install of Netware 6.5 SP4. The volume label of the CD is NW65OS. During install, I get the following error when it tries to mount the CD- ROM: Failed to mount the CD-ROM volume "NW65OS". Some possible reasons are... Correct the problem if possible. (nwconfig-6-391) I've tried the jumper settings and changed many cdroms, to no avail. Anyone has the solution or the work-around ??!!! Thanks a lot !! boot from CD-ROM and install that way. > > I am doing a fresh install of Netware 6.5 SP4. > The volume label of the CD is...

Tomcat installation failing during iManager 2.0.2 install
I'm trying to install iManager with default Tomcat server, the Tomcat installation fails with following error Unhandled Exception c0000005 access violation at address 500bf974 I was able to install iManager successfully on couple of other pcs. Thx Hi, I think you may have some faulty ram ..... John >>> <deepakg@interrait.com> 03/12/2004 >>> I'm trying to install iManager with default Tomcat server, the Tomcat installation fails with following error Unhandled Exception c0000005 access violation at address 500bf974 I was able to in...

superreview granted: [Bug 436207] Display error when install fails due to missing install.rdf : [Attachment 327955] patch rev 2
Daniel Veditz <dveditz@cruzio.com> has granted superreview: Bug 436207: Display error when install fails due to missing install.rdf https://bugzilla.mozilla.org/show_bug.cgi?id=3D436207 Attachment 327955: patch rev 2 https://bugzilla.mozilla.org/attachment.cgi?id=3D327955&action=3Dedit ------- Additional Comments from Daniel Veditz <dveditz@cruzio.com> r/sr=3Ddveditz= ...

MDAC 2.5 required to run, cannot install
 Hello!I have a problem with Data Access. There is a DLL i need to use, which was compiled in VB.6 using MDAC 2.5. I am using ..NET 2.0 and on my machine it's MDAC 2.8.When my program is trying to use that DLL, I get an error of connection not being open. The guy who created that DLL says I need to have MDAC 2.5 on my machine in order to use the DLL properly. However, when I download and try to install MDAC 2.5 it tells me that it's already installed on the machine. Yet, when I go to check in the registry, I get 2.8 and 2.6 as a rollback version. Here is the question: how do I i...

Error when upgrading Bugzilla and Testopia to 3.2 and 2.2 respectively #2
Hello, I upgraded testopia and Bugzilla to 2.2 and 3.2 respectively. Previous versions are Bugzilla 3.0.2 and Testopia 2.2. It seems that when I am clicking the "Do some testing" link, error shown below is occuring. Also after I restored the database, test runs doesn't appear anymore. Software error: DBD::mysql::db selectrow_hashref failed: Unknown column 'target_pass' in 'field list' [for Statement " SELECT run_id,plan_id,environment_id,product_version,build_id,plan_text_version,manager_id,start_date,stop_date,summary,notes,target_...

Web resources about - Novell Client 2 upgrade fails to install NICI (error 1603) - novell.netware.winnt-2x-xp

H-1 upgrade program - Wikipedia, the free encyclopedia
The H-1 upgrade program refers to the United States Marine Corps 's program to develop the AH-1Z Viper and UH-1Y Venom to replace its aging fleets ...


Tumblr Referrals From Facebook Up 2.5X Following Upgrade For Timeline
Since upgrading for timeline and launching with open graph in April, Tumblr has seen its referral traffic from Facebook rise by more than 2.5 ...

Update on Android Ice Cream Sandwich upgrades
HTC has been working hard to get its Ice Cream Sandwich upgrades ready, and we’re excited to announce that our first round of ICS upgrades will ...

Facebook Platform Upgrade Guide
Upgrade instructions for Facebook's platform across versions.

Facebook Allows Users to Upgrade to the New Messages Product, Why You Should
Some users are seeing a prompt when they visit their Facebook Messages inbox allowing them to upgrade to the New Messages product launched in ...

Search Twitter - upgrade
... here Search Refresh julia @ d0gbones 3m I laughed at the call handler when he told me it'd be £400 to stay on my current price plan and upgrade ...

Todo 6 (for devices that cannot upgrade to version 7) on the App Store on iTunes
Get Todo 6 (for devices that cannot upgrade to version 7) on the App Store. See screenshots and ratings, and read customer reviews.

Desktop Audio Upgrade - Flickr - Photo Sharing!
I needed some new speakers for my desktop computer system at home. I've been tolerating JBL creature 2.1 system for a couple of years now and ...

Premium Suite Upgrade for Galaxy SIII (Part 1) - YouTube
Now, you can make your Galaxy SIII even smarter with this Premium Suite upgrade which is designed just for the Galaxy SIII! (Part 1) Following ...

Resources last updated: 1/20/2016 10:30:26 PM