Netware 6.5 and secure FTP

I'm not sure which group this should go in. So if I am posting in the
wrong group, I apologies.

Is Netware 6.5 capable of doing FTP/Implicit SSL over port 990? If so,
how is this configured?

In testing, I have only been able to do SSL over port 21. But I have an
app that will only do Implicit SSL on 990.


-- 
daybrite
------------------------------------------------------------------------



0
daybrite
3/1/2010 5:06:02 PM
novell.netware.6x.install 11229 articles. 0 followers. Follow

4 Replies
301 Views

Similar Articles

[PageSpeed] 42

On 01/03/2010 17:06, daybrite wrote:

> I'm not sure which group this should go in. So if I am posting in the
> wrong group, I apologies.

Maybe 
http://forums.novell.com/novell-product-support-forums/netware/nw-other/communications/ 
would be slightly better but I'd say here is close enough.

> Is Netware 6.5 capable of doing FTP/Implicit SSL over port 990? If so,
> how is this configured?
> 
> In testing, I have only been able to do SSL over port 21. But I have an
> app that will only do Implicit SSL on 990.

According to the docs[1] you should be able to change the port from the 
default value of 21 to something else in the range 0-65535 (though why 
0?) so using 990 shouldn't be a problem.

You can also configure secure connections only which might get you the 
implicit SSL.

What you can't do is have FTP listening on both ports 21 and 990, at 
least not in a supported way (you might be able to load a second 
instance of nwftpd in a protected address space with a different config 
file).

HTH.

[1] http://www.novell.com/documentation/nw65/file_ftp_nw/data/configftp.html
-- 
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group.  See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0
Simon
3/1/2010 5:53:46 PM
I tried setting security to STRICT and the port to 990, but I still
can't open an implicit connection. Here is the connection log from
WS_FTP_Pro:

Finding Host daybrite-is2 ...
Connecting to 161.88.112.141:990
Connected to 161.88.112.141:990 in 0.000000 seconds, Waiting for Server
Response
Initializing SSL Session ...
SSL Connect error 2:
Connect Failed. 
SSL Connect Failed
Host type (1): Automatic detect

I am also attaching the FTPSERV.CFG file.


+----------------------------------------------------------------------+
|Filename: FTPSERV.CFG.txt                                             |
|Download: http://forums.novell.com/attachment.php?attachmentid=4042   |
+----------------------------------------------------------------------+

-- 
daybrite
------------------------------------------------------------------------
daybrite's Profile: http://forums.novell.com/member.php?userid=15740
View this thread: http://forums.novell.com/showthread.php?t=403295

0
daybrite
3/1/2010 7:06:01 PM
On 01/03/2010 19:06, daybrite wrote:

> I tried setting security to STRICT and the port to 990, but I still
> can't open an implicit connection. Here is the connection log from
> WS_FTP_Pro:
> 
> Finding Host daybrite-is2 ...
> Connecting to 161.88.112.141:990
> Connected to 161.88.112.141:990 in 0.000000 seconds, Waiting for Server
> Response
> Initializing SSL Session ...
> SSL Connect error 2:
> Connect Failed. 
> SSL Connect Failed
> Host type (1): Automatic detect
> 
> I am also attaching the FTPSERV.CFG file.

Let me ask Novell ...
-- 
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group.  See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0
Simon
3/2/2010 12:22:44 PM
On 02/03/2010 12:22, Simon Flood wrote:

> Let me ask Novell ...

 From TID 3364159 NWFTPD doesn't support 'implicit' SSL connections, 
only "explicit."

To pre-empt a possible question, given that general support for NetWare 
6.5 ends in 5 days time on 7 March[1] this will not change.

It should also be noted that Implicit SSL is not defined in an RFC which 
I suspect is partly why Novell have not implemented it in NWFTPD.

[1] see http://support.novell.com/lifecycle/details.jsp?pid=5423
-- 
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group.  See www.novell.com/ttp for more details.
------------------------------------------------------------------------
0
Simon
3/2/2010 1:08:53 PM
Reply: