User Application 3.6 with 3.51 User Application Driver

I'm trying to set up User Application 3.6 in a lab environment.  When I 
start JBoss, I get an error " User application driver (UAD) is not 
compatible with User Application version 3.6. Please upgrade your UAD 
using Designer for Identity Manager."

Designer version 2.1.1 doesn't prompt me to upgrade the driver.  Do I 
need Designer 3.0?




0
Doug
6/23/2008 4:48:18 PM
novell.id-manager.userapp 4379 articles. 0 followers. Follow

5 Replies
692 Views

Similar Articles

[PageSpeed] 44

Doug Black;1584150 Wrote: 
> I'm trying to set up User Application 3.6 in a lab environment.  When I
> start JBoss, I get an error " User application driver (UAD) is not
> compatible with User Application version 3.6. Please upgrade your UAD
> using Designer for Identity Manager."
> 
> Designer doesn't prompt me to upgrade the driver.  Do I
> need Designer 3.0?

Designer 2.11 (20071026 is what I have) with the Roles Addon (20080215)
is what you need if you want to stick with "production" code.  There is
an option to migrate your UA driver in Designer. You have to right
click on the UA driver in the Provisioning view. One of the upgrade
options is to 3.6 with Roles. I've already done it, so I cannot see it
anymore or I'd give you more details.  Check the 3.6 User App docs for
more details.


-- 
tse7147
------------------------------------------------------------------------
tse7147's Profile: http://forums.novell.com/member.php?userid=4730
View this thread: http://forums.novell.com/showthread.php?t=333772

0
tse7147
6/23/2008 5:56:01 PM
tse7147,
> 
> Designer 2.11 (20071026 is what I have) with the Roles Addon (20080215)
> is what you need if you want to stick with "production" code.  There is
> an option to migrate your UA driver in Designer. You have to right
> click on the UA driver in the Provisioning view. One of the upgrade
> options is to 3.6 with Roles. I've already done it, so I cannot see it
> anymore or I'd give you more details.  Check the 3.6 User App docs for
> more details.
> 

I'm having trouble finding the Roles Addon.  Got a link?

Thanks


0
Doug
6/23/2008 7:31:32 PM
Disregard, I found it.
0
Doug
6/23/2008 7:54:21 PM
tse7147,
> 
> Designer 2.11 (20071026 is what I have) with the Roles Addon (20080215)
> is what you need if you want to stick with "production" code.  There is
> an option to migrate your UA driver in Designer. You have to right
> click on the UA driver in the Provisioning view. One of the upgrade
> options is to 3.6 with Roles. I've already done it, so I cannot see it
> anymore or I'd give you more details.  Check the 3.6 User App docs for
> more details.
> 

Bleh, I forgot that UA 3.6 requires eDir 8.8.  This significantly 
increases the scope of my (proposed) project.  I guess I'll find out how 
keen management is on role-based provisioning.

Thanks again.

0
Doug
6/23/2008 8:20:13 PM
Doug Black;1584421 Wrote: 
> tse7147,
> >
> > Designer 2.11 (20071026 is what I have) with the Roles Addon
> (20080215)
> > is what you need if you want to stick with "production" code.  There
> is
> > an option to migrate your UA driver in Designer. You have to right
> > click on the UA driver in the Provisioning view. One of the upgrade
> > options is to 3.6 with Roles. I've already done it, so I cannot see
> it
> > anymore or I'd give you more details.  Check the 3.6 User App docs
> for
> > more details.
> >
> 
> Bleh, I forgot that UA 3.6 requires eDir 8.8.  This significantly
> increases the scope of my (proposed) project.  I guess I'll find out
> how
> keen management is on role-based provisioning.
> 
> Thanks again.

I would go for it.  We started on 8.8.1, and upgraded to 8.8.2 as part
of the upgrade. We also went from IDM  3.5 to 3.5.1. All the upgrades
are well worth the effort.


-- 
tse7147
------------------------------------------------------------------------
tse7147's Profile: http://forums.novell.com/member.php?userid=4730
View this thread: http://forums.novell.com/showthread.php?t=333772

0
tse7147
6/25/2008 7:06:01 PM
Reply: