Problem with replica

Hello

We have an environment with 3 replicas, after extending the schema via
the designer pointing to the master replica, one of the replicas R / W
stopped working, checked the ndsd.log and we get the following error:


Code:
--------------------
    Jan 31 15:12:53  NDS iMonitor for Novell eDirectory 8.8 SP6 v20601.10 started successfully.
  Jan 31 15:12:55  Novell PKI Services Started Successfully
  Jan 31 15:12:55  Loading SecretStore Server...
  Jan 31 15:12:55  Novell SecretStore Service Version 3.4.2 Loaded Successfully
  Jan 31 15:12:55  Loading SecretStore NCP Transport Plugin...
  Jan 31 15:12:55  Novell SecretStore NCP Plugin Version 3.4.2 Loaded Successfully.
  Jan 31 15:33:43  Got SIGINT/SIGTERM signal, server shutting down
  Jan 31 15:33:43  Unloading SSNCP...
  Jan 31 15:33:43  SecretStore NCP Plugin Unloaded Successfully
  Jan 31 15:33:43  Novell PKI Services unloaded
  Jan 31 15:33:46  NDS iMonitor for Novell eDirectory 8.8 SP6 v20601.10 shutdown successfully.
  Jan 31 15:33:49  LDAP Agent for Novell eDirectory 8.8 SP6 (20601.08) stopped
  Jan 31 15:33:49  Information: SNMP Trap Server for Novell eDirectory 8.8.6 v20601.30 stopped.
  
  Jan 31 15:33:49  GAMS closed
  Jan 31 15:33:49  MASV closed
  Jan 31 15:33:49  SPM DClient closed
  [ -- DHost Logging STOPPED Tue Jan 31 15:33:49 2012 -- ]
  Jan 31 15:32:37  Path of Novell eDirectory configuration file /etc/opt/novell/eDirectory/conf/nds.conf
  Jan 31 15:32:38  Host process for Novell eDirectory 8.8 SP6 v20601.18  successfully started
  Jan 31 15:32:38  DHLog: file size 1048576
  [ -- DHost Logging STARTED Tue Jan 31 15:32:38 2012 -- ]
  Jan 31 15:32:38  MASV Init called
  Jan 31 15:32:38  Mandatory Access Control Service Version: 2.0.1 started
  Jan 31 15:32:39   started
  Jan 31 15:32:39  SPM DClient Version:3.3.3.0 Build:20100914 started
  Jan 31 15:32:39  MASV Init called
  Jan 31 15:32:39  MASV already initialized.
  JAN 31 15:32:40  THE LOCAL AGENT COULD NOT BE OPENED - FAILED, DIB ERROR (-785)
  Jan 31 15:32:41  GAMS Init called
  Jan 31 15:32:41  Graded Authentication Management Service Version: 2.0.1 started
  Jan 31 15:32:41  Information: SNMP Trap Server for Novell eDirectory 8.8.6 v20601.30 started.
  
  Jan 31 15:32:42  NDS iMonitor for Novell eDirectory 8.8 SP6 v20601.10 started successfully.
  Jan 31 15:32:44  Novell PKI Services Started Successfully
  Jan 31 15:32:44  Loading SecretStore Server...
  Jan 31 15:32:44  Novell SecretStore Service Version 3.4.2 Loaded Successfully
  Jan 31 15:32:44  Loading SecretStore NCP Transport Plugin...
--------------------


May be due to an error in the database? Can we solve the problem with
command ndsrepair -R?


On the other hand, after that no driver could not start in any of the
servers, giving us the following error:

Unable to start the driver: Driver.DrvSet.services.companyr into
com.novell.admin.common.exceptions.UniqueSPIException: (Error -783) The
DirXML Interface Module (VRDIM) is not currently loaded into NetWare or
into DHost.



Thank you very much!


-- 
adnowak
------------------------------------------------------------------------



0
adnowak
1/31/2012 7:46:02 PM
novell.id-manager.drivers 10360 articles. 0 followers. Follow

5 Replies
560 Views

Similar Articles

[PageSpeed] 34

On Tue, 31 Jan 2012 19:46:02 +0000, adnowak wrote:

> We have an environment with 3 replicas, after extending the schema via
> the designer pointing to the master replica, one of the replicas R / W
> stopped working, checked the ndsd.log and we get the following error:

I don't think these are related, but I guess it's possible. It looks like 
the DIB is corrupt.


>   Jan 31 15:32:39  MASV already initialized. JAN 31 15:32:40  THE LOCAL
>   AGENT COULD NOT BE OPENED - FAILED, DIB ERROR (-785)

The only recent hit in the knowledgebase is TID #5116991. Is it relevant 
to your servers?


> May be due to an error in the database? Can we solve the problem with
> command ndsrepair -R?

That's probably your next step, yes. I don't know if it will help.


> On the other hand, after that no driver could not start in any of the
> servers, giving us the following error:
> 
> Unable to start the driver: Driver.DrvSet.services.companyr into
> com.novell.admin.common.exceptions.UniqueSPIException: (Error -783) The
> DirXML Interface Module (VRDIM) is not currently loaded into NetWare or
> into DHost.

vrdim not loading on other servers is unrelated to this server being 
dead. You may have more than one problem here.


-- 
--------------------------------------------------------------------------
 David Gersic                                           dgersic_@_niu.edu
 Knowledge Partner                               http://forums.novell.com

 Please post questions in the forums.      No support provided via email.

0
David
1/31/2012 9:30:01 PM
I run the ndsrepair -U command, and it found 1 error :


Code:
--------------------
    ERROR: Attribute type is not valid schema, ID: 000001d3, attribute is purged
--------------------


Then, I reboot the server, there are no more problem with replica and
the error in ndsd.log disappear.

But I still working with drivers error. They can't start, with the same
error :


Code:
--------------------
    Unable to start the driver: Driver.DrvSet.services.companyr into
  com.novell.admin.common.exceptions.UniqueSPIExcept ion: (Error -783) The DirXML Interface Module (VRDIM) is not currently loaded into NetWare or into DHost.
--------------------


How can I solve it?

Thanks!


-- 
adnowak
------------------------------------------------------------------------
adnowak's Profile: http://forums.novell.com/member.php?userid=112383
View this thread: http://forums.novell.com/showthread.php?t=451600

0
adnowak
2/1/2012 1:16:03 PM
I was looking for a solution of this problem, and somebody say that it
was a problem of asociation between the DriverSet and servers.

So I removed all servers from DriverSet, I added there again, and this
solve the problem.

Take care of Name Password (and maybe some Driver Configuration)
because they need to be setting again!


-- 
adnowak
------------------------------------------------------------------------
adnowak's Profile: http://forums.novell.com/member.php?userid=112383
View this thread: http://forums.novell.com/showthread.php?t=451600

0
adnowak
2/1/2012 2:56:01 PM
On Wed, 01 Feb 2012 13:16:03 +0000, adnowak wrote:

> I run the ndsrepair -U command, and it found 1 error :

In the future, please use "ndsrepair -R" for repairs. The "-U" is an 
anachronism that should have died off years ago.


> Code:
> --------------------
>     ERROR: Attribute type is not valid schema, ID: 000001d3, attribute
>     is purged
> --------------------

Ouch. Interesting. So this could be related to your schema change. Does 
the schema look correct on the server that holds the Master replica of 
the [Root] partition?


> Then, I reboot the server, there are no more problem with replica and
> the error in ndsd.log disappear.
> 
> But I still working with drivers error. They can't start, with the same
> error :
> 
> 
> Code:
> --------------------
>     Unable to start the driver: Driver.DrvSet.services.companyr into
>   com.novell.admin.common.exceptions.UniqueSPIExcept ion: (Error -783)
>   The DirXML Interface Module (VRDIM) is not currently loaded into
>   NetWare or into DHost.
> --------------------

Is this server associated with a driver set? What OS is it running? If 
it's NetWare, then "load dirxml" on the console. If it's Linux, then load 
ndstrace and "load vrdim". See what that reports and let us know.



-- 
--------------------------------------------------------------------------
 David Gersic                                           dgersic_@_niu.edu
 Knowledge Partner                               http://forums.novell.com

 Please post questions in the forums.      No support provided via email.

0
David
2/1/2012 3:00:02 PM
For you information, the schema was correct on the master replica, and
now in the other replica too.

Servers are running on SUSE, with IDM 4.0.1. 

And I solve the problem of VRDIM with rebuilding the association
between Driver Set and Servers .

Thanks for you help!


-- 
adnowak
------------------------------------------------------------------------
adnowak's Profile: http://forums.novell.com/member.php?userid=112383
View this thread: http://forums.novell.com/showthread.php?t=451600

0
adnowak
2/1/2012 8:56:01 PM
Reply:

Similar Artilces:

problem in notes driver for no-id-file
guys....i had configure my notes driver not to create user id file...here is my policy(under creation): <rule> <description>New: No ID File </description> <conditions> <and> <if-operation op="equal">add</if-operation> </and> </conditions> <actions> <do-set-xml-attr expression="../add[@class-name='User']" name="no-id-file"> <arg-string> <token-text xml:space="preserve">TRUE</token-text> </arg-string> </do...

Problems, problems, problems
Name: Hans Halvorsen Email: capricorn_at_online.no Product: Thunderbird Summary: Problems, problems, problems Comments: Hi, I downloaded Thunderbird some time ago, and I was over-satisfied whit it and how well it worked. In fact it worked 100% PERFECTLY UNTIL I got an newer update version of it. Since then I' ve had nothing BUT trouble! I've checked adresses, notes, password, deleted accounts and made new one's, checked sign-ins and sign-outs, passwords inside and out, upside and down, so many times that my frustration now is about to turn into pure and major ...

Problems Problems Problems
So, I have OpenSUSE installed on my laptop and everything is working well, except the wireless. It almost seems that every time I run a KDE distro I can not get the internet to work. I've run YaST and used iwconfig. nothing is working for me. Please help -ZAD -- zadnik18 ------------------------------------------------------------------------ someone is going to tell you to supply some more information 'My wireless doesn't work - a primer on what I should do next - openSUSE Forums' (http://tinyurl.com/6peanc) this is one of the stick...

Problems, problems, problems
Name: Product: Firefox Summary: Problems, problems, problems Comments: I use FF all the time for work - I'm a software tester - the add-ons are invaluable. But v3.5 really has been a disappointment. It just keeps hanging all the time. And when Internet Explorer windows pop up, FF often just dies. It can't even restart itself - I have to manually kill the process every time; every update, every add-on that updates, "restart" fails - it's so frustrating. I hope v3.6 will be addressing this - PLEASE! Browser Details: Mozilla/4.0 (compatible; MSIE 7....

PROBLEMS, PROBLEMS, PROBLEMS.
Name: Product: Firefox Summary: PROBLEMS, PROBLEMS, PROBLEMS. Comments: Does Google's Chrome browser block out Firefox? Am having a lot of trouble getting Firefox to run after I run Chrome. No trouble what-so- ever before running Chrome. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see ...

Problems problems and problems.
Name: A.A. Product: Firefox Summary: Problems problems and problems. Comments: I am not specific, but in short I can not use This site to listen music anymore, while I can in IE explorer. Just to let you guys know, new version messed something up. http://hypem.com/ Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see it. ...

[ID 20011220.001] problem with using PPM3 package manager
This is a bug report for perl from fin@rda.berezne.com, generated with the help of perlbug 1.33 running under perl v5.6.1. ----------------------------------------------------------------- [Please enter your report here] When I'm just try lanch ppp3 I've get such message: Can't locate object method "new" via package "PPM::Repository::Error" at PPM/Repository.pm line 42. Even I type - ppm3 describe URI (or any other preinstalled package) from command line, get the same message :-( Within simle PPM (old one) have no problem. Help me PLEASE! [P...

[ODBC Driver Manager] Program type out of range and OLE language problem
I have developed an application which uses a Acess97 database. It works properly in the PB development environment. But after I compiled it on the same machine, it always returned the following error message if data were retrieved from the database: Select error SQLSTATE=S1003 [Microsoft] [ODBC Driver Manager] Program type out of range. I don't know what's the meaning about it. My OS is Windows98. Even the simple SQL select statement didn't work. I suppose the reason is based on the ODBC driver because when I changed the database to informix, the compiled code worke...

[ODBC Driver Manager] Program type out of range and OLE language problem
I have developed an application which uses a Acess97 database. It works properly in the PB development environment. But after I compiled it on the same machine, it always returned the following error message if data were retrieved from the database: Select error SQLSTATE=S1003 [Microsoft] [ODBC Driver Manager] Program type out of range. I don't know what's the meaning about it. My OS is Windows98. Even the simple SQL select statement didn't work. I suppose the reason is based on the ODBC driver because when I changed the database to informix, the compiled code wor...

[ODBC Driver Manager] Program type out of range and OLE language problem
I have developed an application which uses a Acess97 database by PB6.0. It works properly in the PB development environment. But after I compiled it on the same machine, it always returned the following error message if data were retrieved from the database: Select error SQLSTATE=S1003 [Microsoft] [ODBC Driver Manager] Program type out of range. I don't know what's the meaning about it. My OS is Windows98. Even the simple SQL select statement didn't work. I suppose the reason is based on the ODBC driver because when I changed the database to informix, the compiled ...

[ODBC Driver Manager] program type out of range and OLE language problem
I have developed an application which uses a Acess97 database. It works properly in the PB development environment. But after I compiled it on the same machine, it always returned the following error message if data were retrieved from the database: Select error SQLSTATE=S1003 [Microsoft] [ODBC Driver Manager] Program type out of range. I don't know what's the meaning about it. My OS is Windows98. Even the simple SQL select statement didn't work. I suppose the reason is based on the ODBC driver because when I changed the database to informix, the compiled code worke...

Notes Driver problem: Failure in Publication. ID = 4005. Message: Notes error: Operation stopped at your request
running the latest notes driver (v225) with RL and Notes CLIENT 702 on a = windows machine, connecting to a domino server 702. Every now and then all = five driver instances stop working properly (within about 30min timeframe) = with a level 3 trace showing "ID =3D 4005. Message: Notes error: = Operation stopped at your request": DirXML: [01/02/07 17:44:10.31]: TRACE: DRV_NAMES: Publisher Event =3D = Class: null; Event: delete; UNID 7B89043456352A11C125710D0048AB94; Notes = DN: null DirXML: [01/02/07 17:44:10.31]: TRACE: Remote Loader: Received document = from publicati...

Loosing events between replica, with drivers on multiple replicas
IDM 3.5.1 engine ir3 on SLES 10. eDir 8.8.2 FT2 with LOTS of drivers (eDir, Ad, Linux/Unix, JDBC, Work Order, Null, loopback, NXSettings, Composer shims (3 different screen scrapers), and more!) I have a somewhat complex driver set up (what, me? Complex? Never you say!). Anyway, when we developed this, we ran it all on one server. Now in production with greater load we want to split it out across three boxes. Thing is, I am loosing events in several different cases: 1) First box creates a WO object, and modifies a user. The other two replicas often see the User mod...

A problem when I use script manager, script manager proxy
I have an default.aspx and 3 link in that page. When I click to one of these links I want to load a usercontrol( ex: control1.ascx ) and in this user control I also use ajax in this control. Other Developer said that I must use a master page and declare a script manager in this page. In usercontrol I just need to use scriptmanagerproxy... But I don't know exactly what I have to do. Can you help me. Thanks all of you a lot. manhtuan Hi hamanhtuan, Well the scriptmanagerproxy is an extended version of the scriptmanager. In your situation i think you can fix it with just a scr...

Performance problems with PB10 driver vs. PB84 driver
I am experiencing very poor performance problems when using the PB10 drivers vs. the PB84 drivers. Even the PB90 driver is slower then the PB84 driver. I recently migrated my application from PB9 to PB10.2.0(8075) running on Windows XP(Oracle 10 client) connecting to Oracle 10g Unix server. I have a simple window retrieving data to three seperate data windows. The PB84 driver works great, the PB90 and PB10 drivers are more then 10 times slower. Any suggestions or solutions are welcome. Thanks. Have you enabled the pbtrace.log for both the PB8 and PB10 test applications to ...

Web resources about - Problem with replica - novell.id-manager.drivers

Problem novel - Wikipedia, the free encyclopedia
Working class, or proletarian novels are often also social problem novels . This was in many ways a reaction to rapid industrialization , and ...

Malcolm Turnbull's first 100 days as Prime Minister: Successes and problems
December 23 marks 100 full days as Prime Minister for Malcolm Turnbull. How has he fared? Lisa Cox looks at his successes and the headaches. ...

Malcolm Turnbull's first 100 days as PM: agile, disruptive, but problems persist
As the nation winds down for the summer break, its newly installed&nbsp;leader will be working through after deciding that with&nbsp;just three ...

China's Shenzhen ignored warnings of waste problem a year before landslide disaster
A government official warned a year ago that China's boomtown Shenzhen would run out of space to dump building waste. On Sunday his worst fears ...

Malcolm Turnbull's first 100 days as Prime Minister: Successes and problems
December 23 marks 100 full days as Prime Minister for Malcolm Turnbull. How has he fared? Lisa Cox looks at his successes and the headaches. ...

Malcolm Turnbull's first 100 days as Prime Minister: Successes and problems
December 23 marks 100 full days as Prime Minister for Malcolm Turnbull. How has he fared? Lisa Cox looks at his successes and the headaches. ...

"When there’s a problem, people need someone or something to blame. Among L.A. residents peeved with ...
... they’d take their garden-wrecking, loudly squawking, prolifically pooping selves and fly the coop...." Did you know L.A. has a peacock problem ...

Maps Minutes Hack #7: No signal, no problem. Navigate your holiday travels with Google Maps offline
Part of our series on how to save time this holiday season with Google Maps. This time of year, millions take a road trip home for the holidays ...

Lawler: "Yes, Houston will have a problem next year"
Some thoughts on the Houston housing market from housing economist Tom Lawler: Earlier this week I sent out a message with a link to the Houston ...

Michael Moore Reveals European Solutions To American Problems
... that we as Americans should also enjoy: free (University) education, child care, maternity leave, paid vacation, health care for all. Problems ...

Resources last updated: 12/23/2015 12:53:53 AM