HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration.

BM 3.8sp2 sry071
NW 6.5sp2

I have a couple of web sites that my BM proxy is not allowing access
to. I keep getting 401 errors:

HTTP Error 401.2 - Unauthorized: Access is denied due to server
configuration.
Internet Information Services (IIS)

The other just comes back with: Error: Access is Denied.

No login prompt. Not anything. This is if I use IE - proxy settings
turned on/off - it doesn't matter.

If I use Firefox, I get prompted for authentication, but it never
allows me in.

If I bypass BM, there is no problem.

I am not sure where to go with this.

Any ideas?



0
Steven
1/18/2006 12:49:17 AM
novell.bordermanager.proxies 3217 articles. 0 followers. Follow

6 Replies
733 Views

Similar Articles

[PageSpeed] 13

hi Steven,

this is a known issue with certain types of authentication to the IIs 
server.
See
http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/iis/maintain/featusability/authmeth.mspx
for a list of authentication method that can be used with IIS. As the 
chart mentions, only the basic authentication works through proxies. You 
should contact the owner of the site and point out this issue.

-- 
Cat
NSC Volunteer Sysop
0
Caterina
1/18/2006 3:15:59 PM
Thanks for the quick response. 

In both instances it was NTLM authentications. I was able to get one
of them to change. The other, well. They aren't as open to it. Sad. As
I see it NTLM is only really proper for internal stuff.

Oh well.

Thanks again.


On Wed, 18 Jan 2006 15:15:59 GMT, Caterina Luppi <cat@not-here.com>
wrote:

>hi Steven,
>
>this is a known issue with certain types of authentication to the IIs 
>server.
>See
>http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/iis/maintain/featusability/authmeth.mspx
>for a list of authentication method that can be used with IIS. As the 
>chart mentions, only the basic authentication works through proxies. You 
>should contact the owner of the site and point out this issue.
0
Steven
1/24/2006 9:40:58 PM
Should this method work with NTLM?

I tried it and it did not seem to work.

If you get desperate, there is a workaround to bypass the proxy for 
problem sites.

1. Create a stateful filter exception (www-http-st) from private to 
public, dest. IP address=problem site address.
2. Go into the browser proxy settings and tell the browser to bypass 
proxy for that URL.
3. Be sure routing and dynamic NAT are enabled on the server, and the 
PC has a default gateway and working DNS.



On Wed, 18 Jan 2006 15:15:59 GMT, Caterina Luppi <cat@not-here.com>
wrote:

>hi Steven,
>
>this is a known issue with certain types of authentication to the IIs 
>server.
>See
>http://www.microsoft.com/technet/prodtechnol/windows2000serv/technologies/iis/maintain/featusability/authmeth.mspx
>for a list of authentication method that can be used with IIS. As the 
>chart mentions, only the basic authentication works through proxies. You 
>should contact the owner of the site and point out this issue.
0
Steven
1/24/2006 9:48:02 PM
Steven,

yes, it should work. You might have either a routing issue or a 
filtering issue if that doesn't work.
This is how to pin down which one it is.
UNLOAD IPFLT at the BM server for a test (remember to load it).
Make sure that the workstation has a "direct connection" in the browser 
and that it can resolve DNS names.
try to access the site (or any other web site).
If it works, and doesn't work when ipflt is loaded, you've a filtering 
issue. If it still doesn't work it means that you've a routing or 
configuration issue.
Let me know which case it is, and we can work from there.

-- 
Cat
NSC Volunteer Sysop
0
Caterina
1/24/2006 10:03:07 PM
Ok, I have set it, and done a test. It does hit the web server. But,
it does not let me through to the website. I believe the first thing
it is trying to do is go https. I have transparent proxy turned on.
And with it, port 80 (http) works fine, but 443 does not. I think I
have a port conflict. (if we should take this to a new thread let me
know)

So, I went to my portal screen (or tried to anyways). The portal is
not loaded. I get an error:

Loading module PORTAL.NLM                                     
  Novell Remote Manager NLM                                   
  Version 4.01   December 8, 2005                             
  Copyright 1998-2005 Novell, Inc.  All rights reserved.      
                                                              
Error allocating resource tag (0x48424E57).                   
)  SERVER-5.70-1553: Module initialization failed.            
  Module PORTAL.NLM NOT loaded                                
Module PORTAL.NLM load status INIT FAIL                       

Also, ndsimon unloads as well. httpstk does not unload.

I don't know why. I can't find anything in the technotes on this one.
Any ideas?


On Tue, 24 Jan 2006 22:03:07 GMT, Caterina Luppi <cat@not-here.com>
wrote:

>Steven,
>
>yes, it should work. You might have either a routing issue or a 
>filtering issue if that doesn't work.
>This is how to pin down which one it is.
>UNLOAD IPFLT at the BM server for a test (remember to load it).
>Make sure that the workstation has a "direct connection" in the browser 
>and that it can resolve DNS names.
>try to access the site (or any other web site).
>If it works, and doesn't work when ipflt is loaded, you've a filtering 
>issue. If it still doesn't work it means that you've a routing or 
>configuration issue.
>Let me know which case it is, and we can work from there.
0
Steven
1/24/2006 10:25:19 PM
Steven,

> Ok, I have set it, and done a test. It does hit the web server. But,
> it does not let me through to the website. I believe the first thing
> it is trying to do is go https. I have transparent proxy turned on.
> And with it, port 80 (http) works fine, but 443 does not. I think I
> have a port conflict. (if we should take this to a new thread let me
> know)

ok, the transparent proxy is the culprit here. Regardless if you've the 
browser configured to use the proxy or not, the transparent proxy WILL 
pick up the communication and process it through the proxy. Your only 
real solution, here is to disable the transparent proxy completely.


-- 
Cat
NSC Volunteer Sysop
0
Caterina
1/25/2006 4:47:12 PM
Reply:

Similar Artilces:

My POST still getting HTTP error 401 Access Denied after adding proxy usesystemdefault="False" to web.config
I am confused about what is going on here. I have an initial page I call QueryController.aspx which has some form elements and some Javascript that posts a request to a page called  MapController.aspx. I had been able to set breakpoints in MapController.aspx and step thru the code. I don't recall what incremental thing I changed or added but suddenly I could no longer do that. If I ran without breakpoints my code never returned anything to the elements on the QueryController page. Trace.axd showed that MapController.aspx was posted. I added a Page_Error event handler but no error se...

configuration error
Dear ASP.NET Programmers, I encountered the following problem: Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Access is denied: 'ExportTechnologies.WebControls.RTE' This component was working for months without any problem. I searched the net for the solution, but suggested solutions did not help me. I don't use the Indexing Service. I hope I can fing help here. Tha...

Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists)
  I got this error after creating the virtual directory and trying to access the webpage through wireless.. I had access before..but somehow I don't have any more does someone know how to resolve this issue? cheers    claudi   Cheers, Claudi Check NTFS permissions on the file/folder. JeffPlease: Don't forget to click "Mark as Answer" on the post that helped you. That way future readers will know which post solved your issue. All accounts are allowed for everything: read, write, execute...etcCheers, Claudi  Hello,t...

Access denied error message 401.2
Hi, I want my .Net app to be accessible to a group only.For this I entered the following in web.config <authorization> <allow roles="Group name" />   <deny users="*" /> </authorization> and want all users who are not member of this group redirected to customised page NoAccess.htm <customErrors mode="On" defaultRedirect="Error.aspx" > <error statusCode="401" redirect="NoAccess.htm" /> </customErrors>   I am using Windows authetication,have added the group in the local ...

Error 401.2. Server Error
Hi All, I am using Forms Authentication on a subdirectory. The authentication and authorisation is all working out well. The problem is a webcontrol button I have added to the page. When clicked, I get a Server error 401.2. Somehow the authentication gets in between, because when I remove it everything runs just fine. It´s not the procedure that is to be run when the button is clicked, because I get the error even on a "naked" web control button. I was already on the msdn site, but none of the articles applied to my problem. this is the erro...

The request failed with HTTP status 401: Access Denied. #2
Here is a new twist on the numerous 401 posts that are out there.  I am developing a Website for a client that uses forms authentication.  The Webservices that it calls are also local and have been working for months.  Both the Website and the Webservice allow anonymous access using the IUSER account.  Here is the twist: For a different client last week, I had to join their domain to do some Active Directory work (I know I should have used a VPC).  While I was there, I decided to do some work on the other client, but when I tried to login to the Website, I received ...

How to give a nice friendly access denied page, rather than 'server error access denied'
I have a question:How do i redirect people to a friendly HTML page if they aren't allowed access,rather than the rude error that asp.net gives as below: Server Error in '/refunds' Application.--------------------------------------------------------------------------------Access is denied. My web.config is like this: <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">  <system.web>    <authorization>      <allow users="domain\abcd" />    &nbs...

iManager error with Error: NMAS LDAP Transport Error javax.naming.CommunicationException: [LDAP: error code 2
I have a problem exactly as related in tid (3947462), but the fix that I tried as posted in the TID did not do anything to rectify the problem. My server shows only 6 nmasldap before and after performing nmasinstall. This is a netware 6.5 server with service pack 5. No additional configuration changes or service packs were installed on the server since the last time this part of the functionality worked. The document says that there are 2 possible causes. The second cause, I don't beleive applies as there is only 1 netware server. I ran both the nmasinstall command on a wi...

"SQL Server does not exist or access denied" error #2
I'm trying to create to set up connection between my web application on the server and the database on another box and getting "SQL Server does not exist or access denied" error. Both the web server and the database machine are Windows 2003 Server, there's no firewall enabled, there's mixed authentication enabled on the sql server. The machines are not on the same domain so I'm using SQL Server authentication from web.config. Here's my connection string: <add key="ConnectionString" value="Server=sqlboxip;User id=sqlaccountname;Pwd=sqlpass;Initial catalog=dbname"> I've also...

Random SQL Server does not exist or access denied errors in ASP.NET 2.0?
 I receive the following error randomly in my ASP.NET 2.0 website:  OleDbException (0x80004005): [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.]   I might be able to login to my site for 5 minutes with no problem.  Other times it bombs out at the login.  I know the user name and password are correct.  I am using SQL Server 2005 in a QA environment.  The port that is needed to send traffic from the web server to the database server is open.  Before firewall rule changes I always received this message now ...

ASP.NET Webservices: "The request failed with HTTP status 401: Access Denied." Error
You may receive the error "The request failed with HTTP status 401: Access Denied." when trying to access a Webservice from your ASP.NET Application.This normally indicates that Anonymous access has been disabled for the Webservice.Also, when you try to step into the webservice using the Visual Studio debugger, "Unable to automatically step into the server. The remote procedure could not be debugged. This usually indicates that debugging has not been enabled on the server. See help for more information"in this scenario.We can resolve this issue by either of the following ways:1. Enabling Ano...

Server Error: HTTP Error 500.19
I got the following error while trying to make a test WCF project on VistaServer Error HTTP Error 500.19 - Internal Server ErrorDescription: The requested page cannot be accessed because the related configuration data for the page is invalid. Error Code: 0x80070005 Notification: BeginRequest Module: IIS Web Core Requested URL: http://localhost:80/ProductsService/ProductsService.svc Physical Path: C:\Test\ProductsService\ProductsService\ProductsService.svc Logon User: Not yet determined Logon Method: Not yet determined Handler: Not yet determined Config Error: Cannot read configura...

Connecting to SQL Server,,,Error Server Does not exist or access denied
Hello please assist me I will appreciate it I have a problem in my scripting I gues,I "ve done the config and server registrations and allow a public permission ,but stil giving me trouble well this is my coding::::::: < <script language="vb" runat="server"> Dim MyConnection As SqlConnection Sub Page_Load(Sender As Object, E As EventArgs) MyConnection = New SqlConnection("server=(localHost);Database=CampusLANDB;Trusted_Connection=yes") If Not (IsPostBack) Dim DS As DataSet Dim MyCommand As SqlDataAdap...

CascadingDropDown random errors after uploading to server. access denied and method error 500
Hello there, I've started using c# and Ajax not too long ago and had fun playing with the toolkit. In my website I'm now using the CascadingDropDown to autocomplete the second drop down. The calls are done to a webservice on the same domain (not machine) When developing on my computer - website was working fine. I now uploaded everything to the server and it has been giving me problems. Problem 1: when calling the website from the server's machine,  the page that has the CascadingDropDown sometimes fetch the first drop down from the webservice fine and sometimes it giv...

Configuration Error (Parser Error Message: Access is denied: 'dll_Name'.)
Hi All Some times I get this ugly error: Parser Error Message: Access is denied: 'dll_Name'. === Pre-bind state information === LOG: DisplayName = dll_Name (Partial) LOG: Appbase = file:///C:/Inetpub/wwwroot/domainLOG: Initial PrivatePath = bin Calling assembly : (Unknown). === But the DLL is there! Who don't have access rights, the MACHINE/ASPNET? I get this error some times when I am using a 3th-party DLL. Some times just force me to restart the PC!, because is the only way I can reach again the web site in my IIS! Is there a way to fix this issue in the machine.con...

Web resources about - HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration. - novell.bordermanager.proxies

Resources last updated: 12/28/2015 2:03:18 AM