JSEXT version 1.0 is out! (server-side js)

If you haven't heard about jsext, it is one of 23 projects mentioned
on http://en.wikipedia.org/wiki/Server-side_JavaScript . What makes
this one stand out is the way it connects with underlying libraries
on
the host: Jsext automatically parses C header files and links to
dynamic libraries to provide direct access to them from JavaScript.
That simplifies module writing _a lot_. For example, the project
includes an SMTP client which supports attachments, international
characters in message and address, multiple recipients, cc, bcc (217
lines + 92 lines of documentation), an FTP client which supports
upload, download, directory listing and more (276 lines), an HTTP
client + server which supports authentication, connection pooling,
scripting, directory listing, caching, static pages, get and post
(2383 lines), a MySQL client (362 lines), an Sqlite client (345
lines), a fastCGI client (471 lines, but that also uses the CGI
handler, 198 lines, and parts of the HTTP server which I already
mentioned) and a SOAP/WSDL import/export module (749 lines). All in
all, 1.5 MB of code, *and that includes SpiderMonkey*. You'll find it
here: http://jsext.net. The current version only compiles on Linux
(and possibly BSD), and is available as a tarball and .deb package.
Previous versions have been Windows-compatible. Later versions are
likely to be Windows, Linux and OS X-compatible.

--


Svein Berge
0
sveinb
6/12/2008 8:58:56 AM
netscape.mozilla.jseng 1530 articles. 0 followers. Follow

0 Replies
108 Views

Similar Articles

[PageSpeed] 23

Reply:

Similar Artilces:

web matrix web server compiles in Microsoft .NET Framework Version:1.0.3705.288; ASP.NET Version:1.0.3705.288 even with version 1.1 installed
I have web matrix defaulting to use v1.1 but when it compiles it using Microsoft .NET Framework Version:1.0.3705.288; ASP.NET Version:1.0.3705.288, does anybody know why this is happening and how do i change it to use v1.1? thanks Hi, I suggest you to build a "WebServer.exe.config" file to match 1.1 NET. Yes, please take a look at this post: view post 249010 Regards,...

Install 1.0 and 1.1 side-by-side and use the 1.1 csc to compile a 1.0
Hi, I have the following (tricky) questions: 1. Can I install the 1.0 and 1.1 .NET Framework side-by-side with NO drawbacks on MY PC where I develop the .NET applications? (I do NOT use VS.NET) 2. After installing the 1.1 version, am I STILL ABLE to compile a 1.0 version, since our production web-server still runs on 1.0 (our development web-server was upgraded to 1.1) ?? thx Eau .... as long as you compile DLLs with the right csc.exe/vbc.exe from 1.0 or 1.1 Free ASP.NET Version Switcher may interest you.DNN skins ForumTressleworks modulesDNN & webhostingIEWCtrls...

superreview requested: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246921] 1.8.0 patch: SeaMonkey version -> 1.0.7
Robert Kaiser <kairo@kairo.at> has asked neil@parkwaycc.co.uk <neil@httl.net> for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246921: 1.8.0 patch: SeaMonkey version -> 1.0.7 https://bugzilla.mozilla.org/attachment.cgi?id=246921&action=edit ------- Additional Comments from Robert Kaiser <kairo@kairo.at> This is the 1.8.0 branch patch for bumping SeaMonkey version to 1.0.7 ...

superreview granted: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246921] 1.8.0 patch: SeaMonkey version -> 1.0.7
neil@parkwaycc.co.uk <neil@httl.net> has granted Robert Kaiser <kairo@kairo.at>'s request for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246921: 1.8.0 patch: SeaMonkey version -> 1.0.7 https://bugzilla.mozilla.org/attachment.cgi?id=246921&action=edit ...

Never experienced so many crashes as with version Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Name: Kåre Nilsen Email: kaanil3atyahoodotcom Product: Firefox Summary: Never experienced so many crashes as with version Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 Comments: Forefox which used to be so stable and a dream to use has become a nightmare to use for me! Unfortunately I downloaded and installed the above mentioned version, and I strongly regret it! It crashes daily! This version must be so full of bugs that it is very surprising that you folks even dared to release this version. I am definitely going back to ei...

superreview requested: [Bug 283181] installer version text needs to be upgraded from 1.0 to 1.0.1 : [Attachment 175188] Bump version in installers to 1.0.1/1.7.6
Chase Phillips <cmp@mozilla.org> has asked Ben Goodger <bugs@bengoodger.com> for superreview: Bug 283181: installer version text needs to be upgraded from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283181 Attachment 175188: Bump version in installers to 1.0.1/1.7.6 https://bugzilla.mozilla.org/attachment.cgi?id=175188&action=edit ...

superreview granted: [Bug 283181] installer version text needs to be upgraded from 1.0 to 1.0.1 : [Attachment 175188] Bump version in installers to 1.0.1/1.7.6
Ben Goodger <bugs@bengoodger.com> has granted Chase Phillips <cmp@mozilla.org>'s request for superreview: Bug 283181: installer version text needs to be upgraded from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283181 Attachment 175188: Bump version in installers to 1.0.1/1.7.6 https://bugzilla.mozilla.org/attachment.cgi?id=175188&action=edit ...

superreview requested: [Bug 283224] mail installer version text needs to be bumped from 1.0 to 1.0.1 : [Attachment 175211] Bump Tb Windows installer to version 1.0.1
Chase Phillips <cmp@mozilla.org> has asked Scott MacGregor <mscott@mozilla.org> for superreview: Bug 283224: mail installer version text needs to be bumped from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283224 Attachment 175211: Bump Tb Windows installer to version 1.0.1 https://bugzilla.mozilla.org/attachment.cgi?id=175211&action=edit ...

superreview granted: [Bug 283224] mail installer version text needs to be bumped from 1.0 to 1.0.1 : [Attachment 175211] Bump Tb Windows installer to version 1.0.1
Scott MacGregor <mscott@mozilla.org> has granted Chase Phillips <cmp@mozilla.org>'s request for superreview: Bug 283224: mail installer version text needs to be bumped from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283224 Attachment 175211: Bump Tb Windows installer to version 1.0.1 https://bugzilla.mozilla.org/attachment.cgi?id=175211&action=edit ------- Additional Comments from Scott MacGregor <mscott@mozilla.org> thanks chase ...

Running .net version 2.0 and 1.1 side by side
Hi there, I read a thread on this forum which suggested that it's possible to intall both versions 2.0 and 1.1 on the same server. Can someone please provide me more information on how this works. for example, how do you tell the application the use Version 1.1. instead of version 2? It seems to me that once you have version 2 installed it takes over version one and you can't go back but I'm sure I'm just inexperienced. One other thing, sometimes I need to compile C# classes to produce libraries (.dll). Right now in my command prompt I have access to the c# compiler for version 2. Surelly,...

superreview granted: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Brian Ryner <bryner@brianryner.com> has granted Chase Phillips <chase@mozilla.org>'s request for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

superreview requested: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Chase Phillips <chase@mozilla.org> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

superreview requested: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246922] 1.8 patch: SeaMonkey version -> 1.1, localeVe
Robert Kaiser <kairo@kairo.at> has asked neil@parkwaycc.co.uk <neil@httl.net> for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246922: 1.8 patch: SeaMonkey version -> 1.1, localeVersion -> 1.8.1 https://bugzilla.mozilla.org/attachment.cgi?id=246922&action=edit ------- Additional Comments from Robert Kaiser <kairo@kairo.at> ...and here's the 1.8 branch patch, setting SeaMonkey version to 1.1 for final, and locale...

superreview granted: [Bug 362139] bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch : [Attachment 246922] 1.8 patch: SeaMonkey version -> 1.1, localeVers
neil@parkwaycc.co.uk <neil@httl.net> has granted Robert Kaiser <kairo@kairo.at>'s request for superreview: Bug 362139: bump SeaMonkey versions to 1.0.7/1.1 on 1.8.0/1.8 branches, localeVersion to 1.8.1 on 1.8 branch https://bugzilla.mozilla.org/show_bug.cgi?id=362139 Attachment 246922: 1.8 patch: SeaMonkey version -> 1.1, localeVersion -> 1.8.1 https://bugzilla.mozilla.org/attachment.cgi?id=246922&action=edit ...

Web resources about - JSEXT version 1.0 is out! (server-side js) - netscape.mozilla.jseng

Resources last updated: 12/3/2015 5:38:48 AM