"Get Mail" vs "Get All New Messages"

I have a few different email accounts set up in Thunderbird, and I'm 
using the unified view to view them. Recently, I noticed that the "Get 
Mail" button seems to only retrieve email for the first account 
(sometimes?). I'd like to click on that button and retrieve email for 
all of the accounts.

I can get the behavior that I want consistently if I pull down the menu 
for "Get Mail" and select "Get All New Messages", but I'd prefer to get 
that in a single click if possible.

I tried starting from scratch and recreating my profile, but I still see 
the same problematic behavior. I'd appreciate any 
thoughts/suggestions/pointers on this.

Thanks,

	-Kartik
0
Kartik
7/12/2012 9:28:33 PM
mozilla.support.thunderbird 22506 articles. 5 followers. Post Follow

12 Replies
1367 Views

Similar Articles

[PageSpeed] 28

On 07/12/2012 05:28 PM, Kartik Subbarao wrote:
> I have a few different email accounts set up in Thunderbird, and I'm
> using the unified view to view them. Recently, I noticed that the "Get
> Mail" button seems to only retrieve email for the first account
> (sometimes?). I'd like to click on that button and retrieve email for
> all of the accounts.
>
> I can get the behavior that I want consistently if I pull down the menu
> for "Get Mail" and select "Get All New Messages", but I'd prefer to get
> that in a single click if possible.
>
> I tried starting from scratch and recreating my profile, but I still see
> the same problematic behavior. I'd appreciate any
> thoughts/suggestions/pointers on this.

Just to clarify one thing -- the context in which I'd like "Get Mail" to 
behave this way is when I have selected the Unified Inbox folder.

Thanks,

	-Kartik
0
Kartik
7/12/2012 9:30:02 PM
On 12-07-12 5:28 PM, Kartik Subbarao wrote:
> I have a few different email accounts set up in Thunderbird, and I'm
> using the unified view to view them. Recently, I noticed that the "Get
> Mail" button seems to only retrieve email for the first account
> (sometimes?). I'd like to click on that button and retrieve email for
> all of the accounts.
>
> I can get the behavior that I want consistently if I pull down the menu
> for "Get Mail" and select "Get All New Messages", but I'd prefer to get
> that in a single click if possible.
>
> I tried starting from scratch and recreating my profile, but I still see
> the same problematic behavior. I'd appreciate any
> thoughts/suggestions/pointers on this.

There are a couple of extensions that will add a toolbar button for that.

1. At the top of Thunderbird, open the Tools menu and select Add-ons. 
The Add-ons Manager will open.

2. Along the left side, select "Get Add-ons".

3. In the top-right, there should be a search field. Enter the text:
get all messages

4. Among the results, either "Get all mails" or "Get All Mail Button 
Thunderbird" should be what you want. Pick one, and click on the 
[Install] button that appears to the right of it.

5. Restart Thunderbird.

-- 
Chris Ilias <http://ilias.ca>
Mailing list/Newsgroup moderator
0
Chris
7/12/2012 11:24:46 PM
On 12/07/2012 22:28, Kartik Subbarao wrote:
> I have a few different email accounts set up in Thunderbird, and I'm
> using the unified view to view them. Recently, I noticed that the "Get
> Mail" button seems to only retrieve email for the first account
> (sometimes?). I'd like to click on that button and retrieve email for
> all of the accounts.
>
> I can get the behavior that I want consistently if I pull down the menu
> for "Get Mail" and select "Get All New Messages", but I'd prefer to get
> that in a single click if possible.
>
> I tried starting from scratch and recreating my profile, but I still see
> the same problematic behavior. I'd appreciate any
> thoughts/suggestions/pointers on this.
>
> Thanks,
>
>      -Kartik


You could configure your TB to get all messages at startup and then at a 
set interval.  Look at this picture to get an idea:

<http://tinyurl.com/7q6nja6>

The settings is under "Server Settings"

Good luck.


-- 
Good Guy
Website: http://mytaxsite.co.uk
Website: http://html-css.co.uk
Forums: http://mytaxsite.boardhost.com
Email: http://mytaxsite.co.uk/contact-us


0
Good
7/12/2012 11:52:58 PM
On Thu, 12 Jul 2012 17:28:33 -0400, Kartik Subbarao
<subbarao@computer.org> wrote:

> I'd like to click on that button and retrieve email for 
> all of the accounts.

I was annoyed that Thunderbird didn't set a flag when it was through
downloading messages, then realized that I need that information only
when I intend to shut down the program when download is complete.  So
I set the option to download messages whenever I click "go offline" --
offline *does* set a flag.  

This incidentally gave me a "download all messages for every account"
button, so I use it even when I don't care whether or not the job is
finished.

-- 
Joy Beeson
joy beeson at comcast dot net
0
Joy
7/13/2012 3:49:16 AM

On 12/07/2012 10:28 PM, Kartik Subbarao wrote:
> I have a few different email accounts set up in Thunderbird, and I'm 
> using the unified view to view them. Recently, I noticed that the "Get 
> Mail" button seems to only retrieve email for the first account 
> (sometimes?). I'd like to click on that button and retrieve email for 
> all of the accounts.
> 
> I can get the behavior that I want consistently if I pull down the menu 
> for "Get Mail" and select "Get All New Messages", but I'd prefer to get 
> that in a single click if possible.
> 
> I tried starting from scratch and recreating my profile, but I still see 
> the same problematic behavior. I'd appreciate any 
> thoughts/suggestions/pointers on this.
> 
> Thanks,
> 
> 	-Kartik
> 

Have you got "Include this server when getting new mail" ticked under
Account Settings> Server Settings > Advanced? You need to do it for
*every* account, then "get Mail" works as you want it - it does here,
anyway.


-- 
Bob
Tetbury, Gloucestershire, UK


Reality is an illusion brought on by alcohol deficiency.


0
Bob
7/13/2012 9:13:31 AM
On 07/12/2012 07:24 PM, Chris Ilias wrote:
> On 12-07-12 5:28 PM, Kartik Subbarao wrote:
>> I have a few different email accounts set up in Thunderbird, and I'm
>> using the unified view to view them. Recently, I noticed that the "Get
>> Mail" button seems to only retrieve email for the first account
>> (sometimes?). I'd like to click on that button and retrieve email for
>> all of the accounts.
[...]
> There are a couple of extensions that will add a toolbar button for that.
[...]
> 4. Among the results, either "Get all mails" or "Get All Mail Button
> Thunderbird" should be what you want.

Thanks Chris, will check these out!

Also FYI for others who are running into this issue -- I found this 
bugzilla thread which has active development to get this functionality 
enhanced in Thunderbird:

https://bugzilla.mozilla.org/show_bug.cgi?id=281417

Regards,

	-Kartik
0
Kartik
7/13/2012 1:25:20 PM
On 07/12/2012 11:49 PM, Joy Beeson wrote:
> On Thu, 12 Jul 2012 17:28:33 -0400, Kartik Subbarao
> <subbarao@computer.org> wrote:
>
>> I'd like to click on that button and retrieve email for
>> all of the accounts.
>
> I was annoyed that Thunderbird didn't set a flag when it was through
> downloading messages, then realized that I need that information only
> when I intend to shut down the program when download is complete.  So
> I set the option to download messages whenever I click "go offline" --
> offline *does* set a flag.
>
> This incidentally gave me a "download all messages for every account"
> button, so I use it even when I don't care whether or not the job is
> finished.

Interesting observation. Taking a quick look at one of the extensions 
that Chris referred to, I see that there's a function
GetMessagesForAllAuthenticatedAccounts() that does the work. My guess is 
that the underlying functionality is being invoked in the "go offline" 
case as well.

	-Kartik

0
Kartik
7/13/2012 1:36:16 PM
On 07/12/2012 07:52 PM, Good Guy wrote:
> You could configure your TB to get all messages at startup and then at a
> set interval.  Look at this picture to get an idea:

I appreciate the suggestion, but this is actually what I *don't* want to 
do :-) The reason I want to get "Get Mail" working reliably is because I 
want to be able to pull my email on-demand and not have it show up 
automatically. There's actually another problem I'm seeing related to 
this which I'll post about separately.

	-Kartik
0
Kartik
7/13/2012 1:40:55 PM
On 07/13/2012 05:13 AM, Bob Henson wrote:
> Have you got "Include this server when getting new mail" ticked under
> Account Settings> Server Settings > Advanced? You need to do it for
> *every* account, then "get Mail" works as you want it - it does here,
> anyway.

I think this option only shows up for POP-based accounts, not IMAP-based 
accounts. I don't see it in any of my IMAP accounts.

	-Kartik
0
Kartik
7/13/2012 1:41:42 PM
> On 07/13/2012 05:13 AM, Bob Henson wrote:
>> Have you got "Include this server when getting new mail" ticked under
>> Account Settings> Server Settings > Advanced? You need to do it for
>> *every* account, then "get Mail" works as you want it - it does here,
>> anyway.
> 
> I think this option only shows up for POP-based accounts, not IMAP-based 
> accounts. I don't see it in any of my IMAP accounts.
> 
> 	-Kartik
> 

IMAP has a push-like characteristic, which means it will update as and
when it becomes aware of unread messages.

You might wish to look at Tools|Accounts|<select account>|Server
Settings->Advanced and uncheck the IDLE option if you really prefer it
to "pull" messages only when you want.

Chris.
0
Chris
7/13/2012 2:33:30 PM
> 
> You might wish to look at Tools|Accounts|<select account>|Server
> Settings->Advanced and uncheck the IDLE option if you really prefer it
> to "pull" messages only when you want.
> 
> Chris.
> 

Ah, OK, I see you've done this already, in your other post.

0
Chris
7/13/2012 2:35:50 PM
Bob, thanks for posting the solution.  I've been having the same problem and couldn't figure it out.  Your reply enabled me to fix it. Need to include the server in the get email group. 

Thanks!!!

--tamas

On Friday, July 13, 2012 11:13:31 AM UTC+2, Bob Henson wrote:
> On 12/07/2012 10:28 PM, Kartik Subbarao wrote:
> 
> > I have a few different email accounts set up in Thunderbird, and I'm 
> 
> > using the unified view to view them. Recently, I noticed that the "Get 
> 
> > Mail" button seems to only retrieve email for the first account 
> 
> > (sometimes?). I'd like to click on that button and retrieve email for 
> 
> > all of the accounts.
> 
> > 
> 
> > I can get the behavior that I want consistently if I pull down the menu 
> 
> > for "Get Mail" and select "Get All New Messages", but I'd prefer to get 
> 
> > that in a single click if possible.
> 
> > 
> 
> > I tried starting from scratch and recreating my profile, but I still see 
> 
> > the same problematic behavior. I'd appreciate any 
> 
> > thoughts/suggestions/pointers on this.
> 
> > 
> 
> > Thanks,
> 
> > 
> 
> > 	-Kartik
> 
> > 
> 
> 
> 
> Have you got "Include this server when getting new mail" ticked under
> 
> Account Settings> Server Settings > Advanced? You need to do it for
> 
> *every* account, then "get Mail" works as you want it - it does here,
> 
> anyway.
> 
> 
> 
> 
> 
> -- 
> 
> Bob
> 
> Tetbury, Gloucestershire, UK
> 
> 
> 
> 
> 
> Reality is an illusion brought on by alcohol deficiency.

0
tamaskee
1/27/2014 4:33:00 PM
Reply:

Similar Artilces:

Get "Mail"/"Get "News" / "Write"/"Post" buttons?
If the "Get Mail" button text changed to "Get News", and "Write" changed to "Post" when TB's in the news-reading mode, it would save me and probably others from constantly forgetting to make the change before proceeding. :-) Or is there an extension to do this which I don't know about? Thanks! Bob Bob P wrote: > If the "Get Mail" button text changed to "Get News", and "Write" > changed to "Post" when TB's in the news-reading mode, it would save me > and probably others...

Precedence of "where" ("of", "is", "will")?
Nobody on #perl6 today could answer this one. Is: Str | Int where { $_ } the same as: (Str | Int) where { $_ } or: Str | (Int where { $_ }) ? Followup questions, Mr. President: What kind of operators are "where", "of", "is", and "will"? Is there a reason that S03 doesn't list them? What are their precedence(s)? -- Chip Salzenberg - a.k.a. - <chip@pobox.com> Open Source is not an excuse to write fun code then leave the actual work to others. Chip Salzenberg writes: &...

.ALLCOL("%COLUMN%", " ", ", ", ", ")
Do you know anyway for me to exclude a subset of columns returned by this function. We have two columns (rec_user and rec_datetime) which are in all of our tables, but when generating triggers I want automatically generate a script which does not include those two columns but does include all other columns in that table. Bruce I should add that I am using PD 9.0.0.580. Bruce "Bruce Lamb" <lamb.bruce@mayo.edu> wrote in message news:6HgI315nCHA.155@forums.sybase.com... > Do you know anyway for me to exclude a subset of columns returned by this > function. ...

"SSL" "Mail" and "Code"
Does anybody know of any discussions taking place within Mozilla regarding these 3 bits in the certificate manager? Perhaps I've missed something in the discussions here. In any case, I think a new mechanism for indicating trust w/in the Mozilla apps are needed. Take for example the "StartCom Certification Authority" root. The Certificate Manager (I'm using Firefox on Windows) says it can identify web sites, email users, and code yet the cert itself says it can only be used for signing other certs (essentially, that is). At a minimum this is confusing but I have...

Feature Request: "Get Extensions" and "Get Themes"
I think that when you click on the "Get Extensions" or "Get Themes" links, it should open depending on your default window-opening behavior. For example, all new windows for me open up in new tabs. However, when I click the "Get" links, they always open in new windows. I can't even find an extension to do this. How hard would this be to incorporate natively? ...

quotes, quotes, quotes...
I am getting this error and I know what is causing it, but I have no idea how to fix it, any help would be great. The script steps through the /var/log/messages file on a linux server and puts The entries into a mysql database. However when it gets to the 'hlt' line in the messages file it just barfs. The single quotes are freaking it out. I know about quotes but not how to use in this situation. Thanks, Paul Error: May 27 17:53:00 localhost kernel: Checking 'hlt' instruction... OK. <----- doesn't like this in the messages file DBD::mysql::st exec...

Script to perform a "Get latest", then a "Build", then a "Publish"
I frequently have to copy out of source safe, the latest version of some source code. Then perform a build and then a publish. The publish is published to a local directory where I then copy it out to a server. This is a bit of a hassle to have to do all of this mannualy. What I would prefer to do is to use some type of script that would do this. Does anyone know if this is possible? I can manage copying to the server. I just need a script that I could kick off to do the following. 1. Copy the latest source code for the project out of source safe. 2. Perform a build of the projec...

Which all pop3 accounts would "Get All New Messages" get messages from?
When I click on menu item "Get All New Messages", which all of my pop3 accounts would TB get messages from? Anything to do with settings in: - Check for messages at startup/ every x mins - Automatically download new messages? - Advanced - Include this server when getting new mails? It is surely not downloading messages from all 3-4 pop3 accounts that I have put in TB with different settings in above. Is there any command that would fetch all messages from all my pop3 accounts, irrespective of the settings in the above or any other field? I can run it one a day or...

"PopupExtender" vs "PopupControl" vs "PopupExtenderControl"
I am looking through the Toolkit source code and trying to understand it wrt the PopupExtenderControl.  In the project I see two folders: "PopupExtender" and "PopupControl".  These contains classes "PopupControlExtender" and "PopupExtender" and these both eventually derived from "AnimationExtenderControlBase".Do these two classes work in conjunction to implement the PopupExtender?  Or are they separate, autonomous extenders wth different purposes?  If so, which one corresponds to the PopupExtender on the sample page? ...

"Re:" and "Fwd:" are removed when a message gets filtered
Hello, I am using Thunderbird version 2.0.0.12 (20080213) on Windows XP with an IMAP server. I have a few message filters that move messages from inbox to other folders. When I click on the folder that messages have been moved to, in the message listing pane, I noticed that none of the subjects have the "Re:" or "Fwd:" prefixes for replied or forwarded messages. However, when I click on a message, in the message view pane, the "Re:" or "Fwd:" is present. Is this a bug in Thunderbird? Thanks. -- Regards, Nagaraj ...

"0E0 messages" vs "0 messages"
I just noticed one of the inormational messages in tkmail changed from "0 messages ..." to "0E0 messages" when running under 5.005_62+ - it is no big deal but looks odd. What has happened to stringifying things in _62 ? The modules and such should be the same as I was using in _60+ -- Nick Ing-Simmons On Tue, 19 Oct 1999 20:29:25 BST, Nick Ing-Simmons wrote: >I just noticed one of the inormational messages in tkmail >changed from "0 messages ..." to "0E0 messages" >when running under 5.005_62+ - it is no big deal but >...

"To" and "From" missing
When I print emails, the words "To" and "From" are blank, even though the "To" name and "From name (addresser, addressee) do show up. This is not a problem for other users on my system. Suggestions In mailbox right click, view. On the message window, right click and choose print options. Make sure print header is checked. -- Barry Merchant NSC Volunteer SysOp *** no email unless requested please!! *** > In mailbox right click, view. On the message window, right click and > choose print options. Make sure prin...

Replacing "\\" with "\"
Hi all I'm getting this value from a CheckBoxList control - a location of file, i have to remove "\\" and replace it with "\" and pass it to Query, how to do it, i tried with Replace, but coud'nt suceed. "\\\\Blaze10xp\\BLZ_SFS_07\\Sample Excel Files\\Excel Files\\report2.xls" thank's in advance - Prakash.C you tried Replace like this? string newstring = oldstring.Replace(@"\\",@"\");Plese, do not forget to click "Mark as Answer" on the post that helped you. Thanx!My blog: Scenes From A Developer Memory yes i tr...

"Using" or "With"
Hi all Please can someone enlighten to me as regards the difference with the "Using" and "With" statement when accessing data - which is better, what are the limitations and/or any pointers. Many thanks. Regards DaveDavid WinchesterPlease mark as answer if this is the solution.  using gives you the ability to use the connection and it closes the connection directlly after you finish using it. and there is no need to try- cach - finaly. there is no limitation on using USING keywordMuhanad YOUNISMCSD.NETMy Blog || My Photos || LinkedIn I have a dataobject the re...

Web resources about - "Get Mail" vs "Get All New Messages" - mozilla.support.thunderbird

Resources last updated: 1/1/2016 5:13:55 AM