Images not displaying on brickset.com

When I visit a URL like 
https://brickset.com/sets/79111-1/Constitution-Train-Chase I should see a 
picture of a train. If I visit using an alternative browser (Internet 
Explorer in this case) or with a fresh profile for testing, the image shows 
up. But on my primary SeaMonkey profile, I can't see the images.
I am using SeaMonkey 2.49.3 (the latest release version).

I have tested a restart in safe mode (on my primary profile) and the images 
are still gone (so that rules out adblock or any other add-ons being the cause)

Anyone know what could cause the images not to display? I have attempted to 
check the permissions by going to "preferences-privacy and security-images" 
and pressing "manage permissions" which displays a "data manager" window 
but that doesn't work (SM hangs for a bit then displays an error that 
dataman.js is too slow or something and stops running the script, the 
dialog does nothing after that)

Is there a way to see/edit any image related permissions that may be set 
without needing to use the "data manager"? Is there a way to get the "data 
manager" to work without crashing (and without me needing to delete any of 
my stored cookies or other stored data?)

0
Jonathan
5/30/2018 9:26:53 AM
mozilla.support.seamonkey 13205 articles. 0 followers. Post Follow

4 Replies
117 Views

Similar Articles

[PageSpeed] 27

Wed, 30 May 2018 19:26:53 +1000, _Jonathan Wilson_:

> When I visit a URL like 
> https://brickset.com/sets/79111-1/Constitution-Train-Chase I should see 
> a picture of a train. If I visit using an alternative browser (Internet 
> Explorer in this case) or with a fresh profile for testing, the image 
> shows up. But on my primary SeaMonkey profile, I can't see the images.
> I am using SeaMonkey 2.49.3 (the latest release version).
> 
> I have tested a restart in safe mode (on my primary profile) and the 
> images are still gone (so that rules out adblock or any other add-ons 
> being the cause)
> 
> Anyone know what could cause the images not to display?

Have you by any chance disabled JavaScript?


> I have attempted 
> to check the permissions by going to "preferences-privacy and 
> security-images" and pressing "manage permissions" which displays a 
> "data manager" window but that doesn't work (SM hangs for a bit then 
> displays an error that dataman.js is too slow or something and stops 
> running the script, the dialog does nothing after that)
> 
> Is there a way to see/edit any image related permissions that may be set 
> without needing to use the "data manager"? Is there a way to get the 
> "data manager" to work without crashing (and without me needing to 
> delete any of my stored cookies or other stored data?)
0
Stanimir
5/30/2018 12:40:25 PM
On 30/05/2018 11:26, Jonathan Wilson wrote:
> When I visit a URL like 
> https://brickset.com/sets/79111-1/Constitution-Train-Chase I should see a 
> picture of a train. If I visit using an alternative browser (Internet 
> Explorer in this case) or with a fresh profile for testing, the image shows 
> up. But on my primary SeaMonkey profile, I can't see the images.
> I am using SeaMonkey 2.49.3 (the latest release version).
> 
> I have tested a restart in safe mode (on my primary profile) and the images 
> are still gone (so that rules out adblock or any other add-ons being the cause)
> 
> Anyone know what could cause the images not to display? I have attempted to 
> check the permissions by going to "preferences-privacy and security-images" 
> and pressing "manage permissions" which displays a "data manager" window 
> but that doesn't work (SM hangs for a bit then displays an error that 
> dataman.js is too slow or something and stops running the script, the 
> dialog does nothing after that)
> 
> Is there a way to see/edit any image related permissions that may be set 
> without needing to use the "data manager"? Is there a way to get the "data 
> manager" to work without crashing (and without me needing to delete any of 
> my stored cookies or other stored data?)

Take a look at about:support
Especially "Important Modified Preferences" section.

Does anything suspicious stand out?

As Stanimir points out, image does not load if Javascript for the
page is disabled (either globally or through NoScript).

Regards.
0
Mason83
5/30/2018 7:41:19 PM
Wed, 30 May 2018 15:40:25 +0300, _Stanimir Stamenkov_:
> Wed, 30 May 2018 19:26:53 +1000, _Jonathan Wilson_:
> 
>> When I visit a URL like 
>> https://brickset.com/sets/79111-1/Constitution-Train-Chase I should 
>> see a picture of a train. If I visit using an alternative browser 
>> (Internet Explorer in this case) or with a fresh profile for testing, 
>> the image shows up. But on my primary SeaMonkey profile, I can't see 
>> the images.
>> I am using SeaMonkey 2.49.3 (the latest release version).
>>
>> I have tested a restart in safe mode (on my primary profile) and the 
>> images are still gone (so that rules out adblock or any other add-ons 
>> being the cause)
>>
>> Anyone know what could cause the images not to display?
> 
> Have you by any chance disabled JavaScript?

I guess I should have been more specific – look in the Preferences:

   Advanced / Scripts & Plugins:
     Enable JavaScript for:
       [x] Browser (make sure it's checked)

This one is not affected in safe mode, and could be triggered by other 
than the "Preferences" window means.


>> I have attempted to check the permissions by going to 
>> "preferences-privacy and security-images" and pressing "manage 
>> permissions" which displays a "data manager" window but that doesn't 
>> work (SM hangs for a bit then displays an error that dataman.js is too 
>> slow or something and stops running the script, the dialog does 
>> nothing after that)
>>
>> Is there a way to see/edit any image related permissions that may be 
>> set without needing to use the "data manager"? Is there a way to get 
>> the "data manager" to work without crashing (and without me needing to 
>> delete any of my stored cookies or other stored data?)
0
Stanimir
6/1/2018 8:10:48 AM
Wed, 30 May 2018 21:41:19 +0200, _Mason83_:
> On 30/05/2018 11:26, Jonathan Wilson wrote:
>
>> When I visit a URL like
>> https://brickset.com/sets/79111-1/Constitution-Train-Chase I should see a
>> picture of a train. If I visit using an alternative browser (Internet
>> Explorer in this case) or with a fresh profile for testing, the image shows
>> up. But on my primary SeaMonkey profile, I can't see the images.
>> I am using SeaMonkey 2.49.3 (the latest release version).
>>
>> I have tested a restart in safe mode (on my primary profile) and the images
>> are still gone (so that rules out adblock or any other add-ons being the cause)
>>
>> Anyone know what could cause the images not to display? I have attempted to
>> check the permissions by going to "preferences-privacy and security-images"
>> and pressing "manage permissions" which displays a "data manager" window
>> but that doesn't work (SM hangs for a bit then displays an error that
>> dataman.js is too slow or something and stops running the script, the
>> dialog does nothing after that)
>>
>> Is there a way to see/edit any image related permissions that may be set
>> without needing to use the "data manager"? Is there a way to get the "data
>> manager" to work without crashing (and without me needing to delete any of
>> my stored cookies or other stored data?)
> 
> Take a look at about:support
> Especially "Important Modified Preferences" section.
> 
> Does anything suspicious stand out?
> 
> As Stanimir points out, image does not load if Javascript for the
> page is disabled (either globally or through NoScript).

A particular thing to look for under "Important Modified Preferences" 
could be "javascript.enabled" (that's the global preference) with a 
value of "false".

-- 
Stanimir
0
Stanimir
6/1/2018 8:15:47 AM
Reply: