converse.js xmpp browser client doesno longer Work in SeaMonkey

Hi,

https://conversejs.org/fullscreen.html
no longer works for my
installed unofficial (by wg9s) De SeaMonkey 2.53.6 beta 1 pre 
Mozilla/5.0  (NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 
Build 20201115220004 (Normal User Profile and also with newly created 
User Profile, Default Classic Theme) on German WIN7 64bit

Only shows blue (or so) empty screen instead of white screen with login 
dialog.

Error console shows:

Zeitstempel: 07.01.2021, 18:42:58
Fehler: XML-Verarbeitungsfehler: Syntax-Fehler
Adresse: https://conversejs.org/fullscreen.html
Zeile Nr. 1, Spalte 1:
Quelldatei: https://conversejs.org/fullscreen.html
Zeile: 1, Spalte: 1
Quelltext:
invalid


Zeitstempel: 07.01.2021, 18:42:58
Fehler: ReferenceError: customElements is not defined
Quelldatei: https://conversejs.org/dist/converse.min.js
Zeile: 456

I can't tell whether related or not.

Of course I tried FF compatibity, older versions, ...
So seems not to be a SM regression, but incompatibility with SM and 
latest Page versions. Page worksfine with EDGE and Trox and probably 
most other browsers.

Similar problems with

Any Ideas how to get that working again?

CU

Rainer
0
Rainer
1/7/2021 5:59:44 PM
mozilla.support.seamonkey 13722 articles. 0 followers. Post Follow

2 Replies
13 Views

Similar Articles

[PageSpeed] 12

On 1/7/2021 9:59 AM, Rainer Bielefeld wrote:
> Hi,
> 
> https://conversejs.org/fullscreen.html
> no longer works for my
> installed unofficial (by wg9s) De SeaMonkey 2.53.6 beta 1 pre 
> Mozilla/5.0  (NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 
> Build 20201115220004 (Normal User Profile and also with newly created 
> User Profile, Default Classic Theme) on German WIN7 64bit
> 
> Only shows blue (or so) empty screen instead of white screen with login 
> dialog.
> 
> Error console shows:
> 
> Zeitstempel: 07.01.2021, 18:42:58
> Fehler: XML-Verarbeitungsfehler: Syntax-Fehler
> Adresse: https://conversejs.org/fullscreen.html
> Zeile Nr. 1, Spalte 1:
> Quelldatei: https://conversejs.org/fullscreen.html
> Zeile: 1, Spalte: 1
> Quelltext:
> invalid
> 
> 
> Zeitstempel: 07.01.2021, 18:42:58
> Fehler: ReferenceError: customElements is not defined
> Quelldatei: https://conversejs.org/dist/converse.min.js
> Zeile: 456
> 
> I can't tell whether related or not.
> 
> Of course I tried FF compatibity, older versions, ...
> So seems not to be a SM regression, but incompatibility with SM and 
> latest Page versions. Page worksfine with EDGE and Trox and probably 
> most other browsers.
> 
> Similar problems with
> 
> Any Ideas how to get that working again?
> 
> CU
> 
> Rainer
> 

I had a similar problem with the Web site of Unify Financial Credit
Union, only the screen was pale lavender.  They told me I should switch
my browser to Chrome.  Instead, I am switching credit unions.

-- 
David E. Ross
<http://www.rossde.com/>

I just do not understand why so many people think
a sore loser makes a great President.
0
David
1/8/2021 12:11:36 AM
On 07/01/2021 17:59, Rainer Bielefeld wrote:
> 
> https://conversejs.org/fullscreen.html
> no longer works for my
> installed unofficial (by wg9s) De SeaMonkey 2.53.6 beta 1 pre 
> Mozilla/5.0  (NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 
> Build 20201115220004 (Normal User Profile and also with newly created 
> User Profile, Default Classic Theme) on German WIN7 64bit
> 
> Only shows blue (or so) empty screen instead of white screen with login 
> dialog.
> 
> Error console shows:
> 
> Zeitstempel: 07.01.2021, 18:42:58
> Fehler: XML-Verarbeitungsfehler: Syntax-Fehler
> Adresse: https://conversejs.org/fullscreen.html
> Zeile Nr. 1, Spalte 1:
> Quelldatei: https://conversejs.org/fullscreen.html
> Zeile: 1, Spalte: 1
> Quelltext:
> invalid
> 
> 
> Zeitstempel: 07.01.2021, 18:42:58
> Fehler: ReferenceError: customElements is not defined
> Quelldatei: https://conversejs.org/dist/converse.min.js
> Zeile: 456
> 
> I can't tell whether related or not.
> ...

Definitely. With a Custom Elements polyfill, the page appears as you 
expect. I guess that not having Custom Elements could cause the XML 
syntax error too. As discussed previously for github.com:

Subject: Re: SeaMonkey and Github
Date: Fri, 27 Nov 2020 20:05:45 +0000

/df

-- 
London
UK
0
Dirk
1/8/2021 1:06:57 AM
Reply: