Compiling Seamonkey 2.49.5

In looking at the configure files for the source of Seamonkey 2.49.5, I 
see it needs python 2.7. The file bootstrap.py says, "Bootstrap 
currently only runs on Python 2.7 or Python 2.6."

Is is possible to compile with Python 2.4, even if it is a convoluted 
process?

Thanks,


Craig
0
Craig
12/18/2019 1:41:10 AM
mozilla.support.seamonkey 13515 articles. 0 followers. Post Follow

4 Replies
62 Views

Similar Articles

[PageSpeed] 7

Craig McCluskey wrote:
> In looking at the configure files for the source of Seamonkey 2.49.5, I see it 
> needs python 2.7. The file bootstrap.py says, "Bootstrap currently only runs 
> on Python 2.7 or Python 2.6."
> 
> Is is possible to compile with Python 2.4, even if it is a convoluted process?
> 
> Thanks,
> 
> 
> Craig

If you have only 2.4 chance is that everything else is downlevel too. Which OS?

FRG
0
Frank
12/18/2019 3:18:32 AM
Frank-Rainer Grahl wrote:
> Craig McCluskey wrote:
>> In looking at the configure files for the source of Seamonkey 2.49.5,
>> I see it needs python 2.7. The file bootstrap.py says, "Bootstrap
>> currently only runs on Python 2.7 or Python 2.6."
>>
>> Is is possible to compile with Python 2.4, even if it is a convoluted
>> process?
>>
>> Thanks,
>>
>>
>> Craig
>
> If you have only 2.4 chance is that everything else is downlevel too.
> Which OS?
>
> FRG

CentOS 5.11


Craig
0
Craig
12/18/2019 3:04:06 PM
Craig McCluskey wrote:
> Frank-Rainer Grahl wrote:
>> Craig McCluskey wrote:
>>> In looking at the configure files for the source of Seamonkey 2.49.5,
>>> I see it needs python 2.7. The file bootstrap.py says, "Bootstrap
>>> currently only runs on Python 2.7 or Python 2.6."
>>>
>>> Is is possible to compile with Python 2.4, even if it is a convoluted
>>> process?
>>>
>>> Thanks,
>>>
>>>
>>> Craig
>>
>> If you have only 2.4 chance is that everything else is downlevel too.
>> Which OS?
>>
>> FRG
> 
> CentOS 5.11
> 
> 
> Craig

Sorry forget it. 6 might work with some plumbing. Official builders did run it 
till decommisioned. Official 2.49.5 was done under 7.

FRG
0
Frank
12/18/2019 5:41:20 PM
Frank-Rainer Grahl wrote:
> Craig McCluskey wrote:
>> Frank-Rainer Grahl wrote:
>>> Craig McCluskey wrote:
>>>> In looking at the configure files for the source of Seamonkey 2.49.5,
>>>> I see it needs python 2.7. The file bootstrap.py says, "Bootstrap
>>>> currently only runs on Python 2.7 or Python 2.6."
>>>>
>>>> Is is possible to compile with Python 2.4, even if it is a convoluted
>>>> process?
>>>
>>> If you have only 2.4 chance is that everything else is downlevel too.
>>> Which OS?
>>
>> CentOS 5.11
>
> Sorry forget it. 6 might work with some plumbing. Official builders did
> run it till decommisioned. Official 2.49.5 was done under 7.

That's too bad. I want to keep Gnome 2. I despise Gnome 3, but my wife, 
who is not computer literate and who has memory problems needs to have
the same UI.

I thought compiling a version of Seamonkey with TLS 2 would be easier 
than compiling all of Gnome 2.


Craig

0
Craig
12/20/2019 7:38:56 PM
Reply: