No more nightly builds since 21/3, 6.4a1 unavailable

Have nightly builds been put on hold? The latest version advertised on the =
compatibility page is 6.4a1[1], but the latest nightly available is 6.3a1 f=
rom 21/3 which for me fails to install in 62.0a1 ("This add-on could not be=
 installed because it appears corrupt.").

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Vers=
ions
0
Florian
6/14/2018 6:24:04 PM
mozilla.support.calendar 2584 articles. 0 followers. Post Follow

2 Replies
19 Views

Similar Articles

[PageSpeed] 57

On 6/14/18 2:24 PM, Florian D. wrote:
> Have nightly builds been put on hold? The latest version advertised on the compatibility page is 6.4a1[1], but the latest nightly available is 6.3a1 from 21/3 which for me fails to install in 62.0a1 ("This add-on could not be installed because it appears corrupt.").
> 
> [1] https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions
> 


My understanding is that it is failing tests and can't be built.

<https://bugzilla.mozilla.org/show_bug.cgi?id=1457087>

-- 
CPU: 3.2 Ghz AMD Athlon(tm) II X3 455 Processor
RAM: 8 GiB
Graphics: GeForce GT 630/PCIe/SSE2
OS: Ubuntu Linux 16.04LTS - Unity Desktop
0
WaltS48
6/14/2018 8:18:09 PM
Florian D. wrote:
> Have nightly builds been put on hold? The latest version advertised on the compatibility page is 6.4a1[1], but the latest nightly available is 6.3a1 from 21/3 which for me fails to install in 62.0a1 ("This add-on could not be installed because it appears corrupt.").
> 
> [1] https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions

Lightning extension is always included in Thunderbird and therefore the 
standalone xpi can no longer being created. As far as I know this was 
required due to changes in the build system.

In addition the Firefox developers removed support for non-restartless 
extensions like Lightning from the Mozilla platform. If you use a 
current Thunderbird 62.0a1 build and open the developer console you will 
see a message that <Lightning UID> cannot be installed because of this 
fact.

Thunderbird 60 is the last release where Lightning is currently working. 
I assume Lightning is dead unless it will be rewritten as a bootstrapped 
(restartless) extension. See Bug 1449487.

/Stefan
0
Stefan
6/15/2018 5:40:33 PM
Reply: