lightning incompatible with default thunderbird version of ubuntu 16.04.2

Hello I tryed to install lightning on a fresh install of ubuntu but it does=
n't work with the default thunderbird version of ubuntu 16.04.2 : thunderbi=
rd 45.7.0

"Le composant binaire n=C3=A9cessaire pour Lightning ne peut pas =C3=AAtre =
charg=C3=A9, probablement en raison d'une mauvaise combinaison de versions.=
 Lightning 4.7.4 est install=C3=A9, mais vous devriez utiliser une version =
de la s=C3=A9rie 4.7."

I tried to install olders versions of the addon without succes

how to solve this please?
0
cddoutriaux
3/20/2017 7:49:42 AM
mozilla.support.calendar 2534 articles. 0 followers. Post Follow

3 Replies
87 Views

Similar Articles

[PageSpeed] 54

On 03/20/2017 08:49 AM, cddoutriaux@gmail.com wrote:
> Hello I tryed to install lightning on a fresh install of ubuntu but it doesn't work with the default thunderbird version of ubuntu 16.04.2 : thunderbird 45.7.0

First of all, Lightning ships with Thunderbird by default. So there
shouldn't be any need to separately install Lightning in the first place.
https://support.mozilla.org/kb/thunderbird-calendar-integration

Whether this also applies for the Ubuntu provided version of Thunderbird
I don't know.

In general, never mix up the vanilla versions of Thunderbird and
Lightning from Mozilla with those provided by your distribution.

> "Le composant binaire nécessaire pour Lightning ne peut pas être
> chargé, probablement en raison d'une mauvaise combinaison de versions.
> Lightning 4.7.4 est installé, mais vous devriez utiliser une version
> de la série 4.7."

Lightning contains binary components, so you cannot use one profile for
both, Linux and Windows.

> I tried to install olders versions of the addon without succes

There is always a dependency on versions. Only use the Lightning version
in connection with the corresponding version of Thunderbird.

There is no point trying arbitrary combinations.

https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/
0
Christian
4/1/2017 2:31:07 PM
On 3/20/17 3:49 AM, cddoutriaux@gmail.com wrote:
> Hello I tryed to install lightning on a fresh install of ubuntu but it doesn't work with the default thunderbird version of ubuntu 16.04.2 : thunderbird 45.7.0
>
> "Le composant binaire nécessaire pour Lightning ne peut pas être chargé, probablement en raison d'une mauvaise combinaison de versions. Lightning 4.7.4 est installé, mais vous devriez utiliser une version de la série 4.7."
>
> I tried to install olders versions of the addon without succes
>
> how to solve this please?


Install xul-ext-lightning from Ubuntu.

Run sudo apt-get install xul-ext-lightning in a terminal window.

-- 
Go Gonzaga!
Coexist <https://www.coexist.org/>
National Popular Vote <http://www.nationalpopularvote.com/>
Ubuntu 16.04LTS

0
WaltS48
4/1/2017 3:12:50 PM
On Monday, March 20, 2017 at 10:34:22 AM UTC-5, C=C3=A9dric Doutriaux wrote=
:
> Hello I tryed to install lightning on a fresh install of ubuntu but it do=
esn't work with the default thunderbird version of ubuntu 16.04.2 : thunder=
bird 45.7.0
>=20
> "Le composant binaire n=C3=A9cessaire pour Lightning ne peut pas =C3=AAtr=
e charg=C3=A9, probablement en raison d'une mauvaise combinaison de version=
s. Lightning 4.7.4 est install=C3=A9, mais vous devriez utiliser une versio=
n de la s=C3=A9rie 4.7."
>=20
> I tried to install olders versions of the addon without succes
>=20
> how to solve this please?

it also broke in thunderbird 52, which was just released today. um, help?
0
bb4034
4/6/2017 2:25:58 AM
Reply: