FreeBSD freebsd 11.1-RELEASE-p4 : Lightning could not be installed because it is not compatible with SeaMonkey 2.49.1

Installing Lightning failed with message on FreeBSD 11.1-RELEASE-p4: 

Lightning could not be installed because it is not compatible with SeaMonkey 2.49.1.

The latest version of SeaMonkey is installed.
Name           : seamonkey
Version        : 2.49.1_7


Other Add-ons like LightBird and Provider for Google Calender could be installed but will not work without lightning.



0
stefan
1/6/2018 11:13:31 AM
mozilla.support.calendar 2586 articles. 0 followers. Post Follow

2 Replies
94 Views

Similar Articles

[PageSpeed] 18

On 1/6/18 6:13 AM, stefan.everhartz.x11max@gmail.com wrote:
> Installing Lightning failed with message on FreeBSD 11.1-RELEASE-p4:
>
> Lightning could not be installed because it is not compatible with SeaMonkey 2.49.1.
>
> The latest version of SeaMonkey is installed.
> Name           : seamonkey
> Version        : 2.49.1_7
>
>
> Other Add-ons like LightBird and Provider for Google Calender could be installed but will not work without lightning.
>
>
>

What version of Lightning did you try to install?

SM use version 5.4.

https://www.mozilla.org/en-US/projects/calendar/

0
WaltS48
1/6/2018 8:40:52 PM
Am Samstag, 6. Januar 2018 21:41:29 UTC+1 schrieb WaltS48:
> On 1/6/18 6:13 AM, stefan.everhartz.x11max@gmail.com wrote:
> > Installing Lightning failed with message on FreeBSD 11.1-RELEASE-p4:
> >
> > Lightning could not be installed because it is not compatible with SeaMonkey 2.49.1.
> >
> > The latest version of SeaMonkey is installed.
> > Name           : seamonkey
> > Version        : 2.49.1_7
> >
> >
> > Other Add-ons like LightBird and Provider for Google Calender could be installed but will not work without lightning.
> >
> >
> >
> 
> What version of Lightning did you try to install?
> 
> SM use version 5.4.
> 
> https://www.mozilla.org/en-US/projects/calendar/

I got it working by changing the install.rdf file.

  unzip xpi file : lightning-5.4-sm+tb-linux.xpi
  edit install.rdf

 removed --  <em:targetPlatform>Linux_x86-gcc3</em:targetPlatform>
 removed --  <em:targetPlatform>Linux_x86_64-gcc3</em:targetPlatform>
 changed ++ <em:strictCompatibility>false</em:strictCompatibility>

 zip files to lightning-5.4-sm+tb-linux.xpi
 install add-ons

works.
0
stefan
1/8/2018 9:00:59 AM
Reply: