resources issue

I have installed bugzilla 5.0.4 while i am browsing it doesn't displaying in css style.
i have also tested ./testserver.pl it giving error :
TEST-OK Webserver is running under group id in $webservergroup.
TEST-OK Got padlock picture.
TEST-FAILED Webserver is not executing CGI files.
TEST-FAILED Webserver is permitting fetch of http://172.16.1.45/cgi-bin/index.cgi/localconfig.
This is a serious security problem.
Check your web server configuration.

and http.conf configuration file is:

<Directory /var/www/cgi-bin/>
  AddHandler cgi-script .cgi .pl
  Options +Indexes +ExecCGI +FollowSymLinks
  DirectoryIndex index.cgi
  AllowOverride all
  Order allow,deny
  Allow From all
</Directory>


and in browser if i press ctrl+shift+i
Failed to load resource: the server responded with a status of 500 (Internal Server Error)
1b4e898422a669ab82b604a2c23edce5.js Failed to load resource: the server responded with a status of 500 (Internal Server Error)
(index):17 Uncaught ReferenceError: YAHOO is not defined
    at (index):17
d41d8cd98f00b204e9800998ecf8427e.js Failed to load resource: the server responded with a status of 500 (Internal Server Error)
(index):1 This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.
/cgi-bin/images/favicon.ico Failed to load resource: the server responded with a status of 500 (Internal Server Error)
2f5735cf3abd04bddc8e363a8613a9f5.css Failed to load resource: the server responded with a status of 500 (Internal Server Error)

what should i do to run bugzilla in proper manner?

Thanks & Regards

Yeldi Shravanakumar Ganesh 
0
shravana
4/28/2018 6:40:32 AM
mozilla.support.bugzilla 10094 articles. 0 followers. Post Follow

4 Replies
127 Views

Similar Articles

[PageSpeed] 18

Guten Tag shravana yeldi,
am Samstag, 28. April 2018 um 08:40 schrieben Sie:

> what should i do to run bugzilla in proper manner?

Follow the installation instructions, you are not, which can easily be
seen by the fact that you are doing stuff in "cgi-bin". Bugzilla
doesn't support that and there's no part in the docs whcih tell you to
do so.

So start from scratch, do exactly what the docs say, use exactly the
same paths and come back if you run into troubles this time. You
shouldn't of course, because the docs worked for a lot of people
already.

https://bugzilla.readthedocs.io/en/5.0/installing/index.html

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
4/28/2018 12:15:47 PM
Guten Tag shravana yeldi,
am Samstag, 28. April 2018 um 08:40 schrieben Sie:

> what should i do to run bugzilla in proper manner?

Follow the installation instructions, you are not, which can easily be
seen by the fact that you are doing stuff in "cgi-bin". Bugzilla
doesn't support that and there's no part in the docs whcih tell you to
do so.

So start from scratch, do exactly what the docs say, use exactly the
same paths and come back if you run into troubles this time. You
shouldn't of course, because the docs worked for a lot of people
already.

https://bugzilla.readthedocs.io/en/5.0/installing/index.html

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
4/28/2018 2:14:45 PM
On Saturday, 28 April 2018 12:10:34 UTC+5:30, shravana yeldi  wrote:
> I have installed bugzilla 5.0.4 while i am browsing it doesn't displaying in css style.
> i have also tested ./testserver.pl it giving error :
> TEST-OK Webserver is running under group id in $webservergroup.
> TEST-OK Got padlock picture.
> TEST-FAILED Webserver is not executing CGI files.
> TEST-FAILED Webserver is permitting fetch of http://172.16.1.45/cgi-bin/index.cgi/localconfig.
> This is a serious security problem.
> Check your web server configuration.
> 
> and http.conf configuration file is:
> 
> <Directory /var/www/cgi-bin/>
>   AddHandler cgi-script .cgi .pl
>   Options +Indexes +ExecCGI +FollowSymLinks
>   DirectoryIndex index.cgi
>   AllowOverride all
>   Order allow,deny
>   Allow From all
> </Directory>
> 
> 
> and in browser if i press ctrl+shift+i
> Failed to load resource: the server responded with a status of 500 (Internal Server Error)
> 1b4e898422a669ab82b604a2c23edce5.js Failed to load resource: the server responded with a status of 500 (Internal Server Error)
> (index):17 Uncaught ReferenceError: YAHOO is not defined
>     at (index):17
> d41d8cd98f00b204e9800998ecf8427e.js Failed to load resource: the server responded with a status of 500 (Internal Server Error)
> (index):1 This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.
> /cgi-bin/images/favicon.ico Failed to load resource: the server responded with a status of 500 (Internal Server Error)
> 2f5735cf3abd04bddc8e363a8613a9f5.css Failed to load resource: the server responded with a status of 500 (Internal Server Error)
> 
> what should i do to run bugzilla in proper manner?
> 
> Thanks & Regards
> 
> Yeldi Shravanakumar Ganesh

The same i shifted to /var/www/html/bugzilla/

<Directory /var/www/html/bugzilla/>
  AddHandler cgi-script .cgi .pl
  Options +Indexes +ExecCGI +FollowSymLinks
  DirectoryIndex index.cgi
  AllowOverride all
  order allow,deny
  allow From all
</Directory>


same error continues.....
0
shravana
4/30/2018 6:24:33 AM
Guten Tag shravana yeldi,
am Montag, 30. April 2018 um 08:24 schrieben Sie:

> The same i shifted to /var/www/html/bugzilla/

You did not start from scratch as I suggested, but instead only
changed some paths. And do you know why I can see that? Because of the
following line, which is NOT in the docs and doesn't make sense for
Bugzilla the way it is, because Bugzilla doesn't use files with the
extension ".pl" to be executed by the web server.

>   AddHandler cgi-script .cgi .pl

vs.

> AddHandler cgi-script .cgi

https://bugzilla.readthedocs.io/en/5.0/installing/apache.html#apache-with-m=
od-cgi

So the problem with your setup now is because you were NOT following
the docs in the first place and as advised afterwards, arbitrary things
can be broken now. Therefore I suggested to start from scratch, because
either it solves all of your problems right from the start or makes
spotting errors far easier if you have a setup which is documented and
comparable to that of others.

So, I advice again, start from scratch by following the docs and if
you then run into problems provide the errors you get, including web
server logs etc.

https://bugzilla.readthedocs.io/en/5.0/installing/index.html

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
4/30/2018 7:46:24 AM
Reply: