Perl Mysql - install_driver(mysql) failed: Can't load mysql.dll

Hi all,

I am installing Bugzilla3 on a windowsXP box together with Mysql5.0.45 
and ActivePerl-5.8.8.820. It passed the checksetup and created the 
database. However, when I point my Firefox to http://localhost/ I got 
the following error:

install_driver(mysql) failed: Can't load 
'C:/Perl/site/lib/auto/DBD/mysql/mysql.dll' for module DBD::mysql: 
load_file:The specified module could not be found at 
C:/Perl/lib/DynaLoader.pm line 230.
  at (eval 34) line 3
Compilation failed in require at (eval 34) line 3.
Perhaps a required shared library or dll isn't installed where expected
  at Bugzilla/DB.pm line 902

Googled it and tried to uninstall DBI and DBD-mysql package, problem 
didn't go away... any hint?

Cheers,
Henry
0
HS
7/19/2007 12:18:47 AM
mozilla.support.bugzilla 10104 articles. 0 followers. Post Follow

6 Replies
1534 Views

Similar Articles

[PageSpeed] 19

On Thu, 19 Jul 2007 10:18:47 +1000 HS <henrysun99999@hotmail.com> wrote:
> Googled it and tried to uninstall DBI and DBD-mysql package, problem 
> didn't go away... any hint?

	I think the DBD-mysql from Theory58S is broken. Do:

	ppm repo off theory58S

	And then remove and re-install DBD-mysql.

	-Max
-- 
http://www.everythingsolved.com/
Competent, Friendly Bugzilla Services. And Everything Else, too.
0
Max
7/19/2007 1:35:48 AM
Just installed the old 3.0002 version and it worked! Thanks Max~ Who 
would think of that is causing a problem...

Max Kanat-Alexander wrote:
> On Thu, 19 Jul 2007 10:18:47 +1000 HS <henrysun99999@hotmail.com> wrote:
>> Googled it and tried to uninstall DBI and DBD-mysql package, problem 
>> didn't go away... any hint?
> 
> 	I think the DBD-mysql from Theory58S is broken. Do:
> 
> 	ppm repo off theory58S
> 
> 	And then remove and re-install DBD-mysql.
> 
> 	-Max
0
HS
7/19/2007 2:06:48 AM
On Jul 19, 6:35 am, Max Kanat-Alexander <mka...@bugzilla.org> wrote:
> On Thu, 19 Jul 2007 10:18:47 +1000 HS <henrysun99...@hotmail.com> wrote:
>
> > Googled it and tried to uninstall DBI and DBD-mysql package, problem
> > didn't go away... any hint?
>
>         I think the DBD-mysql from Theory58S is broken. Do:
>
>         ppm repo off theory58S
>
>         And then remove and re-install DBD-mysql.
>
>         -Max
> --http://www.everythingsolved.com/
> Competent, Friendly Bugzilla Services. And Everything Else, too.

Hi,

i have tried, ppm repo up theory58S not properly installed on my pc
but i have installed ppm repo add theory58S http://theoryx5.uwinnipeg.ca/ppms
on my pc properly still i am geting the same problem.

C:\>ppm repo up theory58S
The repo command 'up' isn't recognized; try one of add, delete,
describe,
  list, location, off, on, rename, search, suggest, or sync
Usage:  ppm repo <cmd> <args>
        Run 'ppm help repo' to learn more.

C:\>ppm repo off theory58S
ppm repo failed: No such repo; 'ppm repo list' will print what's
available

Thanks
Shadab Hasan
S/W Eng.
shasan@zansys.com

0
shasan
7/30/2007 3:32:03 PM
On Jul 19, 7:06 am, HS <henrysun99...@hotmail.com> wrote:
> Just installed the old 3.0002 version and it worked! Thanks Max~ Who
> would think of that is causing a problem...
>
>
>
> Max Kanat-Alexander wrote:
> > On Thu, 19 Jul 2007 10:18:47 +1000 HS <henrysun99...@hotmail.com> wrote:
> >> Googled it and tried to uninstall DBI and DBD-mysql package, problem
> >> didn't go away... any hint?
>
> >    I think the DBD-mysql from Theory58S is broken. Do:
>
> >    ppm repo off theory58S
>
> >    And then remove and re-install DBD-mysql.
>
> >    -Max- Hide quoted text -
>
> - Show quoted text -

Hi,

i have tried, ppm repo up theory58S not properly installed on my pc
but i have installed ppm repo add theory58S http://theoryx5.uwinnipeg.ca/ppms
on my pc properly still i am geting the same problem.

C:\>ppm repo up theory58S
The repo command 'up' isn't recognized; try one of add, delete,
describe,
  list, location, off, on, rename, search, suggest, or sync
Usage:  ppm repo <cmd> <args>
        Run 'ppm help repo' to learn more.

C:\>ppm repo off theory58S
ppm repo failed: No such repo; 'ppm repo list' will print what's
available

Thanks
Shadab Hasan
S/W Eng.
shasan@zansys.com

0
shasan
7/30/2007 3:32:16 PM
On Jul 19, 5:18 am, HS <henrysun99...@hotmail.com> wrote:
> Hi all,
>
> I am installing Bugzilla3 on a windowsXP box together with Mysql5.0.45
> and ActivePerl-5.8.8.820. It passed the checksetup and created the
> database. However, when I point my Firefox tohttp://localhost/I got
> the following error:
>
> install_driver(mysql) failed: Can't load
> 'C:/Perl/site/lib/auto/DBD/mysql/mysql.dll' for module DBD::mysql:
> load_file:The specified module could not be found at
> C:/Perl/lib/DynaLoader.pm line 230.
>   at (eval 34) line 3
> Compilation failed in require at (eval 34) line 3.
> Perhaps a required shared library or dll isn't installed where expected
>   at Bugzilla/DB.pm line 902
>
> Googled it and tried to uninstall DBI and DBD-mysql package, problem
> didn't go away... any hint?
>
> Cheers,
> Henry

Hi,

i have tried, ppm repo up theory58S not properly installed on my pc
but i have installed ppm repo add theory58S http://theoryx5.uwinnipeg.ca/ppms
on my pc properly still i am geting the same problem.

C:\>ppm repo up theory58S
The repo command 'up' isn't recognized; try one of add, delete,
describe,
  list, location, off, on, rename, search, suggest, or sync
Usage:  ppm repo <cmd> <args>
        Run 'ppm help repo' to learn more.

C:\>ppm repo off theory58S
ppm repo failed: No such repo; 'ppm repo list' will print what's
available

Thanks
Shadab Hasan
S/W Eng.
shasan@zansys.com

0
shasan
7/30/2007 3:32:27 PM
Hallo shasan mca,
Monday, July 30, 2007, 5:32:16 PM, haben Sie folgendes geschrieben:

C:\>>ppm repo up theory58S
> The repo command 'up' isn't recognized; try one of add, delete,
> describe,
>   list, location, off, on, rename, search, suggest, or sync
> Usage:  ppm repo <cmd> <args>
>         Run 'ppm help repo' to learn more.

There is no "up"-command anymorte in the most recent versions aof
Activstate Perl for Windows.

C:\>>ppm repo off theory58S
> ppm repo failed: No such repo; 'ppm repo list' will print what's
> available

What does ppm repo list show you?

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning
AM-SoFT IT-Systeme - Hameln | Potsdam | Leipzig
=20
Telefon: Potsdam: 0331-743881-0
E-Mail:  tschoening@am-soft.de
Web:     http://www.am-soft.de

AM-SoFT Potsdam GmbH, Konsumhof 1-5, 14482 Potsdam
Amtsgericht Potsdam HRB 12480, Gesch=E4ftsf=FChrer Andreas Muchow

0
windows
7/30/2007 3:52:59 PM
Reply:

Web resources about - Perl Mysql - install_driver(mysql) failed: Can't load mysql.dll - mozilla.support.bugzilla

MIUI ROM is now available for the Kindle Fire – video
There’s a new version of Android available for Amazon Kindle Fire users that aren’t afraid of rolling up their sleeves and hacking the tablet. ...

Virtualbox lubuntu ccsv6 - Texas Instruments Wiki
This page details how to create a virtualbox image running Lubuntu, on which CCSv6 is installed.In this example I'm configuring for MSP430, using ...

How to root a Kindle Fire with Software Version 6.3.1
Amazon released a minor software update for the Kindle Fire this week. It gives users a little more control over some security settings by letting ...

How to install Android 4.1 Jelly Bean on the Kindle Fire
The Amazon Kindle Fire ships with a custom version of Android 2.3 Gingerbread designed to run apps and access digital media from Amazon’s content ...

Linux Host Support CCSv6 - Texas Instruments Wiki
Linux Host Support CCSv6 From Texas Instruments Wiki Jump to: navigation , search Contents 1 Overview 1.1 Devices 1.1.1 Supported 1.1.2 Not Supported ...

Resources last updated: 12/15/2015 3:45:48 AM