keep running into the same error when installing bugzilla

I'm installing on RHEL 7.7 server, I run checksetup.pl and it asks me to install  the required modules. I can install some but other like install module.pl DateTime
I run into this error

Warning: prerequisite JSON::PP 2.27300 not found. We have 2.27202.
Writing Makefile for CPAN::Meta
Writing MYMETA.yml and MYMETA.json
---- Unsatisfied dependencies detected during ----
----    DAGOLDEN/CPAN-Meta-2.150010.tar.gz    ----
    JSON::PP [requires]
Skipping test because of notest pragma
Running make install
  Delayed until after prerequisites
Running install for module 'JSON::PP'
Running make for I/IS/ISHIGAKI/JSON-PP-4.04.tar.gz
CPAN: LWP::UserAgent loaded ok (v6.05)
CPAN: Time::HiRes loaded ok (v1.9725)
Fetching with LWP:
http://www.cpan.org/authors/id/I/IS/ISHIGAKI/JSON-PP-4.04.tar.gz
read timeout at /usr/share/perl5/vendor_perl/Net/HTTP/Methods.pm line 236. at /usr/share/perl5/LWP/UserAgent.pm line 915.
0
amirk
3/19/2020 2:06:44 AM
mozilla.support.bugzilla 10121 articles. 0 followers. Post Follow

2 Replies
19 Views

Similar Articles

[PageSpeed] 37

Guten Tag amirk.2oseven@gmail.com,
am Donnerstag, 19. M=E4rz 2020 um 03:06 schrieben Sie:

> I'm installing on RHEL 7.7 server, I run checksetup.pl and it asks
> me to install  the required modules. I can install some but other like in=
stall module.pl DateTime
> I run into this error

Don't use install-module.pl unless absolutely necessary, prefer the
package manager of your distribution instead. That might provide a
version of DateTime compatible with your installed version of
JSON::PP. Only if that is NOT the case, try top remove the installed
version of JSON::PP using your package manager and afterwards use
install-module.pl again for DateTime. That should install a more
recent version of JSON::PP as well then.

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
3/19/2020 9:09:54 AM
Hello Thorsten,

Thanks for the tip. I managed to install the module with

yum install perl-DateTime



0
amirk
3/19/2020 3:11:44 PM
Reply: