Install problem updating 2.20.2 to 3.0.2 (DBD::mysql::db )

Hi All,
I perform the update of the mysql from v. 4.0.15 to 5.0.45
I permorm the update of the modules required from checksetup log through =
bugzilla 3.0.2.
But when I try to enter in buzilla, I receive the following error.
When I downgrade to ver 2.20.2 all came back ok.

How I can solve the problem ?
Thank you

ERROR:

DBD::mysql::db selectrow_hashref failed: Unknown column =
'profiles.disable_mail' in 'field list' [for Statement "
            SELECT profiles.userid     AS =
id,profiles.login_name,profiles.realname,profiles.mybugslink AS =
showmybugslink,profiles.disabledtext,profiles.disable_mail FROM profiles
             WHERE userid =3D ?"] at Bugzilla/Object.pm line 69
	Bugzilla::Object::_init('Bugzilla::User', 1) called at =
Bugzilla/Object.pm line 40
	Bugzilla::Object::new('Bugzilla::User', 1) called at Bugzilla/User.pm =
line 131
	Bugzilla::User::new('Bugzilla::User', 1) called at =
Bugzilla/Auth/Verify.pm line 111
	=
Bugzilla::Auth::Verify::create_or_update_user('Bugzilla::Auth::Verify::DB=
=3DARRAY(0xb9bdf4)', 'HASH(0xc803b0)') called at =
Bugzilla/Auth/Verify/Stack.pm line 65
	=
Bugzilla::Auth::Verify::Stack::create_or_update_user('Bugzilla::Auth::Ver=
ify::Stack=3DARRAY(0xb95850)', 'HASH(0xc803b0)') called at =
Bugzilla/Auth.pm line 77
	Bugzilla::Auth::login('Bugzilla::Auth=3DARRAY(0xb71aac)', 0) called at =
Bugzilla.pm line 232
	Bugzilla::login('Bugzilla', 0) called at =
/home/cvsadmin//bugrep/bugzilla-2.18/index.cgi line 40




The LOG of checkconfig seems ok.


* This is Bugzilla 3.0.2 on perl 5.8.8
* Running on SunOS 5.8 Generic_117350-26

Checking perl modules...
Checking for             CGI (v2.93)   ok: found v3.25=20
Checking for        TimeDate (v2.21)   ok: found v2.22=20
Checking for             DBI (v1.41)   ok: found v1.58=20
Checking for       PathTools (v0.84)   ok: found v3.21=20
Checking for Template-Toolkit (v2.12)   ok: found v2.15=20
Checking for      Email-Send (v2.00)   ok: found v2.185=20
Checking for Email-MIME-Modifier (any)     ok: found v1.442=20

Checking available perl DBD modules...
Checking for          DBD-Pg (v1.45)   ok: found v1.49=20
Checking for       DBD-mysql (v2.9003) ok: found v3.0008=20

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.35=20
Checking for     Template-GD (any)     ok: found v1.56=20
Checking for           Chart (v1.0)    ok: found v2.1=20
Checking for         GDGraph (any)     ok: found v1.4308=20
Checking for      GDTextUtil (any)     ok: found v0.86=20
Checking for        XML-Twig (any)     ok: found v3.26=20
Checking for      MIME-tools (v5.406)  ok: found v5.420=20
Checking for     libwww-perl (any)     ok: found v2.036=20
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5=20
Checking for      PerlMagick (any)      not found=20
Checking for       perl-ldap (any)     ok: found v0.34=20
Checking for       SOAP-Lite (any)     ok: found v0.55=20
Checking for     HTML-Parser (v3.40)   ok: found v3.55=20
Checking for   HTML-Scrubber (any)     ok: found v0.08=20
Checking for Email-MIME-Attachment-Stripper (any)     ok: found v1.313=20
Checking for     Email-Reply (any)     ok: found v1.202=20
Checking for        mod_perl (v1.999022)  not found=20
Checking for             CGI (v3.11)   ok: found v3.25=20
Checking for      Apache-DBI (v0.96)   ok: found v1.06=20

* NOTE: You must run any commands listed below as root.

**********************************************************************
* OPTIONAL MODULES                                                   *
**********************************************************************
* Certain Perl modules are not required by Bugzilla, but by          *
* installing the latest version you gain access to additional        *
* features.                                                          *
*                                                                    *
* The optional modules you do not have installed are listed below,   *
* with the name of the feature they enable. If you want to install   *
* one of these modules, just run the appropriate command in the      *
* "COMMANDS TO INSTALL" section.                                     *
**********************************************************************

***********************************************************************
* MODULE NAME * ENABLES FEATURE(S)                                    *
***********************************************************************
*  PerlMagick * Optionally Convert BMP Attachments to PNGs            *
*    mod_perl * mod_perl                                              *
***********************************************************************
COMMANDS TO INSTALL:

     PerlMagick: /home/cvsadmin/bugrep/perl-5.8.8.p/bin/perl -MCPAN -e =
'install Image::Magick'
       mod_perl: /home/cvsadmin/bugrep/perl-5.8.8.p/bin/perl -MCPAN -e =
'install mod_perl2'
Reading ./localconfig...

OPTIONAL NOTE: If you want to be able to use the 'difference between two
patches' feature of Bugzilla (which requires the PatchReader Perl module
as well), you should install patchutils from:

    http://cyberelk.net/tim/patchutils/

Checking for       DBD-mysql (v2.9003) ok: found v3.0008=20
Checking for           MySQL (v4.1.2)  ok: found v5.0.45

Creating ./data directory...
Creating ./data/attachments directory...
Creating ./data/duplicates directory...
Creating ./data/mimedump-tmp directory...
Creating ./data/mining directory...
Creating ./data/webdot directory...
Creating ./extensions directory...
Creating graphs directory...
Creating skins/contrib directory...
Creating skins/custom directory...
Creating ./data/mail...
Creating ./Bugzilla/.htaccess...
Creating ./data/.htaccess...
Creating ./data/attachments/.htaccess...
Creating ./data/webdot/.htaccess...
Creating ./template/.htaccess...
Creating .htaccess...
Precompiling templates...

    setting in ./localconfig.

0
Paolo
10/25/2007 3:16:01 PM
mozilla.support.bugzilla 10111 articles. 0 followers. Post Follow

0 Replies
708 Views

Similar Articles

[PageSpeed] 19

Reply:

Similar Artilces:

Problem updating 2.20.2 to 3.0.2 bugzilla-update.xml file cannot be created.
Hi, I successful update the bugzilla. I also set the preferences. But now = when I browse the new bugzilla In main page I receive the following = error message: > The local XML file './data/bugzilla-update.xml' cannot be created.=20 > Please make sure the web server can write in this directory and=20 > that you can access the web. If you are behind a proxy, set=20 > the proxy_url parameter correctly. Now : - I checked the data folder and the privileges seems good (777).=20 - I don't use the proxi. Moreover in ./data folder I also found the params file...

2.0.0.2 to 2.0.0.3 update failure #2
Name: firefox_fan Product: Firefox Summary: 2.0.0.2 to 2.0.0.3 update failure Comments: The new update fails to install other than in admin mode (Windows XP SP2). Now every time I start Firefox (other than admin mode), it tries to update but fails due to lack of privileges. Let me know how to over come this problem. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 ...

Update between 2.0.0.2 and 2.0.0.3
Name: John P Wright Email: klemnoctraatyahoodotcom Product: Firefox Summary: Update between 2.0.0.2 and 2.0.0.3 Comments: I have been reminded at regular intervals ( when online) by a pop up indicating that upgrade to 2.0.0.3 is recommended. I have now performed this exercise twice but the reminder pop up keeps re-appearing. Also the 'about Mozilla Firefox' tab persists in indicating that I am running 2.0.0.2 The update appeared in both cases to download and update without error or information on any problem found. Browser Details: Mozilla/5.0 (Windows; U; Win...

Update from 2.0.0.2 to 2.0.0.3
Name: Alexander Wijnhamer Email: arvwijnhameratlycosdotnl Product: Firefox Summary: Update from 2.0.0.2 to 2.0.0.3 Comments: I get a pop-up that: "Firefox was unable to verify the integrity of the incremental update it downloaded, so it is now downloading the complete update package" However the counter is at 4 of 4 kb and has been for 5 minutes now. It doesn't seem to be doing anything. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 ...

2.0.0.2 to 2.0.0.3 update failure
Name: firefox_fan Product: Firefox Summary: 2.0.0.2 to 2.0.0.3 update failure Comments: The new update fails to install other than in admin mode (Windows XP SP2). Now every time I start Firefox (other than admin mode), it tries to update but fails due to lack of privileges. Let me know how to over come this problem. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 ...

Problem migrating database from bugzilla 2.20.2 to bugzilla 3.0
hi all, I installed bugzilla 3.0 and was working fine till I tried migrating the mysql db from previous version of bugzilla 2.20.2. These two versions are on different machines. I created .dmp file to get the data in bugzilla 2.20.2 to update it to bugzilla 3.0. Tables seemed to be updated(not sure if there is mismatch between the table structure), but after that upon trying to run checksetup.pl script, I am getting the following message ------------------------------------------------ "There was an error connecting to MySQL: Access denied for user 'bugs'@'localh...

Firefox version 2.0.0.3 is being updated to 2.0.0.2?
Name: Russell Nelson Email: rnelsonatgenedotcom Product: Firefox Summary: Firefox version 2.0.0.3 is being updated to 2.0.0.2? Comments: I am currently using a version of Firefox with the version number of 2.0.0.3. This is the second time that I have been told that it has now been updated to a newer version of Firefox with a version number of 2.0.0.2. I assume that 2.0.0.3 is newer (and better) than version 2.0.0.2. How can I stop this "update"? Russ Nelson 650-225-7212 Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070...

Firefox 2.0.0.2 & 2.0.0.3 niggly problem
I just upgraded both my desktop and my laptop to FF v2.0.0.2 a couple days ago. Both began doing the same annoying thing. When I click a URL shortcut on my desktop or a link in my newsreader, an error box pops up saying "File http://blahblahblah or one of its components not found. Make sure the path and filename are correct." Then FF goes ahead and loads the page. This doesn't happen if FF is already running. If it's not running, it happens every time. I just downloaded 2.0.0.3. Same story. Any clues? -- Dale Beckett Dale Beckett wrote:...

Problem installing Bugzilla 3.2.3 #2
Hello,=20 =20 Am facing problem while installing Bugzilla 3.2.3 on Fedora 10, database is MySQL 5.0.67 and perl is V5.10.0, apache for Internet.=20 =20 Done the configuration following Bugzilla document, bugzilla is installed in /var/www/html/bugzilla/=20 =20 Getting following error message in /var/log/httpd/error_log --=20 =20 (13)Permission denied: exec of '/var/www/html/bugzilla/index.cgi' failed=20 Premature end of script headers: index.cgi =20 And getting following error message on executing ./testserver.pl -=20 =20 Use of uninitialized va...

Release of Bugzilla 2.18.6, 2.20.3, 2.22.1, and 2.23.3
We have many releases for you, today! Bugzilla 2.18.6 and 2.20.3 are security-fix releases for our older branches. Bugzilla 2.22.1 is our first bugfix release in the 2.22 series, and contains many useful fixes that improve the experience of using Bugzilla. Finally, we are releasing an unstable development snapshot, Bugzilla 2.23.3. This snapshot has both custom fields and mod_perl support, but has not been tested as thoroughly as our other releases. The 2.23 series will eventually culminate in Bugzilla 3.0. Users of the 2.18.x series should note that 2.18.x will r...

Have 2.0.0.3.
Name: Mickey Mouse Email: grabthebonusatgmaildotcom Product: Firefox Summary: Have 2.0.0.3. - just received 2.0.0.2. as an "Update"? Comments: Hi, I have version 2.0.0.3 installed. I just got a dialogue box telling me that I have received 2.0.0.2 as an update. This obviously doesn't make sense. What is going on here? Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3 ...

P4DTI 2.3.0 released to support Bugzilla 2.20
I have made release 2.3.0 of the Perforce Defect Tracking Integration (P4DTI): <http://www.ravenbrook.com/project/p4dti/release/2.3.0/> This release works with Bugzilla 2.20 and with Perforce servers in Unicode mode, and the User's Guide includes instructions for P4V users. This release has not yet been approved by Perforce Inc. As and when it is approved, it will be uploaded to the Perforce public repository. Unless and until it is approved, it is not a supported product of Perforce Inc. In the meantime, I welcome feedback from anyone prepared to try this release...

2.0.0.2 update #2
Name: Jim moore Product: Firefox Summary: 2.0.0.2 update Comments: I don't know if this came with the 2.0.0.2 update or an earlier one, but the fact that I can't delete the bookmarks toolbar folder from the bookmarks really ticks me off. whatever happened to configuring firefox the way I want it? Not to mention that when it updated to 2.0.0.2 it removed ALL my bookmarks, silly me thinking that they were safe, now they are all gone, all the sites that I had found and wanted to go back to, gone, over a years worth of saving websites in my bookmarks. Browser Details: Mo...

Updated from 2.0.15pre to 2.2 with no problems.
Today I updated my laptop from 2.0.15pre to 2.2 with no problems. First I installed the Add-on Compatibility Reporter ver 0.8.6 Next I installed SM 2.1 overtop of 2.0.15pre. Then I installed SM 2.2 overtop of 2.1. Viola - all my add-ons are working - my bookmarks imported fine no problem with address books (15 different books) - and I'm happy! ..................... This was the same process in which I updated this machine. Add-ons on this one: Last updated: Mon Jul 18 2011 10:34:37 GMT-0400 (Eastern Daylight Time) User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/...

Web resources about - Install problem updating 2.20.2 to 3.0.2 (DBD::mysql::db ) - mozilla.support.bugzilla

Resources last updated: 12/25/2015 7:45:48 AM