ERROR: Using install-module.pl requires that you install "make".

--_005_7C2D9ABAD3B1744E97650076A3F2E91123C5715BONENETEXCH07ser_
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

Hi there

Below is the issue:

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 F=
irefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

whenever I execute "/data/perl5.14/bin/perl-static install-module.pl DateTi=
me" or "perl install-module.pl DateTime", or try to install any other modul=
es.


Actual results:

It comes out "ERROR: Using install-module.pl requires that you install "mak=
e"." but actually make has been installed in /usr/bin and it is inside the =
PATH.


Expected results:

let me install the modules.


Please refer to my attached pictures to know more about the issue.

Cheers
David Lin


--_005_7C2D9ABAD3B1744E97650076A3F2E91123C5715BONENETEXCH07ser_--
0
David
2/27/2012 10:53:43 PM
mozilla.support.bugzilla 10157 articles. 0 followers. Post Follow

3 Replies
1748 Views

Similar Articles

[PageSpeed] 16

David,

What you describe as a bug is intended behavior. The script install-modules.pl
uses CPAN to install modules, and implicitly installing a CPAN module requires
downloading the source code and building from source locally on the machine.

http://www.cpan.org/modules/INSTALL.html

--
Fredrik Jonson
0
Fredrik
2/29/2012 7:21:07 PM
Hi David,

 I'm getting this same behavior, trying to upgrade to bugzilla 4.2 and
I've definitely got 'make' installed, and on the path.
Any other ideas as to what could be causing this?

Cheers
Nick


On Feb 29, 2:21=A0pm, Fredrik Jonson <fred...@jonson.org> wrote:
> David,
>
> What you describe as a bug is intended behavior. The script install-modul=
es.pl
> uses CPAN to install modules, and implicitly installing a CPAN module req=
uires
> downloading the source code and building from source locally on the machi=
ne.
>
> http://www.cpan.org/modules/INSTALL.html
>
> --
> Fredrik Jonson

0
Nick
3/4/2012 9:58:16 PM
Sorry, Fredrick, not David :)

On Mar 4, 10:58=A0pm, Nick Jennings <nkj...@gmail.com> wrote:
> Hi David,
>
> =A0I'm getting this same behavior, trying to upgrade to bugzilla 4.2 and
> I've definitely got 'make' installed, and on the path.
> Any other ideas as to what could be causing this?
>
> Cheers
> Nick
>
> On Feb 29, 2:21=A0pm, Fredrik Jonson <fred...@jonson.org> wrote:
>
>
>
>
>
>
>
> > David,
>
> > What you describe as a bug is intended behavior. The script install-mod=
ules.pl
> > uses CPAN to install modules, and implicitly installing a CPAN module r=
equires
> > downloading the source code and building from source locally on the mac=
hine.
>
> >http://www.cpan.org/modules/INSTALL.html
>
> > --
> > Fredrik Jonson

0
Nick
3/4/2012 10:04:05 PM
Reply:

Similar Artilces:

Module::Install: dependencies don't install with "make install"
I want to make a distribution that packages up dependencies for me. I think Module::Install is supposed to do this for me. Without the boring details, So I make a little module, tweak the Makefile.PL thusly: And I say "make dist", move the tar.gz file over to my other (windoze) machine, and untar it, and have what I expect in the inc dir: I say perl Makefile.PL, and make install - happy: =========================================== So I make a little module, tweak the Makefile.PL thusly: use 5.005; use inc::Module::Install; name ('SGlicense'); version ('1....

installation package error: "The installer was interrupted before [program] could be installed"
Hi,     I encountered one problem with my web application installation package. Before, it works well. While after some minor changes to code, I rebuild the setup file, when I tried to run it, I got such error.     I searched on web to find similar problems due to file <VS Install>\Common 7\tools\deployment\dpca.dll     My symptom is the same as described, I used the tool Qwerty.Msi to check errors, when debug, at sequence WEBCA_GatherWebSites 12:30:12 PM  Action start 12:30:12: WEBCA_GatherWebSites.12:30:15 PM  Action ended 12...

Error in installing "Bundle::Expect" as dependency for some other module using CPAN
--_000_8a2078bcf15342e2b66d38f319b80b33BLUPR05MB021namprd05pro_ Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Hello, I am uploading my module Net::Netconf http://search.cpan.org/search?mode=3D= all&query=3Dnet%3A%3Anetconf in CPAN, but its giving error of dependency no= t found for Bundle::Expect. I am mentioning all my dependency in Makefile.P= l "use ExtUtils::MakeMaker; our $VERSION =3D'0.01'; use 5.006; WriteMakefile( NAME =3D> 'Net-Netconf', AUTHOR =3D> 'Juniper ...

Packages to install to use "mkuser" and "passwd" or "pwdadm" commands
Hello everybody, can anyone suggest me what packages do I have to install to use user admin commands stated in Subject? Hope to hear from you soon, Paolo De Nictolis Paolo, It appears that in the past few days you have not received a response to your posting. That concerns us, and has triggered this automated reply. Has your problem been resolved? If not, you might try one of the following options: - Do a search of our knowledgebase at http://support.novell.com/search/kb_index.jsp - Check all of the other support tools and options available at http://support.novell.com...

4.0.2
  I have a successful install of 4.0.2 running on a Win 2K box with SQL Server 2005 (on the same box). Today I tried to install DNN on a new Win 2K server (IIS 5) with a separate SQL Server 2000 database server. Most things in DNN seem to work fine (login, adjust host & admin settings, etc.), but the basic modules (like Text/HTML and Links) throw up an error: Error: Links is currently unavailable.DotNetNuke.Services.Exceptions.ModuleLoadException: Keyword not supported: 'cosda199,10433;database'. ---> It looks like something is funny about the connection string, but other part...

MDAC 2.5 required to run, cannot install
 Hello!I have a problem with Data Access. There is a DLL i need to use, which was compiled in VB.6 using MDAC 2.5. I am using ..NET 2.0 and on my machine it's MDAC 2.8.When my program is trying to use that DLL, I get an error of connection not being open. The guy who created that DLL says I need to have MDAC 2.5 on my machine in order to use the DLL properly. However, when I download and try to install MDAC 2.5 it tells me that it's already installed on the machine. Yet, when I go to check in the registry, I get 2.8 and 2.6 as a rollback version. Here is the question: how do I i...

How can I install a "install.pl" for Linux?
Hello, I look about a possible way to install a "install.pl" file to create a on line photo album. Is this possible under Suse 11.0? -- RVeit :p ------------------------------------------------------------------------ Open a console type *cd /pathTo/install.p*l Then *sudo ./install.pl* then root pass /Geoff RolandVeit;1917974 Wrote: > Hello, > I look about a possible way to install a "install.pl" file to create a > on line photo album. Is this possible under Suse 11.0? -- Core 2 Duo E8500 3.16GHz - 4GB DDR2 - 2.5 TB - GeForce 7...

Installation Guide is weak. Has a "no Worry FYI" but not "how to install"
Name: Ari V Email: defygravity79atyahoodotcom Product: Thunderbird Summary: Installation Guide is weak. Has a "no Worry FYI" but not "how to install" Comments: read / review it for yourself. Browser Details: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11 ...

bugzilla: undef error
I'm encountering the problem described here: https://bugzilla.mozilla.org/show_bug.cgi?id=300448 I'm running bugzilla 2.18.3 on fedora. The problem seems to be that a line was added to this file: template/en/default/bug/create/created.html.tmpl So I commented out this line: mailrecipients = item.mailrecipients and restarted everything, but I'm still getting the same error. I'm not sure that I understand the solution very well. Any ideas? Thanks, Bryan ...

Installed AjaxToolkit but get the error "A ScriptManager is required " error ? What is going on?
So I created a new tab in my toolbox and added the AjaxToolkit file which I placed in my bin folder first. Everything works fine, the ajax tools are displaying no problem. So next I decide I want to add a calendarExtender to my gridview and associate it with a button so when a user edits the appoitment date field they will be able to select it from the calendar. However when I run the file I recieve this error: A ScriptManager is required on the page to use ASP.NET AJAX Script Components.Exception Details: System.InvalidOperationException: A ScriptManager is required on the page to use ASP....

Error on run "make install"
Hi all; When I try to run make install a error occurs: > > make[1]: Entrando no diret�rio `/home/muramatsu/wine/include' > ../tools/mkinstalldirs -m 755 /usr/local/include/wine/windows/ddk > make[1]: execvp: ../tools/mkinstalldirs: Permiss�o negada > make[1]: ** [/usr/local/include/wine/windows/ddk] Erro 127 > make[1]: Saindo do diret�rio `/home/muramatsu/wine/include' > make: ** [include/__install__] Erro 2 > This occurs with root and normal user. Can you help me? tks Mura -- P4 HT 3.0 @3.2 2Gb DDR 400 Dual Channel NVidia GForce ...

Installation Guide is weak. Has a "no Worry FYI" but not "how to install" #2
Name: Ari V Email: defygravity79atyahoodotcom Product: Thunderbird Summary: Installation Guide is weak. Has a "no Worry FYI" but not "how to install" Comments: read / review it for yourself: Installing Thunderbird 2 Please note that installing Thunderbird 2 will overwrite your existing installation of Thunderbird. You won't lose any of your mail, but some of your extensions and other add-ons might not work until updates for them are made available. Browser Details: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (...

cannot find "Module Installation" after clicking "Configure" icon
I've been working through the Linux OES Lab setup on a test server according to the Doc. of "LAB GUIDE FOR OES SP2 LINUX". Everything seemed to work well with the installation until "4.3 Installing the iFolder 3.x iManager Plug-in" I cannot find "Module Installation" menu item after clicking "Configure" icon. Also it display nothing after clicking "Roles and Tasks" icon. What is wrong? Should I check my eDirectory setting ? Or had I put the wrong value "In the iFolder Admin DN field, type cn=admin.o=COMPANY."...

cannot find "Module Installation" after clicking "Configure" icon
I've been working through the Linux OES Lab setup on a test server according to the Doc. of "LAB GUIDE FOR OES SP2 LINUX". Everything seemed to work well with the installation until "4.3 Installing the iFolder 3.x iManager Plug-in" I cannot find "Module Installation" menu item after clicking "Configure" icon. Also it display nothing after clicking "Roles and Tasks" icon. What is wrong? Should I check my eDirectory setting ? Or had I put the wrong value "In the iFolder Admin DN field, type cn=admin.o=COMPANY." ?...

Web resources about - ERROR: Using install-module.pl requires that you install "make". - mozilla.support.bugzilla

Resources last updated: 1/21/2016 7:06:17 AM