converting to utf8 with recode.pl doesn't appear to work

Hello,

I have an old install of bugzilla that was originally done a long time 
ago and so utf8 support was switched off. It is now running 5.0.3. There 
are multiple instances of bugzilla running from this install, only this 
one is not already utf8.

I want to run contrib/recode.pl to update everything to utf8 so I can 
change the install parameter to utf8.

When I run:
PROJECT=carallon contrib/recode.pl --guess --dry_run

It runs through and spits out a number of strings that it wants to 
upgrade, the detected charsets look good and all seems sensible.

I then run:
PROJECT=carallon contrib/recode.pl --guess

It runs without errors. At this point I'd like to think the conversion 
is complete. However if I run it again with --dry-run then it again 
lists the same set of strings needing an update

Is the recode processes working or not? I assume not. What must I do to 
fix it?

Thanks
Will
-- 
------------------------------------------------------------------------
Will Wagner                                     will_wagner@carallon.com
Engineering Manager                      Office Tel: +44 (0)20 7471 9424
Carallon Ltd, International House, 7 High Street, Ealing, London  W5 5DB
------------------------------------------------------------------------

0
Will
7/12/2017 2:51:55 PM
mozilla.support.bugzilla 9827 articles. 0 followers. Post Follow

0 Replies
20 Views

Similar Articles

[PageSpeed] 16

Reply: