Bugzilla email configuration #2

Hello,

I have installed Bugzilla (version 4.2.16) on Linux Server
release 6.4 (Santiago) and the issue I am facing is that
everytime I complete an action that involves the generation
of an email
(for example when I input a new user request and enter an
email for validation), I am getting an error similar to the
one below:

Bugzilla has suffered an internal error. Please save this
page and send it to xxx@my.domain with details of what you
were doing at the time this message appeared.

URL:
http://10.1.148.3/bugzilla-4.2.16/createaccount.cgi?login=yyy@mydomain&token=1541596479-7734b9e349dc08fee308eeed6d56c6f8

There was an error sending mail from '@10.1.148.3' to '':
Can't call method "address" on an undefined value
at /usr/local/share/perl5/Email/Send/SMTP.pm line 29.

Traceback:
 at Bugzilla/Mailer.pm line 196
        Bugzilla::Mailer::MessageToMTA(...) called at
Bugzilla/Token.pm line 91
        Bugzilla::Token::issue_new_user_account_token(...)
called at Bugzilla/User.pm line 2013

Bugzilla::User::check_and_send_account_creation_confirmation
(...) called
at /gl/lungl/www/html/bugzilla-4.2.16/createaccount.cgi line
55



I have configured my email parameters as:

mail_delivery_method    -> SMTP
mailfrom                                -> bugzilla-daemon  (I have
also tried my other valid emails)
use_mailer_queue                -> off
smtpserver                              -> 10.0.0.4
smtp_username                   -> I have left this empty
smtp_password                   -> I have left this empty as well
smtp_debug                              -> on

also in 'Required settings' options I have configured the
urlbase as follows:

http://10.1.148.3/bugzilla-4.2.16/

I would appreciate any insight on the issue.

Many thanks.
0
helenaki83
11/8/2018 7:58:06 AM
mozilla.support.bugzilla 10008 articles. 0 followers. Post Follow

3 Replies
9 Views

Similar Articles

[PageSpeed] 2

Guten Tag helenaki83@gmail.com,
am Donnerstag, 8. November 2018 um 08:58 schrieben Sie:

> I have installed Bugzilla (version 4.2.16) on Linux Server

You shouldn't start fresh with an older release than the current
stable one, which is 5.0. That acontains a lot of bug fixes.

> There was an error sending mail from '@10.1.148.3' to '':
> Can't call method "address" on an undefined value
> at /usr/local/share/perl5/Email/Send/SMTP.pm line 29.

"mailfrom" is most likely wrong for your local setup, try some
complete mail address like "bugzilla-daemon@example.org" instead only
using "bugzilla-daemon". But heavily depends on you local mail system
etc.

> to ''

I'm pretty sure that this is an incompatibility of your Bugzilla
version with current versions of the mentioned lib that has been fixed
in newer versions of Bugzilla only:

https://bugzilla.mozilla.org/show_bug.cgi?id=3D502625

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
11/8/2018 9:19:47 AM
On Thursday, November 8, 2018 at 9:58:08 AM UTC+2, helen...@gmail.com wrote:
> Hello,
> 
> I have installed Bugzilla (version 4.2.16) on Linux Server
> release 6.4 (Santiago) and the issue I am facing is that
> everytime I complete an action that involves the generation
> of an email
> (for example when I input a new user request and enter an
> email for validation), I am getting an error similar to the
> one below:
> 
> Bugzilla has suffered an internal error. Please save this
> page and send it to xxx@my.domain with details of what you
> were doing at the time this message appeared.
> 
> URL:
> http://10.1.148.3/bugzilla-4.2.16/createaccount.cgi?login=yyy@mydomain&token=1541596479-7734b9e349dc08fee308eeed6d56c6f8
> 
> There was an error sending mail from '@10.1.148.3' to '':
> Can't call method "address" on an undefined value
> at /usr/local/share/perl5/Email/Send/SMTP.pm line 29.
> 
> Traceback:
>  at Bugzilla/Mailer.pm line 196
>         Bugzilla::Mailer::MessageToMTA(...) called at
> Bugzilla/Token.pm line 91
>         Bugzilla::Token::issue_new_user_account_token(...)
> called at Bugzilla/User.pm line 2013
> 
> Bugzilla::User::check_and_send_account_creation_confirmation
> (...) called
> at /gl/lungl/www/html/bugzilla-4.2.16/createaccount.cgi line
> 55
> 
> 
> 
> I have configured my email parameters as:
> 
> mail_delivery_method    -> SMTP
> mailfrom                                -> bugzilla-daemon  (I have
> also tried my other valid emails)
> use_mailer_queue                -> off
> smtpserver                              -> 10.0.0.4
> smtp_username                   -> I have left this empty
> smtp_password                   -> I have left this empty as well
> smtp_debug                              -> on
> 
> also in 'Required settings' options I have configured the
> urlbase as follows:
> 
> http://10.1.148.3/bugzilla-4.2.16/
> 
> I would appreciate any insight on the issue.
> 
> Many thanks.

We want the testopia plugin. For testopia2.5 the highest compatible release we can have is 4.4.13?
Should we give it a try?
For the "from" part we tried valid e-mails but still have the same issue.


Thank you

0
pitufita
11/8/2018 2:13:59 PM
Guten Tag pitufita,
am Donnerstag, 8. November 2018 um 15:13 schrieben Sie:

> We want the testopia plugin. For testopia2.5 the highest compatible relea=
se we can have is 4.4.13?
> Should we give it a try?

I wouldn't, the bug I mentioned seems only fixed in 5.0 and there's a
Testopia version available working with Bugzilla 5. While that hasn't
been released yet, it seems to work for users. You won't have a choice
but to use that version in case you upgrade to 5 anyway, because that
is what people easily forget: Testopia registers itself in Bugzilla's
database schema and needs to be used "forever" since then. You can't
easily "uninstall" it.

https://groups.google.com/forum/#!topic/mozilla.support.bugzilla/fl7asEwZOxY
https://developer.mozilla.org/en-US/docs/Mozilla/Bugzilla/Testopia#Testopia=
_3.0_(not_yet_released)

> For the "from" part we tried valid e-mails but still have the same issue.

Because the wrong "from" wrong is not the root cause, but an
additional, distinct problem, which might hit you only when mails get
actually send.

Mit freundlichen Gr=FC=DFen,

Thorsten Sch=F6ning

--=20
Thorsten Sch=F6ning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Gesch=E4ftsf=FChrer: Andreas Muchow

0
windows
11/8/2018 3:47:40 PM
Reply: