strange nss error

Hello all,

I'm getting an NSS error in my httpd logs and it's a bit strange.  The error I'm getting is this:

Misconfiguration of certificate's CN and virtual name. The certificate CN has server.name. We expected server.name as virtual name.

In this error above, server.name is mentioned twice and in both cases it's the same server name.  So that's why it's confusing.  

If anyone has any insight, I would love it since I cannot start my httpd service.

Chris
0
Chris
2/6/2017 2:45:34 PM
mozilla.dev.security 626 articles. 0 followers. Post Follow

2 Replies
103 Views

Similar Articles

[PageSpeed] 50

On Monday, 6 February 2017 17:06:29 UTC, Chris Tomlin  wrote:
> Hello all,
>=20
> I'm getting an NSS error in my httpd logs and it's a bit strange.  The er=
ror I'm getting is this:
>=20
> Misconfiguration of certificate's CN and virtual name. The certificate CN=
 has server.name. We expected server.name as virtual name.
>=20
> In this error above, server.name is mentioned twice and in both cases it'=
s the same server name.  So that's why it's confusing. =20
>=20
> If anyone has any insight, I would love it since I cannot start my httpd =
service.
>=20
> Chris

What have you tried to research to find a solution? Using some key words fr=
om your issue I have searched google and found a whole host of *possible* c=
auses and solutions. Obviously I can't say much else as I don't know anythi=
ng about your system, but I doubt many people can shed much light on this w=
ithout knowing much more about your system. =20

Also, I don't mean to appear rude, but I never considered this Group akin t=
o the Stack Exchange network. Perhaps you can find useful solutions on Serv=
erFault or StackOverflow?=20

p.s.> does this help: http://unix.stackexchange.com/questions/266838/troubl=
es-with-certificates=20
And I read a lot of topics about this refering to mod_nss errors/issues.
0
Martin
2/6/2017 9:10:46 PM
On Monday, February 6, 2017 at 4:10:55 PM UTC-5, Martin Heaps wrote:
> On Monday, 6 February 2017 17:06:29 UTC, Chris Tomlin  wrote:
> > Hello all,
> >=20
> > I'm getting an NSS error in my httpd logs and it's a bit strange.  The =
error I'm getting is this:
> >=20
> > Misconfiguration of certificate's CN and virtual name. The certificate =
CN has server.name. We expected server.name as virtual name.
> >=20
> > In this error above, server.name is mentioned twice and in both cases i=
t's the same server name.  So that's why it's confusing. =20
> >=20
> > If anyone has any insight, I would love it since I cannot start my http=
d service.
> >=20
> > Chris
>=20
> What have you tried to research to find a solution? Using some key words =
from your issue I have searched google and found a whole host of *possible*=
 causes and solutions. Obviously I can't say much else as I don't know anyt=
hing about your system, but I doubt many people can shed much light on this=
 without knowing much more about your system. =20
>=20
> Also, I don't mean to appear rude, but I never considered this Group akin=
 to the Stack Exchange network. Perhaps you can find useful solutions on Se=
rverFault or StackOverflow?=20
>=20
> p.s.> does this help: http://unix.stackexchange.com/questions/266838/trou=
bles-with-certificates=20
> And I read a lot of topics about this refering to mod_nss errors/issues.

Thanks Martin for some pointers.  I know I didn't provide as much info abou=
t my system as I could have but I thought possibly someone would have come =
across this same error without more details.  So far I've Googled this erro=
r but there doesn't seem to be too much info on this specific error.
0
Chris
2/10/2017 12:06:14 AM
Reply: